Jump to content
IGNORED

What streaming player should I put on my RaspberryPi today?


Recommended Posts

I should have been more clear. I was doing the installation wrong. I was NOT going into the root directory thinking I was already in the root directory. After I did the installation to the root meaning after I did the installation correctly, the problem got fixed. 

 

You can be sure it works now :)  but the autostart does not work.

 

Please disregard my previous posts regarding installation. I just have the autostart issue now. Everything else is fixed, I assure you:)

 

Again now, my only issue is although the system boots to active (running) openhome-player.service, there seems to be no server/player seen in Lumin.

 

Actually, just to confirm this; after a boot, I did openhome-player command MANUALLY. It says 192.168.1.0 is already in use because the service is running. But again no where in Lumin I can see the DietPi. I have to stop the service and then start manually to be able to use the service with Lumin.

Link to post
Share on other sites

Ok, that makes perfect sense now! The error was due to you doing an improper installation and not due to the service init script I posted. :D

 

Yes, the reason why the OpenHome Player service isn't appearing on the network at startup is because DietPi distro starts up differently to the stock Raspbian distro: the OpenHome Player service needs to also wait for the (special) dietpi-boot.service to start to be certain that the RPi has connected to the network with a valid IP.

 

Unfortunately, I forgot about this when I posted the original script. That was actually taken from a copy of the OpenHome Player service init script I have for Raspbian Jessie, as I didn't have the DietPi one to hand at the time - sorry about that!

Well at least I remembered to change the pi user to root. :)

 

This is what the script should have been:

[Unit]
Description=OpenHome Player
Wants=network-online.target
After=network.target network-online.target dietpi-boot.service

[Service]
User=root
ExecStart=/usr/bin/openhome-player

[Install]
WantedBy=multi-user.target

We will win because our NHS is the beating heart of this country. It is the best of this country. It is unconquerable. It is powered by love.

-- Boris Johnson

 

We are far more united and have far more in common with each other than things that divide us.

-- Jo Cox

Link to post
Share on other sites

YES! Autostart works now!

 

Thank you!

 

Sorry for being pain in the neck:)

 

I really do not understand why more people do not use the OpenHome Player. It works great and it has everything in one piece of service/software.

 

I also do not understand why the developers stopped developing. There is no other service/software (AFAIK) that offers what Openhome offers.

 

 

Link to post
Share on other sites

No worries, glad you got it working!

 

Indeed, the OpenHome Player can be regarded as a 'mini Linn DS', as it shares so many of those devices' streaming/OpenHome functions, including synchronised mult-iroom streaming (via Songcast)!

 

The OpenHome developers haven't stopped as such. They are just a bit slow in providing new builds for the supported platforms, eg the the latest Raspbian Stretch for the RPi. They also tend to be a bit slow in replying to posts on the official OpenHome forum. Apparently the source code for the OpenHome Player is available for anyone brave enough to tackle to building their own.

 

We will win because our NHS is the beating heart of this country. It is the best of this country. It is unconquerable. It is powered by love.

-- Boris Johnson

 

We are far more united and have far more in common with each other than things that divide us.

-- Jo Cox

Link to post
Share on other sites

Hi Cebolla,

 

Just found this thread and I've got an RPI 2 and allo digi one in the post arriving any day. The allo will be feeding a Chord 2Qute. 

 

Is there a noob step by step guide to setting up openhome on the pi? I want to use the Linn user interface on my Android tablet to control.

 

Thanks in anticipation...

Link to post
Share on other sites

You did not ask me but let me answer you since I have put a guide together from this thread and other site(s). This is what I did and it worked. Of course @Cebolla was the main person who made this happen.

 

@Cebolla will you pls double check? :)

 

Download this: http://dietpi.com/downloads/images/DietPi_RPi-ARMv6-Jessie.7z

and flash it to your card with Etcher.

 

You need to login as root via SSH  (run this command  cd / to be in the root), plus be in the root directory when you run the downloaded installer.

 

1. Once you've logged into the RPi as root via SSH, download the piheadless.sh OpenHome Player installer file (assuming you require the headless OpenHome Player) into the /tmp directory:
wget -P /tmp http://builds.openhome.org/releases/openhome/piheadless.sh

 

2. Give the installer file executable access permissions:

chmod +x /tmp/piheadless.sh

 

3. Make sure you're in the root directory:

cd /

 

4. Run the installer:

/tmp/piheadless.sh

 

5. Once installed, you can tidy up by manually deleting the installer file - though as it is in the /tmp directory, it should be removed automatically after next reboot:

rm /tmp/piheadless.sh

 

 

AUTOSTART SERVICE INSTRUCTIONS (I named it oh.service instead, you can name it whatever you want AFAIK)

 

 

sudo nano /etc/systemd/system/oh.service (this will create the oh.service and open a page where you can copy paste below script)

 

[Unit]

Description=OpenHome Player

Wants=network-online.target

After=network.target network-online.target dietpi-boot.service

 

[Service]

User=root

ExecStart=-/usr/bin/openhome-player

Restart=on-failure

 

[Install]

WantedBy=multi-user.target

Alias=openhomeplayer.service

 

AFTER YOU COPY PASTE THE ABOVE SCRIPT,  CTRL-X AND Y (YES) TO SAVE.

 

THEN do below commands step-by-step (not too sure if below commands are necessary but I did it)

 

Initialize the service using

sudo systemctl daemon-reload

 

Start service with

sudo systemctl start oh.service

 

Enable the service to start after a  reboot

sudo systemctl enable oh.service

 

@Cebolla please recheck my message as I maybe wrong at some parts.

Link to post
Share on other sites
23 hours ago, dongi said:

You did not ask me but let me answer you since I have put a guide together from this thread and other site(s). This is what I did and it worked. Of course @Cebolla was the main person who made this happen.


@Cebolla will you pls double check? :)@Cebolla

 

On 4/24/2018 at 7:14 PM, Moppit said:

Hi Cebolla,

 

Just found this thread and I've got an RPI 2 and allo digi one in the post arriving any day. The allo will be feeding a Chord 2Qute. 

 

Is there a noob step by step guide to setting up openhome on the pi? I want to use the Linn user interface on my Android tablet to control.

 

Thanks in anticipation...

 

Hi Moppit,

 

Didn't you already mention getting an RPi with Volumio working a good while ago in a thread of yours on that other forum (way before I did) - so not quite a noob, eh?

 

Looks like @dongi has pulled together the relevant posts on this thread ok - definitely saved me the job of referencing them all!

 

The DietPi distro has built-in support for the Allo Digi One board, so should work well. Don't forget to set it as the Soundcard in dietpi-config's Audio Options.

 

John

 

We will win because our NHS is the beating heart of this country. It is the best of this country. It is unconquerable. It is powered by love.

-- Boris Johnson

 

We are far more united and have far more in common with each other than things that divide us.

-- Jo Cox

Link to post
Share on other sites

Good to know all is good @Cebolla

 

Now, I have another problem :)

 

So I wanted to try the wifi connection on the RPi3. Dietpi jessie doesn't recognize. So, I tried the fix you @Cebolla suggested in this thread but no go. So, I put my wifi adapter from RPi2 to RPi3 and it works fine.

 

However, the autostart doesn't work with wifi only. If I change to ethernet connection, it works fine. I wonder if I need to add wifi-network line or something like that to the autostart script?

Link to post
Share on other sites
1 hour ago, dongi said:

So I wanted to try the wifi connection on the RPi3. Dietpi jessie doesn't recognize. So, I tried the fix you @Cebolla suggested in this thread but no go. So, I put my wifi adapter from RPi2 to RPi3 and it works fine.

I suggested no such fix!

 

If you are referring to this post:

On 4/12/2018 at 6:32 PM, Cebolla said:

Ah, that makes sense - the last Raspbian 8/Jessie image doesn't appear to have been updated to work with the new RPi 3B+ either.

 

There is this fix for Raspbian Jessie, which may also work for DietPi Jessie. However, it advises doing the first step (update the image's bootloader) on an RPi 3 - not sure if it will work on your RPi 2:

Raspberry Pi Stack Exchange - Raspbian 8 on Raspberry Pi 3 B+

then that was in reply to the OP ( @davide256)'s specific problem with DietPi Jessie not working at all with the latest RPi 3BPlus, so nothing to do with (your) older RPi 3B nor its WiFi!!!

 

You'd best make sure you go back to the original image.

We will win because our NHS is the beating heart of this country. It is the best of this country. It is unconquerable. It is powered by love.

-- Boris Johnson

 

We are far more united and have far more in common with each other than things that divide us.

-- Jo Cox

Link to post
Share on other sites

@Cebolla, sorry my fault. At that link, there is also a mention about the Wifi fix. So, since I went to that link from your suggested link, I thought it was a wifi fix also. Sorry.

 

Not to mention, I thought I had the B+ version. I bought it on Feb 2017. Did the B+ exist back then? Geez, since it had been sitting in a closet, I did not realize it was not B+.

 

You did NOT suggest a fix.

Link to post
Share on other sites

Cannot test at the moment, but don't you simply setup the RPi 3's WiFi in dietpi-config?

 

BTW, waiting for the dietpi-boot.service to start, in the OpenHome Player service init script should still work, as it is supposed to guarantee a valid IP network connection via either LAN or WLAN.

We will win because our NHS is the beating heart of this country. It is the best of this country. It is unconquerable. It is powered by love.

-- Boris Johnson

 

We are far more united and have far more in common with each other than things that divide us.

-- Jo Cox

Link to post
Share on other sites
14 minutes ago, Cebolla said:

Cannot test at the moment, but don't you simply setup the RPi 3's WiFi in dietpi-config?

Yes that's how it is done. I set up correctly I believe because it works fine. However, the autostart won't work for some reason. Maybe I did not wait long enough or something (I doubt it). I will look into again. Thanks.

Link to post
Share on other sites
4 hours ago, Cebolla said:

Didn't you already mention getting an RPi with Volumio working a good while ago in a thread of yours on that other forum (way before I did) - so not quite a noob, eh?

 

Hi John,

 

Yes indeed! ...though Volumio requires no knowledge of Linux to get started and even then I struggled!  That was an RPi 1b with a hifiberry DAC. Got a bit fed-up with that as Sound Quality was no better than my Pioneer N50 and there were regular drop-outs. 

 

In this instance I'm attracted to the possibility of the Linn user interface. Alternatively it could be a future Roon endpoint. The use of RP2 with the Digione should in theory address the SQ issues giving a nice clean signal to my 2Qute. Thanks for your point about the soundcard. 

Link to post
Share on other sites
2 hours ago, dongi said:

Not to mention, I thought I had the B+ version. I bought it on Feb 2017. Did the B+ exist back then?

 

No the 3b+ board is new, it was just released in mid-March 2018.

no-mqa-sm.jpg

Boycott TIDAL

Boycott Warner Music Group

Link to post
Share on other sites
3 hours ago, Cebolla said:

Cannot test at the moment, but don't you simply setup the RPi 3's WiFi in dietpi-config?

 

BTW, waiting for the dietpi-boot.service to start, in the OpenHome Player service init script should still work, as it is supposed to guarantee a valid IP network connection via either LAN or WLAN.

DietPi admin wrote  a script because of the error message I posted there. It is fixed now!

 

 

Hi,

Thanks for the report.

I've applied a fix for this, please copy and paste all following commands to update the script:

CODE: SELECT ALL
wget https://github.com/Fourdee/DietPi/raw/fed5638d23e3fd49b982d9a456fd76d8a7e329be/dietpi/func/dietpi-set_hardware -O /DietPi/dietpi/func/dietpi-set_hardware



Now, when enabling WiFi, error should no longer appear.

Link to post
Share on other sites
  • 3 months later...
On 11/15/2017 at 11:11 AM, Cebolla said:

 

The latest version of Volumio v2.0(?) I tried several months ago was buggy. The last decent Volumio version I tried was v1.55.

 

Moode Audio is a decent very well supported streamer for the RPi, so defintely worth a go:

http://moodeaudio.org/

https://www.computeraudiophile.com/forums/topic/23233-moode-audio-player-for-raspberry-pi/?do=getLastComment

 

I'm currently using the current headless version of openhome.org's free OpenHome Player for the RPi under Raspbian Jessie Lite. Unfortunately there's no compiled version available for the latestest Rasbian Stretch distro for the RPI. Also, it requires a bit of Linux knowledge to install, setup as a service process, output to the USB DAC & appropriately respond to it being connected/disconnected, etc.

However, it does take you closest to a Linn DS streamer native OpenHome streaming user experience (via the Linn Kazoo controller app), without actually having a Linn device!

http://openhome.org/pages/use/downloads/pi

 

 

Hi everyone, long time reader, first post here.

 

Trying to implement the Raspbian + OpenHome Player (OHP) + Linn Kazoo app combination.

 

So far, did a good progress with installation of Raspbian Jessie (current supported version for OHP) and headless version of OHP itself. I can use my Linn Kazoo and Lumin Apps to stream music from the onboard headphone jack.

 

The challenge is I can not get audio out from Hifiberry Digi+ sound card using OHP, I did the setup with config.txt file and can use the HF Digi+ in the web browser for youtube, but not with OHP.

 

When I try to boot OHP, I get an error as;

Using Subnet 192.168.0.0
Volume Control Unavailable
Segmentation fault

 

While being not a Linux whiz, I guess, OHP is concerned that there is no volume control in HF Digi+ card, any ideas how to get over this?

 

Many thanks!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...