Jump to content
IGNORED

Can I use JRiver with M2Tech Hiface?


tz1963
 Share

Recommended Posts

Hi,

 

I have ordered the M2Tech Hiface to run to my DAC.

 

I am new to all this and am trying to follow the recommendations made on this site. So the plan was to use JRiver on my Windows7 laptop.

 

But I am not sure it is possible to get JRiver to work with the HiFace.

 

Can someone tell me how to do that, or should I use Foobar, as that is definitely compatible with HiFace.

 

Thanks,

 

T.

 

Link to comment
Share on other sites

Guest WATERLOGIC

FROM : http://www.m2tech.biz/public/pdf/FAQ_eng.pdf

 

11)Does hiFace work with all players? If 1.00 driver is installed it only works with FooBar, a free player that can be downloaded from Internet and must be installed together with its optional DLL to enable the operation in Kernel Streaming mode. With the driver release 1.01 for Microsoft OSes it also works with Winamp and Media Monkey, provided the plug-in for Kernel Streaming operation is installed. iTunes will be used on Mac. With the driver release 1.02 every player can be used, provided the Direct Sound mode is selected. This option, at the cost of a lesser sound quality, allows for listening Internet streams using browsers.

12)Why, with old drivers, must I use FooBar instead of other players, such as iTunes, Media Monkey or Windows Media Player? With old drivers, hiFace only works in Kernel Streaming mode. Some player, like Windows Media Player, only work in Direct Sound mode, which doesn’t allow to obtain the results provided by the Kernel Streaming mode. Instead, with the driver release 1.02 hiFace also works both in Direct Sound and Kernel Streaming mode. Thus, it is also suitable to reproduce Windows sounds and game sounds, like any sound card.

------------------------------------

 

Best thing - contact their tech support by email - these guys are really helpful.

 

Regards

WL

 

Link to comment
Share on other sites

I am using J.River with Hiface on a Windows XP computer but through ASIO4All. It works perfectly. I know I've used it through my Windows 7 PC too, but cant remember the configuration now - probably also through ASIO.

 

Roon Rock | OpticalRendu | EMM Dac | Dartzeel Preamp | Dartzeel Power Amp | Evolution Acoustics Speakers
sOTM Switch | Ansuz USB Cable | Transparent Power Cables | Bertram Speaker Cables | Zeel Interconnects | Dedicated Room | Balanced Power

Link to comment
Share on other sites

I use to use JRMC with ASIO (full) on my XP laptop. I now use the M2tech Hi-Face and I use Media Monkey with the Kernel streaming plugin (steve monk). The bungheads at JR will make a kernel streaming plugin and teh hi face software will not work with the full version of ASIO.

 

Powerbook G4 15 inch Aluminum, \"Fidela,\" M2tech EVO (BNC)with RF attenuator,dedicated PSU, Stereovox XV Ultra (BNC) Audio Note Dac Kit 2.1 Level B Signature Upgraded to 12AU7 tubes, ARC SP-16L Tube preamp , VAC PA100/100 Tube Amp), Vintage Tubes, Furutech ETP-80, (Alon 2 Mk2, (upgraded tweeters, Usher Woofers), Pangea Power cords, Omega Micro Active Planar PC. Signal Cable Silver Resolution ICs.

Link to comment
Share on other sites

Well here I am again throwing my ignorance at your pearly gates of ca expertise.

After settling down quite nicely with MM3 and replacing the M-Audio Transit with a Hiface, I thought I'd look at JRMC on the strength of the new Header on the homepage here at CA.

I wasn't entirely happy with some things with MM3 like navigating the interface and the handling of

gapless etc, except that latter part is more due to my ignorance I fear. I did however getting it working fine with Steve Monks KS plugin.

Whimsically, I downloaded the 'Trial' version of JRMC.

Initially and strangelly for I know not why, I decided to tinker with the interface and pointed it at my Library even before having a listen. Then went through Chris' "Setup" recommendation.

Selected a track, hit play and nothing. The player is paying the track but there is no audio reaching my ears.

My settings are all as Chris suggested except I made my Hiface the default device in windows(W 7) as my DAC does not display sampling frequency so will not inform me as to the sampling frequency state of the file it is handling.

I have selected WASAPI but when I hit play I get an error message saying something about

"Playback could not be started on the output 'Windows Audio Output API(WAAPI)' using the format '96000 Hz, 24 bits per sample 2 chanels.'

It dispays the same message with 16 bit but just changes it description.

Then says 'This output format may not be supported by your hardware. You can use DSP Studio to change the output to a compatible format'.

It displays the same message when I select ASIO as the output mode.

However, when I select 'DirectSound' I am able to hear music. The same is true when I select 'Wav out' When either of these 2 options are selected the Hiface appears in the 'Output Mode' settings Device drop down. With ASIO selected only the M-Audio device appears. With 'WASAPI' selected,the M2 Hiface appears. But when I ok that and then try and play a track be it 16 bit or 24 bit I get the above error message.

So I guess I have a few queries for anybody(Chris??) with experience of JRMC 14, W7, M2Tech Hiface.

Is it true to say that only with WASAPI selected will I be gettig 'bitperfect'?

What is happening when the other 2 outputs are being used, is there resampling going on?

Is the limitation I'm experiencing as a resut of me using the "Trial version"?

Is the Hiface incompatible with WASAPI/JRMC?

Do I need asio4all ?

Am I going mad?

Mst admit that I like the GUI of JRMC. Maybe more than MM3(which I had no hesitation in buying).

Will be happy to purchase JRMC if I'm sure it is delivering on the quality audio front.

All help and thoughts, as ever are massively appreciated.

 

Regards,

 

Lew

 

Asus Eeebox EB1501 > HiFace > MF Vdac > Naim NAC102/NAP180 > Castle Howard

Link to comment
Share on other sites

Hi,

Try it with ASIO4ALL and then select ASIO in output with ASIO4ALL as the output device. When the ASIO4ALL icon appears in the tray (it will appear once you play a file), click it and select the Hiface device. This should work.

 

Roon Rock | OpticalRendu | EMM Dac | Dartzeel Preamp | Dartzeel Power Amp | Evolution Acoustics Speakers
sOTM Switch | Ansuz USB Cable | Transparent Power Cables | Bertram Speaker Cables | Zeel Interconnects | Dedicated Room | Balanced Power

Link to comment
Share on other sites

Hi,

 

I had exactly the same problem, not being able to get wasapi to work for the hiface in a was that got bitperfect. I have now followed the above instructions and they seem to work. I still have no way of knowing what exactly is happening, because I also don't have a display on my dac (using the Onkyo A-5VL's inbuilt dac with the hiface). The difference I hear is that now the soundstage is much clearer, with voices truly in the middle and instruments clearly located. Thanks for the help.

 

Link to comment
Share on other sites

Hi guys and thanks for the response. I have now installed

ASIO4ALL as suggested and this works fine.

I will check the driver version for the Hiface tonight when I'm home from work.

A question still remains though. Even with Asio4all, am I getting a bit perfect

through put or is the OS(W7) getting it's hands on my lovely Flacs.

If indeed it should work with the Hiface driver and isn't, can anybody run me through

the config again. Like I said, I did follow Chris' recommendations already.

 

Many thanks,

Lew

 

Asus Eeebox EB1501 > HiFace > MF Vdac > Naim NAC102/NAP180 > Castle Howard

Link to comment
Share on other sites

JRMC - ASIO4ALL - Hiface should theoretically be bit perfect.

ASIO bypasses the windows sound drivers as I understand.

The new HIface driver includes a small 'display' program that opens a window giving stream details.

 

JRMC presently does not work directly with Hiface, you have to go through ASIO4ALL or similar.

 

 

Roon Rock | OpticalRendu | EMM Dac | Dartzeel Preamp | Dartzeel Power Amp | Evolution Acoustics Speakers
sOTM Switch | Ansuz USB Cable | Transparent Power Cables | Bertram Speaker Cables | Zeel Interconnects | Dedicated Room | Balanced Power

Link to comment
Share on other sites

I bought a hiFace recently but so far I can't use it with Win 7 64 bit OS.... Win7 32 bit is okay....so my hiFace have been useless for so far.... sigh.... hope they can get those drivers working quick.....

 

Link to comment
Share on other sites

I have windows 7 professional (64 bit) on my laptop and confirm that I am able to use Hiface via ASIO4ALL with driver version 1.02 as well as the new driver 1.03.

 

Roon Rock | OpticalRendu | EMM Dac | Dartzeel Preamp | Dartzeel Power Amp | Evolution Acoustics Speakers
sOTM Switch | Ansuz USB Cable | Transparent Power Cables | Bertram Speaker Cables | Zeel Interconnects | Dedicated Room | Balanced Power

Link to comment
Share on other sites

I recieved my Hiface today and have just finished setting up 2 diferent Vista Computers, both Home Premium, but one is 64 bit, the other is 32 bit. Previously I have had a Musiland 01USD working with both of them and have been able to play 192/24 using WASAPI. The Hiface will not play on either machine at any resolution using WASAPI. I can tell it is doing something because my BDA-1 will light up and lock depending upon the input. The BDA-1 will also switch resolutions as I switch between different songs in my library. I am using the latest version (155) of JRMC on both machines.

 

It is interesting that I can play the test tones in control panel on both machines but not music when using JRMC. JRMC shows that it is playing music according to the little RTA's at the top of the screen. Time to talk to Marco, I guess....

 

Chuck

 

Link to comment
Share on other sites

That's strange, I installed both 1.02 and 1.03 Win7 64bit drivers into my Dell Zino HD and it can't work at all in my J Rivers.

 

I re-format the hdd as I thought maybe I corrupted the window 7 64 bit but it still doesn't work. Install ASIO4ALL and tried.... doesn't work still....

 

I am planning to return the unit back to the shop I bought.... unless they have a solution soon.

 

Link to comment
Share on other sites

There is some information on the Ayre site about setting up J River with Wasapi.

http://www.ayre.com/usb-jriver_setup_vista.htm

 

Apparently the free version (Media Jukebox) does not support Wasapi. Only the paid version does.

 

I tried going on to the J River forums but for some reason my IP is banned which is strange as I have never visited their forums nor posted on them!

 

Roon Rock | OpticalRendu | EMM Dac | Dartzeel Preamp | Dartzeel Power Amp | Evolution Acoustics Speakers
sOTM Switch | Ansuz USB Cable | Transparent Power Cables | Bertram Speaker Cables | Zeel Interconnects | Dedicated Room | Balanced Power

Link to comment
Share on other sites

I have received a driver from Marco at Hiface this morning. It is not a new driver but an older beta driver. I will load it up tonight and see whether or not WASAPI come to life. I will post back when I have results.

 

Chuck

 

Link to comment
Share on other sites

I just installed the 30 day trial J.River Media Center on my laptop running Windows 7 Pro 64bit and confirm that I was able to use the Hiface device through WASAPI.

 

Settings are:

Output Mode: WASAPI

Output Mode Settings: SPDIF Hiface

 

Hiface Driver is the 64bit version of 1.03.

 

Works perfectly. Have played 16/44.1 and 24/192 without a problem. My DAC shows the sample rate.

 

Roon Rock | OpticalRendu | EMM Dac | Dartzeel Preamp | Dartzeel Power Amp | Evolution Acoustics Speakers
sOTM Switch | Ansuz USB Cable | Transparent Power Cables | Bertram Speaker Cables | Zeel Interconnects | Dedicated Room | Balanced Power

Link to comment
Share on other sites

I am trying to use m2tech with j river and asio4all

 

Able to open ASIO4ALL control panel and get the following error message:

 

"Status: Beyond Logic!

 

-> Disable System Sounds in Control Panel!

-> Deactivate unused inputs and outputs!

-> Drivers too old/too new?

-> Computers Hate You!

#87"

 

I am working on a 4 week own windows 7 home edition laptop. Dell 15z model. Downloaded ASIO4ALL and HiFace drivers today.

 

Entertaining, sort of.

 

Tried with Wasapi (the plug in that comes with output package for j river). 16/44 stuff plays, but in direct mode. DAC shows 48, even though the file is 44. Oddly, if I try to play 176 material, DAC shows 176 but there is no sound.

 

Any suggestions?

 

Link to comment
Share on other sites

I uninstalled the current 1.03.141 driver from Hiface and installed what appears to be the original 1.03 driver. It all works now. Every resolution between 44.1 and 192 and all in between. Sounds pretty good, too.

 

I have to thank dtc here at CA because he must have read my post and sent me the driver he had that worked for him. It was the same one that Marco sent me this morning but it was a very nice thing to do. Thanks dtc!

 

All is working well now and it is time for some serious pleasurable listening. The wife and daughter will be out at the Heat basketball game tomorrow night so I will have uninterrupted time to listen. My preliminary judgement is that the Hiface is much better than the Musiland 01USD I previously had. And the Bryston BDA-1 is not too shabby either.

 

Chuck

 

Link to comment
Share on other sites

Wow, looks like the can of worms is truly open.

I quote an email or two from Marco at M2Tech

" Hello Lewis,

I know that WASAPI is a bit difficult to use. But it may be a problem with our driver. Please try the attached beta which is a bit older than the driver you've installed but is said by some customer to work better with WASAPI.

Cheers, Marco "

 

AND

 

"Hi Lewis,

please apologize for answering so late: we have quite a lot of hiFaces around, now, and we're receiving a lot of e-mails...

 

The file which I sent you is a zip which contains a beta driver which is said by many to work even better than the one presently released on the website. You should first manually uninstall any hiFace driver you have in your PC and then open the zip and launch setup32.exe or setup64.exe, depending on your OS (is it a 32 bit-or a 64-bit version?). Thenk you should be able to use WASAPI and JRiver.

Cheers, Marco"

 

The file he sent me can't be opened, it is either corrupt or incomplete or as his suggestion some Antivirus has had some effect on it. He asked me for another email adress and I'm hoping he's resending.

 

Will let you all know.

Just have to say big thankyou to all who have offered help and advice

and also those who are struggling on this new journey, keep trying. ;-)

 

Kind regards,

 

Lew

 

Asus Eeebox EB1501 > HiFace > MF Vdac > Naim NAC102/NAP180 > Castle Howard

Link to comment
Share on other sites

I sent the file off to rtankm and Leo1311 this morning and they have emailed me back saying that they had received it. The file I received was named 'Win7Vista103.zi_'. Once you have copied the file to your hard drive it must be renamed Win7Vista103.zip in order for it to unpack and be usable. If you need the file, let me know.

 

Chuck

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...