Jump to content
ted_b

HQPlayer Linux Desktop and HQplayer embedded

Rate this topic

Recommended Posts

On 8/31/2019 at 6:39 PM, shadowlight said:

@Miska I am going back to using USBStreamer but I cannot seem to get it working.  Here is what I am seeing in the logs

 

output from aplay -L

 

I am seeing "! 2019/08/31 15:28:07 clHQPlayerEngine::Execute(): clReadAudio::Read(): clALSAEngine::Start(): failed to configure and start device" in hqplayerd.log file.  Please let me know if you need a copy of the complete log.  I am having hard time uploading it to the message.

 

Please do not put logs in message, it creates so much noise on the forum.

 

From aplay output it looks like USBStreamer is the only audio device. What distro is this and what are you using for output? Maybe some other process like pulseaudio is keeping the audio device busy.

 


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites
On 8/30/2019 at 8:47 PM, maya said:

Tried build 34, same . 4.11.1-31 no stuttering 

20190831_011114.jpg

 

At least the load distribution looks correct, working as intended...

 


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites
1 minute ago, Miska said:

 

Please do not put logs in message, it creates so much noise on the forum.

 

From aplay output it looks like USBStreamer is the only audio device. What distro is this and what are you using for output? Maybe some other process like pulseaudio is keeping the audio device busy.

 

Sorry, I was hoping to attach just the log file as attachment but forum software was preventing access.

 

Using Ubuntu LTS Bionic server with latest patches installed, along with the latest HQPe version.  Using Win10 based NAA as output connected to Amanero USB interface.

Share this post


Link to post
Share on other sites
5 hours ago, Miska said:

 

Please do not put logs in message, it creates so much noise on the forum.

 

From aplay output it looks like USBStreamer is the only audio device. What distro is this and what are you using for output? Maybe some other process like pulseaudio is keeping the audio device busy.

 

 

Got it working by reverting back to the previous HQPe Config file.  I was using the config file that came with the latest version of HQPe which has the following entry

 

"<input channels="2" device="hw:CARD=USBStreamer,DEV=0" name="USBStreamer @48k" nperiods="4" period_time="100" samplerate="48000" script="amixer -D hw:CARD=USBStreamer sset &apos;miniDSP Clock Selector Clock Source&apos; &apos;miniDSP TOSLINK Clock&apos;"/>"

 

My previous hqplayerd.xml file has the following entry which is working well for me.

 

"<input channels="2" device="hw:CARD=USBStreamer,DEV=0" name="USBStreamer @44.1k" nperiods="4" period_time="100" samplerate="44100"/>"

 

I am wondering if the "&apos" is creating the problme.

Share this post


Link to post
Share on other sites
2 hours ago, shadowlight said:

Got it working by reverting back to the previous HQPe Config file.  I was using the config file that came with the latest version of HQPe which has the following entry

 

I am using USBStreamer on latest HQPe v4.11.2 on Ubuntu 18.04.3 LTS

 

I haven't modified HQPe config file at all.

 

Works fine for me (fed with Chromecast Audio device)

 

image.thumb.png.a3074c57289ea071c655559c4488cc03.png

 

image.thumb.png.2dc42d6f001015b9cf3eac1bbe72bfde.png

Share this post


Link to post
Share on other sites
8 hours ago, shadowlight said:

Got it working by reverting back to the previous HQPe Config file.  I was using the config file that came with the latest version of HQPe which has the following entry

 

"<input channels="2" device="hw:CARD=USBStreamer,DEV=0" name="USBStreamer @48k" nperiods="4" period_time="100" samplerate="48000" script="amixer -D hw:CARD=USBStreamer sset &apos;miniDSP Clock Selector Clock Source&apos; &apos;miniDSP TOSLINK Clock&apos;"/>"

 

My previous hqplayerd.xml file has the following entry which is working well for me.

 

"<input channels="2" device="hw:CARD=USBStreamer,DEV=0" name="USBStreamer @44.1k" nperiods="4" period_time="100" samplerate="44100"/>"

 

I am wondering if the "&apos" is creating the problme.

 

Based on log it seemed to be working correctly. XML needs escaping quotation marks and that's why there is "&apos;". The latter one is missing the script that switches clock sync source to Toslink clock instead of USBStreamer's internal clock. This is necessary to avoid clicks in the sound that are caused by the two clocks running out of sync. However, you can do the sync source selection manually too.

 


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites
6 minutes ago, Miska said:

The latter one is missing the script that switches clock sync source to Toslink clock instead of USBStreamer's internal clock. This is necessary to avoid clicks in the sound that are caused by the two clocks running out of sync.

 

Even with latest HQPe version, it never works for me - it always boots with 'internal clock' and I always need to manually change it using alsamixer. Without access to a Terminal (like sonicTransporter) this would be an issue.

Share this post


Link to post
Share on other sites
11 minutes ago, asdf1000 said:

Even with latest HQPe version, it never works for me - it always boots with 'internal clock' and I always need to manually change it using alsamixer. Without access to a Terminal (like sonicTransporter) this would be an issue.

 

At what point are you checking it out? Script is run at the time when you select the relevant input. So if you want to check it with alsamixer, you need to do it after selecting the input.

 

If the source device connected to USBStreamer is not sending clock, USBStreamer automatically reverts back to internal clock. That's why the script is there and why the setting doesn't stick. So it is better to first start playback to the USBStreamer and then select input, not vice versa...

 


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites
Just now, Miska said:

At what point are you checking it out? Script is run at the time when you select the relevant input.

 

The only way I am able to select USBstreamer as an input is before I have Tidal play to Chromecast Audio.

 

If I already have Tidal playing to Chromecast Audio then I'm not able to select USBStreamer as input.

 

So I select USBStreamer input first, then play Tidal to Chromecast Audio and then I check alsamixer and it is internal clock.

 

But this is the only sequence I have found to be able to select USBStreamer input.

 

Is there a sequence that works for you that I can try?

 

 

Share this post


Link to post
Share on other sites
55 minutes ago, asdf1000 said:

The only way I am able to select USBstreamer as an input is before I have Tidal play to Chromecast Audio.

 

If I already have Tidal playing to Chromecast Audio then I'm not able to select USBStreamer as input.

 

So I select USBStreamer input first, then play Tidal to Chromecast Audio and then I check alsamixer and it is internal clock.

 

But this is the only sequence I have found to be able to select USBStreamer input.

 

Is there a sequence that works for you that I can try?

 

OK, problem is a bug (or "feature") in the USBStreamer firmware...

 

Problem for the failure is this:

[ 2644.137579] usb 1-7: 2:1: freq mismatch (RO clock): req 44100, clock runs @192000

 

So USBStreamer is not detecting correct input rate, but instead sticks to what ever rate has been on the USB interface, and then switching clock sync source makes sampling rate read-only property. Thus HQPlayer cannot anymore change it to 44.1k... Solution is to switch to internal clock first, start the device and then switch to Toslink clock after starting the device.

 

There is now updated build 35 (for Bionic) with feature to have two scripts and the default configuration has been updated to reflect this for USBStreamer.

 


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites
1 hour ago, Miska said:

There is now updated build 35 (for Bionic) with feature to have two scripts and the default configuration has been updated to reflect this for USBStreamer.

 

Just installed.

 

Works well! Thanks Jussi!

 

Hopefully miniDSP can fix this bug

Share this post


Link to post
Share on other sites
On 9/2/2019 at 12:05 AM, Miska said:

 

At least the load distribution looks correct, working as intended...

 

Same machine with HQPe 4.11.1 and CPU percentage of usage 

IMG-20190903-WA0006.jpg

Share this post


Link to post
Share on other sites

Hi Miska, is it possible to 'tell' hqplayer to treat 24 /44 and 24/48 files as nx and not 1x? I get stuttering with these bit rates but not with 16/44 and 16/48 files when using asdm7ec @dsd256 and closed form filter (1x). I'd like to use closed form in the 1x drop down menu and a less intensive filter for the nx menu. The problems occur with roon radio mixing different source sampling rates.

Maybe something to keep in mind for future builds? The ability to choose different filters for different formats and source sampling rates would be great.

Thanks!

Share this post


Link to post
Share on other sites
6 hours ago, Luvdac said:

Hi Miska, is it possible to 'tell' hqplayer to treat 24 /44 and 24/48 files as nx and not 1x? I get stuttering with these bit rates but not with 16/44 and 16/48 files when using asdm7ec @dsd256 and closed form filter (1x). I'd like to use closed form in the 1x drop down menu and a less intensive filter for the nx menu. The problems occur with roon radio mixing different source sampling rates.

Maybe something to keep in mind for future builds? The ability to choose different filters for different formats and source sampling rates would be great

 

No, because they are all 1x rate files. If you get stuttering with such, it is something else like slow storage media / source. Once 16- and 24-bit files enter DSP they are all already 64-bit floating point... From the DSP point of view 24/44 and 16/44 look the same since they are same sampling rate.

 

Roon is sometimes sluggish sending media to HQPlayer. I have seen similar when playing Tidal from Roon, but if I play same resolution with Roon from local storage it doesn't happen. I reported it to Roon, but so far they are not doing anything about it because I guess I'm the only one who reported it.

 


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites

Thanks Miska. Understood. So if storage media is the culprit, would shifting to ssd drives alleviate the problem? I don't use tidal or any other OTA streaming medium, btw.

Also I do want to thank you for the EC modulators, brilliant stuff.

Share this post


Link to post
Share on other sites
On 8/12/2019 at 12:29 AM, shadowlight said:

Link to the document

@shadowlight On p 7 of your document, when editing the netplan with nano, how do you get the indentation looking like that? I seem to have screwed mine up and when I try to apply the netplan I get "Error in network definition: expected mapping (check indentation)"

 

thanks! 

Share this post


Link to post
Share on other sites
35 minutes ago, Luvdac said:

Thanks Miska. Understood. So if storage media is the culprit, would shifting to ssd drives alleviate the problem? I don't use tidal or any other OTA streaming medium, btw.

 

I find it unlikely that local storage would have much issues, unless Roon is busy scanning it. External USB discs sometimes can suffer from such, but unlikely SATA ones. You could try playing the content directly with HQPlayer without Roon and see if it makes any difference.

 

The only notable difference here is that 24-bit files are larger than 16-bit ones and thus increase storage traffic. I don't have other explanation...

 

Is Roon on the same computer or different one? IOW, is the content being sent over network or just through "localhost"? If it goes over network, then network issues are also a possibility (more data to send in this case).

 


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites
1 hour ago, craighartley said:

@shadowlight On p 7 of your document, when editing the netplan with nano, how do you get the indentation looking like that? I seem to have screwed mine up and when I try to apply the netplan I get "Error in network definition: expected mapping (check indentation)"

 

thanks! 

I just use 3 spaces to achieve the format.  It took be a bit of trial and error to get the formatting correct.

Share this post


Link to post
Share on other sites
6 minutes ago, shadowlight said:

I just use 3 spaces to achieve the format.  It took be a bit of trial and error to get the formatting correct.

thanks - and what keystrokes are you using to start a new line?

Share this post


Link to post
Share on other sites
1 minute ago, shadowlight said:

Just a return/enter key.

 

sadly I still get the same error message doing it that way with 3 spaces as the indent.

Now I have no network connection and the only thing I can think of doing is reinstalling Ubuntu (which took me a whole day to achieve in the first place!)

Share this post


Link to post
Share on other sites
12 minutes ago, craighartley said:

sadly I still get the same error message doing it that way with 3 spaces as the indent.

Now I have no network connection and the only thing I can think of doing is reinstalling Ubuntu (which took me a whole day to achieve in the first place!)

 

 

Do you have a backup copy of the file that you can restore?  Check the following https://ubuntu.com/blog/ubuntu-bionic-netplan to see if there is another yaml file that you can leverage in the directory.  The link seems to indicate 4 spaces instead of 3.

 

Edit: to get you back up and running again, see if you can get DHCP working so you can listen to music.

Share this post


Link to post
Share on other sites
13 minutes ago, shadowlight said:

 

 

Do you have a backup copy of the file that you can restore?  Check the following https://ubuntu.com/blog/ubuntu-bionic-netplan to see if there is another yaml file that you can leverage in the directory.  The link seems to indicate 4 spaces instead of 3.

 

Edit: to get you back up and running again, see if you can get DHCP working so you can listen to music.

same error message with 4 spaces.

 

same problem if I edit the when I change netplan file back to DHCP!

 

I didn't consciously make a backup and can't locate an automatic backup - although I don't really know how to find one! 

Share this post


Link to post
Share on other sites
On 8/7/2019 at 7:09 PM, sledwards said:

Fixed my issue with installing embedded with CUDA support. Apparently order of install operations matters. This time I completely installed embedded and made sure it was running (CUDA offload was not working). I then installed the latest Nvidia driver files and CUDA offloading came alive. Everything is working great now. Here is CUDA working:

 

+-----------------------------------------------------------------------------+

| NVIDIA-SMI 430.40       Driver Version: 430.40       CUDA Version: 10.1     |

|-------------------------------+----------------------+----------------------+

| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |

| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |

|===============================+======================+======================|

|   0  GeForce RTX 2080    Off  | 00000000:01:00.0 Off |                  N/A |

| 28%   37C    P2    45W / 215W |   1303MiB /  7979MiB |      7%      Default |

+-------------------------------+----------------------+----------------------+

                                                                               

+-----------------------------------------------------------------------------+

| Processes:                                                       GPU Memory |

|  GPU       PID   Type   Process name                             Usage      |

|=============================================================================|

|    0     26000      C   /usr/bin/hqplayerd                          1293MiB |

+-----------------------------------------------------------------------------+

I've got hqpe running (with DHCP!). How do I download the lated NVIDIA driver file please? (GTX 1080)

Share this post


Link to post
Share on other sites
On 8/12/2019 at 1:01 AM, asdf1000 said:

 

@shadowlight and @craighartley .

 

We were just discussing all the steps yesterday from here and onwards:

 

https://audiophilestyle.com/forums/topic/56966-hqplayer4-ec-modulator-tips-and-techniques/?do=findComment&comment=981190

 

Thanks to @k6davis and @sledwards

 

These are the values in the config file to change:

 

Cuda:

Attribute: cuda
Offload part of the processing to GPU using Nvidia CUDA.
Values:
    0 : Disabled
    1 : Enabled
    convolution : Convolution engine only

 

Multicore:

Attribute: multicore Enables multicore processing splitting work to higher number of processing units. Also used with GPU offload. Values:     auto : Automatic configuration     0    : Disabled     1    : Enabled
 

Change values in the config file.

 

Save the changes.

 

Run sudo systemctl restart hqplayerd to restart the server with the changes you just made - or else the web interface will overwrite them.

Is there no equivalent in HQP Embedded for the CUDA auto (greyed) setting in Desktop?

 

Edit: Okay, I've answered my own question; I'd misunderstood that the Desktop greyed out setting is CUDA only for Convolution.

Edited by craighartley

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...