Jump to content
IGNORED

HQPlayer Linux Desktop and HQplayer embedded


ted_b
 Share

Recommended Posts

12 hours ago, Rune said:

sudo apt install nvidia-driver-470
Then CUDA works in HQplayer, but now I got a desktop installed as well which is really annoying, because now my server goes to sleep after 20 minutes. It is only if I login to the desktop and disable sleep it will not go to sleep as long as I log in each time I start the server. So not really headless anymore.

 

Not really sure why it would go to sleep in 20 minutes, since I have two machines with Ubuntu desktop running 24/7 where I login remotely. And these never go to sleep.

 

But anyway, you can disable desktop startup at boot with

sudo systemctl set-default multi-user

 

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to comment
Share on other sites

2 hours ago, Miska said:

sudo systemctl set-default multi-user

 

Thanks, very helpful to know. I used this for both my Roon server (Intel NUC - Ubuntu 20.04 minimal) and HQP NAA (fitlet2 - Linux Mint) for which I typically only access via SSH (PuTTY) and no need for GUI.

Eric


Ubuntu Studio Linux box (i7-9700, 8 cores, 16GB RAM, Intel X520-DA1 NIC, HQP Desktop) > fiber optic > MikroTik CRS305-1G-4S+ > fiber optic > fitlet2 (Linux Mint - HQP NAA) > T+A DAC8 DSD > Rogue Audio DragoN > Klipsch La Scala — digital volume control with HQP via Roon client, DSP with HQP convolution engine, Intel NUC (Roon server)

Link to comment
Share on other sites

16 hours ago, Rune said:

Are there another version than nvidia-dkms-470 that will work with hqplayer embedded?

 

By the way, have you tried installing just the regular Nvidia driver, not from repository but from their installer package. It could work as it shouldn't pull in anything. Of course it is not as "clean" as installing something from a repository, but at least it shouldn't break anything either.

 

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to comment
Share on other sites

22 hours ago, fishflower said:

linux-headers-5.10.42-jl+_5.10.42-jl+-1_amd64.deb is real-time embedded kernel ??

 

It is low-latency kernel. Nvidia driver is not compatible with realtime kernel.

 

19 hours ago, fishflower said:

question

debian 11 + hqplayerd_4.25.2-86amd_amd64.deb : :Segmentation fault!

 

I have not yet built any kernels for Debian 11.

 

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to comment
Share on other sites

6 hours ago, Miska said:

 

Yes... Debian 10 is called "buster" and Debian 11 is called "bullseye". Ubuntu 20.04 is named "Focal Fossa" aka "focal".

 

 
This is the case, used the system installed by'debian-11.0.0-amd64-netinst.iso' ,Standard installation, and then used the package linked to https://www.signalyst.eu/bins/hqplayerd/bullseye/hqplayerd_4.25.2-86amd_amd64.deb, an error occurred::: :Segmentation fault!
The machine is nuc11 i7 pro
 

 
Link to comment
Share on other sites

** Message: 00:02:25.274: Enable UPnP Renderer functionality for interface: auto
** Message: 00:02:25.274: Adding interface 'eno1' for UPnP Renderer
** Message: 00:02:25.292: property updated; volume: 0.95

** (process:3506): WARNING **: 00:02:25.293: clPlayerDaemon::OnNameLost() for 'org.mpris.MediaPlayer2.hqplayerd'
^C
[1]+  Segmentation fault               sudo hqplayerd hq hq

 

Link to comment
Share on other sites

9 minutes ago, fishflower said:

** Message: 00:02:25.274: Enable UPnP Renderer functionality for interface: auto
** Message: 00:02:25.274: Adding interface 'eno1' for UPnP Renderer
** Message: 00:02:25.292: property updated; volume: 0.95

** (process:3506): WARNING **: 00:02:25.293: clPlayerDaemon::OnNameLost() for 'org.mpris.MediaPlayer2.hqplayerd'
^C
[1]+  Segmentation fault               sudo hqplayerd hq hq

 

 

How are you trying to run hqplayerd in first place?

 

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to comment
Share on other sites

28 minutes ago, Miska said:

 

How are you trying to run hqplayerd in first place?

 

sudo apt-get -y update
sudo apt-get -y dist-upgrade
sudo reboot
sudo dpkg -i linux-headers-5.10.42-jl+_5.10.42-jl+-1_amd64.deb
sudo dpkg -i linux-image-5.10.42-jl+_5.10.42-jl+-1_amd64.deb
sudo reboot
sudo apt-get install alsa-utils
sudo apt-get install libflac8 libasound2 libasound2-data libasound2-plugins
sudo dpkg -i libgmpris_2.2.1-7_amd64.deb
sudo apt install libcairo2 libgee-0.8-2 libgssdp-1.2-0 libgupnp-1.2-0 ibgupnp-av-1.0-2 librygel-core-2.6-2 librygel-renderer-2.6-2 libwavpack1 rygel zip unzip
sudo dpkg -i hqplayerd_4.25.2-86amd_amd64.deb
sudo apt install -f
# sudo apt -y --fix-broken install 
sudo hqplayerd hq hq 
    
sudo ps -ef | grep -i hq
sudo systemctl enable hqplayerd
sudo systemctl start hqplayerd
sudo hqplayerd -s usr pass 

i run above

On newly installed debian 11.

------------------ Commands executed later

sudo apt-get install iptables
iptables -I INPUT -p tcp --dport 8088 -j ACCEPT
reboot

sudo apt install net-tools

ifconfig

--------  --------------------   Commands executed later

I don't know why it can be used!!

now ok!! thank you

 

Link to comment
Share on other sites

16 minutes ago, fishflower said:
sudo apt-get -y update
sudo apt-get -y dist-upgrade
sudo reboot
sudo dpkg -i linux-headers-5.10.42-jl+_5.10.42-jl+-1_amd64.deb
sudo dpkg -i linux-image-5.10.42-jl+_5.10.42-jl+-1_amd64.deb
sudo reboot
sudo apt-get install alsa-utils
sudo apt-get install libflac8 libasound2 libasound2-data libasound2-plugins
sudo dpkg -i libgmpris_2.2.1-7_amd64.deb
sudo apt install libcairo2 libgee-0.8-2 libgssdp-1.2-0 libgupnp-1.2-0 ibgupnp-av-1.0-2 librygel-core-2.6-2 librygel-renderer-2.6-2 libwavpack1 rygel zip unzip
sudo dpkg -i hqplayerd_4.25.2-86amd_amd64.deb
sudo apt install -f
# sudo apt -y --fix-broken install 
sudo hqplayerd hq hq 
    
sudo ps -ef | grep -i hq
sudo systemctl enable hqplayerd
sudo systemctl start hqplayerd
sudo hqplayerd -s usr pass 

i run above

On newly installed debian 11.

------------------

sudo apt-get install iptables
iptables -I INPUT -p tcp --dport 8088 -j ACCEPT
reboot

--------

I don't know why it can be used!!

now ok!! thank you

 

 

What is that "sudo hqplayerd hq hq" trying to do and why do you do that?

 

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to comment
Share on other sites

15 minutes ago, Miska said:

 

What is that "sudo hqplayerd hq hq" trying to do and why do you do that?

 

sudo hqplayerd hq hq It was copied from the Internet, some people said it was displaying status.

 

[email protected]:~# sudo hqplayerd hq hq
active locale: C.UTF-8
Signalyst HQPlayer Embedded v4.25.2
Copyright (C) 1998-2021 Jussi Laako / Signalyst. All rights reserved.
^C** Message: 01:01:41.653: quit main loop

 

Link to comment
Share on other sites

1 minute ago, fishflower said:

sudo hqplayerd hq hq It was copied from the Internet, some people said it was displaying status

 

It won't do anything useful... It shouldn't crash either, but in any case remove that step from your set of commands.

 

These are not needed and shouldn't be done

14 minutes ago, Miska said:

sudo apt-get install alsa-utils

sudo apt-get install libflac8 libasound2 libasound2-data libasound2-plugins

 

19 minutes ago, Miska said:

sudo apt install libcairo2 libgee-0.8-2 libgssdp-1.2-0 libgupnp-1.2-0 ibgupnp-av-1.0-2 librygel-core-2.6-2 librygel-renderer-2.6-2 libwavpack1 rygel zip unzip

 

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to comment
Share on other sites

38 minutes ago, fishflower said:

sudo apt-get install iptables
iptables -I INPUT -p tcp --dport 8088 -j ACCEPT

 

This shouldn't be needed either. If you need to do this, then you will have other problems as well, because you have number of other things being blocked by your firewall.

 

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to comment
Share on other sites

24 minutes ago, Miska said:

 

This shouldn't be needed either. If you need to do this, then you will have other problems as well, because you have number of other things being blocked by your firewall.

 

Because I didn’t find it on web:8088

Link to comment
Share on other sites

When I stopped playing without clicking on the web and dialed dac to restart, an error was reported.

[email protected]:~# sudo hqplayerd hq hq 
active locale: C.UTF-8
Signalyst HQPlayer Embedded v4.25.2
Copyright (C) 1998-2021 Jussi Laako / Signalyst. All rights reserved.
ALSA lib pcm_hw.c:1829:(_snd_pcm_hw_open) Invalid value for card
^C** Message: 01:28:10.326: quit main loop

Need me to plug in dac again and It’s hard to restart hq.

now  ok.

 

982179755_QQ20210905012704.jpg.85caa9c84c9dd51da46db45cc17d6e7a.jpg

 

1492352602_QQ20210905014628.jpg.d17cd5b14aa3835724f4172cad590915.jpg

Link to comment
Share on other sites

11 minutes ago, fishflower said:

When I stopped playing without clicking on the web and dialed dac to restart, an error was reported.

[email protected]:~# sudo hqplayerd hq hq 
active locale: C.UTF-8
Signalyst HQPlayer Embedded v4.25.2
Copyright (C) 1998-2021 Jussi Laako / Signalyst. All rights reserved.
ALSA lib pcm_hw.c:1829:(_snd_pcm_hw_open) Invalid value for card
^C** Message: 01:28:10.326: quit main loop

Need me to plug in dac again and It’s hard to restart hq.

now  ok.

 

982179755_QQ20210905012704.jpg.85caa9c84c9dd51da46db45cc17d6e7a.jpg

 

You first start it from the console and then try to restart the service. Since you started it with "&" it is already running in background.

 

Since you are already logged in as "root", you don't need to use "sudo" either.

 

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to comment
Share on other sites

I need some assistance getting my local files set up to play via HQPlayer (I have been using Roon plus HQPlayer to date).  I tried with limited success importing my local files into HQPlayer embedded. I provided the path on my sonicTransporter where all of my files reside. HQPlayer told me to wait 10 seconds, and then ... only 75 of my 1,000+ albums got imported. 

Link to comment
Share on other sites

5 minutes ago, jiminlogansquare said:

I need some assistance getting my local files set up to play via HQPlayer (I have been using Roon plus HQPlayer to date).  I tried with limited success importing my local files into HQPlayer embedded. I provided the path on my sonicTransporter where all of my files reside. HQPlayer told me to wait 10 seconds, and then ... only 75 of my 1,000+ albums got imported. 

I have this setup right now. Is your music on an internal drive inside the sT or USB or NAS?

 

Sometimes it takes a little while for the scan to complete. 

Founder of Audiophile Style

Announcing The Audiophile Style Podcast

Link to comment
Share on other sites

9 hours ago, jiminlogansquare said:

Can I return or redirect the discussion to, how do I use my current convolution filters - which are two-channels and were created by @mitchco using Audiolense - with HQPlayer, which as far as I can see demands that you have separate convolution files for each channel, left and right?

 

You need to split those files into two mono WAVs. For example using free Audacity application.

 

HQPlayer uses mono files, because in complex setups like for example doing multi-channel digital cross-overs it wouldn't be clear which channel in filter file applies to which matrix pipeline.

 

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...