Jump to content
IGNORED

HQPlayer Linux Desktop and HQplayer embedded


Recommended Posts

1 hour ago, Outlaw said:

Okay thanks.So if purchase HQplayer embedded and install HQPlayer OS and down the road purchase a videos card for cuda and install minimal Ubuntu Server install as OS is it covered under same license ? 

 

Yes, if the hardware is otherwise the same, even the hardware fingerprint shouldn't change.

 

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to post
Share on other sites
2 hours ago, hifi25nl said:

At this time driver 460.27.04 is beta. Last Nvidia for linux is 455.45.01

https://www.nvidia.com/download/driverResults.aspx/167671/en-us

 

It is what Nvidia delivers with CUDA 11.2 that is used to build latest HQPlayer Embedded.

 

2 hours ago, hifi25nl said:

The message CUDA offload: all is telling me that CUDA is working with HQPlayer? Or not?

 

It tells about the request, when you start playback you see offload status on front page of web interface if it's active. Or you can see it for HQPlayer player process if you run for example "nvidia-smi -l 10".

 

But definitive answer is in the web interface in Offload column.

 

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to post
Share on other sites

I am making this request for the Italian user Casperx...

 

He has HQPlayer-embedded with option Direct SDM active. His DSD files always play at a higher volume level than PCM files (both local and through Qobuz). Is it possible to overturn this inconvenience? The "6 db gain" option has no effect.

He needs to keep option Direct SDM active.

Link to post
Share on other sites
8 hours ago, WilliamWykeham said:

@Miska using HQPe in Euphony, is there an option to select multicore, and to do so in the same way one would with Desktop (ie grayed or checked?)  I am on the :8089 web interface and can’t find a button for multicore.  

 

Embedded doesn't have it on the web interface, because it is one of the things that is supposed to be configured by the hardware manufacturer. Setting is documented in the readme.txt and can be done by manually editing the configuration file.

 

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to post
Share on other sites
12 hours ago, bibo01 said:

He has HQPlayer-embedded with option Direct SDM active. His DSD files always play at a higher volume level than PCM files (both local and through Qobuz). Is it possible to overturn this inconvenience? The "6 db gain" option has no effect.

He needs to keep option Direct SDM active.

 

Direct SDM locks PCM volume control to -3 dBFS for safety reasons, so that it doesn't go into limiting, but also that you don't get big volume jumps accidentally when switching between DSD and PCM content, since with Direct SDM DSD goes through unprocessed.

 

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to post
Share on other sites
20 minutes ago, Miska said:

 

Direct SDM locks PCM volume control to -3 dBFS for safety reasons, so that it doesn't go into limiting, but also that you don't get big volume jumps accidentally when switching between DSD and PCM content, since with Direct SDM DSD goes through unprocessed.

 

Thanks. Yes, that is what I told him. However, why in his case is DSD volume always higher than PCM? Usually, it's the opposite or at least, with direct sdm, they should be very similar.

Link to post
Share on other sites
1 hour ago, bibo01 said:

Thanks. Yes, that is what I told him. However, why in his case is DSD volume always higher than PCM? Usually, it's the opposite or at least, with direct sdm, they should be very similar.

 

I could almost bet the DAC in question is ESS Sabre based, which applies +6 dB gain to DSD inputs. Thus you could have +3 dB higher DSD levels.

 

Just disable Direct SDM and you'll get volumes in level, plus DSD upsampling.

 

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to post
Share on other sites

There is now build 4.20.1-56 for Ubuntu Focal with experimental support for AMD GPUs. Totally untested, because I'm just waiting for RX 6800 XT to arrive at some point in future. (nowadays, getting a recent CPU/GPU seems to be difficult)

 

It will need some packages from AMD's repositories, so check this out:

https://rocmdocs.amd.com/en/latest/Installation_Guide/Installation-Guide.html

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to post
Share on other sites

@MiskaAround September last year I let you know that an Italian user had setup LMS with Embedded v4.x through the use of UPnPBridge plugin. The only downside was, at the time, to use an old version of the plugin - 0.2.9.5 (2016-09-06).

We suggested you - and you seemed to agree - to get in touch with philippe44ca, the plugin developer, to overcome a couple of problems connected to the use of that old version. 

Have you ever done anything about it? Any development?  

Link to post
Share on other sites
6 hours ago, bibo01 said:

@MiskaAround September last year I let you know that an Italian user had setup LMS with Embedded v4.x through the use of UPnPBridge plugin. The only downside was, at the time, to use an old version of the plugin - 0.2.9.5 (2016-09-06).

We suggested you - and you seemed to agree - to get in touch with philippe44ca, the plugin developer, to overcome a couple of problems connected to the use of that old version. 

Have you ever done anything about it? Any development?  

Yes +1 here. And maybe the new but not old plugin version? I personally wasn't able to find that old plugin myself and philippe44ca wasn't supportive too.

 

Link to post
Share on other sites
On 12/27/2020 at 5:14 PM, bibo01 said:

@MiskaAround September last year I let you know that an Italian user had setup LMS with Embedded v4.x through the use of UPnPBridge plugin. The only downside was, at the time, to use an old version of the plugin - 0.2.9.5 (2016-09-06).

We suggested you - and you seemed to agree - to get in touch with philippe44ca, the plugin developer, to overcome a couple of problems connected to the use of that old version. 

Have you ever done anything about it? Any development?  

@MiskaAny reply?

Link to post
Share on other sites

I don't know why I did it but I 'upgraded' to 4.20.1 and now my CUDA libraries don't init:

*when I downgrade to 4.20.0 it works again ...

 

Ubuntu 20.04.1 5.4.0-58-generic

+-----------------------------------------------------------------------------+

| NVIDIA-SMI 455.32.00    Driver Version: 455.32.00    CUDA Version: 11.1     |

|-------------------------------+----------------------+----------------------+

 

When I play 24/192 log says:

 

 

2020/12/31 15:15:26 Control started from 10.0.11.10:51364
& 2020/12/31 15:15:26 Stop...
& 2020/12/31 15:15:27 Playlist clear
& 2020/12/31 15:15:27 Playlist add URI: http://10.0.11.10:9104/bda5e49b84234cdb8cd71d7221b41089/stream.raw
& 2020/12/31 15:15:27 Play
  2020/12/31 15:15:27 Offload: resampler=disabled convolution=disabled
+ 2020/12/31 15:15:27 Playback engine running
  2020/12/31 15:15:27 Rate or blocksize change triggered
  2020/12/31 15:15:27 Rate: 192000, block size: 15360, frame size: 2560
  2020/12/31 15:15:27 Block size: 15360 (sample: 3)
  2020/12/31 15:15:27 Oversampling: sinc (1M taps)
  2020/12/31 15:15:27 Modulator: adaptive seventh order 1-bit ec
  2020/12/31 15:15:27 Integrator: IIR
! 2020/12/31 15:15:27 clHQPlayerEngine::Execute(): clFilterCuda::Init(): CUDA init error 1
  2020/12/31 15:15:27 Stop request (reset)
- 2020/12/31 15:15:27 Playback engine stopped

Custom room treatments for headphone users.

Link to post
Share on other sites
On 12/24/2020 at 1:41 PM, asdf1000 said:

 

Also @Ales Prochazka, when I use USBStreamer "input" of HQP Embedded , I don't have any volume control options in HQPDControl... when I use Roon I do have volume in HQPDControl.

 

Can you allow volume control when using other HQP Embedded inputs ? Like the HQPe web browser allows

 

See attached screenshot

 

IMG_0982.thumb.PNG.6c96989d73d391d881f4bbea1dcac22f.PNG

 

Hi @Ales Prochazka and Happy New Year.

 

I got the latest app update and now I can change matrix profiles from your app - thanks for this!

 

However I still cannot change volume from your app.

 

Would be really great to be able to change matrix profiles (digital room EQ profiles) and volume from the same screen.

 

Is this possible for you to do?

 

Thanks again

 

 

 

 

Link to post
Share on other sites
12 minutes ago, asdf1000 said:

 

Hi @Ales Prochazka and Happy New Year.

 

I got the latest app update and now I can change matrix profiles from your app - thanks for this!

 

However I still cannot change volume from your app.

 

Would be really great to be able to change matrix profiles (digital room EQ profiles) and volume from the same screen.

 

Is this possible for you to do?

 

Thanks again

 

 

 

 

 

Hi and Happy New Year!

 

It's a bit of a problem.
Missing volume control is an error.
Unfortunately, I don't have a USBStreamer and I can't simulate (and fix) this error.
I can't switch the input in HQPlayer. An awkward situation.

Developer of HQPDcontrol.

Link to post
Share on other sites
2 minutes ago, Ales Prochazka said:

 

Hi and Happy New Year!

 

It's a bit of a problem.
Missing volume control is an error.
Unfortunately, I don't have a USBStreamer and I can't simulate (and fix) this error.
I can't switch the input in HQPlayer. An awkward situation.

 

Ok I understand.

 

Is @Miska able to help you at all with this, to try and get it working? 

 

He uses miniDSP USBStreamer too.

 

Link to post
Share on other sites
21 hours ago, Ales Prochazka said:

 

Ok, give me time.
I have a lot of other work to do. I work on HQPDC in my free time.

 

I noticed even when Roon is playing music, i cannot control volume in HQPDC. But I can on HQPe web page.

 

So I wonder if it is fixed for Roon, if it automatically fixes things for all HQPe "inputs" like miniDSP usbstreamer b 

 

Since I'm not asking to change volume of the miniDSP device - I'm asking to change the same volume on HQP Embedded webpage. While the music is playing is the main issue.

Link to post
Share on other sites
On 12/31/2020 at 10:29 PM, jabbr said:

I don't know why I did it but I 'upgraded' to 4.20.1 and now my CUDA libraries don't init:

*when I downgrade to 4.20.0 it works again ...

 

Ubuntu 20.04.1 5.4.0-58-generic

+-----------------------------------------------------------------------------+

| NVIDIA-SMI 455.32.00    Driver Version: 455.32.00    CUDA Version: 11.1     |

|-------------------------------+----------------------+----------------------+

 

You need to have Nvidia driver >= 460.27 for CUDA 11.2 support to work.

 

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to post
Share on other sites
14 hours ago, Miska said:

 

You need to have Nvidia driver >= 460.27 for CUDA 11.2 support to work.

 

 

Aha,

 

The highest driver level reported in

 

$ ubuntu-drivers devices

 

is nvidia-driver-455

 

Its possible to add 

sudo add-apt-repository ppa:graphics-drivers/ppa

 

and get the experimental/beta drivers

alternatively the driver can be downloaded from the nvidia site and installed.

 

(just so folks know)

 

Custom room treatments for headphone users.

Link to post
Share on other sites

Hi all hq fans.

I'm trying to get the latest hqplayer to work on a simple win 10 machine  that will be connected to a antipodes dx,the thing is that i can't get the hqplayer to start on the win 10 machine,all i get is hqplayer4 won't start,any ideas ??

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...