Jump to content
IGNORED

microRendu & LMS


MrUnderhill
 Share

Recommended Posts

Hi Jesus,

 

I have been using LMS & Squeezelite for a number of months, and had become a bit dissatisfied. A few nights ago I realised that in solving one problem I had set a poor configuration, and that my WAV files were streaming as flac. I reset the config and regained my composure.

 

This made me consider Quboz, which provides files as flac.

 

Please can you confirm:

 

1. Are the flac streams being unpacked on the mR; and

2. Is there any specific format of PCM that the mR requires (little endian et al).

 

I can then play with the LMS config.

 

Thx,

 

M

Link to comment
Share on other sites

Seeking help!

 

I am trying to stream Quboz files (flac) to my microRendu (mR) as PCM. They do stream as flac, but I have found that with my local files they sound better as PCM, and stream in this format.

 

I have LMS installed on my Synology NAS, and have the current settings for File Types:

 

FLAC: All disabled, apart from PCM > flac/sox

WAV: All disabled, apart from PCM > native

 

 

The only change to the mR Squeezelite settings I have made is to set a 2000ms buffer.

 

When a try and play a Quboz file it appears to try for three seconds before just stopping. Looking in the server logs, with player.source set to debug I see:

 

[17-02-13 09:40:26.0510] Slim::Player::TranscodingHelper::enabledFormat (212) Testing flc-aif-*-* vs flc-aif-*-*

[17-02-13 09:40:26.0516] Slim::Player::TranscodingHelper::enabledFormat (216) ** flc-aif-*-* Disabled **

[17-02-13 09:40:26.0521] Slim::Player::TranscodingHelper::checkBin (231) Checking formats for: flc-pcm-squeezelite-00:52:1c:61:ac:76

[17-02-13 09:40:26.0527] Slim::Player::TranscodingHelper::checkBin (231) Checking formats for: flc-pcm-*-00:52:1c:61:ac:76

[17-02-13 09:40:26.0532] Slim::Player::TranscodingHelper::checkBin (231) Checking formats for: flc-pcm-squeezelite-*

[17-02-13 09:40:26.0538] Slim::Player::TranscodingHelper::checkBin (231) Checking formats for: flc-pcm-*-*

[17-02-13 09:40:26.0543] Slim::Player::TranscodingHelper::enabledFormat (198) Checking to see if flc-pcm-*-* is enabled

[17-02-13 09:40:26.0549] Slim::Player::TranscodingHelper::enabledFormat (206) There are 3 disabled formats...

[17-02-13 09:40:26.0554] Slim::Player::TranscodingHelper::enabledFormat (212) Testing flc-aif-*-* vs flc-pcm-*-*

[17-02-13 09:40:26.0559] Slim::Player::TranscodingHelper::enabledFormat (212) Testing flc-flc-*-* vs flc-pcm-*-*

[17-02-13 09:40:26.0565] Slim::Player::TranscodingHelper::enabledFormat (212) Testing wav-flc-*-* vs flc-pcm-*-*

[17-02-13 09:40:26.0570] Slim::Player::TranscodingHelper::checkBin (239) enabled

[17-02-13 09:40:26.0575] Slim::Player::TranscodingHelper::checkBin (241) Found command: [flac] -dcs $START$ $END$ -- $FILE$ | [sox] -q -t wav - -t wav - -b 24 -r 96k

[17-02-13 09:40:26.0581] Slim::Player::TranscodingHelper::getConvertCommand2 (361) Rejecting [flac] -dcs $START$ $END$ -- $FILE$ | [sox] -q -t wav - -t wav - -b 24 -r 96k because no available stream mode supported: R

 

Before noting:

[17-02-13 09:40:26.0651] Slim::Player::TranscodingHelper::checkBin (264) couldn't find binary for: lame

[17-02-13 09:40:26.1100] Slim::Player::TranscodingHelper::getConvertCommand2 (425) Error: Didn't find any command matches for type: flc

 

It then runs round a similar loop ending with:

 

[17-02-13 09:40:26.1025] Slim::Player::TranscodingHelper::getConvertCommand2 (361) Rejecting [flac] -dcs $START$ $END$ -- $FILE$ | [sox] -q -t wav - -t wav - -b 24 -r 96k because no available stream mode supported: I,R

 

Thoughts

LAME is not installed on the Synology as part of the LMS package.

Is this a problem on the Synology OR within the Squeezelite client on the microRendu?

 

Any pointers gratefully received.

 

M

Link to comment
Share on other sites

Update:

 

I installed LAME on the NAS. This just effects MP3!

 

In the custom-convert.conf I have:

flc pcm * *

# FT:{START=--skip=%t}U:{END=--until=%v}

[flac] -dcs $START$ $END$ -- $FILE$ | [sox] -q -t wav - -t wav - -b 24 -r 96k

where the first line is:

flc\tpcm\t*\t*

I did use spaces initially, but that barfed. All other spaces are that, spaces.

 

M

Link to comment
Share on other sites

  • 1 month later...
Apparently LMS cannot stream remote flac files as PCM.

Sorry, late to the party, but LMS can certainly do that. I use LMS server side and that choice is controlled by configuration in Web Control.

 

Web Control-->Advanced-->File Types

 

For FLAC file type, choose "Flac-disabled" and "PCM-Native"

 

You can verify operation by running task manager. In addition to the LMS server process. you will find a FLAC process for each player running.

Link to comment
Share on other sites

The only options for FLAC > PCM that I have are: Disabled; and, flac.

Hmmm. For years, I chose what you seek by sending the full PCM signal to my SBT. Now that I have gigaflop capability uRendu and RPi players, I changed it to send the compressed stream and let the renderer do the minor work given their ability.

Sorry, the correct settings are:

 

And this editor doesn't allow me to remove a previous image! Arraghhhhh! Refer to the second image.

flac.jpg

flac.jpg

Link to comment
Share on other sites

I have found in my system, in which I also use the mR, that PCM simply sounds better. Historically, with other hardware I have heard no difference.

 

Do you think that the options that are presented are dependent upon the downstream hardware/Squeezelite?

 

M

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...