Jump to content
IGNORED

Odd muting with some files...


Recommended Posts

My DAC's USB input handles both PCM and DSD (EmmLabs XDS1v2, 192/64 max respectively).

 

With some recordings with deep bassy notes - eg the song "Dangerous" from The xx's latest album "I see you", the DAC mutes intermittently at some points. I think it is because the PCM stream is such that it makes the DAC think the input suddenly switched to a DSD stream encoded in DoP.

 

This happens both with the untouched redbook file and the upsampled file (to 176, by HQP). If I upsample to DSD in HQP it does not happen.

 

Anyone seen this? Cures?

 

Thx.

mini+Roon > dCS Rossini DAC + Rossini Master Clock 

SME 20/3 + SME V + Dynavector XV-1s > vdH The Grail

Audio Note Kondo Ongaku > Avantgarde Duo Mezzo G2

system pics

Link to comment
Share on other sites

My DAC's USB input handles both PCM and DSD (EmmLabs XDS1v2, 192/64 max respectively).

 

With some recordings with deep bassy notes - eg the song "Dangerous" from The xx's latest album "I see you", the DAC mutes intermittently at some points. I think it is because the PCM stream is such that it makes the DAC think the input suddenly switched to a DSD stream encoded in DoP.

 

This happens both with the untouched redbook file and the upsampled file (to 176, by HQP). If I upsample to DSD in HQP it does not happen.

 

Anyone seen this? Cures?

 

Thx.

@Miska... You must know... :)

mini+Roon > dCS Rossini DAC + Rossini Master Clock 

SME 20/3 + SME V + Dynavector XV-1s > vdH The Grail

Audio Note Kondo Ongaku > Avantgarde Duo Mezzo G2

system pics

Link to comment
Share on other sites

I think it is because the PCM stream is such that it makes the DAC think the input suddenly switched to a DSD stream encoded in DoP.

 

This happens both with the untouched redbook file and the upsampled file (to 176, by HQP).

Your 'sudden switch to DoP' theory doesn't make sense for 16/44.1kHz red book as there's no top 8 bits to place the DSD marker required for DoP. Even for 176.4kHz upsampled file, assuming you're getting 24 bit depth, it would have to be some amazing coincidence for the top 8 bits to be interpreted by the DAC as DSD markers!

 

What can happen is the other way around, ie, a DoP stream interpreted as 'normal' PCM instead of requiring decoding to DSD, because the DSD markers are corrupted.

We will win because our NHS is the beating heart of this country. It is the best of this country. It is unconquerable. It is powered by love.

-- Boris Johnson

 

We are far more united and have far more in common with each other than things that divide us.

-- Jo Cox

Link to comment
Share on other sites

Your 'sudden switch to DoP' theory doesn't make sense for 16/44.1kHz red book as there's no top 8 bits to place the DSD marker required for DoP. Even for 176.4kHz upsampled file, assuming you're getting 24 bit depth, it would have to be some amazing coincidence for the top 8 bits to be interpreted by the DAC as DSD markers!

Yes you're right - I must have heard this off of HQP upsampling only (16/44 -> 24/176).

 

What can happen is the other way around, ie, a DoP stream interpreted as 'normal' PCM instead of requiring decoding to DSD, because the DSD markers are corrupted.
This is not what I have experienced as the stream was PCM (24/176) out of HQP. When I set HQP to upsample 16/44 to DSD64 I did not hear this muting. Just to be clear, it is perfectly repeatable.

mini+Roon > dCS Rossini DAC + Rossini Master Clock 

SME 20/3 + SME V + Dynavector XV-1s > vdH The Grail

Audio Note Kondo Ongaku > Avantgarde Duo Mezzo G2

system pics

Link to comment
Share on other sites

Ok, in which case you need to take this up with @Miska, as it's his software that's doing the upsampling. I suppose it's conceivable for there to be some sort of bug that corrupts the top 8 bits of the 24/176.4 PCM signal with DoP DSD markers in short bursts - anything is possible in error.

We will win because our NHS is the beating heart of this country. It is the best of this country. It is unconquerable. It is powered by love.

-- Boris Johnson

 

We are far more united and have far more in common with each other than things that divide us.

-- Jo Cox

Link to comment
Share on other sites

Ok, in which case you need to take this up with @Miska, as it's his software that's doing the upsampling. I suppose it's conceivable for there to be some sort of bug that corrupts the top 8 bits of the 24/176.4 PCM signal with DoP DSD markers in short bursts - anything is possible in error.

Is it not possible to have a tone/music that results in DoP-looking markers for the 8 MSBs?

 

 

 

This is a very rare occurrence, it happens with a the song I mentioned as well as a few tracks in Moby's Long Ambients. In all cases it is a sound like a very deep and full synthesizer sound that triggers it. It is rare but it is there and it is annoying.

mini+Roon > dCS Rossini DAC + Rossini Master Clock 

SME 20/3 + SME V + Dynavector XV-1s > vdH The Grail

Audio Note Kondo Ongaku > Avantgarde Duo Mezzo G2

system pics

Link to comment
Share on other sites

Anything's possible as a coincidence, but it'll need to be alternating between 0x05 and 0xFA as the value of those bits, every sample, for both channels!

DoP open Standard | DSD-Guide.com

 

Also, given that it is a possibility, however unlikely, if HQPlayer is aware of the connected DAC supporting DoP, should it not be filtering those 'confusing' samples in some way to avoid the switch to DSD?

We will win because our NHS is the beating heart of this country. It is the best of this country. It is unconquerable. It is powered by love.

-- Boris Johnson

 

We are far more united and have far more in common with each other than things that divide us.

-- Jo Cox

Link to comment
Share on other sites

Sounds like really strange behavior, I have not seen or heard about such before. I don't know how this particular DAC does DoP detection, but the recommendation is to check at least 32 subsequent samples before switching to DSD mode... And it should happen for both channels.

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to comment
Share on other sites

Anything's possible as a coincidence, but it'll need to be alternating between 0x05 and 0xFA as the value of those bits, every sample, for both channels!

Yes, I'm aware.

 

Also, given that it is a possibility, however unlikely, if HQPlayer is aware of the connected DAC supporting DoP, should it not be filtering those 'confusing' samples in some way to avoid the switch to DSD?

That's interesting... It would have to really make sure every time it produces a 0x05 in the 8MSBs, it never produces a 0xFA in the next (ie would have to change that next sample). Wouldn't this mean that it could introduce distortion if it does something like this? Especially since they are the MSBs.

 

I have no idea how the USB interface determines that it is a DoP marker. I imagine it doesn't just switch on the first pair 0x05/0xFA it depects but waits for a few to replicate the pattern before it switches. I don't know but that would make sense to me.

mini+Roon > dCS Rossini DAC + Rossini Master Clock 

SME 20/3 + SME V + Dynavector XV-1s > vdH The Grail

Audio Note Kondo Ongaku > Avantgarde Duo Mezzo G2

system pics

Link to comment
Share on other sites

If it happens with only with few certain tracks, I think the most likely explanation is that some DC detection is triggering the mute...

Yes it's very rare and I never really made much of it. It has happened while connected to my mini directly (a long while back) and now with the microRendu. But like I said, only a few tracks.

 

 

Heavy clipping of very low frequencies may also do the same. I assume you have HQPlayer volume set to -3 dBFS?

Yes, this happens with certain lower notes from synthesizers played very loud in the track. In HQP I have "Direct SDM" checked, so this would in principle add a -3dBFS correction. HQP's volume is set to zero (ie max).

mini+Roon > dCS Rossini DAC + Rossini Master Clock 

SME 20/3 + SME V + Dynavector XV-1s > vdH The Grail

Audio Note Kondo Ongaku > Avantgarde Duo Mezzo G2

system pics

Link to comment
Share on other sites

If it happens with only with few certain tracks, I think the most likely explanation is that some DC detection is triggering the mute...

 

Heavy clipping of very low frequencies may also do the same. I assume you have HQPlayer volume set to -3 dBFS?

Actually, I recall that the track "Dangerous" mentioned above is the 24/96 version from HDTracks. It would have been upsampled by HQP to 192 according to my configs.

 

However, in all cases it is tracks with clipping low bass synths that do this. Moby's Long Ambients (track 2 and 3 IIRC) as well.

mini+Roon > dCS Rossini DAC + Rossini Master Clock 

SME 20/3 + SME V + Dynavector XV-1s > vdH The Grail

Audio Note Kondo Ongaku > Avantgarde Duo Mezzo G2

system pics

Link to comment
Share on other sites

However, in all cases it is tracks with clipping low bass synths that do this. Moby's Long Ambients (track 2 and 3 IIRC) as well.

 

OK, I think this is just some DC output detection in the DAC seeing high level long clipped period -> DC voltage and deciding to protect downstream equipment by muting the output. Seems to be quite sensitive though, which is not necessarily a bad thing.

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to comment
Share on other sites

OK, I think this is just some DC output detection in the DAC seeing high level long clipped period -> DC voltage and deciding to protect downstream equipment by muting the output. Seems to be quite sensitive though, which is not necessarily a bad thing.

Thx @Miska

EmmLabs is taking a look.

mini+Roon > dCS Rossini DAC + Rossini Master Clock 

SME 20/3 + SME V + Dynavector XV-1s > vdH The Grail

Audio Note Kondo Ongaku > Avantgarde Duo Mezzo G2

system pics

Link to comment
Share on other sites

Thx @Miska

EmmLabs is taking a look.

Hi @Miska,

 

Here's a reproducible case: Dangerous (the 24/96 track) upsampled with HQPlayer to 24/196 (poly-sinc-short or poly-sinc-short-mp filters, TPDF dither). I have created a chopped version of the first 50 seconds or so. Here’s the link:

 

https://drive.google.com/file/d/0B5a3izile414YkZlRUZVSFJlZEk/view?usp=sharing

 

In my DAC I get muting at 12s and 32s.

mini+Roon > dCS Rossini DAC + Rossini Master Clock 

SME 20/3 + SME V + Dynavector XV-1s > vdH The Grail

Audio Note Kondo Ongaku > Avantgarde Duo Mezzo G2

system pics

Link to comment
Share on other sites

Hi @Miska,

 

Here's a reproducible case: Dangerous (the 24/96 track) upsampled with HQPlayer to 24/196 (poly-sinc-short or poly-sinc-short-mp filters, TPDF dither). I have created a chopped version of the first 50 seconds or so. Here’s the link:

 

https://drive.google.com/file/d/0B5a3izile414YkZlRUZVSFJlZEk/view?usp=sharing

 

In my DAC I get muting at 12s and 32s.

 

OK, at least plays cleanly on iFi iDSD Micro Black Label with those settings (HQPlayer volume set to -3 dBFS). Audacity doesn't even indicate clipping and what I looked on Audacity those places don't look like visually clipping either. So something else is going on.

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to comment
Share on other sites

OK, at least plays cleanly on iFi iDSD Micro Black Label with those settings (HQPlayer volume set to -3 dBFS). Audacity doesn't even indicate clipping and what I looked on Audacity those places don't look like visually clipping either. So something else is going on.

Ok, thx. HQP's -3dBFS you state... Coming from selection "Direct SDM" or are you actually making the volume -3dBFS?

mini+Roon > dCS Rossini DAC + Rossini Master Clock 

SME 20/3 + SME V + Dynavector XV-1s > vdH The Grail

Audio Note Kondo Ongaku > Avantgarde Duo Mezzo G2

system pics

Link to comment
Share on other sites

Ok, thx. HQP's -3dBFS you state... Coming from selection "Direct SDM" or are you actually making the volume -3dBFS?

 

When you are upsampling to PCM, that setting doesn't matter. It only applies when output is set to SDM mode. Anyway, I have Direct SDM disabled, so DSD etc get upsampled too.

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to comment
Share on other sites

When you are upsampling to PCM, that setting doesn't matter. It only applies when output is set to SDM mode. Anyway, I have Direct SDM disabled, so DSD etc get upsampled too.

Ok. So to confirm, you SET the volume control to -3?

mini+Roon > dCS Rossini DAC + Rossini Master Clock 

SME 20/3 + SME V + Dynavector XV-1s > vdH The Grail

Audio Note Kondo Ongaku > Avantgarde Duo Mezzo G2

system pics

Link to comment
Share on other sites

Ok. So to confirm, you SET the volume control to -3?

 

Yes, prevents intersample overs in PCM->DSD conversion.

 

Edit: Speaking of that setting, not big volume knob.

 

 

Sent from my iPhone using Computer Audiophile

One never knows, do one? - Fats Waller

The fairest thing we can experience is the mysterious. It is the fundamental emotion which stands at the cradle of true art and true science. - Einstein

Computer, Audirvana -> optical to EtherREGEN -> microRendu -> ISO Regen -> Pro-Ject Pre Box S2 DAC -> Spectral DMC-12 & DMA-150 -> Vandersteen 3A Signature.

Link to comment
Share on other sites

Ok. So to confirm, you SET the volume control to -3?

 

Yes, I have the range set from -6 to 0 and thus keep the volume set to 12 clock position and thus -3 dBFS.

 

DirectSDM enforces this for PCM-to-DSD case for other reason which is to avoid volume surprises when switching to bit-perfect DSD track playback for example when you have a playlist with mixed PCM and DSD content.

 

For PCM output mode, the volume control is always active so you need to do it manually one way or the other.

 

But in any case, there's the "Limited" indication counter in main window so you know if the internal limiter is triggered.

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to comment
Share on other sites

I have HQP set to-5dB max and I still get an indication of 5 overs on a cut from Big Big Train -English Electric! My McIntosh D150 doesn't mute, though. Miggy, try setting the volume limit down more and see if it happens.

 

 

Sent from my iPad using Computer Audiophile

Link to comment
Share on other sites

Yes, I have the range set from -6 to 0 and thus keep the volume set to 12 clock position and thus -3 dBFS.

 

DirectSDM enforces this for PCM-to-DSD case for other reason which is to avoid volume surprises when switching to bit-perfect DSD track playback for example when you have a playlist with mixed PCM and DSD content.

 

For PCM output mode, the volume control is always active so you need to do it manually one way or the other.

 

But in any case, there's the "Limited" indication counter in main window so you know if the internal limiter is triggered.

 

@Miska: Would it be possible for you to capture the output of this file out of the HQP upsampling with no volume limiting? I would like to send EmmLabs a clean reproducible case, there's something in the upsampled version the way I have it configure that is triggering the muting.

 

Exported settings: https://drive.google.com/file/d/0B5a3izile414UF9zY0I0OFliNGc/view?usp=sharing

 

 

Thank you.

mini+Roon > dCS Rossini DAC + Rossini Master Clock 

SME 20/3 + SME V + Dynavector XV-1s > vdH The Grail

Audio Note Kondo Ongaku > Avantgarde Duo Mezzo G2

system pics

Link to comment
Share on other sites

@Miska: Would it be possible for you to capture the output of this file out of the HQP upsampling with no volume limiting? I would like to send EmmLabs a clean reproducible case, there's something in the upsampled version the way I have it configure that is triggering the muting.

 

Exported settings: https://drive.google.com/file/d/0B5a3izile414UF9zY0I0OFliNGc/view?usp=sharing

 

Since this has DAC bits as "Default", I'm not sure how many bits the DAC uses, is it 24 or 32?

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...