Jump to content
IGNORED

Tidal Windows bug prevents MQA


Mark Dirac
 Share

Recommended Posts

There is a bug in the Tidal Windows app v2.1.2, which may explain why so many people cannot hear the difference between "Masters" and "HiFi" tracks. Others on various forums have reported not-dissimilar problems.

 

The app often "forgets" my selection in "Settings/Streaming" for "Exclusive Mode", and flips back to "System Default" - and then only 16bit/44.1kHz is output. There is sometimes a message "TIDAL requires you to set your system sound settings in Control Panel to 16bit, 44100 Hz (CD Quality) in order to play tracks correctly" - this, even though my Windows is set to 16/44.1.

 

Whenever I play a "HiFi" track this happens. It is then difficult to get the system back to Exclusive Mode. Sleeping the PC is a workaround for me.

 

When I can get Exclusive Mode engaged, my DAC correctly displays 24/88.2 or 24/96 (for Masters tracks). But when Tidal flips back to "System Default" my DAC displays 16/44.1 (for Masters tracks).

 

How many others have this problem? Does anyone have any workarounds to suggest?

Remarkably, I see this on two different W10 PCs with three different DACs, and in different locations. (Suggesting this bug is nothing to do with my PC or my DAC or my network.)

 

In Britain. Tidal Support have sent me a possible fix - but it doesn't work.

Link to comment
Share on other sites

I have been waiting since October 2016 - long before MQA was available - but Tidal could never fix it. I gave up because my DAC still played fairly well with Tidal flipped back to "System Default". But now that MQA is available it has become a big problem, 'cos you cannot get MQA decoding with Tidal set to System Default.

Link to comment
Share on other sites

Mark I have a tentative workaround, but it involves old model hardware that you might not be able to lay your hands on. Sorry.

 

I am using an mAudio Transit DAC/ External Sound card as a USB to SPDIF converter. I have disabled all on board audio and set the Transit as default device in the Control Panel.

 

Tidal's desktop app still jumps between the Transit explicitly and Default but it appears not to matter, the Transit's control panel says it is streaming 24/96 regardless.

 

I appear to get it to "stick" to the Transit setting by changing devices whilst music is playing. But not always

 

Matthew

 
" The greatest obstacle to discovery is not ignorance--it is the illusion of knowledge." Daniel.J.Boorstin
 
Link to comment
Share on other sites

Thanks s. And if you play a "HiFi" track, does the Transit continue to display 24/96? It should display 16/44.1 when streaming a "HiFi" track straight out USB in Exclusive Mode.

 

I am wondering if, since System Default means you are streaming through Windows's audio processing, whether the Transit is simply displaying your Windows "Default Format" which you have set in the Speakers Properties/Advanced control panel?

Link to comment
Share on other sites

  • 2 weeks later...

I finally received a non-trivial response from Tidal, after about 3 months:

 

 

the issue you have been experiencing is a known issue. A fix is currently being developed and will be released after the next hotfix.

 

 

I am not happy with Tidal support. There's nothing unusual, odd or incorrect about my computer, but they've not been very interested in helping.

 

 

I wrote back: Please give me an indication when - days, weeks or months - please. I have spent many hours trying to find a fix or workaround for this myself. I have striven to submit detailed, lucid and unambiguous problem reports to assist Tidal. The inconvenience has been massive. Given this, I think it reasonable for Tidal to take at least a teeny tiny bit of trouble to try and give me some estimate as to when the fix will be delivered.

 

 

... but they refused.

Link to comment
Share on other sites

I finally received a non-trivial response from Tidal, after about 3 months:

 

 

the issue you have been experiencing is a known issue. A fix is currently being developed and will be released after the next hotfix.

 

 

I am not happy with Tidal support. There's nothing unusual, odd or incorrect about my computer, but they've not been very interested in helping.

 

 

I wrote back: Please give me an indication when - days, weeks or months - please. I have spent many hours trying to find a fix or workaround for this myself. I have striven to submit detailed, lucid and unambiguous problem reports to assist Tidal. The inconvenience has been massive. Given this, I think it reasonable for Tidal to take at least a teeny tiny bit of trouble to try and give me some estimate as to when the fix will be delivered.

 

 

... but they refused.

 

Tidal got (or will be getting soon) a much needed infusion of cash from Sprint. What you're experiencing is not necessarily incompetence or apathy, it's more like not being able to afford to pay the developers. How long have we been waiting for gapless playback on the mobile app? Many months.

 

While I don't condone the miserably low level of Tidal's customer support (I am a HiFi subscriber), it's still the only place to get lossless streaming in the U.S., and monopolistic indifference is inevitable.

Link to comment
Share on other sites

What a hell of a way to rollout MQA! Put it on a large platform where a lot of people will try it and it doesn't work. Worse yet, it plays but not decoded so no one will hear the difference. If I was at MQA Corp I would be furious. Partly this is their problem as this should have been better tested and fixed before release.

Link to comment
Share on other sites

Hard luck Bob. Have you found a workaround? Does my "sleep/resume" workaround work for you?

Thanks Mark, This is a problem for me only on my desktop system (which I use mainly to preview). On my main system I use Roon and they will have software decoding of MQA with version 1.3 which should be out very soon. I will just wait for Tidal to fix it. Bob

Link to comment
Share on other sites

  • 2 weeks later...

I had this problem with my Arcam rPAC until I upgraded both the USB drivers and my DAC firmware. The combination of the two fixed the problem. I suspect the issue is the USB drivers not handling the sample rate changing all the time. Or perhaps not supporting exclusive mode at all. Once I did my upgraded, all the problems went away.

 

To clarify: by upgrading I mean I went to the Arcam website and downloaded and installed the latest drivers, rather than using Windows update etc.

Link to comment
Share on other sites

Guys I think I sorted out the bug!!! Just registered to tell you, as there is no solution to be found online easily...

 

I run tidal in my home studio setup, my dac is a fireface uc.

 

So I downloaded VB audio asio bridge + hifi cable here -check the bottom of the page-

 

VB-Audio Virtual Apps

 

The thing is that Tidal cannot 'grab' the fireface asio driver exclusively, or whatever dac driver, so it resets back to system default input, not good.

 

So instead, choose the new 'hi-fi cable input' in streaming options in Tidal, choosing exclusive mode and force volume. From the vb audio app client, select your asio interface.... and BOOM! Now Tidal recognises the interface, and changes sample rates accordingly when playing MASTER qualitiy material -eg 96khz with Good Times, Bad Times- and goes back to 44/16 for regular Hifi.

 

I was looking for something like this to bypass the ugly WDM mixer sound for all system sounds, not only audio apps.

Link to comment
Share on other sites

smartin - what leads you to believe it is a driver issue, and not a Tidal issue?

 

Well, it may not be a driver issue, but it's not a Tidal issue. Tidal doesn't know or care what type of DAC or USB controller you use. It communicates with the driver using standard protocols. If the drivers are written correctly, and there is no physical problem with the connection, everything works (like in the case of the 4 DACs I've used, and in the cases above where updating the drivers resolved the problem).

 

What you're describing sounds like a sync issue. Tidal remembers the output device, but if it's not there, it will switch to system default. It's like if you launch Tidal with your DAC turned off, it will go to system default, and stay there even if you subsequently turn your DAC on. So, for some reason your DAC is disappearing from Windows (not Tidal, Tidal just sees what Windows sees, nothing special). It could be a driver, it could be a firmware issue with your DAC, or it could be a problem in the way the DAC is connected to the computer. It could be a problem with your USB set up, either with the motherboard controller, or anything you happen to have between the computer and the DAC.

 

Tidal can output to any audio device made available by Windows, it has no special arrangement with them. It counts on Windows to provide access to the device, and in your case, that access is not consistent.

 

EDIT: Since you tried multiple set ups, I would start by looking at what was constant between those unsuccessful trials, did you use the same USB cable, a particular HUB, maybe that's the problem?

Link to comment
Share on other sites

  • 4 weeks later...
Well, it may not be a driver issue, but it's not a Tidal issue. Tidal doesn't know or care what type of DAC or USB controller you use.

 

Fixed! It was a Tidal issue, as their support desk had previously admitted. Fixed after sw update last week to

2.1.3.226 (W: 2.0.3--6) (NP: 2.3.25)

I still suspect there will be many folks out there who have not realised that they have not been listening to MQA all these weeks.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...