Jump to content
IGNORED

Meridian Explorer 2: reliable?


Recommended Posts

With all the MQA hoopla underway, I was toying with the idea of picking up an Explorer 2 to hear MQA hardware decoding for myself. I went over to Amazon and was surprised by the number of people who said their Explorer 2 died after a month or two. It was a significant percentage of all the reviews.

 

Does any one here have one? How long have you had it? How many hours a week do you use it? Anyone here had one die on them?

 

Thanks in advance.

Link to comment
Share on other sites

Does any one here have one? How long have you had it? How many hours a week do you use it? Anyone here had one die on them?

I bought the Explorer 2 when it first came out. It is my first USB DAC so I don't have much of a reference to compare it to except that it is better than my built-in MacBook DAC. No surprise.

 

I use it several hours a week for over a year and have had no problems.

 

I'm listening to Fleetwook Mac "Rumors" with the Explorer 2 and HD650's and I can clearly hear an improvement in Tidal Master quality over HIFI. Clarity improved in the guitar in "Never Going Back Again" for instance.

 

-weldp

Link to comment
Share on other sites

Had previous Explorer 4 since now ,never had a problem .

 

I have Explorer2 since 3 weels :improving image and control ,better mid bass articulation;low volume from headphone ;i was not

 

able to upload firmware which enables Mqa (tried on 2 Pc at least 40 times )

 

People at Meridian are not responsive (see post Meridian Director strange problem )

 

Sounds great ;downside :no counceling from Meridian

Link to comment
Share on other sites

Had previous Explorer 4 since now ,never had a problem .

 

I have Explorer2 since 3 weels :improving image and control ,better mid bass articulation;low volume from headphone ;i was not

 

able to upload firmware which enables Mqa (tried on 2 Pc at least 40 times )

 

People at Meridian are not responsive (see post Meridian Director strange problem )

 

Sounds great ;downside :no counceling from Meridian

 

 

Sorry forget "years"

 

Had previous Exolorer 4 years from now

Link to comment
Share on other sites

Had previous Explorer 4 since now ,never had a problem .

 

I have Explorer2 since 3 weels :improving image and control ,better mid bass articulation;low volume from headphone ;i was not

 

able to upload firmware which enables Mqa (tried on 2 Pc at least 40 times )

 

People at Meridian are not responsive (see post Meridian Director strange problem )

 

Sounds great ;downside :no counceling from Meridian

 

Are you using the latest driver?

 

https://www.meridian-audio.com/wp-content/uploads/2016/11/USB_Win_7_8_10_setup_Nov_20162.pdf

 

It is essential that if you have any Meridian USB drivers earlier than version 3.34.1 already installed, these are completely uninstalled prior to installing the latest version. Failure to do this will interfere with correct use of the latest version.
Link to comment
Share on other sites

I looked back a few pages and saw this post. Firmware version 1717 is what you need to play MQA. No need to update, you're on the latest firmware. So assuming you get the driver issue sorted, you should be good.

 

So kind of you ;yes i know ,and that is the firmware which doesn't go to the end ;program find my explorer and says that there

 

is a factory 717 firmware ;whwn i upload the binary file v1717 it goes on and everything seems ok ;then after few minutes

 

the procedure is aborted saying "failed to upload firmware "or something like that ,and "try again );i 've tried so many

 

times ,unistalling and reinstalling the last driver ;no way ;i think that is the same firmware which allows 6 db more gain

 

to the headphone output .

 

I e-mailed Meridian explainig the issue ;no answer (like they did when i had the firmware issue with Director ;at the end

 

they had to admit there was a problem)

Link to comment
Share on other sites

So kind of you ;yes i know ,and that is the firmware which doesn't go to the end ;program find my explorer and says that there

 

is a factory 717 firmware ;whwn i upload the binary file v1717 it goes on and everything seems ok ;then after few minutes

 

the procedure is aborted saying "failed to upload firmware "or something like that ,and "try again );i 've tried so many

 

times ,unistalling and reinstalling the last driver ;no way ;i think that is the same firmware which allows 6 db more gain

 

to the headphone output .

 

I e-mailed Meridian explainig the issue ;no answer (like they did when i had the firmware issue with Director ;at the end

 

they had to admit there was a problem)

 

I wish I could be more help. I'm using on a Mac with no drivers (USB Audio Class 2).

 

Question: why are you attempting to update the firmware to the version you already have loaded on the E2?

Link to comment
Share on other sites

I do appreciate ;do you think that 717 factory loaded it is the same firmware marked v1717 that they make available

 

on the support section of E2?

 

In this case i will try again with a Mqa file ;any way with Pcm files works great (great sound ,just a notch down Director )

Link to comment
Share on other sites

i do appreciate ;do you think that 717 factory loaded it is the same firmware marked v1717 that they make available

 

on the support section of e2?

 

in this case i will try again with a mqa file ;any way with pcm files works great (great sound ,just a notch down director )

 

yes!!!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...