Jump to content
IGNORED

Help - 13 second song playback delay driving me crazy


Recommended Posts

Can someone please help me? When I change tracks it takes approximately 13 seconds for the new song to start playing. I feel it should be virtually instantaneous. Does anyone have any ideas on how to resolve this latency issue? Below are the facts surrounding my situation:

 

Music is stored on an HDD in a computer running Microsoft Windows Server 2012 R2 Essentials 64-bit Operating System (Server)

The Server runs an Intel Core i5-2405S @ 2.5GHz processor with 8GB RAM

Music is primarily FLAC format files ranging from 16/44.1 to 24/192

JRiver Media Center 22 is running on the Server

The Server is connected to a Linksys WRT1900ACS wireless router

A Raspberry Pi 3 Model B with HiFiBerry Digi+ card is connected to the Server in another room via 802.11N wireless LAN

The RasPi3 is running Volumio 2.031

The Digi+ card is connected to an Emotiva Stealth DC-1 DAC via a 24" long optical cable and the DAC is connected to a pair of Emotiva Airmotiv 6S powered monitor speakers via balanced XLR cables

 

I can play songs in my music library (i) wirelessly from a Nexus 9 (Google Android) tablet running the JRemote app or (ii) via Remote Desktop (wired Ethernet connection) onto the Server to play tracks via JRMC. Either way I get the same result, when I am listening to a song and I select a new song it takes roughly 13 seconds before the new song starts to play. Something of interest to note is when I am listening to a playlist of multiple songs there is no gap or latency between the playback of songs. I noticed there is no impact to the latency between songs with higher or lower resolution music. I have made countless playback option changes in Volumio with no chage to the latency issue. Any suggestions on how to fix the latency or even troubleshoot it would be greatly appreciated.

 

Thank you for your consideration.

Link to comment
Share on other sites

Hi bradt

 

The last time I tried Volumio was version 1.55 on my Raspberry Pi 2 and that version did not have any such problems. Just tested with Volumio 2.041 (the latest version) and I had the same slow start to play after user track selection when using every standard UPnP/DLNA controller that I tried with it. So it's not just limited to using JRMC's built-in standard UPnP/DLNA controller (which is what JRMC seemlessly internally uses on your behalf to control standard UPnP/DLNA supporting streamers, such as Volumio) and therefore the issue should have nothing to do with JRMC.

 

I also tried the same with OpenHome (aka UPnP with Linn extensions) controllers, which Volumio also supports. This time the delay drops to a more acceptable ~3 seconds. Unfortunately JRMC (& therefore all of its remote control apps, such as JRemote) doesn't support OpenHome, but you should be able to access JRMC's music library & playlists via an OpenHome supporting controller on your Android device, such as the excellent BubbleUPnP app.

 

The other major difference I've noticed between Volumio versions 1.55 & 2.041, when using standard UPnP/DLNA, is that it no longer displays the now & next played music files in its web browser app's playlist display. Also, in OpenHome mode, Volumio 1.55's web browser playlist display contains the entire current playlist of the OpenHome controller, which is now completely missing in Volumio 2.041's playlist display. There's definitely something not quite right with the current version of Volumio's use of UPnP/DNA & OpenHome streaming.

 

Incidentally, the current version of the Moode Audio Player for the Raspberry Pi, which similary supports standard UPnP/DLNA & OpenHome streaming, starts play virtually instantaneously in both modes - so definitely worth a try!

moodeaudio.org

It's developer also provides excellent support, regularly posting on this Computer Audiophile thread:

http://www.computeraudiophile.com/f11-software/moode-audio-player-raspberry-pi-23858/

 

John

We will win because our NHS is the beating heart of this country. It is the best of this country. It is unconquerable. It is powered by love.

-- Boris Johnson

 

We are far more united and have far more in common with each other than things that divide us.

-- Jo Cox

Link to comment
Share on other sites

  • 1 month later...

Cebolla,

 

Thanks for the great thoughts. I installed Moode Audio. It's running but it doesn't play music. I keep getting MPD failed. I'm not familiar with this. Any thoughts on how to get MPD to work?

 

Thanks.

 

Brad

Link to comment
Share on other sites

  • 2 weeks later...

Hi Brad,

 

I noticed you posted your MPD problem on the Moode Audio thread, so was waiting for any follow up. Did you do the Moode reinstall as was suggested?

http://www.computeraudiophile.com/f11-software/moode-audio-player-raspberry-pi-23858/index46.html#post627697

 

Assuming you didn't manually change the mpd.conf file mentioned in the post (there's no need to for your purposes - just use the default installation), it's possible the Moode Audio image you downloaded is corrupted and/or there's a problem with the microSD card you've installed it on.

 

John

We will win because our NHS is the beating heart of this country. It is the best of this country. It is unconquerable. It is powered by love.

-- Boris Johnson

 

We are far more united and have far more in common with each other than things that divide us.

-- Jo Cox

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...