Jump to content
IGNORED

God Damn Amarra !


PierreDLC
 Share

Recommended Posts

Hello,

 

I am Amarra User. In its latest update, Amarra offers volume control from Rowmote app, Apple Remote app or Apple Remote device. For some reason, none of these devices work. Anyone has the same problem ?

 

Thanks for your help,

 

Pierre

 

MPB/iTunes + Audirvana / Amarra / AVS 3D - Accuphase E 550 / DAC 30 - Apertura Altra Signature

Link to comment
Share on other sites

Yes, I am able to control iTunes : play/pause, move forward / backward, Menu. And I upgrade Amarra to 1.1 version. As I try to control the volume, it is iTunes volume symbol that appears on the screen (speaker symbol), saying volume control is off.

 

MPB/iTunes + Audirvana / Amarra / AVS 3D - Accuphase E 550 / DAC 30 - Apertura Altra Signature

Link to comment
Share on other sites

I downloaded the demo software of Amarra Mini 1.1 some time ago. At first, volume control in Amarra using the Apple Remote device worked fine. But after upgrading to Mac os 10.6.2 it does not work anymore. In the console log you can see a message from Amarra remote saying it does not recognize the button being pushed (or something like that).

 

Outside Amarra the remote works fine.

 

I emailed sonic studio as I have not purchased the software yet, but no response up till now. I hope they will solve it, as it is an important feature for me.

 

Regards,

D.

 

Link to comment
Share on other sites

If you're on 10.6 it's probably Apple's fault, not Amarra's. Apple changed their remote control APIs and that broke a lot of third party applications - apparently they didn't like that people were using their remote for things that weren't Frontrow or iTunes. Anyway there are things you can do about it - read some more here with some links to solutions:

 

http://elan.plexapp.com/2009/10/23/snow-leopard-thaws-to-the-apple-remote-thanks-to-remote-buddy-author/

 

 

 

 

mpdPup maintainer

Link to comment
Share on other sites

Well, the way that Amarra would be likely to fix it is to use the exact same method I just linked. Since Apple broke it at the driver level a new driver is required. The remote buddy developer has released a replacement driver and is allowing any other user/company to use it for free.

 

 

mpdPup maintainer

Link to comment
Share on other sites

for your interest in my problem. A CA member called Werner has the same problem as mine. It makes us 2 in the whole world having the same problem. Idols suggested to download a driver to fix the problem. Unfortunately, not fixing the volume control problem neither. Well, well, the mistery of computer things...

 

MPB/iTunes + Audirvana / Amarra / AVS 3D - Accuphase E 550 / DAC 30 - Apertura Altra Signature

Link to comment
Share on other sites

Linking straight to the Candelair/Remote Buddy Site:

http://www.iospirit.com/labs/candelair/

On that page they mention "Leopard Compatibility Mode", did you try that?

 

Although now that I read the Amarra site they indicate that version Amarra 1.1 is supposed to use 'Rowmote' to fix Apple's broken Snow Leopard remote control:

http://www.rowmote.com/Rowmote/Rowmote.html

 

It's possible that Rowmote didn't install correctly and/or it's conflicting with Candelair....

 

 

 

 

mpdPup maintainer

Link to comment
Share on other sites

I installed Candelair and it has solved the problem for me. The Leopard Compatibiliy Mode has to be enabled for the Amarra Remote to work with the Apple Remote device.

 

I aslo tried Rowmote; it works but is not very responsive when changing the volume. I don't know if this is only in combination with Amarra, I will test it some more and see.

 

Thanks Idolse.

 

Link to comment
Share on other sites

  • 10 months later...

On 10.6 I find that the latest remote buddy will let you map the remote buttons to any keyboard button. Then you can map that keyboard button to Sonic Console. No expensive Amarra needed. To think I was about to drop $695 to get remote volume control.

 

Another thing I agree with is that rowmote is near hopeless. Very unresponsive and my iPhone starts having Wi-Fi issues whenever I use it.

 

In remote buddy you can define custom keyboard commands with repeat rate. So I have short presses simply hit the up or down button and long presses hit that button with a repeat rate of 0.005s. It allows for fine volume control with quick, simple large volume changes.

 

I am absolutely thrilled about this solution. I could never understand why anyone would want to switch between the remote app and rowmote and back just to control volume. You would be better off with 2 iPod touches one running each program. This is not ideal (that would be volume control within the remote app itself for the Sonic Console analog volume control) but at least I can control my music with the iPhone/iPod touch and the volume with that tiny, slim Apple Remote. This solution makes the ULN-8/LIO-8/Sonic Model 4/Model 304/Model 305 etc. very usable as a listening device.

 

The next step for me is to get the Apple Remote to switch sources between Firewire from the Mac to Squeezebox Transporter via AES/EBU with wordclock sync. Then I would never need to open the MacBook to do anything. Either iTunes Remote or iPeng would control the music and the Apple Remote the volume and source. Almost like having a CD player remote and a Pre-Amp remote.

 

In the end I would give up nothing with this setup in terms of control.

 

Link to comment
Share on other sites

I spent a few more minutes and using the Sonic Console keyboard commands and some tinkering with remote buddy I am now able to use the select button to switch between my 2 sources and the menu button to switch between speakers and headphones. I pretty much have the control I need from that Apple Remote. Remote buddy really gets the job done.

 

I still have play/pause and track changing control. This is everything I could have wanted from my computer based audio solution. In fact in some ways I prefer the tiny Apple Remote to handle the basic switching and volume controls.

 

Link to comment
Share on other sites

  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...