Jump to content
IGNORED

Please help with streaming pauses


PaulF
 Share

Recommended Posts

2016 dual-core Mac Mini with SSD & 16 Gb RAM streaming via HQ Player NAA to a microRendu attached to a WiFi extender.

 

I get occasional dropouts in the music, anywhere from .5s to as long as 3s. It happens more often there is some CPU load, such as when converting DSD to PCM on the fly, but happens sometimes even with almost no load.

 

I've optimized the OS (El Cap) via Mojo's instructions, except that I can't turn off WiFi since I control the computer that way.

 

Any advice for me?

Link to comment
Share on other sites

Did you get drop-outs before modifying the operating system? If not, I suggest reinstalling it and see if you can get non-pathological behavior back.

 

Are you serious? Changing settings is not "modifying the operating system".

 

The dropouts were at least as bad before doing that.

Link to comment
Share on other sites

I'm sure with your pleasant responses, people will be queueing up and tripping over themselves to do so.

 

Meanwhile, enjoy the music. And the pauses.

 

Look, it's sad when a thread gets derailed like this, but here's the story in a nutshell: You do not understand the issue nearly enough to comment, let alone offer advice, yet you chose to do that - advice of a decidedly snide sort. And now your ego seems to be bruised.

 

First, again, optimizing an operating system is not "modifying" it. People familiar with computer audio know exactly what I meant, and you could at least have easily Googled to find out yourself.

 

Secondly, when one *does* know what Mac OS optimizing for music playback entails, one also knows that there is simply no way this could *cause* dropouts, since it consists of *turning off* unrelated processes or interrupts.

 

Finally, inquiring as to whether the problem only occurred after I made the optimizations is clearly insulting, as only an idiot would go online to ask for advice when he knew what caused the issue.

 

Again, it seems apparent to me you know little of this domain and should have simply refrained from offering a snide comment.

 

Anyway, again, perhaps someone who does have more experience than I will indeed chime in with some advice here. We'll see. :)

Link to comment
Share on other sites

Any advice for me?

Have you studied your WiFi quality carefully? My old house was in a neighborhood so crowded with WiFi APs and electromagnetic noise from other gear that I could not ensure reliable streaming over WiFi in the evening (when everyone was home making EM noise). Caved in and ran Cat 6 from music server to my two listening locations. Problem gone for good. Can you try to run both Mac Mini and uRendu wired temporarily for a test?

 

When I moved, my first upgrade was to run Cat 6 throughout the new house. Worth the cost and delay in saved annoyance and wasted time tracking down the dropouts. I know, possibly not the advice you were looking for, but life is too short to stream over WiFi...

Link to comment
Share on other sites

Best of luck. I was simply asking a few questions to try to get a handle on your issue. If no one who has the knowledge and skill set you require steps forward any time soon, perhaps it might be worth trying the following, at least for diagnostic purposes:

 

(1) Create a new temporary user account, and test to see if the issue persists. If it does not persist, this is a strong indication that the problem lies within the original user configuration, probably within ~/Library/Preferences. If not, ...

 

(2) Temporarily simplify the setup. Take the microRendu out of the chain, and either replace it temporarily with USB or some other such direct connection to your DAC, or simply plug some headphones into the mac's analog out, and see if the issue persists. If it does not persist, I would investigate the DLNA configuration (assuming that is what you are using). Although more robust than Apple's protocol, it is not flawless. If the issue does persist, it suggests the problem may be with HQplayer. To test that hypothesis, see if the issue still persists with iTunes alone. The key to success is to isolate the weak link in the connection.

 

(3) If the issue still persists, watch the Console.app output. Some of the "optimizations" various entities suggest are not well-implemented, and turning off some "services" improperly will cause the OS to continuously or periodically spawn launchd child processes, which can tax the CPU. You mentioned a correlation between CPU usage and the drop-outs, so this may be the cause. However, in my experience, I have only seen this (since 10.7) during spotlight indexing. Some people suggest disabling all of the md-processes. (I think this is too drastic.)

 

(4) One of the tweaks listed on the Mojo website is to disable disk journaling. Whereas this is not technically a modification of the OS, it can have particularly deleterious effects on the OS due to file corruption, and I have seen no evidence that disk journaling causes any degradation of sound quality.

 

I do apologize for confusing the mojo set of tweaks with some others that are frequently implemented blindly by various folks here, often to the detriment of their audio playback system, and should have asked first if the problem preceded the "optimization" tweaks. However, your response is hardly endearing. I understand that this can be frustrating, but you have to accept that those who bother to answer your pleas for help have no ulterior motives.

Link to comment
Share on other sites

Have you studied your WiFi quality carefully? My old house was in a neighborhood so crowded with WiFi APs and electromagnetic noise from other gear that I could not ensure reliable streaming over WiFi in the evening (when everyone was home making EM noise). Caved in and ran Cat 6 from music server to my two listening locations. Problem gone for good. Can you try to run both Mac Mini and uRendu wired temporarily for a test?

 

When I moved, my first upgrade was to run Cat 6 throughout the new house. Worth the cost and delay in saved annoyance and wasted time tracking down the dropouts. I know, possibly not the advice you were looking for, but life is too short to stream over WiFi...

 

I missed that the streaming itself was also over wi-fi. At the very least, a good test/diagnostic would be to temporarily replace the wi-fi connection with cat5 or cat6. If that solves the problem, then I agree it would be worth hard-wiring it.

Link to comment
Share on other sites

Have you studied your WiFi quality carefully? My old house was in a neighborhood so crowded with WiFi APs and electromagnetic noise from other gear that I could not ensure reliable streaming over WiFi in the evening (when everyone was home making EM noise). Caved in and ran Cat 6 from music server to my two listening locations. Problem gone for good. Can you try to run both Mac Mini and uRendu wired temporarily for a test?

 

When I moved, my first upgrade was to run Cat 6 throughout the new house. Worth the cost and delay in saved annoyance and wasted time tracking down the dropouts. I know, possibly not the advice you were looking for, but life is too short to stream over WiFi...

 

WiFi strength seems very high. I have an Apple Airport in the master bedroom and it is so powerful I can use my laptop sitting by the garden 60 yards away no problem. The living room, where the system is, is maybe 25 feet from the router (though one drywall wall).

 

I tried a wired connection and it made no difference. What I mean is that I ran ethernet from the Mini to the Wifi router (extender) that the mRendu is connected to (via an eth cable of course), and it made the drops still occurred. What I was unsure of is if the Mac would know to route packets for the Rendu over the *wire* to the router - my guess is that it does *not*, and I've no idea how to tell it to do so.

 

I would love to be able to connect the mRendu directly to the Mini but it does not support a direct connection for my mode of operation (using HQ Player with NAA). Sonore confirmed this.

 

As an aside, let me mention that the drops when merely upsampling PCM - when CPU is low - are very rare. Less than one per song, typically. When I'm converting DSD->PCM on the fly and CPU is running 60-80% they are more frequent.

 

Also, the drops decrease in frequency directly after a reboot. These two things tell me that the issue is with the source (the Mini) and not the network.

 

(Now the overall increase in sound quality with the Rendu in the mix is night/day over the plain (optimized) Mini going right to the DAC. There is no way to go back after experiencing it. So I must solve this little problem and I'm sure it's solvable.)

Link to comment
Share on other sites

What I was unsure of is if the Mac would know to route packets for the Rendu over the *wire* to the router - my guess is that it does *not*, and I've no idea how to tell it to do so.

 

Click on the wireless icon in the menu bar and hit "turn wifi off". Alternatively, you can turn it off in system preferences. (As long as your airport extreme is still on, you can still control it wirelessly with respect to the controlling computer or iOS device or whatever as before.)

 

Oh - as to noise - we live in a semi-rural area with only three other houses within 100 yards. It's clean! In fact I cannot ever see another Wifi network.

 

Other sources of interference include microwave ovens and wireless telephones, so it doesn't have to be an interfering neighbor's signal. It might be worth changing channels just in case. Many other household appliances broadcast a wireless signal, like Wemo light switches, etc. It is unlikely the cause of your problem, but not an impossibility.

Link to comment
Share on other sites

 

First, again, optimizing an operating system is not "modifying" it. People familiar with computer audio know exactly what I meant, and you could at least have easily Googled to find out yourself.

 

Secondly, when one *does* know what Mac OS optimizing for music playback entails, one also knows that there is simply no way this could *cause* dropouts, since it consists of *turning off* unrelated processes or interrupts.

 

 

 

I think you are 100% incorrect in the above statements.

Main listening (small home office):

Main setup: Surge protector +_iFi  AC iPurifiers >Isol-8 Mini sub Axis Power Conditioning+Isolation>QuietPC Low Noise Server>Roon (Audiolense DRC)>Stack Audio Link II>Kii Control>Kii Three >GIK Room Treatments.

Secondary Listening: Server with Audiolense RC>RPi4 or analog>Matrix Element i Streamer/DAC (XLR)+Schiit Freya>Kii Three .

Bedroom: SBTouch to Cambridge Soundworks Desktop Setup.
Living Room/Kitchen: RPi 3B+ running RoPieee to a pair of Morel Hogtalare. 

All absolute statements about audio are false :)

Link to comment
Share on other sites

Click on the wireless icon in the menu bar and hit "turn wifi off". Alternatively, you can turn it off in system preferences. (As long as your airport extreme is still on, you can still control it wirelessly with respect to the controlling computer or iOS device or whatever as before.)

 

 

 

Other sources of interference include microwave ovens and wireless telephones, so it doesn't have to be an interfering neighbor's signal. It might be worth changing channels just in case. Many other household appliances broadcast a wireless signal, like Wemo light switches, etc. It is unlikely the cause of your problem, but not an impossibility.

 

Ok, wgscott, thanks for sticking around, and I apologize for being a bit too much of a pipe-hitter early on. (My mother may have been on to something, when she told me, at approximately five years old, "You can be a bit of an a**hole".)

 

I control the Mini via Wifi - Screen Sharing. Via my laptop from the couch. That's the issue. You know what I can try, though, is connecting the laptop to the Mini with a wire with Wifi off and see if that has a result.

 

Of course declaring success here entails proving a negative. Sometimes there isn't a drop-out for an hour or two. So it would take a few evenings of play to declare victory.

Link to comment
Share on other sites

I think you are 100% incorrect in the above statements.

 

Ok - how about some support for that (even though this seems pedantic).

 

Regarding OS "modifications", people *I* know don't say "I've modified my OS!" when they turn off Bluetooth or notifications from some app (this is the kind of stuff in the Mojo optimization script).

 

"Modifying" an OS to me is more akin to, say, rebuilding you Linux kernel. Or, at least, installing some library, driver, etc.

 

But, then, this is just lingo.

 

(Incidentally, I've been a software developer for 25 years.)

 

As for the Mojo optimizations - which again, involve turning off non-essentials - if you have an example of something like this causing streaming drop-outs I would love to hear it. Seriously.

Link to comment
Share on other sites

I thnk Firedog may have figured it out (or at least has a remarkably similar problem):

 

http://www.computeraudiophile.com/f22-networking-networked-audio-and-streaming/new-and-better-router-lots-dropouts-29415/#post569845

 

Remarkably similar, indeed. I'm chagrined by how much networky-type complexity is involved here because, man, I really just don't have time for this.

 

Late tomorrow I should be able to try some of these troubleshooting steps and see what happens. (My setup is a Time Warner cable modem going into the Airport - simple.)

 

It's a good/bad thing the microRendu is so damn good.

Link to comment
Share on other sites

Sorry, cross-post

 

(I was thinking of "modifying" in the sense of altering a bunch of the launchd settings via a script popular here that a lot of people run blindly and can't figure out how to back out of gracefully. OS X doesn't give you a way to rebuild the (micro)kernel, fwiw.)

 

Anyway, if Firedog's issue is the same as yours, it looks like it needs to be resolved by the HQplayer and/or the microrendu folks.

Link to comment
Share on other sites

Here is my update. (I was without digital for a few days as I traded my superb Metrum Menuet DAC in to my dealer for the even better Pavane - my gosh, this thing is incredible already with ~4 hours on it.)

 

The update is: I rebooted my Apple Wifi router and all problems disappeared. When I first started playing digital today the dropouts were worse than ever, even with very low CPU load on the server running HQPlayer. Per the other thread pointing at general network issues I unplugged the Apple Airport Extreme, which probably had not been bounced for a year or more, and all problems completely disappeared - I've had an hour+ of play with zero drops.

 

Sonore really needs to produce an mRendu update that allows a wired connect to the server in HQP mode. It's crazy to have to rely on the quality of your Wifi network for the thing to work.

Link to comment
Share on other sites

Here is my update. (I was without digital for a few days as I traded my superb Metrum Menuet DAC in to my dealer for the even better Pavane - my gosh, this thing is incredible already with ~4 hours on it.)

 

The update is: I rebooted my Apple Wifi router and all problems disappeared. When I first started playing digital today the dropouts were worse than ever, even with very low CPU load on the server running HQPlayer. Per the other thread pointing at general network issues I unplugged the Apple Airport Extreme, which probably had not been bounced for a year or more, and all problems completely disappeared - I've had an hour+ of play with zero drops.

 

Sonore really needs to produce an mRendu update that allows a wired connect to the server in HQP mode. It's crazy to have to rely on the quality of your Wifi network for the thing to work.

Sonore don't recommend Wireless, see post 313:

 

http://www.computeraudiophile.com/f26-sonore-sponsored/sonore-microrendu-27389/index13.html

Link to comment
Share on other sites

 

Sonore really needs to produce an mRendu update that allows a wired connect to the server in HQP mode. It's crazy to have to rely on the quality of your Wifi network for the thing to work.

 

As I believe was noted previously here, hard-wiring the Rendu to the computer does not work in HQPlayer mode. You have to go through the network.

 

 

Why? the mR is designed to be used on an ethernet network - both the mR in HQP NAA mode and the server wired to the same network. NOT directly connected by cable. If you have to rely on your wifi network you aren't setting it up the way it was intended to be used.

 

That's why Sonore doesn't recommend wireless (and also because they think wireless adds noise).

 

Same for HQP and the HQP NAA - specifically designed so that the server desktop device looks for the NAA on the same network. Note the name: "Network Audio" device. The whole point of NAA software is to setup HQP playback from a quiet, isolated networked device, not a noisy HQP server. Hardwiring defeats the purpose of the NAA.

 

 

If you have to use wifi for your mR, you have it setup in a way it wasn't intended to be used. I don't see any reason why Sonore and HQP need to cater to a user who doesn't want to use the product as it was intended: It's a wired network device. Period. Use it as intended and it works fine.

Main listening (small home office):

Main setup: Surge protector +_iFi  AC iPurifiers >Isol-8 Mini sub Axis Power Conditioning+Isolation>QuietPC Low Noise Server>Roon (Audiolense DRC)>Stack Audio Link II>Kii Control>Kii Three >GIK Room Treatments.

Secondary Listening: Server with Audiolense RC>RPi4 or analog>Matrix Element i Streamer/DAC (XLR)+Schiit Freya>Kii Three .

Bedroom: SBTouch to Cambridge Soundworks Desktop Setup.
Living Room/Kitchen: RPi 3B+ running RoPieee to a pair of Morel Hogtalare. 

All absolute statements about audio are false :)

Link to comment
Share on other sites

Why? the mR is designed to be used on an ethernet network - both the mR in HQP NAA mode and the server wired to the same network. NOT directly connected by cable. If you have to rely on your wifi network you aren't setting it up the way it was intended to be used.

 

Same for HQP and the HQP NAA - specifically designed so that the server desktop device looks for the NAA on the same wired network.

 

That's why Sonore doesn't recommend wireless (and also because they think wireless adds noise).

 

If you have to use wifi for your mR, you have it setup in a way it wasn't intended to be used. I don't see any reason why Sonore and HQP need to cater to a user who doesn't want to use the product as it was intended: It's a wired network device. Period. Use it as intended and it works fine.

 

When I had my Mini server wired to the same router as the Rendu, drop-outs still occurred. This tells me that the performance of the Apple router connected to the cable modem - the router in the listening room is setup as an extender - is still a factor even when everything *is* wired.

 

I really didn't indicate I "don't want to use the product as it was intended". I want to use it in the best way possible. If having the music router setup as a Wifi extender creates the possibility of the Wifi network affected packet transmission even to device hard-wired to it - that is not something I would have foreseen. But I'm no networking guru at all.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...