Jump to content
IGNORED

Itunes 12.4


latini
 Share

Recommended Posts

Install the update for itunes 12.4. Pure Music is not working.

 

Massimo

 

And this surprises you? Third party apps and vendors are always behind and often incompatible when OSX updates are released. Hope you have a previous version of iTunes you can re-install.

Everyone should always have a complete external bootable backup of all their computer data before installing ANY software updates, scripts, third party apps, etc. It's called insurance.

Link to comment
Share on other sites

[h=2]Pure Music / Pure Vinyl Tips, Troubleshooting and FAQ[/h] Last Updated May 16, 2016: iTunes 12.4 / OS X 10.11.5 Compatibility

 

If you are running Pure Music 2 and do not intend to upgrade to Pure Music 3, do not install El Capitan and do not update to iTunes 12.4.

 

 

May 16, 2016: iTunes 12.4 and El Capitan 10.11.5 Updates

iTunes 12.4 is not compatible with Pure Music 3.0.3. However, we have already identified the cause of the "show stopping" issue and should be posting a Pure Music compatibility update within 24 hours.

 

Aside from that, we have found that iTunes 12.4 (running by itself) is not operating as smoothly as the previous, 12.3.3.17 release. Consequently, we do not recommend updating to iTunes 12.4 at this time.

 

OX X 10.11.5 is compatible per se, but we also have discovered intermittent underlying performance issues on this OS version, unrelated to Pure Music. Namely, sluggish response and dropped connections with Screen Sharing, and poor network performance. We do not recommend updating to OS X 10.11.5 at this time.

Link to comment
Share on other sites

And this surprises you? Third party apps and vendors are always behind and often incompatible when OSX updates are released. Hope you have a previous version of iTunes you can re-install.

Everyone should always have a complete external bootable backup of all their computer data before installing ANY software updates, scripts, third party apps, etc. It's called insurance.

 

 

It does not surprise me.

Within minutes I reinstalled the backup I had done before doing the upgrade everything is back OK.

Mac Pro Quad Core, Auralic Vega, Accuphase C2110, Accupase A65, Wilson Sophia

Link to comment
Share on other sites

This has always been interesting to me. If you have a working audio environment why upgrade itunes?

 

Btw it breaks Amarra too.

 

 

Why try the effect of the new updates is the essence of the hobby.

With a backup returns immediately to its previous configuration

Mac Pro Quad Core, Auralic Vega, Accuphase C2110, Accupase A65, Wilson Sophia

Link to comment
Share on other sites

Just released Audirvana Plus 2.5.1 that includes a fix for this new compatibility issue introduced by iTunes 12.4, that was happening in the legacy iTunes integrated mode only.

 

Damien

MBP 15"/Mac Mini, Audirvana Plus, Audioquest Diamond USB, AMR DP-777, exD DSD DAC (for DSD), Pioneer N-70AE, Audioquest Niagara balanced/Viard Audio Design Silver HD, Accuphase E-560, Cabasse Sumatra MT420

Link to comment
Share on other sites

This has always been interesting to me. If you have a working audio environment why upgrade itunes?

 

Btw it breaks Amarra too.

 

It works fine here... I have not "fixed" it in anyway.

 

Unless, and I just thought of this, the problem lies not with Amarra but in the "kext" file that Apple changed in .5 that I have already exchanged with the .4 version from my backup so I could continue to use Audirvana Direct Mode.

 

Screen Shot 2016-05-21 at 3.06.00 PM.png

No electron left behind...

Link to comment
Share on other sites

Well, I guess this explains the issues I've been having!

 

this morning I updated to iTunes 12.4 from 12.3.3.17 and OSX 10.11.5 on all of my machines.

 

I use an Mac-Mini as an music server playing into an external DAC and a mac book pro via another DAC in my home office (see signature for complete info) & I use UpTone Audio REGENs and Intona USB high speed isolators in line between both Macs and DACs.

 

Prior to the update everything worked wonderfully.

 

Now neither DAC appears on Midi settings or in applications like Pure Music of Audirvana etc. I have tried installing the latest Pure Music (3.0.5) and Audirvana (2.3.3) updates, swapping cables/machines, restarting and resetting the SMC etc - nothing works. If I connect the USB cables directly to the DACs then they are seen in Midi settings and can be seletcted in the music apps.

I cannot get any playback volume.

 

Does anyone have any insight/ideas/suggestions?

or a link showing how to downgrade to iTunes 12.3.3.17 (no, i didn't keep a previous version copy) - and will I have to reload my music collection if I do so (i.e. its huge and multi file-type)?

any help appreciated!

Main: 2x2TB Ext HDD/Mac Mini 2.3 GhZ core i5 + Uptone MMK & Teradak LPS/Roon/Ethernet LAN/Uptone Audio EtherRegenr/.5M Supra CAT8/SoTM sMs200-ULTRA NEO + SBooster BOTW P&P Eco MkII/Curious cable .2M/UpTone Audio ISORegen + SBooster Ultra/Curious cable .2M/Mutec MC3+USB/DH Labs Silver sonic D110 AES/Genelec 7370A+ 2 x 85351s running GLM 3.1 with wireless remote.

Office: 4TBHDD/MacBookPro/Audirvana /.25M AQvox USB/UpTone Audio ISORegen with SBooster Ultra/.25M Moon Audio Silver dragon USB/Chord Hugo2/.25M Moon Audio Silver dragon phono/Rogue Audio Sphinx 2/Anti-cables level 3/Elac Uni_Fi UB5's on Isoacoustics Apertas/Genelec 7050c Sub.

Link to comment
Share on other sites

Well, I guess this explains the issues I've been having!

 

this morning I updated to iTunes 12.4 from 12.3.3.17 and OSX 10.11.5 on all of my machines.

 

I use an Mac-Mini as an music server playing into an external DAC and a mac book pro via another DAC in my home office (see signature for complete info) & I use UpTone Audio REGENs and Intona USB high speed isolators in line between both Macs and DACs.

 

Prior to the update everything worked wonderfully.

 

Now neither DAC appears on Midi settings or in applications like Pure Music of Audirvana etc. I have tried installing the latest Pure Music (3.0.5) and Audirvana (2.3.3) updates, swapping cables/machines, restarting and resetting the SMC etc - nothing works. If I connect the USB cables directly to the DACs then they are seen in Midi settings and can be seletcted in the music apps.

I cannot get any playback volume.

 

Does anyone have any insight/ideas/suggestions?

or a link showing how to downgrade to iTunes 12.3.3.17 (no, i didn't keep a previous version copy) - and will I have to reload my music collection if I do so (i.e. its huge and multi file-type)?

any help appreciated!

 

2.3.3 is NOT the latest Audirvana, 2.5.1.4 is the latest.

No electron left behind...

Link to comment
Share on other sites

Well, I guess this explains the issues I've been having!

 

this morning I updated to iTunes 12.4 from 12.3.3.17 and OSX 10.11.5 on all of my machines.

 

I use an Mac-Mini as an music server playing into an external DAC and a mac book pro via another DAC in my home office (see signature for complete info) & I use UpTone Audio REGENs and Intona USB high speed isolators in line between both Macs and DACs.

 

Prior to the update everything worked wonderfully.

 

Now neither DAC appears on Midi settings or in applications like Pure Music of Audirvana etc. I have tried installing the latest Pure Music (3.0.5) and Audirvana (2.3.3) updates, swapping cables/machines, restarting and resetting the SMC etc - nothing works. If I connect the USB cables directly to the DACs then they are seen in Midi settings and can be seletcted in the music apps.

I cannot get any playback volume.

 

Does anyone have any insight/ideas/suggestions?

or a link showing how to downgrade to iTunes 12.3.3.17 (no, i didn't keep a previous version copy) - and will I have to reload my music collection if I do so (i.e. its huge and multi file-type)?

any help appreciated!

 

I do not understand why someone with all this expensive kit does not have the common sense to make a bootable backup of their (previously working fine) computer OSX/apps/music library/whatever on external media before installing an "update" in the unfortunate event that somthing goes awry.

 

How many times must it be said?

 

The fact that when the code to an operating system is changed, it is going to effect third-party apps and devices who did not "fix" the incompatibility before it occured. I have used Apple computers exclusively for 25 years, but I think their next OSX should be named "Butterfly".

Link to comment
Share on other sites

2.3.3 is NOT the latest Audirvana, 2.5.1.4 is the latest.

 

Hi AudioDoctor - My mistake, (rushing through post late at night) and a typo. 2.5.1.4 is the version I have installed on both machines not 2.3.3.

Main: 2x2TB Ext HDD/Mac Mini 2.3 GhZ core i5 + Uptone MMK & Teradak LPS/Roon/Ethernet LAN/Uptone Audio EtherRegenr/.5M Supra CAT8/SoTM sMs200-ULTRA NEO + SBooster BOTW P&P Eco MkII/Curious cable .2M/UpTone Audio ISORegen + SBooster Ultra/Curious cable .2M/Mutec MC3+USB/DH Labs Silver sonic D110 AES/Genelec 7370A+ 2 x 85351s running GLM 3.1 with wireless remote.

Office: 4TBHDD/MacBookPro/Audirvana /.25M AQvox USB/UpTone Audio ISORegen with SBooster Ultra/.25M Moon Audio Silver dragon USB/Chord Hugo2/.25M Moon Audio Silver dragon phono/Rogue Audio Sphinx 2/Anti-cables level 3/Elac Uni_Fi UB5's on Isoacoustics Apertas/Genelec 7050c Sub.

Link to comment
Share on other sites

I do not understand why someone with all this expensive kit does not have the common sense to make a bootable backup of their (previously working fine) computer OSX/apps/music library/whatever on external media before installing an "update" in the unfortunate event that somthing goes awry.

 

How many times must it be said?

 

The fact that when the code to an operating system is changed, it is going to effect third-party apps and devices who did not "fix" the incompatibility before it occured. I have used Apple computers exclusively for 25 years, but I think their next OSX should be named "Butterfly".

 

Ok wwaldmanfan - I get it, I'm an idiot....an idiot who's been using Mac products since about 1987, luckily without an issue that I haven't seen a way to resolve/work around before.

 

So I'm asking the forum for advice.

 

Are there are any constructive comments you could offer that might help me?

Main: 2x2TB Ext HDD/Mac Mini 2.3 GhZ core i5 + Uptone MMK & Teradak LPS/Roon/Ethernet LAN/Uptone Audio EtherRegenr/.5M Supra CAT8/SoTM sMs200-ULTRA NEO + SBooster BOTW P&P Eco MkII/Curious cable .2M/UpTone Audio ISORegen + SBooster Ultra/Curious cable .2M/Mutec MC3+USB/DH Labs Silver sonic D110 AES/Genelec 7370A+ 2 x 85351s running GLM 3.1 with wireless remote.

Office: 4TBHDD/MacBookPro/Audirvana /.25M AQvox USB/UpTone Audio ISORegen with SBooster Ultra/.25M Moon Audio Silver dragon USB/Chord Hugo2/.25M Moon Audio Silver dragon phono/Rogue Audio Sphinx 2/Anti-cables level 3/Elac Uni_Fi UB5's on Isoacoustics Apertas/Genelec 7050c Sub.

Link to comment
Share on other sites

Ok wwaldmanfan - I get it, I'm an idiot....an idiot who's been using Mac products since about 1987, luckily without an issue that I haven't seen a way to resolve/work around before.

 

So I'm asking the forum for advice.

 

Are there are any constructive comments you could offer that might help me?

 

Andy,

It is never my intention to insult a fellow member of this forum. It is rude and crass, especially since we are all anonymous here. For that I apologize. However, I did make a strong and basic suggestion in post #2 of this thread, which has, evidently, gone unheard.

 

It is common knowledge that Apple created some USB issues with the release of El Capitan. Some developers, like Damien Plisson, of Audirvana, have been working hard to overcome the snags. But someone who has been using computers as long as you have should know that if you change horses midstsream, you could have problems. You have been fortunate up to now not to have had software conflicts, but now you know.

 

The quick fix is to go back to the old OSX/version of iTunes that worked before you changed it. Backups are not an option, they are a necessity.

Otherwise, hopefully, someone else can offer another, more technical suggestion to help you, or, try contacting Apple tech support.

Mike

Link to comment
Share on other sites

Thank you wwaldmanfan, apology excepted.

 

Ok - morning update in case anyone else is in the same/similar predicament.

 

Pursuing use of iTunes 12.4 and OS X 10.11.5 as an investigation, first thought:

 

I think the issue extends beyond iTunes 12.4, to the OS update.

 

The audio midi refuses to recognise that my Mutec is connected if I leave either the Intona or Regen or both in the USB chain.

If I connect the USB directly to the Mutec using it appears immediately in the Audio Midi devices list & can be selected.

 

I emailed UpTone and Intona last night;

 

Intona contacted me this morning (thank you Intona!) saying that the issue may be solved for their device with a firmware update - so it will be going off shortly.

 

Hopefully I'll hear something from UpTone today.

 

Restarted/reconnected everything and repeated smc flash etc with a direct USB/Mutec connection;

 

iTunes with Pure Music 3.0.5 works! All file types inc DSD.

 

However, if I try using Audirvana 2.5.1.4 (in iTunes integrated mode or standalone) Audio Midi deselects the Mutec as an audio output option and selects built-in audio (on both of my systems) I cannot select the Mutec as an audio output until I quit Audirvana.

 

For now I have music, just without the Regens or Intonas.

Main: 2x2TB Ext HDD/Mac Mini 2.3 GhZ core i5 + Uptone MMK & Teradak LPS/Roon/Ethernet LAN/Uptone Audio EtherRegenr/.5M Supra CAT8/SoTM sMs200-ULTRA NEO + SBooster BOTW P&P Eco MkII/Curious cable .2M/UpTone Audio ISORegen + SBooster Ultra/Curious cable .2M/Mutec MC3+USB/DH Labs Silver sonic D110 AES/Genelec 7370A+ 2 x 85351s running GLM 3.1 with wireless remote.

Office: 4TBHDD/MacBookPro/Audirvana /.25M AQvox USB/UpTone Audio ISORegen with SBooster Ultra/.25M Moon Audio Silver dragon USB/Chord Hugo2/.25M Moon Audio Silver dragon phono/Rogue Audio Sphinx 2/Anti-cables level 3/Elac Uni_Fi UB5's on Isoacoustics Apertas/Genelec 7050c Sub.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...