Jump to content
IGNORED

MQA with Linux MPD


Recommended Posts

I have an Explorer 2 DAC. It plays well through my voyage MPD headless Alix box. High rez up to 192 kHz. But, so far I have not been able to get it to decode 2L mqa files. I.E. no shining blue light. Any comments or help? Patience is a virtue.

snapback77

Link to comment

Make sure that your config settings allow bit perfect playback. Any upsampling or sample rate conversion will kill the mqa decoding.

Main System: Auralic Aries G2, Ayre QX-5 Twenty, Ayre KX-5 Twenty, Ayre VX-5 Twenty, Revel Ultima Studio2, Iconoclast speaker cables & interconnects, RealTraps acoustic treatments

Living Room: Sonore ultraRendu, Ayre QB-9DSD, SimAudio Moon 340iX, B&W 802 Diamond

Link to comment
  • 2 weeks later...

I discovered that my config setting is bit perfect. I am not certain what you mean about upsampling or sample rate conversion.

The following is my output settings:

audio_output {

type "alsa"

name "My ALSA Device"

# device "hw:0,0" optional

device "hw:0,0"

# format "44100:16:2" optional

# mixer_device "default" optional

# mixer_control "PCM" optional

# mixer_index "0" optional

dsd_usb "yes"

}

This all I could find about sampling:

# This setting will change all decoded audio to be converted to the specified

# format before being passed to the audio outputs. By default, this setting is

# disabled.

#

#audio_output_format "44100:16:2"

#

# If MPD has been compiled with libsamplerate support, this setting specifies

# the sample rate converter to use. Possible values can be found in the

# mpd.conf man page or the libsamplerate documentation. By default, this is

# setting is disabled.

#

#samplerate_converter "Fastest Sinc Interpolator"

 

Does this help? Thanks for your consideration. This stumps me.

km

Link to comment

"I discovered that my config setting is bit perfect. I am not certain what you mean about upsampling or sample rate conversion."

 

It means that you are altering bit/sample rates if you use this type of processing. Its not bit perfect under those settings.

 

"# This setting will change all decoded audio to be converted to the specified

# format before being passed to the audio outputs. By default, this setting is

# disabled.

# If MPD has been compiled with libsamplerate support, this setting specifies

# the sample rate converter to use. Possible values can be found in the

# mpd.conf man page or the libsamplerate documentation. By default, this is

# setting is disabled."

 

You want to leave both of those settings disabled.

Link to comment
"I discovered that my config setting is bit perfect. I am not certain what you mean about upsampling or sample rate conversion."

 

It means that you are altering bit/sample rates if you use this type of processing. Its not bit perfect under those settings.

 

"# This setting will change all decoded audio to be converted to the specified

# format before being passed to the audio outputs. By default, this setting is

# disabled.

# If MPD has been compiled with libsamplerate support, this setting specifies

# the sample rate converter to use. Possible values can be found in the

# mpd.conf man page or the libsamplerate documentation. By default, this is

# setting is disabled."

 

You want to leave both of those settings disabled.

 

It might vary with different versions of MPD, but with Volumio 1.55 on a Raspberry Pi2 I found that when the 'device "hw:0,0"' line was commented out everything was resampled to 48 khz via dmix.

System (i): Stack Audio Link > 2Qute+MCRU psu; Gyrodec/SME V/Hana SL/EAT E-Glo Petit/Magnum Dynalab FT101A) > PrimaLuna Evo 100 amp > Klipsch RP-600M/REL T5x subs

System (ii): Allo USB Signature > Bel Canto uLink+AQVOX psu > Chord Hugo > Tandy LX5/REL Tzero v3 subs

System (iii) KEF LS50W/KEF R400b subs

 

Link to comment
  • 1 month later...

Hello,

I finally got the blue light to shine thanks to RAN above. After I followed the directions to run the latest firmware update from meridian it worked. I had to use a Windows 7 instead of Ubuntu but after connecting the Explorer2 back to my Alix box with Voyager MPD everything sounded beautiful. It sounds to me very much like 24/96 files with less grain with the strings and voices. I don't know why the encoded albums cost more than 24/96 downloads. The size of the MQA files are much smaller than those and even CD's 16/44.1?

This could go audio-viral if they sold for about the price of a CD.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...