Jump to content
AudioPhil

[HOW-TO] Roon and RoonServer on Windows Server 2012 R2

Rate this topic

Recommended Posts

Hi

 

This is a new feature of AO 2.00, it does not exist in 1.40, sorry.

 

Best,

Phil


ıllıllı [  ...AO 3.00 IS HERE... ] ıllıllı
____________________________________________________________________________________

 

Shop | Core Audio Music Server | Reviews | Reference System | AudiophileOptimizer 3.00 | PDF Guide

 

Share this post


Link to post
Share on other sites

Not sure if this is a AO problem but I have installed and am trying to setup Roon , for the first time, on a window server 2012 based computer. Also using audiophile optimizer latest version 2.00 which does now recognizes Roon. Can't open Roon at all on this computer. Eventhough I am using the correct password, keeps saying password is unauthorized. I have reset this password many times and still does not work. Can,t log into my account either. This problem only exists on this computer. I can login into my Roon account on my other computer without any problems. This is where I first set up my account with Roon. . I'm not sure if this has anything to do with my account , computer or AO settings? Tryed Roon forum without any useful advice yet.

Thanks Ian

Share this post


Link to post
Share on other sites

I am very excited to have updated to Version 2.0 because I want to compare running HQ Player + Roonserver on Server Essentials to Ubuntu. Unfortunately, I cannot seem to connect my Roon app to Roonserver. I can ping the PC and the Roon app sees Roonserver running on my network but when I try to connect I get a "Network error. Please check your connection." I followed the exact directions on the first post of this thread. The weird thing is that I have Minimserver also running on this PC and I can connect to it with BubbleUPnP no problem.

 

Any ideas??


12TB NAS >> i7-6700 Server/Control PC >> i3-5015u NAA >> Singxer SU-1 DDC (modded) >> Holo Spring L3 DAC >> Accustic Arts Power 1 int amp >> Sonus Faber Guaneri Evolution speakers + REL T/5i sub (x2)

 

Other components:

UpTone Audio LPS1.2/IsoRegen, Fiber Switch and FMC, Windows Server 2016 OS, Audiophile Optimizer 3.0, Fidelizer Pro 6, HQ Player, Roonserver, PS Audio P3 AC regenerator, HDPlex 400W ATX & 200W Linear PSU, Light Harmonic Lightspeed Split USB cable, Synergistic Research Tungsten AC power cords, Tara Labs The One speaker cables, Tara Labs The Two Extended with HFX Station IC, Oyaide R1 outlets, Stillpoints Ultra Mini footers, Hi-Fi Tuning fuses, Vicoustic/RealTraps/GIK room treatments

Share this post


Link to post
Share on other sites
Did you try to kill and manually restart the Roon processes?

 

Ok this is really weird. When I run AO in Ultimist mode and use all the settings I have been using for the past year, my network adapter completely disappears. If I run AO in Advanced mode and use the same common settings as I do in Ultimist, the network adapter is present and I can connect to Room Server.

 

Phil, did you make any changes to AO Ultimist that would make the network adapter disappear?


12TB NAS >> i7-6700 Server/Control PC >> i3-5015u NAA >> Singxer SU-1 DDC (modded) >> Holo Spring L3 DAC >> Accustic Arts Power 1 int amp >> Sonus Faber Guaneri Evolution speakers + REL T/5i sub (x2)

 

Other components:

UpTone Audio LPS1.2/IsoRegen, Fiber Switch and FMC, Windows Server 2016 OS, Audiophile Optimizer 3.0, Fidelizer Pro 6, HQ Player, Roonserver, PS Audio P3 AC regenerator, HDPlex 400W ATX & 200W Linear PSU, Light Harmonic Lightspeed Split USB cable, Synergistic Research Tungsten AC power cords, Tara Labs The One speaker cables, Tara Labs The Two Extended with HFX Station IC, Oyaide R1 outlets, Stillpoints Ultra Mini footers, Hi-Fi Tuning fuses, Vicoustic/RealTraps/GIK room treatments

Share this post


Link to post
Share on other sites

Hi

 

When you say yes to "disable network related services" then the network adapters disappear in the network control panel of windows. This is by design because some relevant (to display the network adapters in control panel) services are disabled upon request. This did not change in the past years. Please do not use this feature if you want to use roon.

 

Best,

Phil


ıllıllı [  ...AO 3.00 IS HERE... ] ıllıllı
____________________________________________________________________________________

 

Shop | Core Audio Music Server | Reviews | Reference System | AudiophileOptimizer 3.00 | PDF Guide

 

Share this post


Link to post
Share on other sites

But I dont say Yes to disable network related services. Thats why this is so strange. I will try again. Maybe my wireless keyboard is sending the wrong keystroke signal???

 

Hi

 

When you say yes to "disable network related services" then the network adapters disappear in the network control panel of windows. This is by design because some relevant (to display the network adapters in control panel) services are disabled upon request. This did not change in the past years. Please do not use this feature if you want to use roon.

 

Best,

Phil


12TB NAS >> i7-6700 Server/Control PC >> i3-5015u NAA >> Singxer SU-1 DDC (modded) >> Holo Spring L3 DAC >> Accustic Arts Power 1 int amp >> Sonus Faber Guaneri Evolution speakers + REL T/5i sub (x2)

 

Other components:

UpTone Audio LPS1.2/IsoRegen, Fiber Switch and FMC, Windows Server 2016 OS, Audiophile Optimizer 3.0, Fidelizer Pro 6, HQ Player, Roonserver, PS Audio P3 AC regenerator, HDPlex 400W ATX & 200W Linear PSU, Light Harmonic Lightspeed Split USB cable, Synergistic Research Tungsten AC power cords, Tara Labs The One speaker cables, Tara Labs The Two Extended with HFX Station IC, Oyaide R1 outlets, Stillpoints Ultra Mini footers, Hi-Fi Tuning fuses, Vicoustic/RealTraps/GIK room treatments

Share this post


Link to post
Share on other sites

Upgraded to AO2.00. Thanks, Phil.

 

I cannot figure out how to automatically start RoonServer on startup and set shell as HQPlayer in Minimal Server. I've re-read these threads looking for the answer and I've tried adding a shortcut to RoonServer.exe in the Start folder (this works in GUI mode).

 

Can anyone help, please.

 

Thanks!


Synology NAS -> Quadcore i7, 3.8GHz -> RoonServer -> HQPlayer (all up sampled to DSD128) -> Sonore urendu (Uptone JS2 PS) -> Lampizator Golden Gate DAC -> Valvet A4 Monoblocks -> Zu Audio Definitions Mk4

Share this post


Link to post
Share on other sites

You can set Roonserver to start automatically by right clicking the icon in the system tray in GUI mode. As for HQPlayer I have Fidelizer set to launch that at startup for me. Both apps start for me automatically in minimal server mode. I am not sure how to get HQPlayer to start as shell though.

 

Upgraded to AO2.00. Thanks, Phil.

 

I cannot figure out how to automatically start RoonServer on startup and set shell as HQPlayer in Minimal Server. I've re-read these threads looking for the answer and I've tried adding a shortcut to RoonServer.exe in the Start folder (this works in GUI mode).

 

Can anyone help, please.

 

Thanks!


12TB NAS >> i7-6700 Server/Control PC >> i3-5015u NAA >> Singxer SU-1 DDC (modded) >> Holo Spring L3 DAC >> Accustic Arts Power 1 int amp >> Sonus Faber Guaneri Evolution speakers + REL T/5i sub (x2)

 

Other components:

UpTone Audio LPS1.2/IsoRegen, Fiber Switch and FMC, Windows Server 2016 OS, Audiophile Optimizer 3.0, Fidelizer Pro 6, HQ Player, Roonserver, PS Audio P3 AC regenerator, HDPlex 400W ATX & 200W Linear PSU, Light Harmonic Lightspeed Split USB cable, Synergistic Research Tungsten AC power cords, Tara Labs The One speaker cables, Tara Labs The Two Extended with HFX Station IC, Oyaide R1 outlets, Stillpoints Ultra Mini footers, Hi-Fi Tuning fuses, Vicoustic/RealTraps/GIK room treatments

Share this post


Link to post
Share on other sites
Upgraded to AO2.00. Thanks, Phil.

 

I cannot figure out how to automatically start RoonServer on startup and set shell as HQPlayer in Minimal Server. I've re-read these threads looking for the answer and I've tried adding a shortcut to RoonServer.exe in the Start folder (this works in GUI mode).

 

Can anyone help, please.

 

Thanks!

 

hi

 

launch ServiceTool and select "Shell Replacement". Then Choose Roon, RoonServer and reboot.

 

Best,

Phil


ıllıllı [  ...AO 3.00 IS HERE... ] ıllıllı
____________________________________________________________________________________

 

Shop | Core Audio Music Server | Reviews | Reference System | AudiophileOptimizer 3.00 | PDF Guide

 

Share this post


Link to post
Share on other sites

Just to close this issue out I believe the problem was with my wireless keyboard. It had been acting a little flakey lately. My system is now working great with Roonserver and HQPlayer.

 

 

But I dont say Yes to disable network related services. Thats why this is so strange. I will try again. Maybe my wireless keyboard is sending the wrong keystroke signal???

12TB NAS >> i7-6700 Server/Control PC >> i3-5015u NAA >> Singxer SU-1 DDC (modded) >> Holo Spring L3 DAC >> Accustic Arts Power 1 int amp >> Sonus Faber Guaneri Evolution speakers + REL T/5i sub (x2)

 

Other components:

UpTone Audio LPS1.2/IsoRegen, Fiber Switch and FMC, Windows Server 2016 OS, Audiophile Optimizer 3.0, Fidelizer Pro 6, HQ Player, Roonserver, PS Audio P3 AC regenerator, HDPlex 400W ATX & 200W Linear PSU, Light Harmonic Lightspeed Split USB cable, Synergistic Research Tungsten AC power cords, Tara Labs The One speaker cables, Tara Labs The Two Extended with HFX Station IC, Oyaide R1 outlets, Stillpoints Ultra Mini footers, Hi-Fi Tuning fuses, Vicoustic/RealTraps/GIK room treatments

Share this post


Link to post
Share on other sites
hi

 

launch ServiceTool and select "Shell Replacement". Then Choose Roon, RoonServer and reboot.

 

Best,

Phil

 

Roonserver as shell doesn't do anything for me. I need Roonserver running and HQPlayer as shell.

 

I know how to get HQPlayer set up as shell, but do not know how to have Roonserver start automatically on boot? I'll try tboooe's suggestion I guess...putting RoonServer in the Start folder did not work in Minimal Server mode.


Synology NAS -> Quadcore i7, 3.8GHz -> RoonServer -> HQPlayer (all up sampled to DSD128) -> Sonore urendu (Uptone JS2 PS) -> Lampizator Golden Gate DAC -> Valvet A4 Monoblocks -> Zu Audio Definitions Mk4

Share this post


Link to post
Share on other sites

Hi

 

windows knows only one shell, you cannot have two programs as shell. If you need such configuration you need to create a batch file which starts both programs, then set this batch file as shell.

 

Forget about the Autostart Folder, Microsoft designed it to work in GUI mode / minimal-server mode only. The shell replacement is the only way for "autostart" in core/minimal aside from true windows services.

 

Best,

Phil

Edited by AudioPhil

ıllıllı [  ...AO 3.00 IS HERE... ] ıllıllı
____________________________________________________________________________________

 

Shop | Core Audio Music Server | Reviews | Reference System | AudiophileOptimizer 3.00 | PDF Guide

 

Share this post


Link to post
Share on other sites
You can set Roonserver to start automatically by right clicking the icon in the system tray in GUI mode. As for HQPlayer I have Fidelizer set to launch that at startup for me. Both apps start for me automatically in minimal server mode. I am not sure how to get HQPlayer to start as shell though.

 

Right clicking Roon icon in system tray only works for GUI mode. RoonServer does not start in minimal server mode which is a big bummer! Using service tool to set HQPlayer as shell is easy, but if RoonServer is not running already it's worthless to have HQP as shell.

 

A few clarifying points:

1.) not sure why anyone would want to set RoonServer as shell? RoonServer does not have a shell...it runs in the background always. Roon, on the other hand, has a GUI.

2.) I use Roon with HQP and HQP's NAA. The reason I need HQP to be set as shell is that sometimes my NAA hiccups and I need to reset parameters on HQP...my DAC does not switch automatically between DSD and PCM.

3.) because I use an NAA, I'm assuming reducing noise in the main computer won't make much of a difference. I was interested in running RoonServer and HQP in minimal server mode to lower the overall load on the PC while HQP does heavy computational up sampling to DSD256 or DSD512.


Synology NAS -> Quadcore i7, 3.8GHz -> RoonServer -> HQPlayer (all up sampled to DSD128) -> Sonore urendu (Uptone JS2 PS) -> Lampizator Golden Gate DAC -> Valvet A4 Monoblocks -> Zu Audio Definitions Mk4

Share this post


Link to post
Share on other sites

Hi

 

RoonServer (and no other software as well) does not run automatically in core mode, that's why the shell replacement is needed.

 

Best,

Phil

Edited by AudioPhil

ıllıllı [  ...AO 3.00 IS HERE... ] ıllıllı
____________________________________________________________________________________

 

Shop | Core Audio Music Server | Reviews | Reference System | AudiophileOptimizer 3.00 | PDF Guide

 

Share this post


Link to post
Share on other sites
Hi

 

RoonServer does not run automatically in minimal-server or core mode, that's why the shell replacement is needed.

 

Best,

Phil

 

I must be delirious then. I am listening now to HQP + Roonserver on my PC in minimal server mode. In fact I restarted my server last night and both Roonserver and HQP started up fine. As I mentioned earlier, I just selected to start Roonserver automatically while in GUI mode, then ran Fidelizer and selected it to start HQP. I just used Remote Desktop to look at my server and I am definitely in minimal server mode. I see a black screen with my command prompt window (I do not set a shell replacement) and HQP interface showing.

 

@Germanboxers, have you tried actually tried right clicking on Roonserver tray icon and checking the start automatically option then switching to minimal server mode to see if it starts automatically?

 

I do not doubt what Phil says but for whatever reason in my system, Roonserver starts up fine by itself in minimal server mode.


12TB NAS >> i7-6700 Server/Control PC >> i3-5015u NAA >> Singxer SU-1 DDC (modded) >> Holo Spring L3 DAC >> Accustic Arts Power 1 int amp >> Sonus Faber Guaneri Evolution speakers + REL T/5i sub (x2)

 

Other components:

UpTone Audio LPS1.2/IsoRegen, Fiber Switch and FMC, Windows Server 2016 OS, Audiophile Optimizer 3.0, Fidelizer Pro 6, HQ Player, Roonserver, PS Audio P3 AC regenerator, HDPlex 400W ATX & 200W Linear PSU, Light Harmonic Lightspeed Split USB cable, Synergistic Research Tungsten AC power cords, Tara Labs The One speaker cables, Tara Labs The Two Extended with HFX Station IC, Oyaide R1 outlets, Stillpoints Ultra Mini footers, Hi-Fi Tuning fuses, Vicoustic/RealTraps/GIK room treatments

Share this post


Link to post
Share on other sites

@Germanboxers, have you tried actually tried right clicking on Roonserver tray icon and checking the start automatically option then switching to minimal server mode to see if it starts automatically?

 

I do not doubt what Phil says but for whatever reason in my system, Roonserver starts up fine by itself in minimal server mode.

 

Yes, I have right clicked on RoonServer in system tray and selected Start automatically. I verified that it automatically starts in GUI mode then switched to minimal server mode, ran AO, checked after each step and no RoonServer.


Synology NAS -> Quadcore i7, 3.8GHz -> RoonServer -> HQPlayer (all up sampled to DSD128) -> Sonore urendu (Uptone JS2 PS) -> Lampizator Golden Gate DAC -> Valvet A4 Monoblocks -> Zu Audio Definitions Mk4

Share this post


Link to post
Share on other sites
Yes, I have right clicked on RoonServer in system tray and selected Start automatically. I verified that it automatically starts in GUI mode then switched to minimal server mode, ran AO, checked after each step and no RoonServer.

 

Then I have no idea why in my system Roonserver starts by itself. I am going to put my system back into Gui mode then put it back into minimal server mode to see if I can repeat what I did previously.

 

EDIT: I can definitely verify that Roonserver starts up automatically on my system in minimal server mode. Not sure if it matters but when I run AO I select not to enable Roon support. I use Server R2 Essentials.

 

Here is what I did:

 

in GUI mode, select option to start Roonserver automatically by right clicking Roon tray icon

 

switch to minimal server mode and verify that Roonserver is running by connecting with my Android Roon app.

 

run AO in Ultimate mode, enable kernel streaming, select to not support Roon.

 

again verify I can connect to Roonserver via Android app

Edited by tboooe

12TB NAS >> i7-6700 Server/Control PC >> i3-5015u NAA >> Singxer SU-1 DDC (modded) >> Holo Spring L3 DAC >> Accustic Arts Power 1 int amp >> Sonus Faber Guaneri Evolution speakers + REL T/5i sub (x2)

 

Other components:

UpTone Audio LPS1.2/IsoRegen, Fiber Switch and FMC, Windows Server 2016 OS, Audiophile Optimizer 3.0, Fidelizer Pro 6, HQ Player, Roonserver, PS Audio P3 AC regenerator, HDPlex 400W ATX & 200W Linear PSU, Light Harmonic Lightspeed Split USB cable, Synergistic Research Tungsten AC power cords, Tara Labs The One speaker cables, Tara Labs The Two Extended with HFX Station IC, Oyaide R1 outlets, Stillpoints Ultra Mini footers, Hi-Fi Tuning fuses, Vicoustic/RealTraps/GIK room treatments

Share this post


Link to post
Share on other sites

Hi Tboooe

 

i would be very happy if you'd stop confusing people with wrong instructions. When you tell not to say yes to roon support its VERY confusing and will generate a lot of support requests on our side, so please stop it. You have no knowledge about the technical backgrounds and you also don't know what happens when one does not install roon support, but i do.

to get full functionality of RoonServer including playback of all filetypes incl mp3 it is mandatory to add roon support!

 

Thanks a lot,

Phil


ıllıllı [  ...AO 3.00 IS HERE... ] ıllıllı
____________________________________________________________________________________

 

Shop | Core Audio Music Server | Reviews | Reference System | AudiophileOptimizer 3.00 | PDF Guide

 

Share this post


Link to post
Share on other sites
Yes, I have right clicked on RoonServer in system tray and selected Start automatically. I verified that it automatically starts in GUI mode then switched to minimal server mode, ran AO, checked after each step and no RoonServer.

 

What happens when you manually start roonserver via taskmanager?


ıllıllı [  ...AO 3.00 IS HERE... ] ıllıllı
____________________________________________________________________________________

 

Shop | Core Audio Music Server | Reviews | Reference System | AudiophileOptimizer 3.00 | PDF Guide

 

Share this post


Link to post
Share on other sites
Hi Tboooe

 

i would be very happy if you'd stop confusing people with wrong instructions. When you tell not to say yes to roon support its VERY confusing and will generate a lot of support requests on our side, so please stop it. You have no knowledge about the technical backgrounds and you also don't know what happens when one does not install roon support, but i do.

to get full functionality of RoonServer including playback of all filetypes incl mp3 it is mandatory to add roon support!

 

Thanks a lot,

Phil

 

Kind of harsh but this is your thread and your product but please note I never said I got full Roon functionality. In fact I was very specific in my post when I wrote "I am listening now to HQP + Roonserver on my PC in minimal server mode." I was only trying to help Germanboxers by explaining what I did because it sounded to me that he wanted to just use Roonserver as the library manager outputting to HQP for playback like me.

 


12TB NAS >> i7-6700 Server/Control PC >> i3-5015u NAA >> Singxer SU-1 DDC (modded) >> Holo Spring L3 DAC >> Accustic Arts Power 1 int amp >> Sonus Faber Guaneri Evolution speakers + REL T/5i sub (x2)

 

Other components:

UpTone Audio LPS1.2/IsoRegen, Fiber Switch and FMC, Windows Server 2016 OS, Audiophile Optimizer 3.0, Fidelizer Pro 6, HQ Player, Roonserver, PS Audio P3 AC regenerator, HDPlex 400W ATX & 200W Linear PSU, Light Harmonic Lightspeed Split USB cable, Synergistic Research Tungsten AC power cords, Tara Labs The One speaker cables, Tara Labs The Two Extended with HFX Station IC, Oyaide R1 outlets, Stillpoints Ultra Mini footers, Hi-Fi Tuning fuses, Vicoustic/RealTraps/GIK room treatments

Share this post


Link to post
Share on other sites

Hi

 

Sorry if I was harsh, that was not my intent. It's just very dangerous, people will read what you wrote, and in most cases it will not work like that. And this will end up on my table in the end, that's not good... It took me many months to find out exactly what roon needs and what not, and all this is in AO 2.00 now. I appreciate you want to help germanboxers, so do I.

 

But as said, also for Roon/RoonServer it is absolutely mandatory to say YES to "add roon support" (at least ONE time). Sure, most of it will work if you skip the Roon support and just Install KS & MediaPlayer support, but not all of it. And again, this will end up on my table and it will also make the roon guys very angry and i don't want that because of misleading instructions (even if they are meant to help).

 

Best,

Phil


ıllıllı [  ...AO 3.00 IS HERE... ] ıllıllı
____________________________________________________________________________________

 

Shop | Core Audio Music Server | Reviews | Reference System | AudiophileOptimizer 3.00 | PDF Guide

 

Share this post


Link to post
Share on other sites

Ok, I am having exactly the same issue as GermanBoxers. I upgraded to AO 2.0 yesterday. I use Roon with HQP in GUI mode. After upgrading to AO 2.0, I switched to minimal server mode. Roon server and HQP, both needs to be started in order for my setup to work. But its not happening:

 

1. I set HQP as default shell. So, RoonServer is not starting by default. Only way to make this work is to manually start RoonServer.

2. I set RoonServer as default shell. In that case, I have to manually start HQP in minimal server mode.

 

It was quite a frustrating experience. I have switched back to GUI mode since.

 

My question is: How can make sure that in minimal server mode, both RoonServer and HQP starts up automatically?

Share this post


Link to post
Share on other sites

Hi

 

i have already explained the limitations of windows (only one shell is possible.) as well as the solution (custom batch starting both HQP and Roon via shell replacement) to start two different programs as shell. So i cannot really understand your frustration? ;-(

 

if this is an often used configuration i can make something ready to run for you guys...

 

but please don't ve disappointed or frustrated when you try something thats not supposed to work.

 

Best,

Phil


ıllıllı [  ...AO 3.00 IS HERE... ] ıllıllı
____________________________________________________________________________________

 

Shop | Core Audio Music Server | Reviews | Reference System | AudiophileOptimizer 3.00 | PDF Guide

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...