Jump to content
IGNORED

Lumin app not seeing certain folders in MinimServer


Recommended Posts

My setup: Synology 1513+ => ethernet => Oppo105

 

On the Synology: several apps including its own DS Audio, Minimserver and BubblUpnp.

 

Control / browse is done using an Ipad and again a choice os apps:

Oppo Media Control

DS Audio

Lumin

 

I like Lumin, but it behaves oddly with a newly (48 hrs ago) created directory. The files inside are from the 2L download site, to compare the same recordings in 24/192, DSD, MQA.

 

If I point Lumin to 'DiskStation', I can see and play the contents of the folder fine. If I point Lumin to Minimserver, it does not see the folder at all. Everything else is readily visible (including all my other 24/192 and DSD64 files and folders).

 

I have already refreshed and even reloaded the library using Minimserver; still the same issue.

 

Any ideas why this might be the case?

Link to comment
Share on other sites

Is this a problem with the Lumin app or Minimserver. The Lumin app only sees what Minimserver shows it. I would try another control point like BubbleUpnP to see if those folders show up there. If not, then its a Minimserver issue.

12TB NAS >> i7-6700 Server/Control PC >> i3-5015u NAA >> Singxer SU-1 DDC (modded) >> Holo Spring L3 DAC >> Accustic Arts Power 1 int amp >> Sonus Faber Guaneri Evolution speakers + REL T/5i sub (x2)

 

Other components:

UpTone Audio LPS1.2/IsoRegen, Fiber Switch and FMC, Windows Server 2016 OS, Audiophile Optimizer 3.0, Fidelizer Pro 6, HQ Player, Roonserver, PS Audio P3 AC regenerator, HDPlex 400W ATX & 200W Linear PSU, Light Harmonic Lightspeed Split USB cable, Synergistic Research Tungsten AC power cords, Tara Labs The One speaker cables, Tara Labs The Two Extended with HFX Station IC, Oyaide R1 outlets, Stillpoints Ultra Mini footers, Hi-Fi Tuning fuses, Vicoustic/RealTraps/GIK room treatments

Link to comment
Share on other sites

It looks like a Minimserver issue considering I can find and play the files using Lumin / DiskStation but not when using Lumin / Minimserver...

 

What is the path to the music folder you are entering to Minimserver settings? Are there any other music folders at this same location? If so, is any other music files showing up in Minimserver or is it just the XL files not showing up?

12TB NAS >> i7-6700 Server/Control PC >> i3-5015u NAA >> Singxer SU-1 DDC (modded) >> Holo Spring L3 DAC >> Accustic Arts Power 1 int amp >> Sonus Faber Guaneri Evolution speakers + REL T/5i sub (x2)

 

Other components:

UpTone Audio LPS1.2/IsoRegen, Fiber Switch and FMC, Windows Server 2016 OS, Audiophile Optimizer 3.0, Fidelizer Pro 6, HQ Player, Roonserver, PS Audio P3 AC regenerator, HDPlex 400W ATX & 200W Linear PSU, Light Harmonic Lightspeed Split USB cable, Synergistic Research Tungsten AC power cords, Tara Labs The One speaker cables, Tara Labs The Two Extended with HFX Station IC, Oyaide R1 outlets, Stillpoints Ultra Mini footers, Hi-Fi Tuning fuses, Vicoustic/RealTraps/GIK room treatments

Link to comment
Share on other sites

The root directory is fine on Minim. I can see all folders, directories and file types, including DSD and HD Flacs, of the same type as those which are in the still invisible 'MQA Test' directory. That sits inside a 'Test Tracks' directory, which can be seen fine by Minim.

The other directories inside Test Tracks can also be seen by Minim.

 

Only the MQA Test directory remains unseen in Minim and seen fine in Diskstation, always using Lumin.

 

MQA Test contains 3 types of files (Flac 24-192, DSD and MQA)

 

Weird innit?

Link to comment
Share on other sites

Maybe try moving the MQA Test Directory up a level?

12TB NAS >> i7-6700 Server/Control PC >> i3-5015u NAA >> Singxer SU-1 DDC (modded) >> Holo Spring L3 DAC >> Accustic Arts Power 1 int amp >> Sonus Faber Guaneri Evolution speakers + REL T/5i sub (x2)

 

Other components:

UpTone Audio LPS1.2/IsoRegen, Fiber Switch and FMC, Windows Server 2016 OS, Audiophile Optimizer 3.0, Fidelizer Pro 6, HQ Player, Roonserver, PS Audio P3 AC regenerator, HDPlex 400W ATX & 200W Linear PSU, Light Harmonic Lightspeed Split USB cable, Synergistic Research Tungsten AC power cords, Tara Labs The One speaker cables, Tara Labs The Two Extended with HFX Station IC, Oyaide R1 outlets, Stillpoints Ultra Mini footers, Hi-Fi Tuning fuses, Vicoustic/RealTraps/GIK room treatments

Link to comment
Share on other sites

Went into the PC and did a full rescan. Now the folders are all showing up... Strange I could not do that from the Ipad / Lumin and also strange that it does not autoupdate even though that is set in the options... What am I missing?

Link to comment
Share on other sites

Went into the PC and did a full rescan. Now the folders are all showing up... Strange I could not do that from the Ipad / Lumin and also strange that it does not autoupdate even though that is set in the options... What am I missing?

 

I think Minimserver has a timer for rescan. Whenever I add new tracks I have to use Minimwatch to tell Minimserver to rescan otherwise wouldn't see new music added in folders till next day. Even rebooting the NAS doesn't cause a rescan

Regards,

Dave

 

Audio system

Link to comment
Share on other sites

Thanks. On a side note: My Synology/Minim/Lumin/Oppo system never played more than one track at a time. The creator of Minimserver informed me that he added a fix in the latest release (3 feb 2016) which I will be testing this weekend.

Link to comment
Share on other sites

Thanks. On a side note: My Synology/Minim/Lumin/Oppo system never played more than one track at a time. The creator of Minimserver informed me that he added a fix in the latest release (3 feb 2016) which I will be testing this weekend.
Wasn't this an issue between the Oppo's own Media Control app and MinimServer, rather than the LUMIN app and MinimServer?

We will win because our NHS is the beating heart of this country. It is the best of this country. It is unconquerable. It is powered by love.

-- Boris Johnson

 

We are far more united and have far more in common with each other than things that divide us.

-- Jo Cox

Link to comment
Share on other sites

Sort of. The way I understand it, it was an issue between Minimserver and Oppo (not the media control app). In the chain Synology/Minim/Lumin/Oppo, the Oppo Media Control app is not used and the problem persists. If I use the Meddia Control app to browse the NAS directly, there is no problem. As I can only use Lumin in conjunction with Minim, I experienced the issue.

 

This is the explanation I got:

"When using the DiskStation media server, each folder has a UPnP class of 'object.container.storageFolder'. When using MinimServer for folder browsing, each folder has a UPnP class of 'object.container'.

 

It looks like the OPPO control point is checking the container class and is playing the whole album if the container class is 'object.container.storageFolder' but not if the container class is 'object.container'."

Link to comment
Share on other sites

Sort of. The way I understand it, it was an issue between Minimserver and Oppo (not the media control app). In the chain Synology/Minim/Lumin/Oppo, the Oppo Media Control app is not used and the problem persists. If I use the Meddia Control app to browse the NAS directly, there is no problem. As I can only use Lumin in conjunction with Minim, I experienced the issue.

 

This is the explanation I got:

"When using the DiskStation media server, each folder has a UPnP class of 'object.container.storageFolder'. When using MinimServer for folder browsing, each folder has a UPnP class of 'object.container'.

 

It looks like the OPPO control point is checking the container class and is playing the whole album if the container class is 'object.container.storageFolder' but not if the container class is 'object.container'."

Hang, from the explanation, it certainly looks like the same thread (yours) I saw on the MinimServer forum, where you actually mentioned getting the problem using "the same steps in the OPPO Media Control app but selecting Minimserver instead of the DiskStation".

 

I don't thnk you mentioned using the LUMIN app at all in any of the posts on that thread, so you'd best let the MinimServer developer know that, as it might need further investigation.

We will win because our NHS is the beating heart of this country. It is the best of this country. It is unconquerable. It is powered by love.

-- Boris Johnson

 

We are far more united and have far more in common with each other than things that divide us.

-- Jo Cox

Link to comment
Share on other sites

I did mention Lumin in a second thread and he felt the issue was one and the same. According to the developer, the issue was on his (the minimserver) side, which is why he released a fix in update 76 yesterday. As soon as I can, I will test with various control apps including Lumin and I will report back in both threads.

Link to comment
Share on other sites

Fair enough, though, I think the "OPPO control point" mentioned in the developer's explanation in the thread I read is a reference to the OPPO MediaControl app, not the OPPO BDP-105, given the context and seeing as (UPnP) control point is used synonymously with UPnP/DLNA controller apps.

We will win because our NHS is the beating heart of this country. It is the best of this country. It is unconquerable. It is powered by love.

-- Boris Johnson

 

We are far more united and have far more in common with each other than things that divide us.

-- Jo Cox

Link to comment
Share on other sites

Mmm, I'd best not continue to add to the cross posts, especially when relating to another forum. Hopefully MinimServer's simoncn isn't himself confused by all this :)

We will win because our NHS is the beating heart of this country. It is the best of this country. It is unconquerable. It is powered by love.

-- Boris Johnson

 

We are far more united and have far more in common with each other than things that divide us.

-- Jo Cox

Link to comment
Share on other sites

I am testing the playback of the new update with the 'desired' chain:

 

 

Synology=>Minimserver=>BubbleUpnp=>Lumin app on the Ipad=>Oppo105

 

 

Still only plays the one song of an album. At the end of the track, play stops on the Oppo and I can see the Lumin app 'churning' like it wants to do something else, but nothing happens.

 

 

When I use the 'old' chain:

 

 

Synology=>Oppo Media Controller on the Ipad=>Oppo105

 

 

The same album plays straight through...

Link to comment
Share on other sites

Oh dear, might be best to summarise exactly what you did and make sure MinimServer's developer knows exactly what that was. Here's my understanding (please correct any misunderstandings as it's all getting quite confusing):

 

The OPPO MediaControl app has two methods of controlling the OPPO 105 with access to your Synology NAS:

1. networked shared folder - what you call "browsing the NAS directly", using either the SMB or NFS Source on MediaControl app, depending on which of those network file sharing protocols you are using on the Synology NAS.

 

2. UPnP/DLNA media server - via either MinimServer or the DiskStation (UPnP/DLNA) media server, using the DMS (Digital Media Server, ie, DLNA speak for UPnP media server) Source on the MediaControl app.

 

I believe you've found that using the OPPO MediaControl app to access the music files via method 1 produces no multiple track playback problems on the OPPO, whereas accessing via method 2 does.

 

Also, I believe you've tried controlling the OPPO with the LUMIN OpenHome (aka UPnP with Linn extensions) app, using the BubbleUPnP Server helper application to provide the OpenHome emulator for the standard UPnP supporting OPPO. I think you've used the LUMIN app to access both the MinimServer and the Diskstation media server, with the OPPO. Both UPnP media servers have the same one track only playback problem as method 2 above. This isn't really surprising as it's actually the same thing, ie using UPnP to access the UPnP media server and control the playback & network streaming of the OPPO.

 

It's very likely that MinimServer's developer is somehow not aware that your successful OPPO multitrack playback is actually only using the network shared folder access to the Synology NAS (ie method 1 with the OPPO MediaControl app) and that you've never had a successful OPPO multitrack UPnP streaming playback, so accessing either the MinimServer or the Diskstation UPnP media servers (ie option 2 with the OPPO MediaControl app and with any UPnP supporting controller such as the LUMIN app).

 

I believe the developer wrongly thinks you are having success with a the DiskStation media server, but not MinimServer when using the MediaControl app (and probably the LUMIN app), hence his explanation for the fix and ultimately the fix not working.

We will win because our NHS is the beating heart of this country. It is the best of this country. It is unconquerable. It is powered by love.

-- Boris Johnson

 

We are far more united and have far more in common with each other than things that divide us.

-- Jo Cox

Link to comment
Share on other sites

I am testing the playback of the new update with the 'desired' chain:

 

 

Synology=>Minimserver=>BubbleUpnp=>Lumin app on the Ipad=>Oppo105

 

 

Still only plays the one song of an album. At the end of the track, play stops on the Oppo and I can see the Lumin app 'churning' like it wants to do something else, but nothing happens.

 

 

When I use the 'old' chain:

 

 

Synology=>Oppo Media Controller on the Ipad=>Oppo105

 

 

The same album plays straight through...

 

Check to old chain, that works for both UPNP and SMB.

 

If you want better controller graphics you should be able to use Bubble UPNP directly with the Oppo and Synology NAS.

 

Oppo is not Open Home friendly, stay away from Open Home based controllers.

Regards,

Dave

 

Audio system

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...