Jump to content
IGNORED

Disappointment with Teradak


dminches
 Share

Recommended Posts

I purchased an ATX 275W power supply from them 6 weeks ago. When it arrived it was shutting off after about 15 minutes of use. I tried to get them to agree to have it shipped back but they pushed back and asked that I try to help them fix it. I said ok.

 

They sent me 3 new power modules and instructions (in Mandarin!) on how to replace them. Fortunately I have a couple people working for me who speak Mandarin so they were able to translate it. I followed their instructions and replaced them one by one. The unit powers up but still shuts off. I can measure the voltage for each module but it is not steady.

 

Skip forward to now and the unit is still not working. I have done my best to fix it but now it should be on them. They still won't agree to have me ship it back. I have filled a claim with paypal to protect myself.

 

I would proceed with caution with them. They make nice products but if they break good luck getting it fixed.

Speakers: Vandersteen Model 7s, 4 M&K ST-150Ts, 1 VCC-5; Amplification: 2 Vandersteen M7-HPAs, CI Audio D200 MKII, Ayre V-6xe; Preamp: Doshi Audio Line Stage v3.0; Phono Pre: Doshi Audio Phono Pre; Analog: Wave Kinetics NVS with Durand Telos composite arm; SME 3012R arm, Clearaudio Goldfinger Statement v2; Reel to Reel:  Technics RS-1500; Doshi Tape Pre-Amp; Studer A810, Studer A812, Tascam BR-20; Multi-channel: Bryston SP-3; Digital: Custom PC (Sean Jacobs DC4/Euphony/Stylus)> Lampizator Pacific

Link to comment
Share on other sites

Yes. Support is not the best. I have had some issues with them also. Not their fault in my case, but they did not care to try and help fix the issue. Specially I was dealing with Michael directly and he did not care about customer's issues with his products...

Synology NAS (LPS) >UA ETHER REGEN (BG7TBL Master Clock) > MACMINI (Uptone MMK JS-2) > Auralic Aries 2.1 > (LPS-2) > AUDIO-GD DI20HE (BG7TBL Master Clock) (I2S OUT)LampizatOr GG /Meridian 808.3> Wavac PRT1 / Wavac EC300B >Tannoy Canterbury SE

 

HP Rig ++ >Woo WES/ > Stax SR-009, Audeze LCD2

Link to comment
Share on other sites

So Michael is the owner? He has said several times that he needs to speak to his boss.

Speakers: Vandersteen Model 7s, 4 M&K ST-150Ts, 1 VCC-5; Amplification: 2 Vandersteen M7-HPAs, CI Audio D200 MKII, Ayre V-6xe; Preamp: Doshi Audio Line Stage v3.0; Phono Pre: Doshi Audio Phono Pre; Analog: Wave Kinetics NVS with Durand Telos composite arm; SME 3012R arm, Clearaudio Goldfinger Statement v2; Reel to Reel:  Technics RS-1500; Doshi Tape Pre-Amp; Studer A810, Studer A812, Tascam BR-20; Multi-channel: Bryston SP-3; Digital: Custom PC (Sean Jacobs DC4/Euphony/Stylus)> Lampizator Pacific

Link to comment
Share on other sites

I followed their instructions and replaced them one by one. The unit powers up but still shuts off. I can measure the voltage for each module but it is not steady.

It seems highly unlikely that all 3 replacement modules are faulty, and perhaps the problem is further back towards the main DC output area. Are the voltages readings of the 3 modules close to their target voltages, and by how much do they fluctuate ?

Regards

Alex

 

How a Digital Audio file sounds, or a Digital Video file looks, is governed to a large extent by the Power Supply area. All that Identical Checksums gives is the possibility of REGENERATING the file to close to that of the original file.

PROFILE UPDATED 13-11-2020

Link to comment
Share on other sites

It seems highly unlikely that all 3 replacement modules are faulty, and perhaps the problem is further back towards the main DC output area. Are the voltages readings of the 3 modules close to their target voltages, and by how much do they fluctuate ?

Regards

Alex

 

Alex, the unit was shutting down since one (or more) of the voltages were out of range. Today they showed me how to short the unit so it wouldn't shut down. I was able to do that and found that the 3.3V module was putting out 7V! All 3 are now at the right level. I need to replace a couple screws before I can fully test the unit.

Speakers: Vandersteen Model 7s, 4 M&K ST-150Ts, 1 VCC-5; Amplification: 2 Vandersteen M7-HPAs, CI Audio D200 MKII, Ayre V-6xe; Preamp: Doshi Audio Line Stage v3.0; Phono Pre: Doshi Audio Phono Pre; Analog: Wave Kinetics NVS with Durand Telos composite arm; SME 3012R arm, Clearaudio Goldfinger Statement v2; Reel to Reel:  Technics RS-1500; Doshi Tape Pre-Amp; Studer A810, Studer A812, Tascam BR-20; Multi-channel: Bryston SP-3; Digital: Custom PC (Sean Jacobs DC4/Euphony/Stylus)> Lampizator Pacific

Link to comment
Share on other sites

Alex, the unit was shutting down since one (or more) of the voltages were out of range. Today they showed me how to short the unit so it wouldn't shut down. I was able to do that and found that the 3.3V module was putting out 7V! All 3 are now at the right level. I need to replace a couple screws before I can fully test the unit.

 

That's great news ! Was this one of the 3 replacement PSU modules that they sent you ? If so, it suggests that perhaps one of the originals was outside limits too, which may indicate poor quality control.

 

How a Digital Audio file sounds, or a Digital Video file looks, is governed to a large extent by the Power Supply area. All that Identical Checksums gives is the possibility of REGENERATING the file to close to that of the original file.

PROFILE UPDATED 13-11-2020

Link to comment
Share on other sites

I have 3 new modules in the unit so I don't know what was bad, but it was way out of spec.

 

Keeping my fingers crossed that the unit will be ok now.

Speakers: Vandersteen Model 7s, 4 M&K ST-150Ts, 1 VCC-5; Amplification: 2 Vandersteen M7-HPAs, CI Audio D200 MKII, Ayre V-6xe; Preamp: Doshi Audio Line Stage v3.0; Phono Pre: Doshi Audio Phono Pre; Analog: Wave Kinetics NVS with Durand Telos composite arm; SME 3012R arm, Clearaudio Goldfinger Statement v2; Reel to Reel:  Technics RS-1500; Doshi Tape Pre-Amp; Studer A810, Studer A812, Tascam BR-20; Multi-channel: Bryston SP-3; Digital: Custom PC (Sean Jacobs DC4/Euphony/Stylus)> Lampizator Pacific

Link to comment
Share on other sites

Alex, the unit was shutting down since one (or more) of the voltages were out of range. Today they showed me how to short the unit so it wouldn't shut down. I was able to do that and found that the 3.3V module was putting out 7V! All 3 are now at the right level. I need to replace a couple screws before I can fully test the unit.

 

Hi DM, I've mentioned in another thread that I'm having exactly the same problem with my Teradak. Michael has asked me to take a video of the issue, but because in my case it's so intermittent it's difficult to catch at the right moment (it rarely happens on boot-up, more often at some random time after boot-up).

 

But it seems you've found the solution. Could you let me know exactly what you did to get all the voltages at the correct levels please? I'd really appreciate this as I would have no way of translating Mandarin instructions into English. (Feel free to send me a PM if it's easier.)

 

Cheers,

Mani.

Main: Okto dac8PRO -> 6x Neurochrome 286 mono amps -> Tune Audio Anima speakers + 2x Rotel RB-1590 stereo amps -> 4x subs
Office: MOTU UltraLite-mk5 -> 6x Neurochrome 286 mono amps -> Impulse H2 speakers
Vinyl: Thöress Phono Enhancer -> RME ADI-2 Pro

Link to comment
Share on other sites

Hi DM, I've mentioned in another thread that I'm having exactly the same problem with my Teradak. Michael has asked me to take a video of the issue, but because in my case it's so intermittent it's difficult to catch at the right moment (it rarely happens on boot-up, more often at some random time after boot-up).

 

But it seems you've found the solution. Could you let me know exactly what you did to get all the voltages at the correct levels please? I'd really appreciate this as I would have no way of translating Mandarin instructions into English. (Feel free to send me a PM if it's easier.)

 

Cheers,

Mani.

 

PM sent.

 

I ran the unit for 2 hours with no issues today. Hopefully this is permanent.

Speakers: Vandersteen Model 7s, 4 M&K ST-150Ts, 1 VCC-5; Amplification: 2 Vandersteen M7-HPAs, CI Audio D200 MKII, Ayre V-6xe; Preamp: Doshi Audio Line Stage v3.0; Phono Pre: Doshi Audio Phono Pre; Analog: Wave Kinetics NVS with Durand Telos composite arm; SME 3012R arm, Clearaudio Goldfinger Statement v2; Reel to Reel:  Technics RS-1500; Doshi Tape Pre-Amp; Studer A810, Studer A812, Tascam BR-20; Multi-channel: Bryston SP-3; Digital: Custom PC (Sean Jacobs DC4/Euphony/Stylus)> Lampizator Pacific

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...