Jump to content
IGNORED

Roon / HQPlayer Integration


The Computer Audiophile
 Share

Recommended Posts

Can not play native DSD files with Roon through Hqplayer.If I try to play DSD file get no sound and the time bar goes from one second to end of song instantly,also switches to a different album.At this point I have to quit Roon and restart as even my Flac files will not play

Link to comment
Share on other sites

Given that a lot of us are going to be interested in implementing this combination, does anyone have it working to their satisfaction yet, i.e. without stutters, playing back both PCM and DSD without restarting the program, etc?

 

If so, could you share what computer hardware you are using and what your HQP settings are?

 

Much appreciated!

Synology NAS>i7-6700/32GB/NVIDIA QUADRO P4000 Win10>Qobuz+Tidal>Roon>HQPlayer>DSD512> Fiber Switch>Ultrarendu (NAA)>SMSL M500 DAC> Bryston SP3 pre>Levinson No. 432 amps>Magnepan (MG20.1x2, CCR and MMC2x6)

Link to comment
Share on other sites

Given that a lot of us are going to be interested in implementing this combination, does anyone have it working to their satisfaction yet, i.e. without stutters, playing back both PCM and DSD without restarting the program, etc?

 

If so, could you share what computer hardware you are using and what your HQP settings are?

 

Much appreciated!

 

No problems here, after a couple of tweaks:

 

1) DSD > DSD resampling takes a *lot* more resources than PCM > DSD transcoding. Don't do it (File | DSDIFF/DSF settings . . . | DirectSDM "On")

2) Limit the DSF sample rate to the highest your computer can do *without* stuttering (e.g., my DAC will do DSD512, but the highest my computer can do reliably is DSD128)

3) Allow enough time between stops in Roon for the interface to reset; i.e., if you click Stop, then immediately try to play something else, you can count on it loosing the connection or hanging

4) For that matter, use the "CTRL-T" keyboard shortcut to stop, instead of clicking the Stop button

5) If you do get stuck (i.e., Roon acts as if it's playing, but no sound is coming out), click the Volume button in the lower right hand corner, then click the (somewhat) hidden "Reset" button - you should regain control without having to restart either Roon or HQPlayer

6) Finally, be sure you have the IP address configured correctly - the stream comes from the *server*, not your remote . . . so the local "loopback" address will only work if HQPlayer is installed on the same box as your Roon server. If your HQPlayer is on a different computer from your Roon server, you must specify the actual IP address of the HQPlayer computer for the stream to work.

John Walker - IT Executive

Headphone - MacMini running Roon Server > Netgear Orbi wireless > Blue Jeans Cable Ethernet > mRendu Roon endpoint > iFi Audio xDSD + iFi Audio xCAN > Focal Elegia

Home Theater - Mac Mini running Roon Server > Blue Jeans Cable HDMI > Pioneer Elite SC-81 > MartinLogan Motion series home theater speakers + M&K subwoofer

Link to comment
Share on other sites

Have direct directSDM on.Will not play native DSD files with Roon and Hqplayer.Will play the DSD file through Hqplayer by itself.Also have had Hqplayer quit a few times .

 

Hm . . . works for me :P Obviously, still some variables to sort out!

John Walker - IT Executive

Headphone - MacMini running Roon Server > Netgear Orbi wireless > Blue Jeans Cable Ethernet > mRendu Roon endpoint > iFi Audio xDSD + iFi Audio xCAN > Focal Elegia

Home Theater - Mac Mini running Roon Server > Blue Jeans Cable HDMI > Pioneer Elite SC-81 > MartinLogan Motion series home theater speakers + M&K subwoofer

Link to comment
Share on other sites

It works well for me. Do have an occasional problem with loss of connection. But as John said, this is solved with a click on the volume icon in Roon, and then a click on the "disconnect" (broken link) icon. After that you can restart playback.

 

Outlaw: Does your Roon setup show that it recognizes and is connected to HQP? If HQP works on it's own, it should work with Roon. All Roon is doing is sending a digital stream to HQP.

 

To repeat: Are your Roon server installation and your HQP setup on the same PC? If so, define HQP as "localhost" in Roon. If they are on different PCs, then define HQP with the home network IP of its' machine in your network.

 

Worth it to look at the Roon Community thread on how to setup HQP integration. Also the Roon people are really good with support, I recommend asking support questions in the support section. There's already an HQP thread.

Main listening (small home office):

Main setup: Surge protector +_iFi  AC iPurifiers >Isol-8 Mini sub Axis Power Conditioning+Isolation>QuietPC Low Noise Server>Roon (Audiolense DRC)>Stack Audio Link II>Kii Control>Kii Three >GIK Room Treatments.

Secondary Listening: Server with Audiolense RC>RPi4 or analog>Matrix Element i Streamer/DAC (XLR)+Schiit Freya>Kii Three .

Bedroom: SBTouch to Cambridge Soundworks Desktop Setup.
Living Room/Kitchen: RPi 3B+ running RoPieee to a pair of Morel Hogtalare. 

All absolute statements about audio are false :)

Link to comment
Share on other sites

Got mu Eureka moment when Roon and HQ worked!

Now I can't get it to play DSD...

 

Anyone figure this out?

thx

You two men go that way...

 

 

QNAP TS-131P->2019 Mac Mini-> -> dCS BArtok  -> balanced XLR -> Nagra MPA ->Shunyata Research cables and Hydra 6 -> Acapella La Campanella 2 horn speakers and REL R-328 SubBase. HiFi Rack Reference audio stand.

Link to comment
Share on other sites

Thank you,

I can leave it on SDM/DSD all of the time, even for 16/44 playback?

Am I ok with the DSD5v2 252 +fs setting?

Bernard

You two men go that way...

 

 

QNAP TS-131P->2019 Mac Mini-> -> dCS BArtok  -> balanced XLR -> Nagra MPA ->Shunyata Research cables and Hydra 6 -> Acapella La Campanella 2 horn speakers and REL R-328 SubBase. HiFi Rack Reference audio stand.

Link to comment
Share on other sites

Apparently, my poor old mid-2011 Mac mini (2.3GHz Core i5, 8GB RAM) doesn't have enough horsepower to convert PCM to DSD on the fly without stuttering. However, if I play my ALAC files as PCM (Roon -> HQP), I can upsample and filter without a lot of issues.

 

Is there a way to set up HQP so that it plays PCM as PCM and DSF as SDM without me having to manually switch it over?

 

(I'm also willing to entertain the possibility that I'm missing something obvious and I should be able to convert PCM to DSD64 on the fly without the stuttering.)

 

--David

Listening Room: Mac mini (Roon Core) > iMac (HQP) > exaSound PlayPoint (as NAA) > exaSound e32 > W4S STP-SE > Benchmark AHB2 > Wilson Sophia Series 2 (Details)

Office: Mac Pro >  AudioQuest DragonFly Red > JBL LSR305

Mobile: iPhone 6S > AudioQuest DragonFly Black > JH Audio JH5

Link to comment
Share on other sites

I'm enjoying the sound of HQ Player fed by Roon, although it is sometimes a struggle to get HQPlayer to work on my MacMini 2011. I am getting frequent crashes, disconnections, etc.

 

If I use the Polysinc setting, I get stuttering, si I cannot use that setting. Closed form settings do work but the program seems to revert to Polysinc whenever it restarts (or after crashes, of which there have been quite a few). How do I get HQPlayer to "remember" to start up in a Closed Form setting?

Link to comment
Share on other sites

I'm enjoying the sound of HQ Player fed by Roon, although it is sometimes a struggle to get HQPlayer to work on my MacMini 2011. I am getting frequent crashes, disconnections, etc.

 

If I use the Polysinc setting, I get stuttering, si I cannot use that setting. Closed form settings do work but the program seems to revert to Polysinc whenever it restarts (or after crashes, of which there have been quite a few). How do I get HQPlayer to "remember" to start up in a Closed Form setting?

 

Definitely a work in progress, BUT, does show promise. I am clueless to the various settings so am just happy to see the possibilities, which I can see are huge, in the near future.

Link to comment
Share on other sites

You have to set the same setting in the settings window. File/Settings. Also, try the polysinc filters with -2s settings —*those are way easier with processors

MacBook Pro + Roon > Airport Extreme > microRendu + mbps-d2s > Auralic Vega > McIntosh MC275 > Yamaha NS-2000

Wired with: High Fidelity CT-1 Enhanced RCA, Revelation Audio Labs, Fadel Art Coherence PC

Link to comment
Share on other sites

You have to set the same setting in the settings window. File/Settings. Also, try the polysinc filters with -2s settings —*those are way easier with processors

 

Thank you for the tip and using Settings (or on my Mac, Preferences) to get the program to remember the preferred filter. That worked. However, I still have the same problem with the polysinc -2s filters -- very bad stuttering, slowed down music, etc.

 

My other difficulty is that when playing tracks with a high sampling rate (96 kHz or 192 kHz) I get a very loud hissing overlaying the music. Playing 44 kHz material or DSD files is no problem (and they sound great). Any ideas?

Link to comment
Share on other sites

Thank you for the tip and using Settings (or on my Mac, Preferences) to get the program to remember the preferred filter. That worked. However, I still have the same problem with the polysinc -2s filters -- very bad stuttering, slowed down music, etc.

 

My other difficulty is that when playing tracks with a high sampling rate (96 kHz or 192 kHz) I get a very loud hissing overlaying the music. Playing 44 kHz material or DSD files is no problem (and they sound great). Any ideas?

 

I'm also getting that hiss sound sometimes (when oversample higher than DSD64) that's because Vega's clock are too sensitive and precise while the current version of HQP isn't as far as I can hear)

 

Regarding the stuttering and stuff, check the processes in the Activity Monitor. Maybe there are some eating the power also? Or it is possible your Mac isn't powerful enough?

MacBook Pro + Roon > Airport Extreme > microRendu + mbps-d2s > Auralic Vega > McIntosh MC275 > Yamaha NS-2000

Wired with: High Fidelity CT-1 Enhanced RCA, Revelation Audio Labs, Fadel Art Coherence PC

Link to comment
Share on other sites

I believe there are some bugs in 3.12b3 that were acknowledged earlier on, and will be fixed soon.

 

I never had problems with the poly-sinc family of filters but now I have major stuttering where I had none before. Using "closed form" with ASDM7, @ DSD256 for now.

Metrum Onyx DAC, Matrix X-SPDIF2 DDC, Snake River Boomslang Digital cable, Verastarr Nemesis USB cable;

Backert Rhumba 1.2 Preamp; Coincident M300B Frankenstein mkII SET monoblocks

Omega Super Alnico HO Monitors (Cherry finish) / Martin Logan Depth i Subwoofer

Macbook Pro (mid-2012, 2.3GHz i7, 16Gb RAM, 512Gb SSD), HQPlayer, Tidal, Roon;

Cabling by Cerious Tech (Graphene SC, Blue PCs), Verastarr (IC and PC) and Teo Audio (GC IC)

 

Link to comment
Share on other sites

I'm also getting that hiss sound sometimes (when oversample higher than DSD64) that's because Vega's clock are too sensitive and precise while the current version of HQP isn't as far as I can hear)

 

Regarding the stuttering and stuff, check the processes in the Activity Monitor. Maybe there are some eating the power also? Or it is possible your Mac isn't powerful enough?

 

I have a probably-underpowered late 2012 Mac Mini 2.3 GHz Intel Core i7 with 8 Gb of RAM -- would doubling the RAM to 16 Gb help? I have basically nothing else running except HQP and RoonServer. With Closed Form I am getting 70% of CPU for HQP; with Polysinc - 2s (which just starting working for some reason), i get 125% of CPU (which seems impossible).

Link to comment
Share on other sites

I have a probably-underpowered late 2012 Mac Mini 2.3 GHz Intel Core i7 with 8 Gb of RAM -- would doubling the RAM to 16 Gb help? I have basically nothing else running except HQP and RoonServer. With Closed Form I am getting 70% of CPU for HQP; with Polysinc - 2s (which just starting working for some reason), i get 125% of CPU (which seems impossible).

 

Not sure regarding +8gig of ram honestly(

At first with clean polysinc I got 200% and I believe it means that 2 cores are 100% loaded. No magic here)

MacBook Pro + Roon > Airport Extreme > microRendu + mbps-d2s > Auralic Vega > McIntosh MC275 > Yamaha NS-2000

Wired with: High Fidelity CT-1 Enhanced RCA, Revelation Audio Labs, Fadel Art Coherence PC

Link to comment
Share on other sites

I believe there are some bugs in 3.12b3 that were acknowledged earlier on, and will be fixed soon.

 

I never had problems with the poly-sinc family of filters but now I have major stuttering where I had none before. Using "closed form" with ASDM7, @ DSD256 for now.

 

Hope so indeed!

MacBook Pro + Roon > Airport Extreme > microRendu + mbps-d2s > Auralic Vega > McIntosh MC275 > Yamaha NS-2000

Wired with: High Fidelity CT-1 Enhanced RCA, Revelation Audio Labs, Fadel Art Coherence PC

Link to comment
Share on other sites

3.12 stable is live now Signalyst

Haven't tested yet but should be more reliable!

 

- Support for Roon as control interface and media source.

- Support for offloading part of the processing to a GPU using NVIDIA CUDA.

- Support for cross-application raw streams and extensions to the remote control API.

- Lower overhead Pipeline SDM implementation.

- Fix ASDM7 initialization bug.

- Various smaller fixes and optimizations.

MacBook Pro + Roon > Airport Extreme > microRendu + mbps-d2s > Auralic Vega > McIntosh MC275 > Yamaha NS-2000

Wired with: High Fidelity CT-1 Enhanced RCA, Revelation Audio Labs, Fadel Art Coherence PC

Link to comment
Share on other sites

Ok, just tested this version and now it works fine even with the clean poly-sinc filter.

MacBook Pro + Roon > Airport Extreme > microRendu + mbps-d2s > Auralic Vega > McIntosh MC275 > Yamaha NS-2000

Wired with: High Fidelity CT-1 Enhanced RCA, Revelation Audio Labs, Fadel Art Coherence PC

Link to comment
Share on other sites

Ok, just tested this version and now it works fine even with the clean poly-sinc filter.

 

Same here. The regular poly-sinc filter works fine, as do various sampling rates that were giving me problems before.

 

I still have occasional problems switching among different albums/tracks. I have to hit the volume control disconnection button to get things going again sometimes.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...