Jump to content
IGNORED

LAN Driver install problem on Server 2012


kilroy

Recommended Posts

I'm having trouble installing a LAN driver on a new server and would like to know how others have gotten around this problem.

 

The LAN chip is Intel I219V on a consumer-level board running Server 2012 R2. No dedicated Server 2012 driver exists for this board. I've tried two different boards from two manufacturers with the same results, using the supplied Win 8.1 and 10 drivers, as well as drivers from the board maker sites and from the Intel site. All fail. The driver install starts up then fails, with the message "Can not install drivers. No Intel adapters are present in this computer."

 

Research online shows other earlier LAN chips had a similar problem. There were driver hacks available which was rewriting the driver inf files, which honestly seems over my head. CA had a post on this as well a few years back for the 82579v LAN chip. I'm hopeful that someone has hacked this driver and is willing to share it. Or another viable solution.

 

Does anyone have a simple solution for this issue? Heck, I'm almost willing to compensate someone for hacking a workable driver for me. Maybe :)

 

The workarounds of course would be to install a separate compatible LAN card, but space is tight, or installing W10, which I really don't want to do.

 

Thanks.

Link to comment
I went through the same problem.

I posted the exact procedure for installing desktop LAN chips.

Here it is:

Windows Server 2012R2 - Pagina 9

(You easily translate it with Chrome)

 

Follow each step closely. It works, as tested by many people.

 

Please give me confirmation :)

 

Thanks for this.

 

I tried it a few times but it did not work. :( The message is "Windows can not find driver software for your device".

 

I followed the directions exactly. Note this is a newer version, I219V. Maybe there is a difference from the I217V/I218V?

 

Do you have any suggestions?

Link to comment
  • 5 months later...
  • 6 months later...

Sometimes going into Device Mgr and choosing (right click) to upgrade driver, then pointing to software will install it. If the driver is in an EXE or install format, you will need to get this unpacked so you can point to the software files. (usually unpacked in a TEMP directory somewhere).

 

There are some commands you can run (tells windows not to validate for other OS) before trying to install the driver which may help, sometimes it doesn't.

 

The last way is to first find the device ID, second find ID in INF file, then edit to be able to install. Plenty of info on the net describing how.

Link to comment
  • 4 years later...

Hello,

 

I came across this topic from a google search.

 

I recently bought an Intel motherboard; ASRock BM460 Pro4. This board comes with Intel I-219V network adapter. I'm running Windows Server 2012 R2, and I cannot get a working driver at all.

 

If someone can help me get this working I would appreciate it.

 

Hardware IDs are:

VEN_8086&DEV_0D55&SUBSYS_0D551849&REV_00
VEN_8086&DEV_0D55&SUBSYS_0D551849
VEN_8086&DEV_0D55&CC_020000
VEN_8086&DEV_0D55&CC_0200

 

Thanks in advance

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...