Jump to content
IGNORED

MCH DSD Skips in Jriver 20


Recommended Posts

every 5 minutes or so I get a ever so brief skip playing multi channel DSD converted to PCM in Jriver. I am also using Dirac, so plenty processing going on, but should be easy workload for my CPU. I don't have the problem playing Blu Ray rips, or any other MCH or 2 channel content. Any suggestions what could be the problem? My be a Jriver setting I could change (buffer?). I'm running Jriver 20. Could upgrading to 21 potentially solve the problem?

Link to post
Share on other sites

Try increasing the buffer size.

 

Tools > Options > Audio > Device Settings > Buffering

 

Default setting is 50 milliseconds, Try bumping it up to 250 or 500 milliseconds.

Win10 Transport + Fidelizer 8.7 + JRMC 27 & HQPlayer | Mutec MC-3+ Smart Clock USB |  Job INT | Green Mountain Audio Eos HX

 

 

Link to post
Share on other sites

How much memory is being used at time of problems?

"The gullibility of audiophiles is what astonishes me the most, even after all these years. How is it possible, how did it ever happen, that they trust fairy-tale purveyors and mystic gurus more than reliable sources of scientific information?"

Peter Aczel - The Audio Critic

no-mqa-sm.jpg

Link to post
Share on other sites

Are you using a mch DAC? I do get skips with JR also. I tried to look up Dirac and found the scientist. Larry

Analog-VPIClas3,3DArm,SoundsmithZephyrII+MiyajimaZeromono,Herron VTPH2APhono,2AmpexATR-102+Doshi3.0+MerrillTridentMaster TapePreamp  Dig Rip-Pyramix,IzotopeRX3Adv,MykerinosCard,PacificMicrosonicsModel2; Dig Play-Lampi Pacific, mch NADAC, Roon-HQPlayer,Oppo105  Electronics-DoshiPre,CJ MET1mchPre,Cary2A3monoamps Speakers-AvantgardeDuosLR,3SolosC,LR,RR

Other-2x512EngineerMarutaniSymmetrical Power+Cables Music-15KRecs(90%classical),1.3KR2Rtapes,1.5KCD's,500SACDs,50TBripped files

Link to post
Share on other sites
Are you using a mch DAC? I do get skips with JR also. I tried to look up Dirac and found the scientist. Larry
I am running JRMC and Dirac in multichannel feeding multichannel DACs via USB and I do not get skips. The player is either an i7-based Baetis or a MacMini i5 running Win7 under BootCamp. I use (or used) several versions of JRMC successfully and I really doubt that hardware is the issue unless the OP's player is a stripped-down wimp.

 

FWIW: Overview | Dirac Research

Kal Rubinson

Senior Contributing Editor, Stereophile

 

Link to post
Share on other sites
I am running JRMC and Dirac in multichannel feeding multichannel DACs via USB and I do not get skips. The player is either an i7-based Baetis or a MacMini i5 running Win7 under BootCamp. I use (or used) several versions of JRMC successfully and I really doubt that hardware is the issue unless the OP's player is a stripped-down wimp.

 

FWIW: Overview | Dirac Research

 

Are you converting DSD (SACD rips) on the fly like me? I don't have a problem playing native MCH Flacs (96/24). What buffer setting are you using?

Link to post
Share on other sites
Try increasing the buffer size.

 

Tools > Options > Audio > Device Settings > Buffering

 

Default setting is 50 milliseconds, Try bumping it up to 250 or 500 milliseconds.

 

Just did. Will check if buffer size increase will solve the problem. I was using 100ms.

Link to post
Share on other sites
Are you converting DSD (SACD rips) on the fly like me? I don't have a problem playing native MCH Flacs (96/24).
I am converting DSFs and ISOs on the fly.

 

What buffer setting are you using?
50ms but I have also checked to "Use large hardware buffers."

Kal Rubinson

Senior Contributing Editor, Stereophile

 

Link to post
Share on other sites

Check that you have this option disabled: "Play files from memory instead of disk (not zone-specific)"

They broke DSD playback when this setting is enabled from JRiver 19 onwards.

 

With JRiver 18 I could play 6ch SACD in 3 rooms at once. (18 channels)

With JRiver 19-21 the same system struggles to play 6ch SACD in a single room without stuttering.

 

The problem is that JRiver 19 made the program store decoded (uncompressed) audio in the memory buffer, while JRiver 18 stored compressed audio in the memory buffer.

Because the buffer is limited to 1GB, and because uncompressed SACD takes up so much memory (some tracks would require >20GB!) it has to keep filling up the buffer every minute or so.

 

Here is playback of a 5 minute track showing the CPU and Disk/Network access.

Memory Playback on:

memory-onkxssy.png

 

Memory Playback off:

memory-offojov6.png

 

Because it requires so much CPU and I/O access every minute or so, it is very susceptible to interruption if anything else is running on the computer, whether that is multi-room playback or doing something else on the PC at the same time.

Conversely, JRiver itself will interrupt other processes running on the system with this. Even scrolling a web page while listening to music is affected by this.

And it uses a lot of memory. The buffer is always 1GB even though most of my SACD tracks are less than one fourth the size.

 

But they won't change it.

It took roughly a year for them to fix their dither once it was discovered that their implementation was distorting, and only because Bob Katz returned after doing his own tests which confirmed it. They still lock discussion of the subject on their forums and have banned many people over it.

As responsive as JRiver seem to be about fixing or changing certain things, they don't like to look back and admit that they made a mistake somewhere.

 

It's a shame because their memory playback could be so much more efficient.

Instead of struggling to play one track at a time, as it does now, it could cache most or all of an album in memory (depending on audio format) with that 1GB if it stored compressed audio, and that would completely eliminate the reliance on disk/network access.

The only thing the option currently does is increase the CPU and disk/network requirements, making it more likely for playback to be interrupted. The exact opposite of what this feature is supposed to do.

Link to post
Share on other sites
Check that you have this option disabled: "Play files from memory instead of disk (not zone-specific)"

They broke DSD playback when this setting is enabled from JRiver 19 onwards.

 

With JRiver 18 I could play 6ch SACD in 3 rooms at once. (18 channels)

With JRiver 19-21 the same system struggles to play 6ch SACD in a single room without stuttering.

 

The problem is that JRiver 19 made the program store decoded (uncompressed) audio in the memory buffer, while JRiver 18 stored compressed audio in the memory buffer.

Because the buffer is limited to 1GB, and because uncompressed SACD takes up so much memory (some tracks would require >20GB!) it has to keep filling up the buffer every minute or so.

 

Very interesting. I have been playing multichannel SACD ISOs decoded to 24/176.4 PCM and piped through DiracLive EQ without interruptions until now. That was with the memory playback option ON. For safety, I just turned it OFF.

Kal Rubinson

Senior Contributing Editor, Stereophile

 

Link to post
Share on other sites
Very interesting. I have been playing multichannel SACD ISOs decoded to 24/176.4 PCM and piped through DiracLive EQ without interruptions until now. That was with the memory playback option ON. For safety, I just turned it OFF.
Well it's possible that something else is the cause, but having memory playback enabled leaves DSD to PCM playback in a vulnerable state - especially with 6ch since that triples the memory and CPU usage compared to 2ch.

I hope that it does fix your playback issues.

Link to post
Share on other sites
Well it's possible that something else is the cause, but having memory playback enabled leaves DSD to PCM playback in a vulnerable state - especially with 6ch since that triples the memory and CPU usage compared to 2ch.

I hope that it does fix your playback issues.

I am not the OP and don't have any playback issues. I just followed your advice to avoid the possibility.

Kal Rubinson

Senior Contributing Editor, Stereophile

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...