Jump to content
Sign in to follow this  
Musicophile

Audirvana 2.2 with iOS remote

Rate this topic

Recommended Posts

Apologies for butting in, but in my case the connection is fine - 200 Mb. The issue happens with every track.

 

My connection also seems fine. You can actually see that the tracks are not completely loading as the grey bar does not reach all the way across to the end of the track.

 

Screen Shot 2015-10-17 at 11.29.32.png

Share this post


Link to post
Share on other sites
My connection also seems fine. You can actually see that the tracks are not completely loading as the grey bar does not reach all the way across to the end of the track

 

That's what I'm seeing too, it looks as if not all of the track is being downloaded from the Qobuz server.

Share this post


Link to post
Share on other sites
Well, I guess the ship has sailed on this, Damien has obviously made the call that Streaming integration is the way to go, and I can't blame him. If he gets a half decent share of the 25K Qobuz prescribers he'll probably be quite happy.

 

In any case the equation more code = more system resources doesn't hold, code only requires resources if it actually runs.

 

+1. I might be misperceiving things, but it seems that people are suggesting that Damien scrap Qobuz integration now that it's about complete and even though @Musicophile has repeatedly stated that if you don't use the service, it's like the Qobuz stuff isn't there. The notion that Qobuz integration should go seems kind of silly, especially, as Musicophile has pointed out, it's an opportunity for Damien to expand his user base significantly.

 

It's a given, I think, that no one wants to see A+'s SQ decline, and I think Damien probably realizes that the "A+ Sound" represents the core value of his creation.

 

My US$0.02. (And personally, assuming the Qobuz stuff works well, I'd like to see Tidal integration follow.)

 

--David

 

 

I think the worry is that A+ 2.x was a sort of milestone (its own DB and remote) and to add a streaming model may take away some of those gains and or some of the priorities to address current/future issues?

 

"code only requires resources if it actually runs" doesn't necessarily hold either. It all depends on how its implemented.

 

Hey the ship has sailed, and I have no say in the matter and doesn't bother me. I don't think anyone is arguing the fact, just voicing some opinions :) Clearly streaming is more important to some than others.

Share this post


Link to post
Share on other sites
Any other beta testers experiencing this?

Hi,

 

I'm trying the beta since yesterday and you maybe right, I think I had the same issue with the last disk I played: the very end of the track was not played. I'm not sure it was every time or not. I will pay attention to it now.

 

Anyway, the Qobuz integration works and sound very well. Actually I found Audirvana sound even better with Qobuz integration than before ;-)

 

Is there any beta of the remote iOS app with Qobuz integration, too ?

 

Côme


Qobuz Sublime subscription & m4a files on Synology DS416play / Macbook Air 13" 2012 + El Capitan (Direct Mode) + Audirvana 3.x / DAC Arcam IrDAC / Ampli NAD C320 / Speaker Cabasse Sloop 500

Share this post


Link to post
Share on other sites

Rather interestingly although the remote app can't be used to control Qobuz streaming (yet?) other than skip tracks, pause etc., it does display what's being played from Qobuz. The interesting thing is that it shows the streaming rate, and for albums that are available in say 24/192 that's what it shows. I've no idea whether it's really streaming at this rate, I doubt it because what's being fed to the DAC is also shown - in my case that's 24/88.2 as I'm up sampling.

Share this post


Link to post
Share on other sites
Rather interestingly although the remote app can't be used to control Qobuz streaming (yet?) other than skip tracks, pause etc., it does display what's being played from Qobuz. The interesting thing is that it shows the streaming rate, and for albums that are available in say 24/192 that's what it shows. I've no idea whether it's really streaming at this rate, I doubt it because what's being fed to the DAC is also shown - in my case that's 24/88.2 as I'm up sampling.

 

I have no insider knowledge, but would assume the remote will get Qobuz control eventually as well.

 

With regards to streaming higher resolutions, that works, but only for titles that you have bought in that resolution.

Share this post


Link to post
Share on other sites
I have no insider knowledge, but would assume the remote will get Qobuz control eventually as well.

 

With regards to streaming higher resolutions, that works, but only for titles that you have bought in that resolution.

 

I'm sure the remote will be updated.

 

The high resolution numbers are appearing on every track I stream that's available in hi-rez - regardless of whether I've bought it or not. That's why I'm think they may not be a true reflection of what's actually being streamed.

Share this post


Link to post
Share on other sites
That's what I'm seeing too, it looks as if not all of the track is being downloaded from the Qobuz server.

 

Same for me, happens on all tracks.

 

It is not streaming the hi-res 24-96 version I purchased, but normal 16-44.1. Is there something to set somewhere or only Sublime subscriber can stream in hi-res (even if purchased in hi-res)?


IsoTek evo3 Sirius⎪Late 2009 27" iMac 20GB w/SSD, 10.10.x ➤Audirvana Plus 3.0.x (Exclusive Direct Integer Mode 1, NOS) & Qobuz HiFi Sublime+ ➤Curious Cables ➤UpTone Audio ISO REGEN (UpTone Audio UltraCap LPS-1 (Breeze Audio R-Core Linear PSU)) ➤UpTone Audio USPCB ➤iFi micro iDAC2 running v5.2a (Bit-Perfect) serving:

➤Nobsound SE OTL headphone amp on Herbie's Soft Tenderfoot (selected tubes with Herbie's UltraSonic Rx) with IsoTek evo3 Premier power cable⎪Audez'e LCD-2 Rev. 2 on Moon Audio Silver Dragon V3 Premium cable

➤Audioengine A5+ with AudioQuest Power NRG-1 cable

➤iFi micro iTube2 ➤Denon AVR-A100 100th Anniversary Edition with IsoTek evo3 Premier power cable on IsoTek evo3 Aquarius⎪B&W 804 D3 bi-amped on Inakustik cables

Share this post


Link to post
Share on other sites

It seems to be dependent on the Internet connection stability. Here in the audio show the Internet connection is unstable and I get this same last 5 seconds missing issue. And I don't have it at home at all...

I'll continue to investigate.


MBP 15"/Mac Mini, Audirvana Plus, Audioquest Diamond USB, AMR DP-777, exD DSD DAC (for DSD), Pioneer N-70AE, Audioquest Niagara balanced/Viard Audio Design Silver HD, Accuphase E-560, Cabasse Sumatra MT420

Share this post


Link to post
Share on other sites

Damien, I don't think I've got an unstable connection, certainly it's fast enough - I've just run a speed test and I'm getting 170 Mbps.

 

What at seems to be happening is that the download that begins when a track's selected is ending before the actual download is complete. The progress bar has a light grey area to the right when the track has finished downloading. The width of this light grey track is dependent on the length of the track, so the shorter the track, the wider the light grey area.

Share this post


Link to post
Share on other sites
The only issue I am having with the current beta is that it is not completely loading tracks from Qobuz. A second or two are lost at the end of each track, so the transition between tracks is a little abrupt and jarring. Any other beta testers experiencing this?

 

Yes, same issue. I suspect Qobuz is not giving the *exact* track length when queried, so Audirvana moves to the next track just a second or two before the previous one finishes downloading. Or I'm completely full of it and there's another reason entirely ;)


John Walker - IT Executive

Headphone - MacMini running Roon Server > Netgear Orbi wireless > Blue Jeans Cable Ethernet > mRendu Roon endpoint > iFi Audio xDSD + iFi Audio xCAN > Focal Elegia

Home Theater - Mac Mini running Roon Server > Blue Jeans Cable HDMI > Pioneer Elite SC-81 > MartinLogan Motion series home theater speakers + M&K subwoofer

Share this post


Link to post
Share on other sites

Some issues I had/have:

 

- first time I entered my Qobuz credentials when I clicked on the purchases icon, A+ crashed. Solution: I entered the credentials, closed A+ and after relaunching I could use the icons.

 

- disconnecting Qobuz account crashes A+

 

- the metadata pane stays open when in Qobuz display but it isn't used and affects the display of selection bar:

Capture d’écran 2015-10-17 à 17.48.34.png


IsoTek evo3 Sirius⎪Late 2009 27" iMac 20GB w/SSD, 10.10.x ➤Audirvana Plus 3.0.x (Exclusive Direct Integer Mode 1, NOS) & Qobuz HiFi Sublime+ ➤Curious Cables ➤UpTone Audio ISO REGEN (UpTone Audio UltraCap LPS-1 (Breeze Audio R-Core Linear PSU)) ➤UpTone Audio USPCB ➤iFi micro iDAC2 running v5.2a (Bit-Perfect) serving:

➤Nobsound SE OTL headphone amp on Herbie's Soft Tenderfoot (selected tubes with Herbie's UltraSonic Rx) with IsoTek evo3 Premier power cable⎪Audez'e LCD-2 Rev. 2 on Moon Audio Silver Dragon V3 Premium cable

➤Audioengine A5+ with AudioQuest Power NRG-1 cable

➤iFi micro iTube2 ➤Denon AVR-A100 100th Anniversary Edition with IsoTek evo3 Premier power cable on IsoTek evo3 Aquarius⎪B&W 804 D3 bi-amped on Inakustik cables

Share this post


Link to post
Share on other sites
Yes, same issue. I suspect Qobuz is not giving the *exact* track length when queried, so Audirvana moves to the next track just a second or two before the previous one finishes downloading. Or I'm completely full of it and there's another reason entirely ;)

 

Another issue users may encounter with unstable Internet connections is buffer underruns (i.e., the cache Audirvana is building runs out of data) - on my DAC, at least, this causes a loud digital "scream" that can only be corrected by putting playback on pause until the buffer is sufficiently ahead of playback to ensure no underrun.

 

Not sure how Damien would fix this other than being more aggressive about monitoring the buffer; e.g., if the buffer gets to 1 sec or less, automatically put playback on pause until the buffer is refilled.


John Walker - IT Executive

Headphone - MacMini running Roon Server > Netgear Orbi wireless > Blue Jeans Cable Ethernet > mRendu Roon endpoint > iFi Audio xDSD + iFi Audio xCAN > Focal Elegia

Home Theater - Mac Mini running Roon Server > Blue Jeans Cable HDMI > Pioneer Elite SC-81 > MartinLogan Motion series home theater speakers + M&K subwoofer

Share this post


Link to post
Share on other sites

I had posted a question (message #695) enquiring about issues regarding responsiveness of A+. As there were no replies, I can only assume that I have somehow eschewed the proper procedural modalities of this forum and that I should inquire elsewhere or in a different thread. Where would be the best place to ask these questions?

Thank you.

Share this post


Link to post
Share on other sites
It seems to be dependent on the Internet connection stability. Here in the audio show the Internet connection is unstable and I get this same last 5 seconds missing issue. And I don't have it at home at all...

I'll continue to investigate.

 

I'm having the same issue and my internet connection is fine for other streaming. The Qobuz app/player streams the same tracks fine, on the same computer and connection.

Share this post


Link to post
Share on other sites
I had posted a question (message #695) enquiring about issues regarding responsiveness of A+. As there were no replies, I can only assume that I have somehow eschewed the proper procedural modalities of this forum and that I should inquire elsewhere or in a different thread. Where would be the best place to ask these questions?

Thank you.

 

 

You can try just trashing your audirvana preferences, maybe they are corrupt... Quit Audirvana than go in:

in your home folder... library... preferences. If you can't see your library there because Apple make it invisible,

hold "alt" while in "home folder" and click GO menu in finder... you'll see the library folder, than trash:

com.audirvana.Audirvana-Plus.plist

 

maybe don't trash it but put them in another place... you will have to set it up again all prefs in A+


If You Got Ears, You Gotta ListenCaptain Beefheart

 

MacMini, i5, 2.5GHz, SSD, 16Gb, 10.15 > Audirvana Plus 3.5.24 > Wyred DAC2 DSD Special Edition >
Proceed AMP2 > Focal Cobalt 826 Signature Series > Audirvana Remote > iPhone 8

Share this post


Link to post
Share on other sites

Thanks for the suggestion; tried it and it didn't help. Still switching between songs takes a very long time. Unless someone has another suggestion I will trash the entire library database and re-import all music again. I suspect this may help, as it did before (see message #695) but if it subsequently slows after the next time I import music, then I am back to where I was unless the cause can be determined. Perhaps, it is simply an issue of library size, although other music apps are not similarly affected.

Share this post


Link to post
Share on other sites

your library is pretty big... mine is around 40k songs, no problem. You could try making like 3 playlist instead of one... might load faster.


If You Got Ears, You Gotta ListenCaptain Beefheart

 

MacMini, i5, 2.5GHz, SSD, 16Gb, 10.15 > Audirvana Plus 3.5.24 > Wyred DAC2 DSD Special Edition >
Proceed AMP2 > Focal Cobalt 826 Signature Series > Audirvana Remote > iPhone 8

Share this post


Link to post
Share on other sites

jumpsturdy: Could be a memory issue. Are you using heavy upsampling on a ram limited machine?


Roon client on iPad/MacBookPro

Roon Server & HQPlayer on Mac Mini 2.0 GHz i7 with JS-2

LPS-1 & ultraRendu → Lampizator Atlantic → Bent Audio TAP-X → Atma-sphere M60 → Zero autoformers → Harbeth Compact 7 ES-3

Share this post


Link to post
Share on other sites
Another issue users may encounter with unstable Internet connections is buffer underruns (i.e., the cache Audirvana is building runs out of data) - on my DAC, at least, this causes a loud digital "scream" that can only be corrected by putting playback on pause until the buffer is sufficiently ahead of playback to ensure no underrun.

 

Not sure how Damien would fix this other than being more aggressive about monitoring the buffer; e.g., if the buffer gets to 1 sec or less, automatically put playback on pause until the buffer is refilled.

I have experienced precisely the same problem, but I don't think it's due to an unstable internet connection. I have a very reliable 75 Mbps internet service. I'm just happy that someone else has encountered this because Damien has advised me that he can't replicate it.

 

Since you are also in the USA, I'm wondering if somehow this issue is location dependent ... jhwalker, are you using a VPN to access Qobuz? I used a VPN only to sign up for Qobuz, but I'm not using a VPN now to use Qobuz. So I'm encountering this problem when NOT using a VPN.

 

I'm finding that the problem hardly ever occurs if I just play an album's tracks sequentially. However, if I interrupt track n in the middle of that track and skip to track n+2 (for example) I get this buffer underrun. The A+ player position catches up with the FLAC stream and A+ runs out of data and plays noise.

 

I have never hit this problem when using the Qobuz app itself.

Edited by rickca

NUC7PJYH/AL --> Berkeley Alpha USB --> Jeff Rowland Aeris --> Jeff Rowland 625 S2 --> Focal Utopia 3 Diablos with 2 x Focal Electra SW 1000 BE subs

 

i7-6700K/Windows 10 Version 1903/HDPLEX 200W/HDPLEX 400W DC-ATX --> EVGA Nu Audio Card --> Focal CMS50's 

Share this post


Link to post
Share on other sites
My connection also seems fine. You can actually see that the tracks are not completely loading as the grey bar does not reach all the way across to the end of the track.

 

[ATTACH=CONFIG]21549[/ATTACH]

I'm not having this problem with the A+ Qobuz beta, but I did experience precisely this problem while testing the Qobuz add-on for Kodi with A+ with Geoffrey Armstrong.

 

If I recall correctly, the problem occurred on every track once I interrupted a track in the middle of a song by switching to a different track. If I just played an album's tracks sequentially, the problem did not occur. So we never really figured out the cause of this behavior. I'm glad that this problem has resurfaced ... maybe we can get to the bottom of the issue now.

 

Again in this case, Geoff (who is in Monaco) was unable to replicate the problem.

 

In my experience with Geoff's Qobuz add-on for Kodi, I actually heard noise play at the end of each track that didn't completely load, exactly like the buffer underrun issue. We eventually had to make A+ stop and restart the audio device between tracks to bypass the problem. This isn't a good solution obviously, because it means you lose gapless capability.

Edited by rickca

NUC7PJYH/AL --> Berkeley Alpha USB --> Jeff Rowland Aeris --> Jeff Rowland 625 S2 --> Focal Utopia 3 Diablos with 2 x Focal Electra SW 1000 BE subs

 

i7-6700K/Windows 10 Version 1903/HDPLEX 200W/HDPLEX 400W DC-ATX --> EVGA Nu Audio Card --> Focal CMS50's 

Share this post


Link to post
Share on other sites
I'm not having this problem with the A+ Qobuz beta, but I did experience precisely this problem while testing the Qobuz add-on for Kodi with A+ with Geoffrey Armstrong.

 

If I recall correctly, the problem occurred on every track once I interrupted a track in the middle of a song by switching to a different track. If I just played an album's tracks sequentially, the problem did not occur. So we never really figured out the cause of this behavior. I'm glad that this problem has resurfaced ... maybe we can get to the bottom of the issue now.

 

Again in this case, Geoff (who is in Monaco) was unable to replicate the problem.

 

In my experience with Geoff's Qobuz add-on for Kodi, I actually heard noise play at the end of each track that didn't completely load, exactly like the buffer underrun issue. We eventually had to make A+ stop and restart the audio device between tracks to bypass the problem. This isn't a good solution obviously, because it means you lose gapless capability.

In my testing of the Qobuz add-on for Kodi, I actually heard noise at the end of tracks that didn't load completely (as shown in RickDastardly's screenshot) ... so it was similar to the buffer underrun problem in that respect.

 

I also had this problem of having the end of a track cut off prematurely (without buffer underrun noise) while testing the Qobuz add-on for Kodi. Geoff solved that problem with his 'interlude slider' set to 8 seconds. Damien perhaps you can talk to Geoff about how his interlude slider works.

 

Damien's Qobuz integration beta and Geoff's Qobuz add-on for Kodi are very different implementations, so I'm not saying the root cause of these issues is the same in both cases. It's just very interesting (and maybe a good thing for troubleshooting) that similar problems exist in both implementations.


NUC7PJYH/AL --> Berkeley Alpha USB --> Jeff Rowland Aeris --> Jeff Rowland 625 S2 --> Focal Utopia 3 Diablos with 2 x Focal Electra SW 1000 BE subs

 

i7-6700K/Windows 10 Version 1903/HDPLEX 200W/HDPLEX 400W DC-ATX --> EVGA Nu Audio Card --> Focal CMS50's 

Share this post


Link to post
Share on other sites

Thanks Freann for the suggestion.

 

I am using a mac mini i7 with 16 gb of ram and an internal SSD (256gb). The machine is dedicated to audio. I have been running it with up sampling set to none and have tried various combinations of exclusive mode, direct mode and integer mode and the sluggishness remains in all configurations.

 

Just timed a switch from one song to the next (using the skip button) and it took just over fifteen seconds. About six seconds before any reaction (original song just kept playing), then beach ball for about seven seconds (silence) and another two seconds as you could see it preparing to play the next song.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...