Jump to content
Sign in to follow this  
bogi

Manage HQPlayer playlist from Foobar2000

Recommended Posts

Hello Bogi,

I forgot to mention that in order to make it work here, I had to disable the DSP conversion option (MathAudio Room EQ).

First trial resulted in converted files that were large in size as any .WAV normally are, but with no sound at all... Guess that is a problem from the Foobar conversion with MathAudio DSP, nothing to do with your solution.

Once the DSP conversion was disabled it began to work just fine and also much faster!

 

I don't know MathAudio Room EQ, thanks for sharing your experience. You can test the Converter setup interactively before testing it with my script.

 

HQPlayer contains it's own support for room correction, so if you cannot use MathAudio Room EQ, you can try that one. There are people using it in the CA forum.

Share this post


Link to post
Share on other sites
Bogi, Thx a bunch. I have look through the documentation and it is definitely of high quality. I am still not running the new HQP beta, so i cannot run through the whole thing. Hopefully, Miska will release whatever you are waiting for soon.

 

After small adaption you can run the script with HQPlayer 3.7.1, but the following bug will appear:

 

~~~~~~~~~~~~~~~~

When some tracks already appear in HQPlayer Desktop playlist and new playlist is sent to HQPlayer Desktop via hqp_control, tracks from the added playlist are correctly appended to the end of HQPlayer playlist, but focus unexpectedly becomes the first track in HQPlayer playlist. Playback is not stopped, but HQPlayer is now messed. The 1st track typically has different length than the track which is playing. I already become a negative number in Remain time field. 3B49BED161F042D888055900B22E8AAF@bogipc Playback then wants to continue with the 2nd track in HQPlayer playlist.

 

Special case - when the 1st track is PCM track, the currently playing track is DSD track and the playlist added via hqp_control contains PCM tracks: Focus again goes to 1st track in HQPlayer playlist, but in this case unexpected behavior occurs. HQPlayer stops playback, or plays the track on much higher speed. When DSD track playback is then manually started again, it can play on much slower speed. Clearing playlist and starting form beginning helps.

~~~~~~~~~~~~~~~~

 

The adaption for 3.7.1 is is to change --playlist-clear with --clear

 

Substitute the line

set CLEARCMD="%TOOLDIR%\hqp-control.exe" localhost --playlist-clear

with this one:

set CLEARCMD="%RDDRIVE%\HQPlayer\hqp-control.exe" localhost --clear

 

Other point, regardless on HQPlayer version:

SendToHQP script is calling hqp-control.exe from the folder where you collected SendToHQP.bat, cmdow.exe, paste.exe, join.exe. So you have to copy hqo-control.exe here too.

Better soluton is: In lines beginning with set CLEARCMD= and set SENDPLAYLISTCMD= substitute "%TOOLDIR%\hqp-control.exe" with "%RDDRIVE%\HQPlayer\hqp-control.exe" (like in the 3.7.1 adaption few lines above).

This small change will be part of the next version.

Share this post


Link to post
Share on other sites

New SendToHQP version 1.0.2 changelog:

- User can now choose an intermediate PCM file format for RAM disk: WAV, AIFF or FLAC

- Music tracks in PCM formats supported by HQPlayer (FLAC, WAV, AIFF) can be now copied to RAM disk without converting them to an intermediate format.

- Added limited support to send DVD audio ISO and SACD ISO content to HQPlayer

 

Find more details in the PDF guide.

 

Download: https://drive.google.com/uc?export=download&id=0B1IZPbDClIn6Q3ppcDE3bldPODA

 

Pre-requisite: HQPlayer Desktop 3.8.0b3 or newer

Share this post


Link to post
Share on other sites

Hi Bogi,

 

your solution is what I've been dreaming for a while....!

 

Unfortunately I'm unable to have it functioning on my Win7-64.

I followed your instructions (at least I think...), but launching the batch file doesn't bring to life any conversion of files and therefore no feeding to HQPlayer.

 

Instead, the batch works perfectly with native WAV files. BTW, the convertion launched from Foobar works fine too.

 

Could you please point me to a solution so to identify what I'm doing wrong?

 

Thanks in advance!

Share this post


Link to post
Share on other sites
launching the batch file doesn't bring to life any conversion of files and therefore no feeding to HQPlayer.

 

Instead, the batch works perfectly with native WAV files. BTW, the convertion launched from Foobar works fine too.

 

Hi tranfa, what's your shortcut setup and Converter setup? Pictures could help.

Share this post


Link to post
Share on other sites

Sorry for the delay in answering, it took a while to be back at my pc....

 

Diapositiva1.JPG Shortcut

 

Diapositiva2.JPG Converter

 

Diapositiva3.JPG Text Tools

 

Hope this helps...

Share this post


Link to post
Share on other sites

I just returned from holiday, I will look at your issue. One idea: Try to disable transferring pictures with Foobar Converter (save the change to your setup 'Pietro'). That's one difference between our setup (compare your setup and the picture from PDF). I'm not sure if transferring pictures works well in automated mode.

 

The bat script contains line:

"%FOOBAR%" /runcmd-playlist="convert/%CONVPRESET%"

With environment variables expanded, it should be in your case something like:

"C:\Program Files (x86)\foobar2000\foobar2000.exe" /runcmd-playlist="convert/Pietro"

That command should result to the same conversion as the interactive conversion in foobar2000 environment.

Share this post


Link to post
Share on other sites
I just returned from holiday, I will look at your issue. One idea: Try to disable transferring pictures with Foobar Converter (save the change to your setup 'Pietro'). That's one difference between our setup (compare your setup and the picture from PDF). I'm not sure if transferring pictures works well in automated mode.

 

The bat script contains line:

"%FOOBAR%" /runcmd-playlist="convert/%CONVPRESET%"

With environment variables expanded, it should be in your case something like:

"C:\Program Files (x86)\foobar2000\foobar2000.exe" /runcmd-playlist="convert/Pietro"

That command should result to the same conversion as the interactive conversion in foobar2000 environment.

 

 

I disabled the pictures transfers, and yes, that's what I get from the bat script once launched....but still, I find the original MP3 file in the ramdisk, with no conversion, and therefore no upload to HQPLayer....

Share this post


Link to post
Share on other sites

The original MP3 file does not have to appear in RAM disk, only the conversion result. How did it happen that it is stored in RAM disk? Try to remove it and then invoke SendToHQP shortcut again.

 

The usage scenario is: You have your music library located outside of RAM disk. You select some tracks from that library in a foobar2000 playlist. When you invoke the SendToHQP shortcut, conversion results are stored in RAM disk. Then temporary playlist has to be created from them (in root of RAM disk). Then that temporary playlist is sent to HQPlayer.

Share this post


Link to post
Share on other sites

Hi Bogi,

 

Yes I understand that the script should allow me to have the converted file in the ramdisk: the issue is exactely the fact that in my setup the script doesn't convert but just copies the file....

Share this post


Link to post
Share on other sites

I see on your picture you are doing resampling with SoX mod and yet something during conversion ... Why are you resampling in foobar2000 when HQPlayer does this job better? Maybe that prevents from successful conversion. Try to disable any DSP during conversion.

 

Although lossy MP3's are not the file type recommended for HQPlayer, I just tried some MP3's with SendToHQP and it worked fine. MP3s were converted to WAWs in RAM disk.

 

Please be sure you select tracks of the same type in foobar2000 (for example only MP3s, or only FLACs). Then it is easier to isolate your issue.

 

Please note also this my post: http://www.computeraudiophile.com/f11-software/hq-player-20293/index119.html#post449434

Share this post


Link to post
Share on other sites
the issue is exactely the fact that in my setup the script doesn't convert but just copies the file....

 

When you invoke the Converter preset Pietro interactively from foobar2000 environment, then MP3s are converted to WAWs or not?

Share this post


Link to post
Share on other sites

Aldo disabling any kind of dsp, the issue remains the same.

 

No conversion happening, no matter the file extension.

Share this post


Link to post
Share on other sites

Does the command like

"C:\Program Files (x86)\foobar2000\foobar2000.exe" /runcmd-playlist="convert/Pietro"

convert MP3 to WAV in RAM disk or does it only copy MP3 file to RAM disk?

 

Do you see the foobar's conversion progress bar window titled 'Converting ...' when the action is done from the SendToHQP script?

Share this post


Link to post
Share on other sites
Does the command like

"C:\Program Files (x86)\foobar2000\foobar2000.exe" /runcmd-playlist="convert/Pietro"

convert MP3 to WAV in RAM disk or does it only copy MP3 file to RAM disk?

 

Do you see the foobar's conversion progress bar window titled 'Converting ...' when the action is done from the SendToHQP script?

 

 

Yes, the command alone in a bat file works fine.

Share this post


Link to post
Share on other sites

Please add a single line containing only

pause

to the end of SendToHQPlayer.bat and run it again.

 

The processing will be paused at the end, a line Press any key to continue . . . will display.

Then use the upper left Command Prompt window icon to copy window content to clipboard:

Edit > Select All

Edit > Copy

Paste the clipboard content to any text editor. Send me that content in any way.

Share this post


Link to post
Share on other sites
Please add a single line containing only

pause

to the end of SendToHQPlayer.bat and run it again.

 

The processing will be paused at the end, a line Press any key to continue . . . will display.

Then use the upper left Command Prompt window icon to copy window content to clipboard:

Edit > Select All

Edit > Copy

Paste the clipboard content to any text editor. Send me that content in any way.

 

Here you go.

 

thank you!tranfa.txt

Share this post


Link to post
Share on other sites

Please send me yet content of file A:\fileformat.txt

Share this post


Link to post
Share on other sites
voila'[ATTACH]20060[/ATTACH]

 

Please perform on your PC:

 

cd /d C:\SendToHQP
set PLAYHQP=yes
%WINDIR%\system32\find /V "DSD" A:\fileformat.txt && set PLAYHQP=no
echo %PLAYHQP%

 

and send me your output.

 

It seems on your PC the variable PLAYHQP remains set to yes like if your find command would not be found.

 

On my PC the variable PLAYHQP is set to no with your fileformat.txt.

Share this post


Link to post
Share on other sites
Please perform on your PC:

 

cd /d C:\SendToHQP
set PLAYHQP=yes
%WINDIR%\system32\find /V "DSD" A:\fileformat.txt && set PLAYHQP=no
echo %PLAYHQP%

 

and send me your output.

 

It seems on your PC the variable PLAYHQP remains set to yes like if your find command would not be found.

 

On my PC the variable PLAYHQP is set to no with your fileformat.txt.

 

result:

 

 

C:\Users\Pietro\Desktop>cd /d C:\SendToHQP

 

C:\SendToHQP>set PLAYHQP=yes

 

C:\SendToHQP>C:\Windows\system32\find /V "DSD" A:\fileformat.txt && set PLAYHQ

P=no

 

---------- A:\FILEFORMAT.TXT

MP3 mp3 0

 

C:\SendToHQP>echo no

no

 

C:\SendToHQP>pause

Press any key to continue . . .

Share this post


Link to post
Share on other sites

cd /d C:\SendToHQP
set PLAYHQP=no
if no == yes findstr /V "WAV AIFF FLAC DSD" A:\fileformat.txt   1>nul  || set PLAYHQP=yes
echo %PLAYHQP%

 

Please run yet these commands and send me output.

What for Windows version do you use?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  



×
×
  • Create New...