Jump to content
IGNORED

32 bit *only* USB DACs and Mac OS


Recommended Posts

Recent experience with the Tidal Mac app has made me aware of something I wasn't before:

 

Mac OS (Mavericks at least) is unable to use a 32 bit only DAC as the default output device.

 

Let me try to explain:

 

All three DSD capable DACs in my current lineup (iDSD Nano, iDSD Micro, AMI Musik DS5) show in the "Audio MIDI Setup" utility as "2ch-32bit integer". There is no pulldown to change the bit depth. By comparison, a Schiit Gungnir does have a pulldown for 16, 24, and 32 bits.

 

The Gungnir can be used as the default audio output device. Audio plays just fine.

 

None of the 32 bit fixed DACs will work. No sound is output when using them as the default output device.

 

So my question: Can anyone else confirm/dispute what I'm seeing and is anyone aware of a way to get a 32 bit only DAC to function as the default audio output device on a Mac? Does it work in Yosemite?

 

Disclaimer: I'm well aware of the benefits of bit perfect playback and use bit perfect playback when playing files (Audirvana). I'm just looking for a way to make a 32 only DAC work as the default audio output device on a Mac.

 

Thanks in advance

Link to comment
If that's true, why do you use a USB connected DAC? USB Audio is not bit perfect.

 

What definition of "bit perfect" are you using, and why does "USB Audio" violate it?

One never knows, do one? - Fats Waller

The fairest thing we can experience is the mysterious. It is the fundamental emotion which stands at the cradle of true art and true science. - Einstein

Computer, Audirvana -> optical to EtherREGEN -> microRendu -> ISO Regen -> Pro-Ject Pre Box S2 DAC -> Spectral DMC-12 & DMA-150 -> Vandersteen 3A Signature.

Link to comment

Sam, I'm sorry, I don't know the answer to your question. I have Yosemite but not a "32-bit only" DAC AFAIK (though I'll take a look at Audio Midi setup).

One never knows, do one? - Fats Waller

The fairest thing we can experience is the mysterious. It is the fundamental emotion which stands at the cradle of true art and true science. - Einstein

Computer, Audirvana -> optical to EtherREGEN -> microRendu -> ISO Regen -> Pro-Ject Pre Box S2 DAC -> Spectral DMC-12 & DMA-150 -> Vandersteen 3A Signature.

Link to comment

Maybe it is some problem with Tidal client. Spotify at least works fine for me with exaSound e28 which is "32-bit only" and I have not heard about anything like this before. I think iFi was also similar?

 

HQPlayer and Tidal client don't care about the default audio output setting of Audio MIDI Settings, so I have not paid much attention to this detail.

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to comment
Maybe it is some problem with Tidal client. Spotify at least works fine for me with exaSound e28 which is "32-bit only" and I have not heard about anything like this before. I think iFi was also similar?

 

HQPlayer and Tidal client don't care about the default audio output setting of Audio MIDI Settings, so I have not paid much attention to this detail.

 

Actually, the Mac Tidal client does have an issue (I have a ticket open with Tidal support). Let's say you select an external DAC in the Tidal (for Mac) preferences. If the player encounters a "non-HiFi" file (Tidal support is careful not to call them lossy. Could they be 32kHz lossless?) that extinguishes the "HiFi light" on the client, the player will not send the audio to the device selected in the Tidal preferences. It will send it to the default output device.

 

Don't take my word for it. Go into the preferences, select a quality level other than "HiFi", and watch the output selection pulldown disappear!

 

That's really what forced me to have to use the DAC as the Mac OS default output. Tidal. And WTF are the attributes of a file that turns off the "HiFi" light on the client?

 

Thanks everyone for your responses so far.

Link to comment

Samuel:

 

Silly question, but when you went into Audio MIDI Setup and highlighted your DAC, did you then go to the cog icon at the bottom of the left pane and choose "Use this device for sound output"? That is what is required to truly make it the "Default."

 

I usually don't bother with Audio MIDI Setup, but for you I was curious and checked the new Geek Pulse I am playing with. It to shows as a "32-bit only" device. I set it to default and then in HQ Player chose "Default" instead of the named DAC in the list. And it played!

 

Of course you probably did this, but hey, we've all overlooked simple steps before…

 

Good luck,

--Alex C.

Link to comment
So with a bit more experimentation and some serious resetting (even NVRAM) on the offending Mac, and all is well and 32 bit only DACs now work.

 

Thanks again everyone!

 

I'm having the same problem, so what was it that actually resolved the problem?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...