Jump to content
IGNORED

Stream radio from NAS with MinimServer


tgb

Recommended Posts

Hi,

This is the way I listen to web radios.

In my main setup, I do not use computer but simply a NAS (Synology DS212J) to stream to a SMS100 through DLNA, with MinimServer installed on the NAS.

 

Maybe some already know you can use Minim to listen to web radio, not only your own audio files.

I guess many know & use that feature, it is just information for the others ;-)

 

This is how to do it :

on your computer, just take a text editor like WordPad and take a new blank sheet

copy to it the following text :

 

#EXTM3U

#EXTINF:-1,[cool1;mp3] cool1

http://4broadcast.de:8000/cool1_192.mp3

#EXTINF:-1,[coolradio-jazz-128s;mp3] coolradio-jazz-128s

http://4broadcast.de:8000/coolradio-jazz-128s.mp3

 

As you can see, the command for each radio is composed by 2 lines :

- in the 1st you mention the name of the radio (here the radios "cool1" & "coolradio jazz" ;

- and on the 2nd line the URLs of the radio ; Add as many radio you wish based on this.

 

save the file

rename the file with ".m3u" as file type

copy this file to your NAS in the folder that is browsed by Minim

relaunch Minim as usual to enable it to take into account this new file

then on your UPNP app, you will see in the playlist folder this playlist with the name you gave to it.

select it

based on the example I gave above, then you will see like 4 "tracks" called "[cool1]", "cool1", "[coolradio-jazz-128s]", "coolradio-jazz-128s". I don't know why 2 lines for each radio... the point is that if you launch the track "[cool1]" I have no sound, but I have sound with the one "cool1"

this is it.

 

I found this way to listen really really in quality, and so convinient...

I find sound is better using the NAS in quality than through PC, don't know why, but I think it is due to 2 points at least :

- NAS runs Linux, known to be better for audio than windows

- the NAS runs much less threads in parallel than a PC, thus less "noise"... The streaming from the NAS requires so low CPU that my 212J switches to hibernate mode when I stream ony radios, meaning that all disks stop, so less noise (I guess that can explain partly the good quality).

I'm not expert... if an expert can confirm/explain in detail I would prefer ;-)

 

Hope it helps

Rgds

Hifi & optical LAN setup => here

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...