Jump to content
IGNORED

New iTunes - has anyone figured out how to copy and paste in new album artwork?


blaven

Recommended Posts

The album artwork function in the new iTunes 12.0.1 seems clumsy....or perhaps I am clumsy.

 

I used to be able to look up album titles, search for images, and then right click, copy and paste into that nice little box in album info.

 

The only way I have been able to add artwork is to save it as jpeg image (tiff etc, etc) and then "Add artwork" from a file.

 

It just seems quite a bit clumsier, and more clicks?

 

I searched apple forums an found nothing

 

I feel like a dufus....please help

Aurender S10--> Berkeley Alpha USB—> Meitner MA-1 --> Audio Research REF6 Pre --> Audio Research REF-110-->Vandersteen Quatro CT Speakers

 

Sonore UltraRendu with Uptone power supply —> Meitner MA1

 

AQ Sky XLR Interconnects, Audioquest Diamond USB, Wireworld Platinum Starlight USB, Nordost Heimdall 2 AES-EBU

 

AMG Giro Turntable w Lyra Delos Cartridge —> Audio Research Ref 3 PhonoPre

 

HRS RXR Rack with Isolation Bases

Link to comment

Tried that....there is no field to even paste into...unless I am missing something big here, I can't find a place to paste anything into...maybe in another field?

 

I am highlighting all songs and doing "get info" that way, and have also tried individual songs

Aurender S10--> Berkeley Alpha USB—> Meitner MA-1 --> Audio Research REF6 Pre --> Audio Research REF-110-->Vandersteen Quatro CT Speakers

 

Sonore UltraRendu with Uptone power supply —> Meitner MA1

 

AQ Sky XLR Interconnects, Audioquest Diamond USB, Wireworld Platinum Starlight USB, Nordost Heimdall 2 AES-EBU

 

AMG Giro Turntable w Lyra Delos Cartridge —> Audio Research Ref 3 PhonoPre

 

HRS RXR Rack with Isolation Bases

Link to comment

I'll be darned...I tried it with a different album art image, and it worked fine...no idea why it wasn't working, but I tried that particular image a few different ways, and it did not work with any approach (never thought of trying a different image) so, perhaps an unsupported format?? I have no idea, but bottom line is that it works fine, like it used to.

 

Very odd

 

Thanks!

Aurender S10--> Berkeley Alpha USB—> Meitner MA-1 --> Audio Research REF6 Pre --> Audio Research REF-110-->Vandersteen Quatro CT Speakers

 

Sonore UltraRendu with Uptone power supply —> Meitner MA1

 

AQ Sky XLR Interconnects, Audioquest Diamond USB, Wireworld Platinum Starlight USB, Nordost Heimdall 2 AES-EBU

 

AMG Giro Turntable w Lyra Delos Cartridge —> Audio Research Ref 3 PhonoPre

 

HRS RXR Rack with Isolation Bases

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...