Jump to content
IGNORED

Clicks and Pops with Dragonfly 1.2 on Cubox-i Arch Linux server


Recommended Posts

Hi all,

 

Pardon me if this is not the right venue or if it has been covered before (I have searched here and elsewhere for a solution before posting!).

 

I am using a Cubox-i4Pro server as a combined Logitech Music Server (LMS)/Squeezelite player driving a DragonFly 1.2 DAC into our home stereo system (the music archive is stored on an external USB 3.0 drive attached to the Cubox-i).

 

It sounds great except for one thing: when I connect the DragonFly directly to the Cubox-i, I get random pops and clicks. I have tried to adjust the ALSA settings on the Cubox-i and have succeeded in significantly reducing the frequency of the pops and clicks, but can't completely eliminate them. They sound almost electrical in nature, which is very distracting (not like the less sharp pops and clicks from playing an old LP, for example).

 

The one thing that has worked is to put a powered USB hub between the Cubox-i and the DragonFly, but that does seem to degrade the signal a little bit--the DragonFly sounds 'brighter' when directly connected to the Cubox-i.

 

It would be great to find a solution where I can eliminate the powered USB hub, not only because of the improved sound but also because I would like to keep the data path as clean and short as possible.

 

My suspicion is that the problem is due to some kind of clocking issue between the Cubox-i and the DragonFly and that introducing the hub between them de-links them enough that the clocking struggle stops. But that is pure speculation.

 

If anyone here has any experience with this, your help or pointers would be most gratefully appreciated!

 

--Ned

Link to comment

Ned,

 

I think you've raised two issues. First, how can you get rid of your powered hub, and sucessfully get rid of the clicks and pops your LMS/Squeezelite/DragonFly/Cubox-i produces? And second, does the hub degrade the audio when used with your setup? Since the second question is moot- if we can solve the first one - I'll stick to the first question for now...

 

I've got the same setup as you AND have also swapped LMS/Squeezelite for MPD/Volumio (both under some flavor of Linux), and have gotten same click and pop artifacts, typically every 30 seconds or so, under both scenarios. However, when I set Volumio up to oversample my 16/44.1 FLACs to 16/96, the artifacts go away. And like yourself, a powered USB hub between the DragonFly and the Cubox-i also makes them disappear. I'd love to lose that hub too.

 

In my limited understanding of USB 2.0 (the highest USB spec both DragonFly and Cubox-i conform to), default power supplied from host to client is 100 mA. And by my calculations - depending on a number of variables - a DragonFly can easily pull more, or less than that. To pull more than that USB clients are supposed to negotiate for more power when needed, up to a limit of 500 mA (far more than a DragonFly should ever need, I think). More is available for "charging", but IMO that is not applicable here.

 

On a powered USB hub those negotions are not supposed to occur between the client and the host, because the hub provides the power as needed. This would IMPLY that one possible culprit is a breakdown of those requests for more power (called enumeration I believe) from the DragonFly to the Cubox-i, when there is no powered hub. And I've reviewed my USB kernel messages on my cubox-i, and some kind of USB messages are indeed failing. But I'm a Linux lightwieght, and do not know what they are. But I'm suspicious.

 

Another possiblity is that the Cubox-i itself does not have the extra (over 100 mA) power to provide. By my calc's (when using my 3A power supply) the DragonFly should the full 500 mA (theoretical max.) available to it. So I doubt that's the problem, but might be would be worth testing. Until then, I've got my money on failed USB power negotiations.

 

- Steve

Link to comment
  • 2 weeks later...

Ned,

 

I think I just proved that this problem is not with the power supply that Solid Run provides with the Cubox-I. See this thread for details. Bottom line of those tests is this... the Cubox-I power supply (if really the stated 3 amps) provides more than enough current. And that replacing it with a clean power supply does not eliminate the problem.

 

- Steve

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...