Jump to content

Recommended Posts

39 minutes ago, Outlaw said:

Is it better to have hyper threading enabled or disabled for HQPlayer ?

Here is an answer from Miska

https://audiophilestyle.com/forums/topic/19715-hq-player/?do=findComment&comment=1013950

 

NUC7PJYH/AL --> Berkeley Alpha USB --> Jeff Rowland Aeris --> Jeff Rowland 625 S2 --> Focal Utopia 3 Diablos with 2 x Focal Electra SW 1000 BE subs

 

i7-6700K/Windows 10 Version 2004/HDPLEX 300W/HDPLEX 400W DC-ATX --> EVGA Nu Audio Card --> Focal CMS50's 

Link to post
Share on other sites
5 hours ago, bisesik said:

Dear Miska, is it possible in practice to get the online conversion in HQP4 for 44.1->ASDM7EC->DSD512 (xtr, ext2) within 2.5k$ budget? Thank you!

Ivan.

I think there is a post from him above where he says that 512 is not possible using EC modulators but 256 is possible. I get 256 using the same path you describe using hardware in that budget.

Link to post
Share on other sites
1 hour ago, bobflood said:

I think there is a post from him above where he says that 512 is not possible using EC modulators but 256 is possible. I get 256 using the same path you describe using hardware in that budget.

Thank you, got it!

Link to post
Share on other sites

Happy New Year to all.   I am hoping to get some suggestions or tips to keep HQP from stuttering and dropping out.  I am running HQP3.  My system is:  2012 MacMini (i7 processor running El Capitan) > router > MOCA ethernet converter > Ultra Rendu > Holo Audio Spring DAC

 

I have been successfully running HQP with a Roon interface while upsampling to DSD256 using the 2s filters.  Until now, this has provided great sound and been very stable.  After not playing the system for over 2 weeks, I started a listening session Thursday night but kept getting frequent stuttering and drop-outs.  I had the same issue when trying it again yesterday,  I have done the following to address the problem:

 

- Unplug DAC and reboot Ultrarendu multiple times 

- Restart Mac

- Play Roon as a standalone player.  Roon plays flawlessly so I have determined it is not the connection to the UltraRendu or DAC causing the drop-outs.

- Lowered the CPU load by only upsampling to DSD64 - this doesn't help.   

 

Does anybody have suggestions on how to get HQP running successfully again?  Any comments are appreciated.

 

Link to post
Share on other sites

@Ellsworth

1.  Time Machine must be disabled.  In OS X Prefs > Time Machine, delete any reference to a time machine backup volume and turn off automatic backups.

2.  Try disabling Spotlight indexing with this command in Terminal:

sudo mdutil -ai off

 

If that solves the problem, but you want to use Spotlight, you can try turning it back on with:

sudo mdutil -ai on

 

If turning on Spotlight subsequently interferes w HQP, "App Tamer" from St Clair Software ($15) can be configured to limit Spotlight indexing to less than 1% of CPU.

https://www.stclairsoft.com

 

Mac Mini (2012 i7) > HQPlayer or Audirvana > exaSound e32 > Parasound JC-1 > Thiel 3.7

Link to post
Share on other sites
20 minutes ago, Bob Stern said:

@Ellsworth

1.  Time Machine must be disabled.  In OS X Prefs > Time Machine, delete any reference to a time machine backup volume and turn off automatic backups.

2.  Try disabling Spotlight indexing with this command in Terminal:

sudo mdutil -ai off

 

If that solves the problem, but you want to use Spotlight, you can try turning it back on with:

sudo mdutil -ai on

 

If turning on Spotlight subsequently interferes w HQP, "App Tamer" from St Clair Software ($15) can be configured to limit Spotlight indexing to less than 1% of CPU.

https://www.stclairsoft.com

 

Thanks for the comments.  I am not sure of the status of Time Machine on my system.  Hopefully that will fix it.  I have never used a Terminal command but assume that you don’t have to be a computer programmer to figure that out.  I will try this in the morning and report back.   Thanks again.

Link to post
Share on other sites
On 1/2/2020 at 9:15 PM, ronnie.sengupta said:

 

 

On my Intel i7 7700k without Cuda - running XTR ASDM7 512 from redbook - I noticed that if I turn on Multicore DSP in settings, the CPU hits close to 100% on all 4 cores (I have Hyper threading turned off). If I disable Multicore DSP the CPU utilization comes down to around 58%.

 

With Multicore enabled and Cuda enabled the CPU utilization comes down to 48% with GPU at 80 to 85%

 

The audio stutters in all three cases.

 

 

 

On my PC with Windows 10, i7 7700k with CUDA (2080 Super), I can run Redbook to DSD256 using the non -2s XTR filters and ASDM7EC without stuttering.  Do you have Hyperthreading turned on?  I find that my system will stutter if that is turned on, but works fine if it is off.  I'm not sure if it makes a difference, but I also have HQPlayer set to Realtime in process lasso.  GPU is at 35% and CPU is at 57% (of which HQPlayer is 55%).

Link to post
Share on other sites
2 hours ago, Hammer said:

 

On my PC with Windows 10, i7 7700k with CUDA (2080 Super), I can run Redbook to DSD256 using the non -2s XTR filters and ASDM7EC without stuttering.  Do you have Hyperthreading turned on?  I find that my system will stutter if that is turned on, but works fine if it is off.  I'm not sure if it makes a difference, but I also have HQPlayer set to Realtime in process lasso.  GPU is at 35% and CPU is at 57% (of which HQPlayer is 55%).

 

I too get stuttering when I turn Hyper threading on. With HT turned off, I can get the above settings to work with and without Cuda on my i7 7700k.

 

PC (Roon +  HQ Player) | Allo US Bridge Sig + Shanti LPS | SOTM TX-USB Ultra + SPS500 PSU| T+A Dac 8 DSD | Luxman C-900u + M-900u | PMC MB2 Se

Link to post
Share on other sites
44 minutes ago, ronnie.sengupta said:

@Hammerand @ronnie.sengupta, what cpu usage do you get on your i7 7700 outputting DSD256 using ADSM7EC?

 

 

 

HQ Player --> Singxer SU-1 --> Matrix X-Sabre Pro --> Feliks Audio Elise Mark II 

Headphone: ZMF Auteur (Walnut) / Headphone Cable: Norne Silvergarde S3

Power Conditioning: Furman Elite-15 PF i

 

Link to post
Share on other sites

I just upgraded the CPU to i7 9700k with z390 board and 3200 c16 ram. To my surprise it is stuttering on dsd256 asdm7ec xtr and using about 90% CPU overclocked at 4900mhz.

 

The pc was only detecting one of the ram modules. So I opened it up to check on the second ram module.

 

Disaster struck! My 4 year old managed to spill a little bit of hot chocolate on the motherbard while I was working on it. Now its not booting up :(

 

I should have just stuck to my i7 7700k!

PC (Roon +  HQ Player) | Allo US Bridge Sig + Shanti LPS | SOTM TX-USB Ultra + SPS500 PSU| T+A Dac 8 DSD | Luxman C-900u + M-900u | PMC MB2 Se

Link to post
Share on other sites
5 hours ago, ronnie.sengupta said:

 

I too get stuttering when I turn Hyper threading on. With HT turned off, I can get the above settings to work with and without Cuda on my i7 7700k.

 

 

7 hours ago, Hammer said:

 

On my PC with Windows 10, i7 7700k with CUDA (2080 Super), I can run Redbook to DSD256 using the non -2s XTR filters and ASDM7EC without stuttering.  Do you have Hyperthreading turned on?  I find that my system will stutter if that is turned on, but works fine if it is off.  I'm not sure if it makes a difference, but I also have HQPlayer set to Realtime in process lasso.  GPU is at 35% and CPU is at 57% (of which HQPlayer is 55%).

 

Without CUDA, CPU jumps from 57% to 97% and there is no stuttering.

 

I had read somewhere that HQPlayer works with and without HT turned on and that it is recommended that HT be turned on...maybe Jussi can shed some light on the issue.

 

 

Link to post
Share on other sites

Jussi had posted earlier that HQP recognises HT and as such it should not make a difference.

 

@Hammer are you able to play asdm7 non ec with dad 512 with xtr with your 2080 super?

PC (Roon +  HQ Player) | Allo US Bridge Sig + Shanti LPS | SOTM TX-USB Ultra + SPS500 PSU| T+A Dac 8 DSD | Luxman C-900u + M-900u | PMC MB2 Se

Link to post
Share on other sites

a question....with HQP 4 desktop

 

inserting two filters on sdm (oversampling X1 and oversampling nx)
does the player manage the input audio formats automatically?
if it reads a 44.1 or 48khz file it "reads" the filter on X1 oversampling
if it reads a file 88,2 or higher it "reads" the filter on oversampling nx
it's correct ?
thank you.

sistema:

Server HDPlex (i7-6700-WS2016) HQPlayer con Ramdisk + HQPDcontrol> rete via cavo> TPlink mc 110cs> monomodale ottico> TPlink mc 110cs> HDPlex NAA (celeron G1840T-WS2016) NAD con Ramdisk, Denafrips Ares2, SPLvolume2 

Link to post
Share on other sites

No further luck this morning.   I went to Time Machine and confirmed that it was turned off.  I did not do the Terminal command to turn off spotlight indexing. (I was afraid of blowing something up).   However, if that is a common problem, I will give it a try.   

 

What is puzzling is that it was working perfectly before and I didn't change anything.  I also tested playing PCM with no upsampling and experienced the same issues.   Does it make sense to do something like delete and reinstall HQP?   

Link to post
Share on other sites
8 hours ago, ronnie.sengupta said:

90 to 95% CPU without Cuda. With Cuda it comes down to around 50 to 60% on both GPU and CPU

Thanks. I don't have a dedicated music PC and try to keep HQP's CPU utilization to <30-40% to allow other app's to run.

 

Jussi, are any other optimizations possible / planned to diminish the EC modulator's CPU needs?

HQ Player --> Singxer SU-1 --> Matrix X-Sabre Pro --> Feliks Audio Elise Mark II 

Headphone: ZMF Auteur (Walnut) / Headphone Cable: Norne Silvergarde S3

Power Conditioning: Furman Elite-15 PF i

 

Link to post
Share on other sites
4 hours ago, giordy60 said:

a question....with HQP 4 desktop

 

inserting two filters on sdm (oversampling X1 and oversampling nx)
does the player manage the input audio formats automatically?
if it reads a 44.1 or 48khz file it "reads" the filter on X1 oversampling
if it reads a file 88,2 or higher it "reads" the filter on oversampling nx
it's correct ?
thank you.

 

That’s my understanding and I see the different modulator selected shown on the main screen during playback of the different rates.  

Link to post
Share on other sites
1 hour ago, Ellsworth said:

No further luck this morning.   I went to Time Machine and confirmed that it was turned off.  I did not do the Terminal command to turn off spotlight indexing. (I was afraid of blowing something up).   However, if that is a common problem, I will give it a try.   

 

What is puzzling is that it was working perfectly before and I didn't change anything.  I also tested playing PCM with no upsampling and experienced the same issues.   Does it make sense to do something like delete and reinstall HQP?   

 

I have the same Mini you have.

 

You could also stop Spotlight indexing on particular drives, folders or your entire computer using the Privacy tab in the Spotlight control panel. Turning it off/on is common and nothing will be damaged if you use Terminal or third party software to control it.

 

Reinstalling HQP is also simple enough but if I was facing this issue, I'd try to think back over the past two weeks for any other changes that may have occurred to the system. Power supplies or cables moved around? Any system hangs or crashes which may have corrupted a preference or file? Maybe new software added or automatically updated without your input? I know Roon rolled out a new version (mid December) and the release notes mention a change when communicating with HQPlayer. It now "sends 64bit float stream when practical".

 

I'm not experiencing your issue but, for me, Roon takes significantly longer to load at launch than it did before the update. It seems like the same software but is not behaving exactly like it did.

Link to post
Share on other sites
6 hours ago, ronnie.sengupta said:

Jussi had posted earlier that HQP recognises HT and as such it should not make a difference.

 

@Hammer are you able to play asdm7 non ec with dad 512 with xtr with your 2080 super?


Yes, XTR and ASDM at DSD512 works with the 2080 Super.  GPU Utilization is around 65% and CPU is around 55% (i7 7700k)

Link to post
Share on other sites

Thanks @Hammer. The cpu upgraded didn't help at all. So was a bit nervous before ordering the 2080. Couldn't decide if I should get the super or ti. I guess at 60% gpu on 2080 super, the TI will be an overkill, given the considerably higher price.

PC (Roon +  HQ Player) | Allo US Bridge Sig + Shanti LPS | SOTM TX-USB Ultra + SPS500 PSU| T+A Dac 8 DSD | Luxman C-900u + M-900u | PMC MB2 Se

Link to post
Share on other sites
6 minutes ago, ronnie.sengupta said:

Thanks @Hammer. The cpu upgraded didn't help at all. So was a bit nervous before ordering the 2080. Couldn't decide if I should get the super or ti. I guess at 60% gpu on 2080 super, the TI will be an overkill, given the considerably higher price.

Yes, seems like overkill until Jussi implements even more hardware demanding features.  I’ve had to upgrade several times starting with the 980!  Enjoy!

Link to post
Share on other sites
7 hours ago, perpetualapprentice said:

 

I have the same Mini you have.

 

You could also stop Spotlight indexing on particular drives, folders or your entire computer using the Privacy tab in the Spotlight control panel. Turning it off/on is common and nothing will be damaged if you use Terminal or third party software to control it.

 

Reinstalling HQP is also simple enough but if I was facing this issue, I'd try to think back over the past two weeks for any other changes that may have occurred to the system. Power supplies or cables moved around? Any system hangs or crashes which may have corrupted a preference or file? Maybe new software added or automatically updated without your input? I know Roon rolled out a new version (mid December) and the release notes mention a change when communicating with HQPlayer. It now "sends 64bit float stream when practical".

 

I'm not experiencing your issue but, for me, Roon takes significantly longer to load at launch than it did before the update. It seems like the same software but is not behaving exactly like it did.

Thanks for your comments.  Prior to Christmas and New Year, I had been running Roon 1.7 with HQP with no issues. Since this computer is only used for music, I haven’t had any other programs running or installed.  I tested upsampling to DSD256 using Roon only.  That worked with no problem.  Of course the sound quality doesn’t match HQP.  This is very mysterious....

Link to post
Share on other sites
13 minutes ago, Ellsworth said:

Thanks for your comments.  Prior to Christmas and New Year, I had been running Roon 1.7 with HQP with no issues. Since this computer is only used for music, I haven’t had any other programs running or installed.  I tested upsampling to DSD256 using Roon only.  That worked with no problem.  Of course the sound quality doesn’t match HQP.  This is very mysterious....

 

My apologies, I should have been clearer... Roon 1.7 was updated to build 511 on December 18 (the original v1.07 build from November was 505). I'm just looking for clues as to what may have changed and Roon definitely did (if you've updated) - plus the timing, one week before Christmas - seemed relevant.

 

Included in the Roon update change log I linked was a terse note that a change was made regarding streams sent to HQPlayer "when practical". Perhaps Roon isn't testing their changes with HQP v3? Maybe their tests aren't as rigorous as they might be with El Capitan? Not pointing fingers - just pulling at threads which may have been overlooked. 

 

I'd narrow it down further by playing directly from HQP. If it stutters on it's own, I'd probably reinstall just because - but there could be other options I'm not thinking of. If it doesn't stutter, it seems possible that Roon and HQP aren't communicating as they should.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...