Jump to content
freesteve

HQ Player

Rate this topic

Recommended Posts

2 hours ago, DancingSea said:

How do I turn off upsampling in HQP Desktop (4)?

 

If it is 16/44 PCM you choose PCM default output and 44.1 sample rate (/limit).  Obviously, or not 😄, you would also select "none" under dither and filters in settings.  

Share this post


Link to post
Share on other sites

My first issue seems to have been solved. i tried setting the hgplayer bitrate limit to 44.1X128 instead of 48X128. And the dac display showed the appropriate output. Hope this was a correct solution?

 

next, on to my NAA issue :)

Share this post


Link to post
Share on other sites
41 minutes ago, rando said:

 

If it is 16/44 PCM you choose PCM default output and 44.1 sample rate (/limit).  Obviously, or not 😄, you would also select "none" under dither and filters in settings.  

 

For some reason, this confuses me.  If I select "none" in the both the filter and dither settings, does the sample rate setting become disabled? Or, if I select "none" must I then manually set the sample rate in HQP to match that of the file being sent from Roon, which would be a bother?

 

Thanks

Share this post


Link to post
Share on other sites

I'm not Miska, but would this not be the only sensible way to remove software upsampling inside HQP? 

 

Personally I'd use a different bit perfect program instead of listening through HQP in this fashion.  One without the expressed singular objective of upsampling inside it.  

Share this post


Link to post
Share on other sites
2 hours ago, rando said:

I'm not Miska, but would this not be the only sensible way to remove software upsampling inside HQP? 

 

Personally I'd use a different bit perfect program instead of listening through HQP in this fashion.  One without the expressed singular objective of upsampling inside it.  

 

Which one, if I may ask?

Share this post


Link to post
Share on other sites

I purposely refused an off topic promotional mention of any other program meeting the stated qualifications of bit perfect playback and not upsampling as a primary function.

 

 

Share this post


Link to post
Share on other sites

No Sample Rate Conversion

 

Version 3 Software

 

Go to Settings and "none" in the PCM Defaults - Filter box. Also, on the main screen, ensure that "Auto" is selected in the Sample format/type box -- it's the box furthest on the right in the Filter/Oversampling section.

 

image.png.20612ffa42bdbb120248ed9b61c9f117.png

 

 

Version 4 Software

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

No Sample Rate Conversion

 

Version 4 Software

 

Go to Settings and select "source" in the Default Output Mode.  Select "none" in the PCM Defaults - Filter box.

 

 

image.png

Share this post


Link to post
Share on other sites
1 hour ago, lucretius said:

 

Audirvana, JRiver Media Center, foobar2000, Roon

 

Thank you. Used/tried every which has macOS version. Also Amarra, Fidelia, etc. Each "adds", imho. HQP without filters sounds most neutral to me. Yes, I know HQP is upsampling software.

Share this post


Link to post
Share on other sites
1 hour ago, rando said:

I purposely refused an off topic promotional mention of any other program meeting the stated qualifications of bit perfect playback and not upsampling as a primary function.

 

 

 

Don't sweat, I know there is not any clean from this or that kind of tinkering.

Share this post


Link to post
Share on other sites
4 hours ago, Ernie said:

My first issue seems to have been solved. i tried setting the hgplayer bitrate limit to 44.1X128 instead of 48X128. And the dac display showed the appropriate output. Hope this was a correct solution?

 

Yes it is. For this reason HQPlayer v4 added setting "48k DSD" that defaults to off, because this is so common problem...

 

Quote

2). I have been trying to get NAA working using the following configuration. Roon to hqplayer on an imac i7. Downloaded NAA for mac and ran the script on a macbook pro connected to the dac (topping d10). Tried selecting NAA from hqplayer on the iMac and no devices were listed. The machine running roon and hqplayer is ethernet connected to router, but the machine running NAA is wireless. What am I missing?

 

Wireless is also connected to that same router's access point? There's no clear reason why this wouldn't work. Assuming software firewall on either one is not causing traffic to be blocked. It is usually good to try with IPv6 backend first.

 


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites
7 hours ago, DancingSea said:

I have a DirectStream Junior DAC which upsamples to 20X DSD on its own.  I greatly enjoy HQP and its upsampling, but have read various places about users not doing any upsampling in HQP and passing it on to the DAC.  For instance, Roon —> HQP (no upsample) —> DAC.

 

Send it highest rate PCM it can accept from HQPlayer for best results... For example 192k, always.

 


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites

Thank you Miska...below are screenshots of NAA on my macbook which is connected to my usb dac,  and of the hqplayer settings on my imac. Trying both network audio adapter  and network audio adapter IPv6 shows no device options. Firewall is off on the machine running NAA. I must be missing something

10402F41-61A0-4CB9-92E9-FA6D017058BE.jpeg

D2D5209B-4180-4BE1-8253-E4833426FD3C.jpeg

Share this post


Link to post
Share on other sites
14 hours ago, Miska said:

 

To me it looks like it is using all 16 cores while not touching the 16 siblings (threads), which is intended.

 

I will continue to try to spread the load more. In your case filters are running on the GPU, so there's less work left for CPU. And there's limited amount of possibility to spread modulator loads, so it they primarily utilize two cores per channel. Rest of the work is scattered to all available remaining physical cores. This seems to be working well in your case.

 

If you have very latest Windows 10 (1903), it has some special AMD support optimizations that may be still missing from some Linux kernels. Which Linux distro/kernel are you using by the way? It may be worth comparing Ubuntu 18.04 LTS using either my kernel or Ubuntu's lowlatency kernel, and Fedora 30 using it's stock kernel. Also note that only Ubuntu build of HQPlayer supports CUDA and the different builds are different also in other ways. While Fedora distro in general is very recent "bleeding edge" unlike Ubuntu (and I also use just LTS kernels).

 

Thanks for the answer. I'm using 1903 build of Windows, and Ubuntu 18.04.2 LTS , the kernel is 4.18.something. I've also tried low latency kernel, the latest available through apt was 4.15, but the results were the same - dropouts were there. I'll try 5.0 later.

 

I've disabled the multi-threading and now see that load is indeed spread over all cores, maybe a bit not even.

 

By your kernel you mean the Embedded one?

Share this post


Link to post
Share on other sites
2 hours ago, fred_com said:

Thanks for the answer. I'm using 1903 build of Windows, and Ubuntu 18.04.2 LTS , the kernel is 4.18.something. I've also tried low latency kernel, the latest available through apt was 4.15, but the results were the same - dropouts were there. I'll try 5.0 later.

 

There is also 4.18-hwe (Hardware Enablement) lowlatency kernel, you can pull it using meta package "linux-lowlatency-hwe-18.04".

 

2 hours ago, fred_com said:

I've disabled the multi-threading and now see that load is indeed spread over all cores, maybe a bit not even.

 

With threading enabled, you are just shown 32 logical processors of which 16 are physical. So in the load figures and load plots you need to take that into account. IOW, 16 physical cores fully loaded is reported as 50% total load.

 

Threading helps OS to reduce overhead of context switching multiple processes/threads.

 

2 hours ago, fred_com said:

By your kernel you mean the Embedded one?

 

No, I mean my custom kernel build for Ubuntu, it works for both Desktop and Server versions of Ubuntu 18.04 LTS. Currently it is based on 4.14 LTS upstream kernel. But in somewhat near future I plan to move changes over to 4.19 LTS kernel.

 


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites
2 hours ago, Ernie said:

Thank you Miska...below are screenshots of NAA on my macbook which is connected to my usb dac,  and of the hqplayer settings on my imac. Trying both network audio adapter  and network audio adapter IPv6 shows no device options. Firewall is off on the machine running NAA. I must be missing something

10402F41-61A0-4CB9-92E9-FA6D017058BE.jpeg

 

Looks like the NAA is not starting due to IPv6 failure...

 


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites
6 minutes ago, Ernie said:

Is there a remedy for that?

 

You can check that you have IPv6 support enabled for the network interface and that it has IPv6 address. Or disable IPv6 support by setting environment variable NETWORKAUDIOD_IPV6=0

 


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites
19 minutes ago, Miska said:

 

You can check that you have IPv6 support enabled for the network interface and that it has IPv6 address. Or disable IPv6 support by setting environment variable NETWORKAUDIOD_IPV6=0

 

 

I am sorry for being a novice on these things. The screenshot below seems to indicate that ipv4 is on. I do not understand how to disable it as you suggest.  Is that a command in the terminal window?  Or something I add to the NAA script?

 

thanks much

6EA9FAD9-D2DF-4084-A818-21A6945E57BE.jpeg

Share this post


Link to post
Share on other sites
11 hours ago, Miska said:

 

Send it highest rate PCM it can accept from HQPlayer for best results... For example 192k, always.

 

 

Out of curiosity, if I disable both the filters and dither, but still run Roon through HQP, is HQP actually doing anything to improve or effect the sound with all of that disabled?

 

A few posters on the Roon forum have said they prefer HQP with upsampling disabled, just wondering if HQP still does something or if its a placebo effect.

Share this post


Link to post
Share on other sites
2 hours ago, Ernie said:

I am sorry for being a novice on these things. The screenshot below seems to indicate that ipv4 is on. I do not understand how to disable it as you suggest.  Is that a command in the terminal window?  Or something I add to the NAA script?

 

That looks OK.

 

What I mean are terminal commands to disable IPv6 support. I don't know what kind of NAA script you are using or where it came from, because I'm not distributing any. Are you using networkaudiod version 3.5.6.1?

 


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...