Jump to content
freesteve

HQ Player

Recommended Posts

38 minutes ago, sdmarquart said:

 

Here's some screenshots. HQPlayer is working great, but when I try to play youtube for "Playback" it appears to be using the Realtek Digital Output and you can see it's getting a signal. But no sound. I'm also getting "device in use" errors when I test the playback and recording devices. And I'm not sure why I need a "recording" device for listening to youtube?

 

I really appreciate all your help guys!

 

 

When you get the Device in Use message, did you click "Yes" to continue?

Share this post


Link to post
Share on other sites
26 minutes ago, sdmarquart said:

Yes. But still no sound.

 

OK. In the Windows Sound Panel under the Recording tab, select the Stereo mix device. Click on Properties.  See if there is a tab named Listen. If so,  where it says Playback Through This Device, select your output device.

 

Also, see if "Stereo mix" appears as a Playback device (under Playback tab), select that as default.  Maybe you will need to "show disabled devices" and enable it).

Share this post


Link to post
Share on other sites
On 5/11/2019 at 9:26 AM, Honoré said:

it's true but the increase for the passage V3 2017 (142,90 €) to V4 (191 €) is difficult to understand!

After Jussi's time, I must say that I do not see the price of the V4 in the same way.  

I understand now that the time it takes to help us is 'free' like many intermediate updates and that it is quite normal that after several years a readjustment of the price of the passage of the version  4 is necessary and justified.  

Alain

Share this post


Link to post
Share on other sites
1 hour ago, lucretius said:

 

OK. In the Windows Sound Panel under the Recording tab, select the Stereo mix device. Click on Properties.  See if there is a tab named Listen. If so,  where it says Playback Through This Device, select your output device.

 

Also, see if "Stereo mix" appears as a Playback device (under Playback tab), select that as default.  Maybe you will need to "show disabled devices" and enable it).

Thanks. I'm at work now so can't test for a few hours. I did remote in and see the "listen" tab in the stereo mix properties. It was set at "Realtek Digital Output". The only other option is "Default Playback Device". I selected that one since the "Realtek" wasn't giving me any sound. Will report back later. Thanks everyone for your help.

 

Spence

PC_SoundsScreenshots2.jpg

Share this post


Link to post
Share on other sites
On 5/15/2019 at 1:42 AM, Miska said:

 

This should also work fine with Google's Chromecast Audio dongle (discontinued, but many shops still have these).

 

Both devices anyway allow easy playback from mobile devices, from applications like Spotify as well, in addition to playing from Tidal app. Quite inexpensive way to broaden sources and allow use of various iOS/Android apps.

 

 

The one problem I can see with my solution with feeding an Airport Express into an input for HQPlayer via S/PDIF is what happens when i finally retire this aging 2008 Mac Pro.  I don't think any modern Mac has digital audio inputs anymore.  In theory you could have a input come through a Thunderbolt attached interface but i don't see any solutions among the docks that most popular right now.

 

As it stands, this 8 core Mac Pro only has the horsepower for PCM upsampling and 16/44.1 khz PCM->DSD conversion.  Any high definition music chokes on DSD conversion....there just isn't enough bandwidth in this machine.

Share this post


Link to post
Share on other sites
45 minutes ago, sdmarquart said:

Thanks. I'm at work now so can't test for a few hours. I did remote in and see the "listen" tab in the stereo mix properties. It was set at "Realtek Digital Output". The only other option is "Default Playback Device". I selected that one since the "Realtek" wasn't giving me any sound. Will report back later. Thanks everyone for your help.

 

Spence

 

 

Apparently, you need to enable and set as default, "Stereo mix" under the Playback tab (in addition to having done this under the Recording tab).

Share this post


Link to post
Share on other sites
1 minute ago, lucretius said:

 

Apparently, you need to enable and set as default, "Stereo mix" under the Playback tab (in addition to having done this under the Recording tab).

Okay will do and test later today!

Share this post


Link to post
Share on other sites

I remotely connected to my PC. And I'm not seeing "Stereo mix" under the Playback tab?  See screenshots.

 

Also, curious if there's an option to connect an optical cable into the RME ADI-2 DAC and get sound from my PC?

 

Here's my PC made by the folks at Sweetwater. It's a powerhouse! Just need to be able to play from the internet through my RME ADI-2 DAC.

 

https://www.sweetwater.com/store/detail/CS250v6--sweetwater-custom-computing-cs250-2u-professional-audio-and-video-production-workstation

 

Thanks!

Spence

PC_SoundsScreenshots3.jpg

Share this post


Link to post
Share on other sites
10 minutes ago, sdmarquart said:

I remotely connected to my PC. And I'm not seeing "Stereo mix" under the Playback tab?  See screenshots.

 

You have to show disabled devices (right click on a device, then check 'show disabled devices') and enable it, then select it as default.

Share this post


Link to post
Share on other sites
14 minutes ago, sdmarquart said:

Also, curious if there's an option to connect an optical cable into the RME ADI-2 DAC and get sound from my PC? 

 

Sure, you can get sound from the input on the RME.  But if you want sound from the Web, you either have to (1) use a loopback device (like "stereo mix" or Virtual Audio Cable), or (2) enable the onboard sound and reroute it via cable to the RME (I'm not sure how effective that is).

Share this post


Link to post
Share on other sites
9 minutes ago, lucretius said:

 

You have to show disabled devices (right click on a device, then check 'show disabled devices') and enable it, then select it as default.

 Hmmm. "Show Disabled Devices" is checked on the two devices in playback. Nothing showing "Stereo Mix"??

Share this post


Link to post
Share on other sites
16 minutes ago, sdmarquart said:

 Hmmm. "Show Disabled Devices" is checked on the two devices in playback. Nothing showing "Stereo Mix"??

 

Hmmm ... that last answer was from a Microsoft tech -- I don't have a sound card supporting "Stereo Mix".

 

You could always download and install Virtual Audio Cable or VB-Audio's virtual cable.  Then you will see the Virtual Audio Cable under both Playback and Recording tab. You can select these as defaults.

Share this post


Link to post
Share on other sites
11 minutes ago, lucretius said:

 

Hmmm ... that last answer was from a Microsoft tech -- I don't have a sound card supporting "Stereo Mix".

 

You could always download and install Virtual Audio Cable or VB-Audio's virtual cable.  Then you will see the Virtual Audio Cable under both Playback and Recording tab. You can select these as defaults.

Thanks. I will try that.

Share this post


Link to post
Share on other sites

Downloaded Virtual Audio Cable. Looks like this will work but I can't tell by remotely accessing my PC. Will report back later today. 

 

Thanks alot!!

Share this post


Link to post
Share on other sites

Alas, Swinsian has not responded to our request to be the front end for HQPlayer.  Given the HQPlayer GUI is unlikely to change, and to be polite, let’s call it “vintage” rather than “antiquated”, is there any way to get a Mac/ iOS remote control for HQP 4?

 

Is that too much to ask?

Share this post


Link to post
Share on other sites
28 minutes ago, DancingSea said:

Swinsian has not responded to our request to be the front end for HQPlayer.  Given the HQPlayer GUI is unlikely to change, and to be polite, let’s call it “vintage” rather than “antiquated”, is there any way to get a Mac/ iOS remote control for HQP 4?

 

HQP Client already is Mac remote control, so I think you need to restate your request more precisely.

 

Regarding Swinsian, I'm thinking I'll wait a few weeks and then ask Jussi if the Swinsian developer has contacted him about adding HQP control to Swinsian.  If not, I should be able to develop a bridge between Swinsian Mac and HQP, similar to the way Bit Perfect, Pure Music and Amarra use iTunes as a front end for their audio engines, although mine might not be quite as seamless.  But you'll have to be very patient, as I'm not a real programmer, so I'll be learning as I go along.  This would strictly be for Mac, not iOS.


Mac Mini (2012 i7) > HQPlayer or Audirvana > exaSound e32 > Parasound JC-1 > Thiel 3.7

Share this post


Link to post
Share on other sites
39 minutes ago, Bob Stern said:

 

HQP Client already is Mac remote control, so I think you need to restate your request more precisely.

 

Regarding Swinsian, I'm thinking I'll wait a few weeks and then ask Jussi if the Swinsian developer has contacted him about adding HQP control to Swinsian.  If not, I should be able to develop a bridge between Swinsian Mac and HQP, similar to the way Bit Perfect, Pure Music and Amarra use iTunes as a front end for their audio engines, although mine might not be quite as seamless.  But you'll have to be very patient, as I'm not a real programmer, so I'll be learning as I go along.  This would strictly be for Mac, not iOS.

 

 

 

Aloha Bob,

 

By remote control, I simply mean being able to control the HQP transport (at least) with my iPad using HQP on my Mac.

 

I did just hear back from James Burton, the Swinsian developer.  He said that incorporating HQP would be a lot of work and that he has other priorities, like creating an iOS remote.  He seems to be targeting, understandably, the much larger non-audiophile market.  Thus he has declined our petition.

 

Feel free to write him at [email protected]  Perhaps he’ll help you do all the work?

 

I’ve played around with the Swinsian free trial and like it.  I currently use iTunes for all of my non DSD files, and drag whatever into HQP - and will continue to do so for now (AIFF).  

 

I have about a TB of DSD files, so Swinsian works quite well for organizing them to easily be dragged into HQP for playback. It’s library system is, imho, much better than HQP’s, and certainly much better than my current DSD system of wandering around Finder.

 

Bob, I wonder if Geoffrey might be interested in helping you?  In any case, the torch has been passed to you, Godspeed!

Share this post


Link to post
Share on other sites

Hi, I’m looping Spotify output into HQPlayer 4 with the new Input feature using Virtual Cable.  I find that it works sometimes but not others and when it works (eg., I can hear music), the music sometimes stutters.  When it doesn’t “work” (eg, no sound), the time counter does not change when I hit play in HQPlayer.  I’m sure I’m doing something wrong...would someone have instructions I can follow on how to do this consistently?  Thank you.

Share this post


Link to post
Share on other sites

I'm finding Swisian to more useful as a HQP library manager than I first thought.  Have been able to import my entire iTunes library, complete with playlists, ratings, etc into Swisian.  I'm also able to rate DSD tracks, something that's important to me.

 

Roon, albeit the Tesla of library managers, never resonated with me in terms of how Roon organizes stuff.  I never knew where anything was.  Swinsian, more of the Kia (visually) of library managers, is not nearly as visually rich, but it's system of organization makes more sense to my particular mind than Roon's way.

 

Imho, if we can connect Swisian to HQP, I'd see little reason to keep using Roon.....  otherwise, I'll continue to drag and drop from Swisian into HQP.

Share this post


Link to post
Share on other sites
3 hours ago, DancingSea said:

I did just hear back from James Burton, the Swinsian developer.  He said that incorporating HQP would be a lot of work and that he has other priorities, like creating an iOS remote.

 

Great news that Swinsian is developing an iOS remote app.

 

If the Swinsian iOS app will control the Swinsian Mac app in client/server fashion rather than being completely independent, my scheme would allow the Swinsian iOS app to control HQP.


Mac Mini (2012 i7) > HQPlayer or Audirvana > exaSound e32 > Parasound JC-1 > Thiel 3.7

Share this post


Link to post
Share on other sites
1 hour ago, Hammer said:

Hi, I’m looping Spotify output into HQPlayer 4 with the new Input feature using Virtual Cable.  I find that it works sometimes but not others and when it works (eg., I can hear music), the music sometimes stutters.  When it doesn’t “work” (eg, no sound), the time counter does not change when I hit play in HQPlayer.  I’m sure I’m doing something wrong...would someone have instructions I can follow on how to do this consistently?  Thank you.

 

I don't think you're doing anything wrong.  You just may need to tweek the virtual cable -- e.g. change the buffer size.  This is where you have to experiment with different settings. Check the manual. 

Share this post


Link to post
Share on other sites
41 minutes ago, Le Concombre Masqué said:

[...] 

Shocking Results : 

 

3 and 4 sounded radically different to her ears, with a marked preference for 4, and much more so @64 while (@Miska : please pay attention, whatever it means on how full range convolution and/or upsampling is performed in 4) 3 sounded much better @128 to her ears. [...]

 

I stopped comparing 3x and 4x for a week or more now. Listen only to 4x (also because upgraded already and have no time limit). It still grows in me. The more perception adapts to it, the more I agree with it. Even despite 4x is more demanding to poor quality/early recordings from 70s than 3x. Version 3 is in the app folder, but I feel no urge to open it.

 

Share this post


Link to post
Share on other sites
3 hours ago, AnotherSpin said:

 

I stopped comparing 3x and 4x for a week or more now. Listen only to 4x (also because upgraded already and have no time limit). It still grows in me. The more perception adapts to it, the more I agree with it. Even despite 4x is more demanding to poor quality/early recordings from 70s than 3x. Version 3 is in the app folder, but I feel no urge to open it.

 

which are your settings? how about the 64 vs 128 (or higher) thing?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...