Jump to content
freesteve

HQ Player

Rate this topic

Recommended Posts

20 minutes ago, Miska said:

 

Main new features are listed on the announcement. It aligns some of the functionality/settings of Embedded and Desktop. Now all three products are again aligned, Desktop, Embedded and Pro. All are in 4.x series.

 

Upgrade is Desktop -> Desktop, Embedded is a separate thing that will keep going as it has been on it's own track. You can find relevant pricing info from the web shop (with/without the coupon code).

 

 

Very nice to see this update :) It appears that integration with Roon no longer functions?  If not, is it planned for a future iteration?

 

To be complete - it appears integration with HQPlayer 3.x on the same machine works just fine, so I'm assuming this is a limitation or temporary glitch with the 4.x "server"?


John Walker - IT Executive

Headphone - MacMini running Roon Server > Netgear Orbi wireless > Blue Jeans Cable Ethernet > mRendu Roon endpoint > iFi Audio xDSD > Focal Elegia

Home Theater - Mac Mini running Roon Server > Blue Jeans Cable HDMI > Pioneer Elite SC-81 > MartinLogan Motion series home theater speakers + M&K subwoofer

Share this post


Link to post
Share on other sites
6 minutes ago, AnotherSpin said:

Ok, I do not use library anyway, just tried to add files alternatively, after drag and drop failed...) Yes, DAC selected in Preferences.

 

Strange... I just tested on Mojave; I started up the HQPlayer application, dropped WAV from Finder on the window and it appeared on the playlist and played fine. If you can enable log file from HQPlayer Preferences, restart the application, try drag-and-drop and then email me the log called HQPlayer4Desktop.log from ~/.hqplayer folder.

 


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites
7 minutes ago, jhwalker said:

 

Very nice to see this update :) It appears that integration with Roon no longer functions?  If not, is it planned for a future iteration?

 

To be complete - it appears integration with HQPlayer 3.x on the same machine works just fine, so I'm assuming this is a limitation or temporary glitch with the 4.x "server"?

Hope this is just a glitch otherwise I wont be able to upgrade.


12TB NAS >> i7-6700 Server/Control PC >> i3-5015u NAA >> Singxer SU-1 DDC (modded) >> Holo Spring L3 DAC >> Accustic Arts Power 1 int amp >> Sonus Faber Guaneri Evolution speakers + REL T/5i sub (x2)

 

Other components:

UpTone Audio LPS1.2/IsoRegen, Fiber Switch and FMC, Windows Server 2016 OS, Audiophile Optimizer 3.0, Fidelizer Pro 6, HQ Player, Roonserver, PS Audio P3 AC regenerator, HDPlex 400W ATX & 200W Linear PSU, Light Harmonic Lightspeed Split USB cable, Synergistic Research Tungsten AC power cords, Tara Labs The One speaker cables, Tara Labs The Two Extended with HFX Station IC, Oyaide R1 outlets, Stillpoints Ultra Mini footers, Hi-Fi Tuning fuses, Vicoustic/RealTraps/GIK room treatments

Share this post


Link to post
Share on other sites

@Miska I find the HQplayer player 4 sold as package including windows, mas OS and linux version.  Is it possible to purchase HQplayer desktop 4 for windows solely? I rarely use mas OS or Linux system. 


Software: Roon, Tidal, HQplayer 

HQplayer PC: i9 7980XE, Titan Xp; i9 9900K, Titan V

DAC: T+A DAC8 DSD, exasound e12, iFi micro iDSD BL

USB tweaks: Intona, Uptone (ISO) regen, LPS-1, LPS-1.2, Sbooster Vbus2, Curious cables,  Certified HiSpeed USB cable

NAA: Logic CL100, Uptone JS-2

AMP: Spectral DMC 30SV, Spectral DMA 300

Speaker: Magico S3 MKII

Share this post


Link to post
Share on other sites
4 minutes ago, jhwalker said:

Very nice to see this update :) It appears that integration with Roon no longer functions?  If not, is it planned for a future iteration?

 

It is working just like before, no changes on that front. I just finished three hours of Tidal playback from Roon...

 

5 minutes ago, jhwalker said:

To be complete - it appears integration with HQPlayer 3.x on the same machine works just fine, so I'm assuming this is a limitation or temporary glitch with the 4.x "server"?

 

4.x server is like 3.x stripped down from the local library management things with slimmer GUI and with support for audio inputs added. So if you use Roon, you don't need the HQPlayer Client of 4.x at all. The idea is that many people use some external remote control application, so the unnecessary bits and pieces not needed for that use case have been moved out to external client application. But the local drag-and-drop and other content browse/input playback cases are still self-contained in the server.

 

Did you remember to enable remote control access from the main window? These don't come over from previous versions. And you cannot have both 3.x and 4.x running simultaneously for remote control because they overlap...

 


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites
Just now, louisxiawei said:

@Miska I find the HQplayer player 4 sold as package including windows, mas OS and linux version.  Is it possible to purchase HQplayer desktop 4 for windows solely? I rarely use mas OS or Linux system. 

 

No, there's just single license for all platforms now. Having separate licenses for Windows and macOS+Linux has been annoyance for many, especially when people transition from one OS to another. And since all three now use same license key system, it is possible (not originally the case for 3.x).

 


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites
Just now, Miska said:

 

It is working just like before, no changes on that front. I just finished three hours of Tidal playback from Roon...

 

 

4.x server is like 3.x stripped down from the local library management things with slimmer GUI and with support for audio inputs added. So if you use Roon, you don't need the HQPlayer Client of 4.x at all. The idea is that many people use some external remote control application, so the unnecessary bits and pieces not needed for that use case have been moved out to external client application. But the local drag-and-drop and other content browse/input playback cases are still self-contained in the server.

 

Did you remember to enable remote control access from the main window? These don't come over from previous versions. And you cannot have both 3.x and 4.x running simultaneously for remote control because they overlap...

 

 

HQPlayer Desktop 4.x is running on the same box as Roon server (address defined as "localhost") and Roon reports it cannot connect to HQPlayer 4.x.  Just for grins, I enabled network connections and added a new HQPlayer in Roon ("HQPlayer 4.x"), specifying the actual IP address of the server, with no success there, either:

 

 

 

 

Screen Shot 2019-04-26 at 3.12.56 PM.png


John Walker - IT Executive

Headphone - MacMini running Roon Server > Netgear Orbi wireless > Blue Jeans Cable Ethernet > mRendu Roon endpoint > iFi Audio xDSD > Focal Elegia

Home Theater - Mac Mini running Roon Server > Blue Jeans Cable HDMI > Pioneer Elite SC-81 > MartinLogan Motion series home theater speakers + M&K subwoofer

Share this post


Link to post
Share on other sites

Much more elegant solution to separate client and server. And thank you for the separate choices of filters for 1-x and n-x; only trouble is makes me want to have separate sample rate limits for each, because the limit chosen for one can limit the use of filters for the other.

Share this post


Link to post
Share on other sites

Ok, this getting ridiculous!

I have the License Key Copied, but when I click on Register, it takes me to the App Folder, everything is greyed-out.

This may be beyond my Pay-Grade.

Share this post


Link to post
Share on other sites
Just now, jimdukey said:

Ok, this getting ridiculous!

I have the License Key Copied, but when I click on Register, it takes me to the App Folder, everything is greyed-out.

This may be beyond my Pay-Grade.

 

This is exactly the same as with 3.x, no changes in this process at all. It is opening OS' default File Open dialog asking you to locate and select the key file you've got. Possibly located in your Downloads folder?

 


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites
16 minutes ago, jhwalker said:

 

HQPlayer Desktop 4.x is running on the same box as Roon server (address defined as "localhost") and Roon reports it cannot connect to HQPlayer 4.x.  Just for grins, I enabled network connections and added a new HQPlayer in Roon ("HQPlayer 4.x"), specifying the actual IP address of the server, with no success there, either:

 

 

 

 

Screen Shot 2019-04-26 at 3.12.56 PM.png

 

Strange... Mac firewall active?

 

1567160919_ScreenShot2019-04-26at23_25_57.thumb.png.500958a0036d0f1987399695b840cdd0.png

 

528132934_Screenshot2019-04-26at23_25_46.thumb.png.25fccea54e51aed392482d9f8c42caec.png

 

If the two are running on the same box "localhost" as address should be fine. Note that do not use normal IP of the machine if the two are in the same computer, instead preferably use "localhost" or less preferably alternatively "127.0.0.1" to use faster local loopback network interface instead of going through full protocol stack.

 


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites
15 minutes ago, Miska said:

 

Strange... Mac firewall active?

 

1567160919_ScreenShot2019-04-26at23_25_57.thumb.png.500958a0036d0f1987399695b840cdd0.png

 

528132934_Screenshot2019-04-26at23_25_46.thumb.png.25fccea54e51aed392482d9f8c42caec.png

 

If the two are running on the same box "localhost" as address should be fine. Note that do not use normal IP of the machine if the two are in the same computer, instead preferably use "localhost" or less preferably alternatively "127.0.0.1" to use faster local loopback network interface instead of going through full protocol stack.

 

 

Yep, strange :(

 

3.x works fine on either my Mac Mini (localhost) or MacBook Pro (over the network), but Roon cannot connect to 4.x on either machine.  I guess I'll keep an eye on this before attempting to buy.

 

By the way - your blurb didn't say how much the discount was for 3.x license owners.  I see the license price has gone up quite a bit since 3.x - would like to think the coupon would bring it back down, at least.


John Walker - IT Executive

Headphone - MacMini running Roon Server > Netgear Orbi wireless > Blue Jeans Cable Ethernet > mRendu Roon endpoint > iFi Audio xDSD > Focal Elegia

Home Theater - Mac Mini running Roon Server > Blue Jeans Cable HDMI > Pioneer Elite SC-81 > MartinLogan Motion series home theater speakers + M&K subwoofer

Share this post


Link to post
Share on other sites
21 minutes ago, jhwalker said:

Yep, strange :(

 

3.x works fine on either my Mac Mini (localhost) or MacBook Pro (over the network), but Roon cannot connect to 4.x on either machine.  I guess I'll keep an eye on this before attempting to buy.

 

Only thing that comes to mind is IPv6, since HQPlayer 4 listens for control connections in dual-stack mode to allow both IPv4 and IPv6. Maybe it is again something to do with macOS' very annoying IPv6 support, I'll look into this...

 

(Roon still doesn't know how to work with IPv6)


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites
12 minutes ago, sixman said:

Has there been any change to NAA? Suddenlthg cant see any device on ver 3 or 4 Desktop.

 

No, not recently unless you have installed some updates related to that.


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites
6 minutes ago, Miska said:

Only thing that comes to mind is IPv6, since HQPlayer 4 listens for control connections in dual-stack mode to allow both IPv4 and IPv6. Maybe it is again something to do with macOS' very annoying IPv6 support, I'll look into this...

 

(Roon still doesn't know how to work with IPv6)

 

For this case, I have a temporary solution to try, so on macOS if you have problems to connect from Roon to HQPlayer, you can try opening terminal and starting HQPlayer with following command:

HQPLAYER_IPV6=0 /Applications/HQPlayer4Desktop.app/Contents/MacOS/HQPlayer4Desktop

This disables IPv6 support and could help the case. Success/failure reports welcome!

 


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites
8 minutes ago, Miska said:

 

For this case, I have a temporary solution to try, so on macOS if you have problems to connect from Roon to HQPlayer, you can try opening terminal and starting HQPlayer with following command:

HQPLAYER_IPV6=0 /Applications/HQPlayer4Desktop.app/Contents/MacOS/HQPlayer4Desktop

This disables IPv6 support and could help the case. Success/failure reports welcome!

 

 

Yep, that's it.

 

I was also seeing initial failure in "seeing" the NAA (i.e., unable to open output device, or whatever), which is now working properly, as well.

 

So the questions would be:  1) Can the IPv6 issue be "fixed" in HQPlayer?  if not 2) Can this setting be saved so that it can be launched normally rather than via the terminal?


John Walker - IT Executive

Headphone - MacMini running Roon Server > Netgear Orbi wireless > Blue Jeans Cable Ethernet > mRendu Roon endpoint > iFi Audio xDSD > Focal Elegia

Home Theater - Mac Mini running Roon Server > Blue Jeans Cable HDMI > Pioneer Elite SC-81 > MartinLogan Motion series home theater speakers + M&K subwoofer

Share this post


Link to post
Share on other sites

OK, problem solved.

I bought it, got my Coupon Code, got it downloaded and playing, Woo-Hoo, etc.

But it says I have a Registered Evaluation version.

I wanted to by-pass that, and since it's paid for, when will it say it's Registered to me?

Or will it just say so automatically at the end of the Trial Period, which I don't even want? ...!

Probably working as it should, but want to check, so Thanks in Advance.

 

Share this post


Link to post
Share on other sites
9 minutes ago, jimdukey said:

OK, problem solved.

I bought it, got my Coupon Code, got it downloaded and playing, Woo-Hoo, etc.

But it says I have a Registered Evaluation version.

I wanted to by-pass that, and since it's paid for, when will it say it's Registered to me?

Or will it just say so automatically at the end of the Trial Period, which I don't even want? ...!

Probably working as it should, but want to check, so Thanks in Advance.

 

You need to install the license key you get by selecting "Register" from HQPlayer's "Help" menu. It will ask you to locate and select the new key file you've got. It reports success. Then just restart HQPlayer and it should tell your name in the title bar and in About-dialog. And not "Trial" or "EVALUATION" anymore.

 


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites
13 minutes ago, jhwalker said:

Yep, that's it.

 

I was also seeing initial failure in "seeing" the NAA (i.e., unable to open output device, or whatever), which is now working properly, as well.

 

So the questions would be:  1) Can the IPv6 issue be "fixed" in HQPlayer?  if not 2) Can this setting be saved so that it can be launched normally rather than via the terminal?

 

OK, thank you! I will start looking into this. NAA things are the same as in HQPlayer Desktop 3, so shouldn't be any different. But anyway I'll check it out. macOS IPv6 support is quite awkward, different from how things work on Linux and Windows and of course not documented anywhere...

 


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites
5 hours ago, RunHomeSlow said:

Hello,

My performer tag is srewed up in HQPlayer can’t find a way to select all my library albums in yates or jriver to edit them to no field or at least same as artist, any help?

 

now if i click arrow to bill evans for exemple all sacd folder are untouched but all the rest is now in another arrow name bizarrely.

can’t put a picture right now...

 

here is my pict to help...

bug.thumb.jpg.f4748d370df6530a89af13cf81b3a6d6.jpg


If You Got Ears, You Gotta ListenCaptain Beefheart

 

MacMini, i5, 2.5GHz, SSD, 16Gb, 10.15b > Audirvana Plus 3.5.18 > Wyred DAC2 DSD Special Edition >
Proceed AMP2 > Focal Cobalt 826 Signature Series > Audirvana Remote > iPhone 8

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...