Jump to content
freesteve

HQ Player

Rate this topic

Recommended Posts

37 minutes ago, tboooe said:

NAA is required if you want to use another PC as an endpoint instead of the microRendu.

 

Oh!  I honestly did not know that.  I have always used an xRendu.

 


Main system:Sources: Lampizator Big 7 DAC; Basis 2200 with Calibration base; Benz Micro LPS cartridge; Audio Research Reference Phono 2SE; Doshi Audio Tape Pre-amp with Technics RS-1500. Amplifiers: Doshi Audio v3 pre-amp; 2 Vandersteen M7-HPAs; Speakers: Vandersteen Model 7s; Aurender W20; 

Share this post


Link to post
Share on other sites

Miska sent you a log file back on Tuesday about slow response when stopping music either by HQPlayer with roon or byitself music sometimes continues to play for awhile when I stop music 

On 3/5/2019 at 2:25 PM, Outlaw said:

Okay sent you log by email.

 

Share this post


Link to post
Share on other sites
5 minutes ago, Outlaw said:

Miska sent you a log file back on Tuesday about slow response when stopping music either by HQPlayer with roon or byitself music sometimes continues to play for awhile when I stop music 

 

Yes, I got it. Also tried to send a response, but outlook.com is rejecting emails for the address...

 

You probably didn't this response

Quote

This looks normal. Stopping takes on average 5 seconds. Can you also send what the NAA side says?

The USB interface in question looks like Amanero, because the driver is blindly claiming to support any rate...

 

Share this post


Link to post
Share on other sites

@Miska I saw measurements for this GUSTARD DAC-X26 DAC:

 

https://www.audiosciencereview.com/forum/index.php?threads/review-and-measurements-of-gustard-dac-x26.7007/

 

Very good measurements, with both balanced and unbalanced outputs.

 

Interesting the Shenzhen Audio page mentions HQPlayer (someone at Gustard probably uses it!).

 

And there is a NOS mode, which turns off all the ESS oversampling?

 

"NOS mode: (only sampling rate of 176.4KHz and above can be used), NOS (No OverSampling) does not perform digital oversampling, directly digital-to-analog conversion of the original digital audio signal. This mode is recommended for use with audio player software such as HQplayer with its own oversampling digital filter function"

 

Also mention of synchronous clocking:

 

"The master clock of the ES9038 chips is also supplied by the GPLL high-precision phase-locked loop module. It works directly in synchronous mode to bypass internal ASRC resampling and no longer relies on ASRC to guarantee performance (no need for 100M clock)."

 

 

Also interesting it uses an ESS USB module, not XMOS or Amanero:

 

1237079103_ScreenShot2019-03-11at9_25_28am.png.af819a2b95ba5b3f593dda421338b6b8.png

 

 

A few different interesting things with this DAC, the marketing material but with good measurements too.

 

Share this post


Link to post
Share on other sites
1 hour ago, Miska said:

 

Yes, I got it. Also tried to send a response, but outlook.com is rejecting emails for the address...

 

You probably didn't this response

 

See on my naa side when stopping music get protocol error : c1Socket : :Recv() : recv(): Unknown error

Share this post


Link to post
Share on other sites

I recently heard a Chord M-Scaler connected to my Qutest DAC and was smitten - but the magic improvement seemed to occur mainly when it was running at 705k though dual BNC SPDIF.

 

However AU$7.5k foth M-Scaler is not pocket-money and so it has been suggested that I try HQplayer set on sinc-M with x16 705k upsampling that should give similar results. Which it does up to a point - similar superb resolution and imaging though not quite the same body and lack of digital glare.

 

I am not sure the Qutest is receiving the magic 705k sample rate from HQplayer even though I am pretty sure I have gotten its settings right (checked by another experienced HQplayer user) - and the Qutest can accept 705k via its USB input. The internal light inside the Qutest window is red suggesting it is only receiving 352k (though this is not very clear). Also when I go to the sound setting in MS Windows it seems to allow choice of up to only 384k even though I am using the Chord 44-768 driver.

 

Am I missing something?

Share this post


Link to post
Share on other sites
9 hours ago, legend said:

However AU$7.5k foth M-Scaler is not pocket-money and so it has been suggested that I try HQplayer set on sinc-M with x16 705k upsampling that should give similar results. Which it does up to a point - similar superb resolution and imaging though not quite the same body and lack of digital glare.

 

You may want to try other filters too, like poly-sinc-ext2, poly-sinc-short, etc.

 

9 hours ago, legend said:

I am not sure the Qutest is receiving the magic 705k sample rate from HQplayer even though I am pretty sure I have gotten its settings right (checked by another experienced HQplayer user) - and the Qutest can accept 705k via its USB input. The internal light inside the Qutest window is red suggesting it is only receiving 352k (though this is not very clear). Also when I go to the sound setting in MS Windows it seems to allow choice of up to only 384k even though I am using the Chord 44-768 driver.

 

In HQPlayer main window, when playing tells the output rate on "Format". There is shown input format, arrow and output rate.

 

Note that you should be using ASIO backend and select Chord ASIO driver under Device. This way you can access all capabilities. Then set PCM output rate limit to 768k.

 

Share this post


Link to post
Share on other sites
1 minute ago, Miska said:

 

I would need full log from the NAA side, hard to say where the error comes from. Sounds like the NAA connection has been lost.

 

How do you get log for naa  ?

Share this post


Link to post
Share on other sites
7 minutes ago, Outlaw said:

How do you get log for naa  ?

 

If you edit the startup script networkaudiod_name.bat by removing "rem" from beginning of the line that defines NETWORKAUDIOD_LOGFILE and then start networkaudiod through that script you get networkaudiod.log file in the same directory.

 

Share this post


Link to post
Share on other sites
On 3/8/2019 at 6:47 AM, Miska said:

 

Have you ever had it installed before?

 

Please uninstall first and then check that nothing remains under C:\Program Files\Signalyst and C:\Program Files (x86)\Signalyst and also that there's nothing under %LOCALAPPDATA%\HQPlayer

 

If there is, remove those first before reinstalling the software and see if it helps. Other than that, I'm pretty much running out of ideas.

 

I'm assuming you are installing from "HQPlayerDesktop3-setup-3253.exe" downloaded from www.signalyst.com

 

Hi Miska

 

Thanks for the advice.

 

I don't think I have had it installed before. I did the uninstall and then checked those locations and deleted what was remaining. I downloaded another .exe from your website and again the same issue. I tried with my Microsoft Surface Pro 3 and it opened fine but it doesn't have the power obviously.

 

Not sure what to do now. Maybe it is just not for me :(


MAIN - Peach Audio Balanced Isolation Power Supply,   Sonore microRendu + Uptone LPS-1,  
 LH Labs Geek Pulse S Infinity + LPS1,     McIntosh MA2275,  
Paradigm 30th Anniversary Tributes,    SVS SB13-Ultra,    Van Den Hul + Isotek DIY cables,    Nordost Sort Kone AC
 
THE REST - Halcro MC50,    Marantz PM-15S1,   Cambridge Audio Azur 551R V2,     Denon AVR-4520,     Cambridge 752BD (Oppomod PSU),     Sonos ZP90 (Cullen Mod),     Cyenne Audio CY-3100,   Audioquest DragonFly v1.2,     Epos Epic 5,    Aaron ATS-5,    Aaron CC-250,    Bose 251,    Bose Soundlink Mini    M&K VF-80

PREVIOUSLY OWNED - Definitive Technology BP7006,     Pro-Ject Debut Carbon DC USB

Share this post


Link to post
Share on other sites
3 hours ago, bunno77 said:

I don't think I have had it installed before. I did the uninstall and then checked those locations and deleted what was remaining. I downloaded another .exe from your website and again the same issue. I tried with my Microsoft Surface Pro 3 and it opened fine but it doesn't have the power obviously.

 

Not sure what to do now. Maybe it is just not for me :(

 

Really hard to say why, or do something about it, unless I can reproduce it here...

 

So far it's been usually due to missing CPU feature, but if also the 32-bit version doesn't run (just remember to uninstall 64-bit before installing 32-bit), then it's not that either.

 

Share this post


Link to post
Share on other sites
27 minutes ago, Miska said:

 

Really hard to say why, or do something about it, unless I can reproduce it here...

 

So far it's been usually due to missing CPU feature, but if also the 32-bit version doesn't run (just remember to uninstall 64-bit before installing 32-bit), then it's not that either.

 

Thanks so much. 

I'll keep playing around and hopefully it works. 


MAIN - Peach Audio Balanced Isolation Power Supply,   Sonore microRendu + Uptone LPS-1,  
 LH Labs Geek Pulse S Infinity + LPS1,     McIntosh MA2275,  
Paradigm 30th Anniversary Tributes,    SVS SB13-Ultra,    Van Den Hul + Isotek DIY cables,    Nordost Sort Kone AC
 
THE REST - Halcro MC50,    Marantz PM-15S1,   Cambridge Audio Azur 551R V2,     Denon AVR-4520,     Cambridge 752BD (Oppomod PSU),     Sonos ZP90 (Cullen Mod),     Cyenne Audio CY-3100,   Audioquest DragonFly v1.2,     Epos Epic 5,    Aaron ATS-5,    Aaron CC-250,    Bose 251,    Bose Soundlink Mini    M&K VF-80

PREVIOUSLY OWNED - Definitive Technology BP7006,     Pro-Ject Debut Carbon DC USB

Share this post


Link to post
Share on other sites

Miska,  HQP desktop for Linux - it is not supposed to play PCM higher than 192khz without dual wire protocol?

 

In my without dual wire ticked in Settings - track proceeds like palying, command line in terminal shows sound card (dac ) outputting 384khz, but no sound.

If I tick dual wire - there is sound, but channels and convolving IR files are completely messed (I suppose xmos is not ready for correct dual wire)

Share this post


Link to post
Share on other sites
1 hour ago, Volodymyr said:

Miska,  HQP desktop for Linux - it is not supposed to play PCM higher than 192khz without dual wire protocol?

 

Sure it will, I've been playing up to 1.536 MHz PCM with it...

 

1 hour ago, Volodymyr said:

In my without dual wire ticked in Settings - track proceeds like palying, command line in terminal shows sound card (dac ) outputting 384khz, but no sound.

If I tick dual wire - there is sound, but channels and convolving IR files are completely messed (I suppose xmos is not ready for correct dual wire)

 

If your hardware doesn't specifically support dual-wire, it won't work... For dual wire stereo, you need four channels, left channel are two first ones (1-2) and right channel next two (3-4). What is your audio hardware like?

 

Share this post


Link to post
Share on other sites

my xmos and dac are 8 channels

 But curremtly I have installed frmware for 4 channels 24/384khz ( I have biamp and digiatl cossover PC based) . If I put firmware for 8ch xmps will be limited itself for 24/192.

4 channels - are capable of 384khz, but....as I said, without dual wire checked - for 384khz no sound with HQP, also GIU shows track as proceeding , in debian termonal I can check that soundcard works with 384khz....

Why when I tck dual wire there is some sound output, just nor enogh channles curremtly in dac, but without dual wire - silence?

 

windows with foobar works for 24/384 correctly with this xmos and dac.

Share this post


Link to post
Share on other sites
5 minutes ago, Volodymyr said:

my xmos and dac are 8 channels

 But curremtly I have installed frmware for 4 channels 24/384khz ( I have biamp and digiatl cossover PC based) . If I put firmware for 8ch xmps will be limited itself for 24/192.

4 channels - are capable of 384khz, but....as I said, without dual wire checked - for 384khz no sound with HQP, also GIU shows track as proceeding , in debian termonal I can check that soundcard works with 384khz....

Why when I tck dual wire there is some sound output, just nor enogh channles curremtly in dac, but without dual wire - silence?

 

windows with foobar works for 24/384 correctly with this xmos and dac.

 

Have you set output to 4 channels? Are you routing something in the matrix to all channels? You have checked HQPlayer's main window volume knob that it is not in the default setting (-60 dB)?

 

If you try to play a 4-channel 384k WAV file through "aplay" do you get sound?

 

Share this post


Link to post
Share on other sites
1 hour ago, Miska said:

 

Have you set output to 4 channels? - YES Are you routing something in the matrix to all channels? YES.I can make screenshot later.  You have checked HQPlayer's main window volume knob that it is not in the default setting (-60 dB)? how should it be? I tried several variants

 

If you try to play a 4-channel 384k WAV file through "aplay" do you get sound? I have to try yet, and to create such file first. But when dual wire is checked - playback is present, so it is not about OS limits.

 

Quote

I wrote in bold above

 

Share this post


Link to post
Share on other sites

As I know 32 bits for stereo, if more channels - 24 is maximum..., set it up in firmware.

 

You aske about routing I route channels like that:

 

1) 1 and 2 channtls summed in mono  for two physical bass sections (mono is needed as I set them up in EndFire array) + WAV IR file  with low pass and correction in it. One bass moule is delayed in "speaker management" of HQP (to make proper End Fire arrangement).

 

2) 3-4 channel are routed to the leaft and right mid-high sections of the speakers + WAV IR file containing high pass and corrections

 

 

 

Share this post


Link to post
Share on other sites
8 hours ago, Volodymyr said:

As I know 32 bits for stereo, if more channels - 24 is maximum..., set it up in firmware.

 

What does it expose as seen through "cat /proc/asound/device/stream0"? Where "device" is short device id of your interface?

 

Share this post


Link to post
Share on other sites

I realize ultimately we can experiment, but I’m wondering if a guide to HQPlayer filters has been created that focuses on common man language sonic descriptions of the various settings?  The manual contains what is for me, highly technical descriptions of the various filters and dither settings that is mostly meaningless to me. 

Share this post


Link to post
Share on other sites

@Miska what makes the Closed Form Fast filter different to the other Closed Form filters? - I know it supposedly has less precision/CPU load, though honestly load doesn't seem much different (very low, I only do PCM upsampling - using 2.3Ghz i7 Mac Mini).

What I find odd is that the less precise 'Fast' filter sounds better to me - it has a clarity and naturalness that I don't find in the other Closed Form variants, or the poly-sinc etc filters either.

Predominately using this with a Benchmark DAC3 (Sabre 9028 based).

I recently acquired the Chord Qutest, but so far the DAC3 (with HQP/closed form fast) has the edge in clarity.


Mac Mini/Uptone Audio JS-2 & MMK > iFi iUSB3 > Benchmark DAC3L > HPA4 pre/HP amp > 2 x AHB2 amps (bridged mono) > ATC SCM19 Mk2

Headphones: Focal Utopia, Sennheiser HD600

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...