Jump to content
freesteve

HQ Player

Rate this topic

Recommended Posts

That would be great... As I mentioned previously Cuda can really be a tie breaker. A much cheaper option thread b upgrading processors.

 

Robert


Software: Roon/HQplayer; System I: Roon Server/HQplayer DSD 512 Upsampling, Custom Windows 10 PC/AO, LPS-1 powered Startech USB card; LPS-1 powered ISO Regen; Holo Cyan DAC; VPI Scout 2 Turntable, Soundsmith Boheme, TTW Clamps and Carbon Matt; Cary SLP-98P Preamp; Van Alstine FET 600 Poweramp;  Aerial Acoustics 6T loudspeakers, SVS SB13 Ultra Subwoofers. System II: Custom PC with Signalyst Linux HQplayer NAA; LPS-1 powered Startech USB card; LPS-1 powered ISO Regen; IFI Micro iDSD Black Label; Primaluna Dialogue 2 with Tung Sol KT-150; Paradigm Studio 20 v3 monitors on Custom Mapleshade stands. Cables: Moon Audio, LUSH, Kimber Kable, Mapleshade, LARRY custom.

Share this post


Link to post
Share on other sites
Thank you for this!!!

 

It's great not to have to manually switch between 5,644,800 and 6,144,000 (in my particular case).

 

Love this feature...

 

clipper, are you using native DSD mode or DoP when you output DSD to your DAC? My DAC is DoP capable only.

 

It works for me with PCM output mode set. I see on my DAC that it re-evaluates the sample rate when switching between tracks. The sample rate blinks few times on the DAC display. It adapts to sample rate family of the track played - I see the sample rate both on DAC display and also on XMOS Control Panel.

 

It doesn't work for me with SDM(DSD) output mode set. The DAC shows DSD128 continuosly when switching between tracks. XMOS Control Panel shows no change of PCM sample rate.

 

Normally, when playback is stopped and then started, I see on my DAC at first the PCM sample rate (for example 352.8 for 5.6 DoP DSD) and only after a while it starts to display DSD128. It seems to me that DAC does not re-evaluate the incoming PCM data stream when switching tracks in the case of DoP. It seems to me that the new Auto rate family feature is not used in this case, no processing happen.

Share this post


Link to post
Share on other sites
Normally, when playback is stopped and then started, I see on my DAC at first the PCM sample rate (for example 352.8 for 5.6 DoP DSD) and only after a while it starts to display DSD128. It seems to me that DAC does not re-evaluate the incoming PCM data stream when switching tracks in the case of DoP. It seems to me that the new Auto rate family feature is not used in this case, no processing happen.

 

I just tested with DoP and iDSD Micro on Linux and seems to be working for me. You can check the HQPlayer log file to see what output rate it is setting at each point.

 

When rate is changed during playback, DAC needs to be stopped and restarted for rate change.


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites
I just tested with DoP and iDSD Micro on Linux and seems to be working for me. You can check the HQPlayer log file to see what output rate it is setting at each point.

 

44.1k to 6.1 takes much longer time to initialize than 44.1 to 5.6 and additionally I get stuttering with 44.1 to 6.1, so I am 100% sure I am reporting the state correctly.

 

Maybe the Windows ASIO DoP case somehow differs from the Linux DoP case, maybe the log will help. I will send you log in the evening from home.

 

When rate is changed during playback, DAC needs to be stopped and restarted for rate change.

 

Right, what I'm missing is that restart between tracks in my DoP case.

Share this post


Link to post
Share on other sites
44.1k to 6.1 takes much longer time to initialize than 44.1 to 5.6 and additionally I get stuttering with 44.1 to 6.1, so I am 100% sure I am reporting the state correctly.

 

OK, I'll check it today with iDSD Nano on Windows with ASIO.

 

Maybe the Windows ASIO DoP case somehow differs from the Linux DoP case, maybe the log will help. I will send you log in the evening from home.

 

Type of DSD output or the backend shouldn't matter. DoP is handled by the backend while the rate selection is in the player engine itself where it doesn't know about type of the backend.


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites
clipper, are you using native DSD mode or DoP when you output DSD to your DAC? My DAC is DoP capable only.

 

It works for me with PCM output mode set. I see on my DAC that it re-evaluates the sample rate when switching between tracks. The sample rate blinks few times on the DAC display. It adapts to sample rate family of the track played - I see the sample rate both on DAC display and also on XMOS Control Panel.

 

It doesn't work for me with SDM(DSD) output mode set. The DAC shows DSD128 continuosly when switching between tracks. XMOS Control Panel shows no change of PCM sample rate.

 

Normally, when playback is stopped and then started, I see on my DAC at first the PCM sample rate (for example 352.8 for 5.6 DoP DSD) and only after a while it starts to display DSD128. It seems to me that DAC does not re-evaluate the incoming PCM data stream when switching tracks in the case of DoP. It seems to me that the new Auto rate family feature is not used in this case, no processing happen.

 

It's working for me in SDM mode and I'm using DoP.

 

If I play 44.1 material (for example), my DAC indicates 5,644,800. If I play 96k material (for example), my DAC indicates 6,144,000.

 

I have HQPlayer running on a Windows 10 machine.

 

Here's a screenshot of my settings:

 

Screen Shot 2016-02-04 at 9.28.01 AM.png

 

The DAC (in this case) is an Eastern Electric Minimax Junior.

Share this post


Link to post
Share on other sites

My problem is solved. It wasn't an HQPlayer issue, but of my Win10 system. It's very curious that 2 things met together at the same time ... an system issue just when I was testing the new HQPlayer beta.

 

I had some general troubles with audio on my Win10 about a week. For example I found during weekend that HQPlayer crashes when my DAC is not powered on, so HQPlayer took the default sound device. I could start HQPlayer only with my DAC powered on. Then I found that I am not able run test sound from Control Panel | Sound - not only for the onboard Realtek audio, but also for my Gustard DAC - although the DAC functioned well via ASIO. So I understood I have some general system problem with Win10 audio, but it seemed it doesn't influence exclusive ASIO access via Foobar or HQPlayer. Therefore I reported the above discussed finding as HQPlayer issue.

 

By running sfc /scannow and dism commands I found I have some system integrity issue. But I needed the latest Windows 10 ISO image to solve the issue. As I have limited internet at home, today I downloaded the Windows ISO at work and successfully repaired my system with dism and sfc. I tried yet at work the test tone from Control Panel | Sound and it worked!

 

Meanwhile I read the clipper's answer. I found that my config is very similar to clipper's. Therefore I was very curious if such a system thing could influence HQPlayer, when ASIO playback went fine. So I tried it just as I came home. The result - no issue in HQPlayer! Now it's working as expected for DSD output and the Thesycon XMOS Control Panel shows bitrate change 352800 <-> 384000 when switching tracks between bitrate families.

 

So sorry for disturbing you. It's interesting, how Windows system DLLs can influence HQPlayer despite of using ASIO isolation from system audio. Interesting is, that the issue arise only for SDM(DSD) output, for PCM output the 'Auto rate family' feature functioned as expected. For me still curious.

Share this post


Link to post
Share on other sites

Jussi,

 

This may have already been suggested...if so...+1...but it would be great if you could change "format" in the "Time:" box to "Input Format" and include "Output Format" right under it. That would solve the problem of not knowing what sampling rate is currently being used in the auto mode.

 

The Auto rate mode still seems to be a bit idiosyncratic in my hands. This may partly be the result of specific equipment. For instance the Auralic Vega, at least with my current firmware, will only do 5644800 but not 6144000. As long as you know that and cap it at the lower rate, auto rate mode works with DSD or PCM 44/88/176 content but not 48/96/192 content. If you turn off the auto rate mode...no problem. Likewise the Auralic will only report DSD64 or DSD128...not finer distinctions. My IFI DACs only have colored lights and they are not very discriminating...thus it would be really useful...particularly for troubleshooting to have what HQplayer is trying to output clearly visible.

 

Robert


Software: Roon/HQplayer; System I: Roon Server/HQplayer DSD 512 Upsampling, Custom Windows 10 PC/AO, LPS-1 powered Startech USB card; LPS-1 powered ISO Regen; Holo Cyan DAC; VPI Scout 2 Turntable, Soundsmith Boheme, TTW Clamps and Carbon Matt; Cary SLP-98P Preamp; Van Alstine FET 600 Poweramp;  Aerial Acoustics 6T loudspeakers, SVS SB13 Ultra Subwoofers. System II: Custom PC with Signalyst Linux HQplayer NAA; LPS-1 powered Startech USB card; LPS-1 powered ISO Regen; IFI Micro iDSD Black Label; Primaluna Dialogue 2 with Tung Sol KT-150; Paradigm Studio 20 v3 monitors on Custom Mapleshade stands. Cables: Moon Audio, LUSH, Kimber Kable, Mapleshade, LARRY custom.

Share this post


Link to post
Share on other sites
What is under each of those albums? How does it look like if you open up the albums with the ">" in the upper library view?

 

Not sure what you're referring to here.

 

 

In the HQPlayer Library dialog you can just change what is in the "Album" cell for each of those. You get proper sorting if you instead of 1, 2, 3, ..., 10, 11 use numbering with 0-prefix like, 01, 02, 03, ..., 10, 11, 12

 

I changed the directory naming from single to two then to three integers. It changed for the better with both two and three integer naming convention. No sort difference between those two types, however:

 

Playlist_sort5.jpg

The library manager is sorting correctly in proper sequence. What's odd is the end result:

 

Playlist_sort6.jpg

Your move!

Share this post


Link to post
Share on other sites
I changed the directory naming from single to two then to three integers.

 

As long as there is metadata inside the file, the directory naming doesn't matter...

 

The library manager is sorting correctly in proper sequence.

 

Now here you see the problem, you have multiple albums of same artist and same album name. Here, double-click the cell where the album name is, and add for example "01" to the end and hit enter, repeat for each of those albums. Then exit the dialog by clicking OK to save the modified library data...


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites
This may have already been suggested...if so...+1...but it would be great if you could change "format" in the "Time:" box to "Input Format" and include "Output Format" right under it. That would solve the problem of not knowing what sampling rate is currently being used in the auto mode.

 

I've thought about it, but it doesn't actually fit there. On some OS and some display/font size settings it would fit, but for example for me on Linux with 4K display it doesn't fit and I'm reluctant to make the information boxes larger because it immediately cuts out one line of space from library or playlist views. I rather just fit it on the same format line.

 

If you use latest Roon builds with HQPlayer, the active rate is actually reported there... ;)

 

 

Edit: I changed it to look like this a bit of fitting exercise, is this better than before?

info-box.png

Edited by Miska

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites

Edit: I changed it to look like this a bit of fitting exercise, is this better than before?

[ATTACH=CONFIG]24014[/ATTACH]

 

For me OK :)

Share this post


Link to post
Share on other sites
I've thought about it, but it doesn't actually fit there. On some OS and some display/font size settings it would fit, but for example for me on Linux with 4K display it doesn't fit and I'm reluctant to make the information boxes larger because it immediately cuts out one line of space from library or playlist views. I rather just fit it on the same format line.

 

If you use latest Roon builds with HQPlayer, the active rate is actually reported there... ;)

 

 

Edit: I changed it to look like this a bit of fitting exercise, is this better than before?

[ATTACH=CONFIG]24014[/ATTACH]

 

Love this - was a concern of mine, as well. Great work on polishing an already-good thing :)


John Walker - IT Executive

Headphone - MacMini running Roon Server > Netgear Orbi wireless > Blue Jeans Cable Ethernet > mRendu Roon endpoint > iFi Audio xDSD + iFi Audio xCAN > Focal Elegia

Home Theater - Mac Mini running Roon Server > Blue Jeans Cable HDMI > Pioneer Elite SC-81 > MartinLogan Motion series home theater speakers + M&K subwoofer

Share this post


Link to post
Share on other sites

Jussi, as you know I am a huge fan of HQPlayer, and it will play a large role in my upcoming review of the Fore Audio DaisY1 dac, since I believe HQPlayer (and no other player) allows one to take this dac to new heights.

 

So.....the amount of change that HQPlayer has seen over the past few releases is enormous, but for me it has added to the infamous complexity that is HQPlayer. For example, now there are three new areas where "auto" is being used (auto family checkbox, auto sample rate, auto format output). And those have different prerequisites and, therefore, outcomes depending on wther a) one's dac can handle 44k and 48k DSD variants; and b) whether the chosen filter can work across 44k and/or 48k integer multiples. Wow!

 

Could someone produce a spreadsheet or matrix that shows the choices (I envision two matrix tables, one for dacs that play 44k/48k SDM, and one for those that don't...with columns being filter type/auto family/sample rate/format so that we can understand the logic flow and raifications. I can envision wanting one way, and it being only a checkbox away, but not sure which checkbox.

Share this post


Link to post
Share on other sites
I've thought about it, but it doesn't actually fit there. On some OS and some display/font size settings it would fit, but for example for me on Linux with 4K display it doesn't fit and I'm reluctant to make the information boxes larger because it immediately cuts out one line of space from library or playlist views. I rather just fit it on the same format line.

 

If you use latest Roon builds with HQPlayer, the active rate is actually reported there... ;)

 

 

Edit: I changed it to look like this a bit of fitting exercise, is this better than before?

[ATTACH=CONFIG]24014[/ATTACH]

 

I've just started using Roon integration and the biggest thing it does for me is convert my old ALAC encoded iTunes library.

 

I also very much want to see what the actual output bitrate is. This looks good.

 

Available for OS X?


Custom room treatments for headphone users.

Share this post


Link to post
Share on other sites

So I have been very successful upsampling all 2 channel material to DSD256 (11.2, 12.x).

 

I am now spending quite a bit of time with my multichannel etup, using the Playpoint as my NAA (or my Caps Carbon). I have no urgent need to upsample 5.1 material to DSD256 (cpu requirements are quite different with 5.1 material). Since I have been fat, dumb and happy (keyword is "dumb") I forget what settings I need for the following:

upsample all multichannel PCM (95% of which is 48k family 24/96 or 24/192) to DSD64

leave all native DSD multichannel alone (highest being DSD256 5.1)

 

If I set max window as 3.1Mhz will DirectSDM still allow me to play DSD 256 material? Do I need to use any auto settings? My filter is poly-sinc-mp-2s (for now)

 

Thanks

Share this post


Link to post
Share on other sites
So I have been very successful upsampling all 2 channel material to DSD256 (11.2, 12.x).

 

I am now spending quite a bit of time with my multichannel etup, using the Playpoint as my NAA (or my Caps Carbon). I have no urgent need to upsample 5.1 material to DSD256 (cpu requirements are quite different with 5.1 material). Since I have been fat, dumb and happy (keyword is "dumb") I forget what settings I need for the following:

upsample all multichannel PCM (95% of which is 48k family 24/96 or 24/192) to DSD64

leave all native DSD multichannel alone (highest being DSD256 5.1)

 

If I set max window as 3.1Mhz will DirectSDM still allow me to play DSD 256 material? Do I need to use any auto settings? My filter is poly-sinc-mp-2s (for now)

 

Thanks

 

 

Ted, if you wish to output always DSD to your DAC AND if your DAC is capable of 48k base DSD rates AND if you use a filter which can upsample to both bitrate families (poly-sinc filters are of this type) then you don't need to use any of the Auto settings.

 

'Auto' in the sample rate combo box has has effect only for filters which can do only integer multiple of sample rate. It avoids non integer multiples for these filters. For other filters it is ignored. See here http://www.computeraudiophile.com/f11-software/hq-player-20293/index184.html#post506160

 

'Auto' in the output mode combo box means "Output PCM as PCM, DSD as DSD".

See also http://www.computeraudiophile.com/f11-software/hq-player-20293/index184.html#post506273

 

Checkbox '[x] Auto rate family' is intended for filters, which can output any sample rate, but you want to avoid non integer multiples because of stuttering. It is similar as 'Auto' in the sample rate combo box but it has effect on all filters.

 

That's my understanding ... Miska, which filters can do only integer multiple of sample rate? Are they all called apodizing? I tried only closed form and poly-sinc-mqa of this type.

 

I hope Miska adds more information to HQPlayer Manual.

Edited by bogi

Share this post


Link to post
Share on other sites

Maybe better formulation than the above is:

 

Checkbox '[x] Auto rate family' is intended for filters, which can output any sample rate, but you want to avoid non integer multiples because of stuttering. It is in effect only if 'Auto' is set in the sample rate combo box. It is used to broad the effect of 'Auto' setting to all filters.

Share this post


Link to post
Share on other sites
I have no urgent need to upsample 5.1 material to DSD256 (cpu requirements are quite different with 5.1 material).

 

My new Win10 development machine intended for the purpose can do it pretty well, CUDA offload with a GeForce GTX980 helps quite a lot!

 

I didn't see yet 8- or 12-core Skylake's, but will investigate those once such become available.

 

I forget what settings I need for the following:

upsample all multichannel PCM (95% of which is 48k family 24/96 or 24/192) to DSD64

leave all native DSD multichannel alone (highest being DSD256 5.1)

 

If I set max window as 3.1Mhz will DirectSDM still allow me to play DSD 256 material? Do I need to use any auto settings? My filter is poly-sinc-mp-2s (for now)

 

Keeping DirectSDM on and using 3.1 as limit should do it.


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites
I also very much want to see what the actual output bitrate is. This looks good.

 

Available for OS X?

 

It will be included on next build. If beta7 looks clean, I'll update the manual and make a final release build...


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites

Please help.

Using Sony PHA-3 amp USB to DAC. PCM files play just fine upsampled to 192kHz.

 

If I select DSD, there's just hiss DSD64 or 128 on any DSD or PCM file. I got Roon to work with PCM OK but DSD is the problem there too.

 

ATM, Roon is off and HQ player is on its own. Win10 + HQPlayer 3.12.0.

 

HQ Player bit depth DSD HISS.jpg


AS Profile Equipment List        Say NO to MQA

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...