Jump to content
IGNORED

Cantata album art


niss_man

Recommended Posts

Hi All. I am currently using cantata as my Mpd client on a windows 8 tablet. I am having trouble getting all my album art to show. All my music files have embedded art but cantata seems to download covers from the net. I can right click and search for album covers but when I hit ok, the image is not copied over to the beaglebone black I am using. It is as if the beaglebone is stoping data from being received.

 

Has anyone had these experiences before as well and knows of a fix??

 

Thanks

 

Simon

Link to comment

Hi Simon, it's a feature. The network protocol between mpd server and client is very light weight and does not transport music files or meta information.

 

To stop the client from using internet album art, place a cover art picture in every folder in your library and call it "folder.jpg" (you can use a different name, but have to use it consistently). Now enable the web server on your BeagleBone and point it to the root of your music library.

 

Then edit the client configuration (your Cantata client should have similar configuration options). My android client has a setting called "Album cover settings". Here you remove the check mark from "Download cover art" and set "Load local album covers" instead. You can configure the directory relative to the web server root address (/Music) and also the name of the cover file (folder.jpg). This normally works with the default settings.

Primary ::= Nabla music server | Mutec MC-3+USB w/ Temex LPFRS-01 RB clock | WLM Gamma Reference DAC; Secondary ::= Nabla music server | WaveIO | PrismSound Lyra

Link to comment
Hi Simon, it's a feature. The network protocol between mpd server and client is very light weight and does not transport music files or meta information.

 

To stop the client from using internet album art, place a cover art picture in every folder in your library and call it "folder.jpg" (you can use a different name, but have to use it consistently). Now enable the web server on your BeagleBone and point it to the root of your music library.

 

Then edit the client configuration (your Cantata client should have similar configuration options). My android client has a setting called "Album cover settings". Here you remove the check mark from "Download cover art" and set "Load local album covers" instead. You can configure the directory relative to the web server root address (/Music) and also the name of the cover file (folder.jpg). This normally works with the default settings.

 

What do you mean by enabling the web server on the beaglebone to point to the root of my music library. I thought I have already done this when modifying the fstab file? I can play music from my nas so the beagllebone is already pointing to my library.

Is there some other setting that needs to be changed?

 

What android client are you using?

Link to comment
What do you mean by enabling the web server on the beaglebone to point to the root of my music library.

 

The mpd clients I am familiar with use a web server to access the music folder tree and read a specific file in the music folder to display album art. My mpd server runs a web server (I think it's lighttpd) which has it's web root in /var/www. Inside this, there is a link to mpd's music directory called Music. The mpd client accesses album art via this web server, using an address like http://voyage/Music/<artis name>/<album name>/folder.jpg.

 

Cantata seems to have more options, I found this explanation on Google Code (you can find the full text here):

 

When displaying covers, Cantata will load album covers in the following order:

...if configured to 'Cache scaled covers', Cantata will check its scaled-covers
  cache folder (~/.cache/cantata/covers-scaled/SIZE) for:

1. ${albumArtist}/${album}.jpg

...if MPD folder exists, is not specified as a http URL, and is readable, then
  cantata will look for the following within the folder containing the song:

2. ${configuredName}.jpg - if set
3. ${configuredName}.png - if set
4. cover.jpg
5. cover.png
6. AlbumArt.jpg
7. AlbumArt.png
8. folder.jpg
9. folder.png
10. ${file}.jpg - e.g. "01 Wibble.mp3" -> "01 Wibble.jpg"
11. ${file}.png
12. ${albumArtist} - ${album}.jpg
13. ${albumArtist} - ${album}.png
14. ${album}.jpg
15. ${album}.png
16. Image embedded within current song's tags.
17. ANY other jpg, or png

...then Cantata will check its cache folder (~/.cache/cantata/covers), for :

18. ${albumArtist}/${album}.jpg
19. ${albumArtist}/${album}.png

...if compiled for Linux

20. Matching Amarok cover
21. Matching Clementine cover

...if the MPD folder was specified as a http URL

22. ${url}/${dirFromFile}/cover.jpg
   - or ${url}/${dirFromFile}/${configuredName}.jpg (if set)
23. ${url}/${dirFromFile}/cover.png
   - or ${url}/${dirFromFile}/${configuredName}.png (if set)

...lastly, if user has enabled downloading via last.fm

24. Query last.fm using ${albumArtist} and ${album}. Cantata will attempt to
   download the image specified with the "extralarge" size.

 

I interpret this to mean you have to specify your file location somewhere within Cantata either as a folder (via SMB /file sharing) or as a URL (via a web server) to prevent it looking for pictures on last.fm.

 

The fstab change was on the mpd server, the same string should be configured on the mpd client, to point it to your library also. You need .jpg or .png files within each folder.

 

I'm using MPDroid as a mpd client. It's less feature rich than Cantata.

Primary ::= Nabla music server | Mutec MC-3+USB w/ Temex LPFRS-01 RB clock | WLM Gamma Reference DAC; Secondary ::= Nabla music server | WaveIO | PrismSound Lyra

Link to comment

Thanks Iago

 

I have got it to work now. It was as you have said. I had to point it to my nas music directory. There was an issue with my windows 8 tablet not seeing my NAS on the network even though I could get to the nas by typing in it's address into explorer. After much mucking around, a simple reboot of the modem fixed that issue. Now I have all album art showing in cantata and my rating of cantata has since gone from an 8 to a 10.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...