Jump to content
IGNORED

Direct ethernet Mac to Devialet: IP settings?


Recommended Posts

Hi: I do have a simple networking problem, but I can't solve it. Formerly I had my Devialet's ethernet connection plugged in a switch which was connected to my MacPro using DHCP. Everything worked fine with this setting.

 

Now I try to connect the Devialet 240 directly to my MacPro's second ethernet port and use a fixed IP-address for the Devialet. On the website with the configurator they suggest this IP: 192.168.0.77

 

How do I need to configure the network setting for ethernet 2:

 

Configure: manually (?)

IP Address: ???

Subnet: 255.255.255.0

Router: ???

 

Thanks.

Link to comment

First off, you need to check that your existing network doesn't use IP addresses in the 192.168.0.x range.

 

If not then set your Mac's up address to any number (other than 0 or 255 or 77) in the 192.168.0.1 to 192.168.0.254 (eg 192.168.0.100).

 

No need for a router address. Subnet 255.255.255.0 as you said.

 

Eloise

Eloise

---

...in my opinion / experience...

While I agree "Everything may matter" working out what actually affects the sound is a trickier thing.

And I agree "Trust your ears" but equally don't allow them to fool you - trust them with a bit of skepticism.

keep your mind open... But mind your brain doesn't fall out.

Link to comment
First off, you need to check that your existing network doesn't use IP addresses in the 192.168.0.x range.

 

If not then set your Mac's up address to any number (other than 0 or 255 or 77) in the 192.168.0.1 to 192.168.0.254 (eg 192.168.0.100).

 

No need for a router address. Subnet 255.255.255.0 as you said.

 

Eloise

 

Thanks Eloise. I followed your instructions and also configured the Dev 240's settings to fixed IP. This was confirmed in the dp_cfg.txt file. However, when checking the Dev's ethernet settings in its bulls eye window, it still shows 0.0.0.0, also in the AIR ETH settings. It doesn't change even on a complete restart of the Dev. Maybe a software problem of the 240?

Link to comment

Errr......are you using the same cables as the ones connected to the switch??

 

If you are, then you would be able to solved your problem by replacing that one ethernet cable between the Mac and Devialet with a "cross wired" ethernet cable.

 

Good luck!

 

(Audio)

Link to comment
Errr......are you using the same cables as the ones connected to the switch??

 

If you are, then you would be able to solved your problem by replacing that one ethernet cable between the Mac and Devialet with a "cross wired" ethernet cable.

 

Good luck!

 

(Audio)

 

Ohhh, yes, you are right. I think I still have a cross-over somewhere. Thanks a lot.

 

But could this be the reason for the Dev not showing an IP number? Probably...

Link to comment
You don't need a crossover cable if both devices are GigE. That issue was fixed quite a while ago with the introduction of Auto-MDIX.

 

Thanks for clarifying this. I haven't had time to try it with a crossover yet. With my normal cable it doesn't work yet.

 

At least however, the Dev240 now accepts the assigned IP#. All connections seem to work, the Dev is set as output but the music doesn't stream. Strange. I'll see to it as soon as I am home again.

Link to comment
Thanks for clarifying this. I haven't had time to try it with a crossover yet. With my normal cable it doesn't work yet.

 

At least however, the Dev240 now accepts the assigned IP#. All connections seem to work, the Dev is set as output but the music doesn't stream. Strange. I'll see to it as soon as I am home again.

 

What are using as streaming software?

David

Link to comment
How is that work over Ethernet? Correct me if I am wrong but doesn't the 240 use Ethernet to connect to a network and a UPnP server? The "Air" software essentially makes the computer a server is that correct?

The Air software is more like a "virtual soundcard" for the computer.

Eloise

---

...in my opinion / experience...

While I agree "Everything may matter" working out what actually affects the sound is a trickier thing.

And I agree "Trust your ears" but equally don't allow them to fool you - trust them with a bit of skepticism.

keep your mind open... But mind your brain doesn't fall out.

Link to comment
The Air software is more like a "virtual soundcard" for the computer.
The 'virtual' bit is important here, since it doesn't appear to be an excercise in streaming the actual captured sound signal being played back by the music software being used (eg iTunes), as I understand it. The AIR software works out the actual music file that is currently being played back and streams that over the network instead!

 

How this is done for a whole playlist, with issues such as working out the next track & queueing it for gapless support, is certainly beyond me. Presumably navigational functions originating from the music player software, such as pause, skip, etc, have also been taken into account.

We are far more united and have far more in common with each other than things that divide us.

-- Jo Cox

Link to comment

Danold,

You are experiencing a firmware issue. I had the same, currently running on a beta version which solves the problem.

 

You basically need to load the new firmware, give both the Devialet and your computer static ip's, and connect them with a normal ethernet cable (no need to cross). This is the best medium I tried so far, taking the noisy router/switch out of the equation.

 

If you cannot wait, I suggest you get in contact with Devialet to request the beta firmware.

 

Cheers

Kii Three + BXT, dCS Network Bridge, Stromtank 2500, Roon Nucleus, Echole Power Cables, Mogami + Bocchino AES, SOTM Switch + CAT7

Link to comment
  • 2 years later...

Sorry to reactivate this discussion but I am trying desperately to establish direct Ethernet connection from my mac to my devialet.

IP fixe address both sides set, well recognized; link looks fine but when starting to stream music no sound ( from iTunes or audirvana)

I tried with different AIR version including the new 3.0 beta test version without any result.

Has anyone an idea that can help me

 

Thanks

 

It is working fine if I use an Ethernet switch but would like t try direct connection to check if sound quality is better.

Link to comment

Try this, and let me know if this works for you:

 

On the Configurator side you do want to enable the ethernet port on the Devialet, and as you mentioned, under Ethernet settings ->Advanced Settings:

 

DHCP - OFF

 

Fixed IP address ( this is an example ) 192.168.0.77

Network Mask - 255.255.255.0

 

Click OK.

 

Download the settings to your SD card.

 

Put SD card into Devialet and re start.

 

Ensure Ethernet input is selected on the Devialet

 

On your Mac choose System Preferences from under the Apple menu ( Apple icon top left on your screen )

 

Select Network.

 

Then select Ethernet ( it probably indicates it is connected and has a small green circle )

 

If you have not done so choose Configure IPv4 - and set to "Manually"

 

IP Address - set to 192.168.0.78 ( note this is exactly the same as you set for the Devialet except the last number (.78)

 

Subnet Mask - set to 255.255.255.0 ( note this is exactly the same as you set for the Devialet )

 

Router - doesn't really matter - put 192.168.0.1

 

If you already have this setup properly then under Status: it should be as follow:

 

Status: Connected

 

Ethernet is currently active and has the IP address 192.168.0.78 ( or however you configured it on your Mac )

 

If you are doing this again then click the APPLY button.

 

Now you are all set on both the Devialet and the Mac side.

 

 

On to the Devialet AIR icon (teardrop - top right of screen)

 

Clicking on it should show the following:

 

Disable Devialet AIR

My Devialet-ETH

Settings

About

Quit

 

Select My Devialet-ETH

 

Choose Settings

 

If you click General Settings in the left pane you will see the following in the right pane:

 

Launch Devialet AIR at startup - I have mine set to ON

 

Unlock Advanced Settings

 

Click the little lock and you should be able to change the "Target Device Buffer"- mine is set to "500 ms" others use higher or lower settings.

 

That is all you can go in General Settings

 

Now go back to the Left Pane and click My Devialet-ETH

 

When you do so in the right pane you should see the following:

 

Round dial with the volume level of your Devialet and the input selected (ethernet)

 

It should also show the following:

 

Ethernet connection: 10/100

 

IP Address - this should match the one you specified in the configurator - from my example above it would be 192.168.0.77

 

Mac Address: ( don't be concerned with what you see here as it is not related to your Mac Mini settings/nor anything else you need based on your setup)

 

When the device appears on the network: I have mine setup to "always stream to it automatically"

 

And that is all you need to do for configuration of Devialet AIR

 

As a verification step - you could go into the following folder on your Mac:

 

Applications -> Utilities

 

Choose the Audio Midi Setup application, and launch it.

 

Verify you see "Devialet AIR"

 

Lastly you can go into System Preferences under the Apple Menu and select Sound

 

Verify Devialet AIR is selected as your Output device.

 

p.s. I have not used Audirvana in a while, but you will want to ensure that AIR is the output device

Silver Circle Audio | Roon | Devialet | Synology | Vivid Audio | Stillpoint Aperture | Auralic | DH Labs

Link to comment

Thanks a lot works fine now, I just omitted to put router address in my Mac ethernet config

 

Try this, and let me know if this works for you:

 

On the Configurator side you do want to enable the ethernet port on the Devialet, and as you mentioned, under Ethernet settings ->Advanced Settings:

 

DHCP - OFF

 

Fixed IP address ( this is an example ) 192.168.0.77

Network Mask - 255.255.255.0

 

Click OK.

 

Download the settings to your SD card.

 

Put SD card into Devialet and re start.

 

Ensure Ethernet input is selected on the Devialet

 

On your Mac choose System Preferences from under the Apple menu ( Apple icon top left on your screen )

 

Select Network.

 

Then select Ethernet ( it probably indicates it is connected and has a small green circle )

 

If you have not done so choose Configure IPv4 - and set to "Manually"

 

IP Address - set to 192.168.0.78 ( note this is exactly the same as you set for the Devialet except the last number (.78)

 

Subnet Mask - set to 255.255.255.0 ( note this is exactly the same as you set for the Devialet )

 

Router - doesn't really matter - put 192.168.0.1

 

If you already have this setup properly then under Status: it should be as follow:

 

Status: Connected

 

Ethernet is currently active and has the IP address 192.168.0.78 ( or however you configured it on your Mac )

 

If you are doing this again then click the APPLY button.

 

Now you are all set on both the Devialet and the Mac side.

 

 

On to the Devialet AIR icon (teardrop - top right of screen)

 

Clicking on it should show the following:

 

Disable Devialet AIR

My Devialet-ETH

Settings

About

Quit

 

Select My Devialet-ETH

 

Choose Settings

 

If you click General Settings in the left pane you will see the following in the right pane:

 

Launch Devialet AIR at startup - I have mine set to ON

 

Unlock Advanced Settings

 

Click the little lock and you should be able to change the "Target Device Buffer"- mine is set to "500 ms" others use higher or lower settings.

 

That is all you can go in General Settings

 

Now go back to the Left Pane and click My Devialet-ETH

 

When you do so in the right pane you should see the following:

 

Round dial with the volume level of your Devialet and the input selected (ethernet)

 

It should also show the following:

 

Ethernet connection: 10/100

 

IP Address - this should match the one you specified in the configurator - from my example above it would be 192.168.0.77

 

Mac Address: ( don't be concerned with what you see here as it is not related to your Mac Mini settings/nor anything else you need based on your setup)

 

When the device appears on the network: I have mine setup to "always stream to it automatically"

 

And that is all you need to do for configuration of Devialet AIR

 

As a verification step - you could go into the following folder on your Mac:

 

Applications -> Utilities

 

Choose the Audio Midi Setup application, and launch it.

 

Verify you see "Devialet AIR"

 

Lastly you can go into System Preferences under the Apple Menu and select Sound

 

Verify Devialet AIR is selected as your Output device.

 

p.s. I have not used Audirvana in a while, but you will want to ensure that AIR is the output device

Link to comment
  • 2 months later...

Hi everyone...

 

Thanks for this thread, but after all the reading and applying I still can't get my MBP to see the Devialet 120 in the AIR menu. I cannot uncheck the "disable Devialet AIR" box.

I've tried everything I can think of...

The instructions above were straightforward enough. Please help.

 

 

Devialet side:

Ethernet is fixed IP, Wifi is NOT activated on the configurator.

 

Mac Side:

Manually set static IP, no router address (either way that doesn't seem to matter)

Internet sharing w/ Ethernet ON.

Wifi is working fine, and Ethernet is supposedly connected (green).

Link to comment

Can you post the settings you enabled on the Devialet side via the configurator?

 

And can you post the settings you used for you Mac in System Preferences -> Sharing -> Internet Sharing?

 

You have it set to share your Wifi connection to Computers using Thunderbolt ethernet?

 

Ethernet cable from MBP Pro to Devialet?

Silver Circle Audio | Roon | Devialet | Synology | Vivid Audio | Stillpoint Aperture | Auralic | DH Labs

Link to comment

First of all, THANK YOU for the reply.

Can you post the settings you enabled on the Devialet side via the configurator?

And can you post the settings you used for you Mac in System Preferences -> Sharing -> Internet Sharing?

You have it set to share your Wifi connection to Computers using Thunderbolt ethernet?

 

Ethernet cable from MBP Pro to Devialet?

 

Wifi Disabled, Ethernet Enabled.

DHCP off.

Static IP of 192.168.0.100

Subnet 255.255.255.0

Internet Sharing ON, Share your connection from: WiFi, Ethernet box checked. (Not Thunderbolt)

 

I have a cable Ethernet cable connected directly from the MBP to the Devialet.

Link to comment

Hi - I suspect we are in very different timezones so there may be a bit of delay in working through this.

 

Can you also share IP address of your Mac?

 

It has been a while since I posted this "how to" so I need to check a few things.

 

Also can you check that you have the input for the Devialet set to Ethernet once you have the Devialet turned on?

 

Finally assuming you are using a router, do you know the IP address of your router?

Silver Circle Audio | Roon | Devialet | Synology | Vivid Audio | Stillpoint Aperture | Auralic | DH Labs

Link to comment
Hi - I suspect we are in very different timezones so there may be a bit of delay in working through this.

 

Can you also share IP address of your Mac?

 

It has been a while since I posted this "how to" so I need to check a few things.

 

Also can you check that you have the input for the Devialet set to Ethernet once you have the Devialet turned on?

 

Finally assuming you are using a router, do you know the IP address of your router?

 

Sure. The IP set to the Ethernet is 192.168.0.101 per the example above (one number "more") in the thread. I was under the impression from the Devialet help site and this thread the address was not a huge concern as long as it was not being used by the computer already.

 

Yes, of course the Devialet is set to Ethernet.

I have tried putting the router address in and leaving it blank as well. It doesn't seem to make a difference.

For what its worth, regular WiFi won't connect either, but I'm pretty sure that's because of a spotty connection, hence the wired connection via ethernet.

Link to comment

Ok, so if possible it would help if you could let me know the IP address of your router?

 

The regular WIFI not working is an issue, is there any way you can resolve that?

 

What version of AIR do you have installed on the Mac?

 

If you select the AIR icon, select Settings.

 

Select My Devialet-ETH

 

Can you tell me details of what is in the right pane?

 

Connection details...

 

IP Address...

 

When the device appears on the network...

Silver Circle Audio | Roon | Devialet | Synology | Vivid Audio | Stillpoint Aperture | Auralic | DH Labs

Link to comment

Hey baddog,

Sorry it took me so long to reply. Thanks again.

 

Why is the WiFi an issue with a hardwired connection?

If that's the case, that may be the long and short of it.

 

I tried filling out the router address with it or leaving it blank and it didn't make a difference either way.

What is the relation between the router address and the Devialet's IP?

 

As far as AIR goes, I can't get it to even recognize the Devialet.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...