Jump to content
IGNORED

Auto Login MBP to Mac Mini - Problem


Recommended Posts

Currently have a new MBP (i7 retina 16GB, SSD, OSX) connecting to a wired LAN Mac Mini (OSX) which holds docs, and some music files. Windows is very good connecting to network shares, the drive sticks after a reboot, but OSX behaves differently.

 

The MBP IP is DHCP, Mac Mini has fixed IP address. DNS settings are the same for both machines.

 

After a cold start and wait say 10s after the MBP clears booting, if I use Command + K and enter afp://192.168.0.4 and after a login, the finder window opens and I can access files OK, read & write.

 

After a reboot, the drive is missing from Finder (unmounted?). If I try to connect to the Mac Mini so that the MBP connects after a reboot, by these methods, nothing is working so far:

 

- Create an alias for the drive and add to login items - Fails (command ignored)

- Drag the drive into Login items - Fails (command ignored)

- Create a script, the app from various sources on the internet - Fails (command ignored)

 

Is there some timing issue going on? By using an alias on the desktop, there's no need for credentials to be presented, the finder window opens right away.

 

Does anyone have a script that I can hack to suit the drive on the Mac Mini?

 

This is a real pain.

AS Profile Equipment List        Say NO to MQA

Link to comment

'evening,

 

Been lurking on here for a couple of years now, just signed up today.

 

We should be able to find a method that works for you in your environment.

 

I just tested adding a mounted network volume to Login Items and it seemed to stick for me in both cases of a logoff/logon, and a reboot. This was using a MacBook Pro running Mavericks 10.9.1 connecting to a Mini running Mavericks Server 10.9.1.

 

I connected to a share on my Mini by using Go -> Connect to Server using afp://mini.local for my server address. When the list of shares came up I selected a volume from those presented then entered my account credentials and selected “Remember this password in my keychain”.

 

Once the volume shared on the Mini was visible on my desktop, I opened System Preferences, selected my account, authenticated so I could makes changes, selected the Login Items tab and dragged the network volume icon from my Desktop into the Login Items list where it says "These items will open automatically...". I checked the Hide box so the volume would not open a window when mounting, and tested it logging out/in, and by rebooting.

 

If this method has not worked on your systems, perhaps there is a permissions issue.

 

Do the steps I have described sound like those you have tested before?

Link to comment

 

If this method has not worked on your systems, perhaps there is a permissions issue.

 

Do the steps I have described sound like those you have tested before?

 

Thank you for the reply. I have dragged the alias and the volume (from the desktop) into login items. (Previously opened the Login items to continue). Both of which don't stick the drive after the MBP is re-booted. There was a message that the location could not be opened, see your Administrator. If I clicked the alias, finder opens the mac mini drive fine without asking for login credentials.

 

I have tried using the name of the mac mini, but the "computer could not be found", however works with the IP address. I read somewhere this could be a DNS issue in the router?

 

Happens on two MBP accessing the same Mini (both MBP have the same spec).

 

The MBP is set to login automatically for one user, and not to ask for credentials at boot. I wonder should this be changed to login with credentials, then OSX might add in the mac mini drive automatically.

AS Profile Equipment List        Say NO to MQA

Link to comment

It would be best to stay away from aliases while working this out.

 

I believe the Login Items method should work even if the computer is set to auto login, provided the mounted network volume is included in the list of items to open at login.

 

Try walking through the steps I described above using either an ip address for the Mini, or the name of the Mini with .local appended. If the Mini is called Fred, you would enter afp://Fred.local in Connect to Server.

Link to comment

Added the folder on the remote drive into Login items. Used the manual logging on system and the remote drive loaded OK. Must have rebooted about 3 times one after another, still OK.

Changed to auto login and the remote drive still loads OK. So it works now...! dunno, really haven't completed anything else differently. Oh well.

IS there a way to hide the finder window after reboot, the drive appears on the desktop, so I could access the files from there. The hide function in the login items doesn't work.

AS Profile Equipment List        Say NO to MQA

Link to comment

This was an interesting puzzle.

 

This is a behaviour I have never really paid a lot of attention to, and I've use Mac's since 1984.

 

Hunting around looking at possible solutions, it appears there are some inconsistencies in methods based on client and server OS versions.

 

Here is a method that seems to work consistently for me.

 

Open AppleScript Editor (from Utilities folder) and create a New Document. Make sure you select On My Mac if you are using a newer OS that defaults to iCloud.

 

Enter the following line for each volume you want to mount automatically on the network server.

 

mount volume "afp://server_name/volume_name"

 

If your server was named after a cartoon, with volumes named for characters, your AppleScript Editor window contents might look like this...

 

mount volume "afp://Flintstones.local/Fred"

mount volume "afp://Flintstones.local/Barney"

 

Save as an application, then add the application to your Login Items.

Link to comment

Thanks, recordgeek, that script (and app) worked.

 

The drives mount on the desktop after boot has completed, even works on autologin.

 

On the first boot after adding the app, credentials needed to be entered to access the drives. On the subsequent boot(s) the two drives popped up on the desktops, the finder windows hidden with no user intervention needed.

 

If there was a Windows drive that needed to mounted, would the command be:

 

mount volume "smb://Slate/Boss" (for non OSX, the .local dissappears?)

 

This of course assumes that the permissions are already setup.

AS Profile Equipment List        Say NO to MQA

Link to comment

That should work. Any protocol that works in the finder should also work with this approach.

 

Apple has broke SMB in different OS versions along the way so watch for that if connecting to a Mac.

 

For older Windows boxes you may also use cifs://

 

The .local is for name resolution. Behavior with SMB on you local network could vary depending on exactly what OS's are running. If you already have a Windows machine up and running it could be the master browser.

Link to comment

Not sure if this is relevant, but Apple switched to SMB2 for the default network protocol.

Apple - OS*X Mavericks - See everything the new OS*X can do.

SMB2 is the new default protocol for sharing files between two Mac computers running OS X Mavericks. SMB2 is faster, increases security, and improves Windows compatibility.

 

I'm wondering if it will work better if you replaced afp with smb or cifs.

 

FWIW, I'm getting generally faster read/write speeds to a NAS with SMB2 on Mavericks.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...