Jump to content
IGNORED

CAPS V3 Topanga - encountered USB problems and solved them


Robert_h

Recommended Posts

Hi, I wanted to post here about my experience of building the Topanga streamer, the problems I encountered, and how I solved them.

 

Up until just a few days ago, my everyday machine was a Shuttle mini PC, and my "streamer" was a Dell laptop, with no modifications. I use JRiver 19 MC, USB connection to an HRT Music Streamer HD DAC, and from that to the amp etc.

 

The Shuttle for some reason hit a fault and effectively died. I was able to RMA it for a refund (had it a few months only) and so decided to reuse the refund and investigate alternatives. As my "streamer" laptop then became my main machine, I thought ooh I could build a streamer, and having seen the CAPS v3 recipes before, looked to see what I could do. I spent a little time looking into what other boards etc I could try, as I was left with the memory (2 x 2 gig) and hard drive (2.5" SATA spinning HD) and laptop slot loading optical drive that came out of the Shuttle. I wanted to find something compatible, mostly with my existing memory, so I could reuse as much as possible.

 

Anyway, I came back to the Topanga, as the motherboard was compatible and the right price etc and so my variation is:

same motherboard, Intel DN2800MT, same Seasonic PSU.

different case, Silverstone SG06

different memory, 2 x 2 gig Crucial - but otherwise similar spec as the Mushkin

different storage, WD blue 2.5" hard drive 320 GB

optical drive as it was spare

different OS, Windows 7 in 32 bit guise - as I owned this already and not Windows 8

same playback software JRiver MC 19

 

Everything was fine until I connected my HRT Music Streamer HD. Music would play back for a few seconds or maybe a few minutes, but at some point there would be a "squawk" sound, then silence. and the only way to get things going again would be to disconnect then uninstall the HRT from the device manager, and reconnect.

 

I emailed HRT for help and got a reply (pretty quickly I might add, and on a Sunday evening too) from Kevin Halverson. He suggested a few things to try:

Note: These are in no particular order

 

 

1) Try a different media player (perhaps Windows Media Player).

2) Upgrade the firmware in the Streamer to current (if not already).

3) Set the host's power management to High Power.

4) Run an optimizer like fidelizer.

5) Insert a self (not bus) powered USB 2.0 hub in the path between host and device (Streamer in this case) making certain that the Streamer is the only device attached to the hub regardless of the number of downstream ports the hub might have.

6) Use the supplied USB A to B cable.

I'd also tried my Meridian Explorer USB Dac which I use just with headphones - worked perfectly, this has dedicated USB 2.0 drivers which the HRT doesn't (yet). I'd made sure to install the latest Intel drivers, experimented with settings in JRiver itself, all the usual things you might try. Nothing seemed to make any difference as far as the HRT DAC was concerned.

 

My conclusion was it must be the USB - and in fact it was the first comment received from Mr Halverson ...

a poorly performing USB controller

 

So I purchased a new USB 3.0 card and added it tonight into my "topanga" - success!

The card is a Silverstone (but that's probably somewhat irrelevant) - SilverStone Technology Co., Ltd.- EC04-E

More importantly it's based around the NEC uPD720201 chipset. I suspect any other card with that same chipset would also "play nicely" with the HRT. (the Silverstone was easy to obtain and not expensive).

 

My final conclusion this is the result of the combination of that Intel NM10 chipset with Windows 7 with the HRT DAC. I dont know which of these is "wrong", as such. My guess is using Windows 8 instead of Windows 7 might just work perfectly too, being I assume different drivers. Or the HRT is fussy, but I wouldn't know why or how.

 

But bottom line is, for me, the onboard USB on that Intel motherboard wouldnt work with my DAC, but adding a dedicated USB card made it work. I deliberately avoided any card with a TI chipset (based on remarks made for the Lagoon streamer ref compatibility issues between the SOtM tX-USBexp card - which uses TI - and Windows 7) and made sure to buy NEC.

 

I hope this post helps someone who is also having problems with USB DACs with a Topanga running Windows 7.

 

regards, Robert.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...