Jump to content
IGNORED

M2Tech HiFace Mavericks problem


Recommended Posts

I'm tempted to re-package the Northstar drivers with the mod, along with commands to remove every variation of older Hiface drivers, so it's easy to install just like any driver would be installed, but that's probably not cool with Northstar, also M2Tech should be doing this, not me :).

 

Yeah, you had better not move this beyond the (with the very greatest of respect) "nasty hack" phase. (A) because as you say Northstar may be decidedly uncool and (B) on the off chance that Manunta is reading anything here (my guess is that he has his head buried in the sand) it will give him an excuse to keep his finger jammed in his dark place.

"The greatest deception men suffer is from their own opinions"

Link to post
Share on other sites
Yeah, you had better not move this beyond the (with the very greatest of respect) "nasty hack" phase. (A) because as you say Northstar may be decidedly uncool and (B) on the off chance that Manunta is reading anything here (my guess is that he has his head buried in the sand) it will give him an excuse to keep his finger jammed in his dark place.

Huy you are already great enough to give us a workable solution so don't risk yourself to do anything that can cause you into trouble. (If I am Northstar I will certainly be more-than-unhappy to know we "steal" the driver for use on non-Northstar products, especially given Mr. Manunta has previous relationship with Northstar)

 

On the other hand, the more I think about it, the more I feel M2Tech actually might not have the OS X driver sole copyright at all, perhaps they have a co-develop / joint licensing deal with the driver developer, otherwise M2Tech should have already sent out their lawyer to sue the developer to hell for damage... (again, this is purely speculative and let's hope it is totally untrue).

Link to post
Share on other sites
It's been more than a month since we received our "Merry Christmas" we have no driver yet excuse card from M2Tech. Has anyone received an update since?

 

Has anyone heard anything new from M2Tech? Have they given up communicating status updates or worse yet just given up trying to develop a driver?

Mac Mini, Audirvana Plus, Metrum Hex NOS DAC w/Upgraded USB Module-2, UpTone Regen Amber, Pass Labs INT-30A Amplifier, B&W 802 Diamond Speakers, Shotgun Bi-wire Kimber 4TC Cables. Headphone setup: Burson Soloist Amp, Audeze LCD-3 Headphones.

Link to post
Share on other sites
Has anyone heard anything new from M2Tech? Have they given up communicating status updates or worse yet just given up trying to develop a driver?

 

I emailed M2Tech just now to let them know about this thread (unsure if they do) and as a heads up that there is a workaround for the Hiface that mostly works (outside of the intermittent popping/crackling) to see if they can license these drivers from Northstar and get the Hiface 1 officially added.

 

Will let you guys know if anything results from this.

Link to post
Share on other sites
I emailed M2Tech just now to let them know about this thread (unsure if they do) and as a heads up that there is a workaround for the Hiface that mostly works (outside of the intermittent popping/crackling) to see if they can license these drivers from Northstar and get the Hiface 1 officially added.

 

Will let you guys know if anything results from this.

 

This will be as crazy as apple licensing Mavericks from Microsoft

Hackintosh I7 16GB Ram, Roon, HQPlayer, Drobo 8 TB NAS, Raspberry Pi 3 NAA, Gustard X20 ES 9018 Xmos, Audio GD C39 Preamp, The First ONE DIY Amp, Monitor Audio GS20 Speakers, Monitor Audio RSW12 Subwoofer, PI Audio MagikBuss filter.

Link to post
Share on other sites

To all using JRiver Mac and experiencing interruptions, I've found effective increase to maximum all buffers in audio setup.

To Huy the Wizard Hong, from an Italian in my opinion you are pretty safe there in California from italian justice, but is all up to you, thanks

G

MacMini 2012 i5 2.3| 4GB |Crucial M4 64 Gb SSD |10.9.1| NorthStar Driver | Optimization Script |HiFace 1| JRiver 19 Mac | Buffalo II DAC | Mastersound 220| Rega Naos

Link to post
Share on other sites

Just looked on the M2tech site and the warming about Mavericks is no longer there - or at least I could not find it . Also, on one visit, I saw that the HiFace 1 was listed as a legacy product. After clicking around, I could not find this

listing again .

MacMini Quad i7/Audirvana Plus 3.5/DigiOne Signature Player/Schiit Yggdrasil GS/Aragon Palladium 1 amplifiers/Stacked Energy 22 speakers (Reference Connoisseur on bottom & Pro 22 on top) set tweeter to tweeter/Kimber Monocle XL speaker wires/stereo Mordaunt Short 309 subwoofers

Link to post
Share on other sites

I'm experiencing crackles and pops running Jriver on my mac using m2tech vaughan dac with north star driver. Audirvana + sounds much better but not without occasional "hiccups". I appreciate what that guy did trying to adjust north star driver to work with m2tech stuff but it's not a solution, at least in my case.

got to create win7 bootcamp partiiton on my mac. Jriver runs on windows problem free.

 

Just wondering if you guys use the north star driver with Audirvana direct/integer mode or not. It gives many hiccups/dropouts with my set up. I do have a North Star DAC (USB32), excellent DAC by the way!

2010 Mac Pro (westmere 6-core, 16G Ram)[br]M2Tech Vaughan DAC[br]McIntosh MA6600 integrated[br]B&W805S[br]Luxman P1_u[br]Sennheiser HD800[br]Silver Streak Interconnects

Link to post
Share on other sites
Just looked on the M2tech site and the warming about Mavericks is no longer there - or at least I could not find it . Also, on one visit, I saw that the HiFace 1 was listed as a legacy product. After clicking around, I could not find this

listing again .

 

I think his website developer buggered off too...if you click around enough you will find the page, although not, as you say, under a legacy item. His links are all messed up. The driver message is gone on the page but it is still there on the Young page.

 

I don't know why I am surprised, but Manunta seems to have decided that ignoring the problem is his most effective course of action. I have decided that this is an individual who has no business running a company and, cruel ad it sounds, I find myself wanting his company to fail.

"The greatest deception men suffer is from their own opinions"

Link to post
Share on other sites
I emailed M2Tech just now to let them know about this thread (unsure if they do) and as a heads up that there is a workaround for the Hiface that mostly works (outside of the intermittent popping/crackling) to see if they can license these drivers from Northstar and get the Hiface 1 officially added.

 

Will let you guys know if anything results from this.

 

Got a reply from M2Tech yesterday:

Dear Huy,

 

thank you for your e-mail. We actually know about using Northstar and Chord drivers to use our products. The fact is that a company cannot suggest using other companies part or apps to run her own products. Anyway, our new driver is almost ready, we hope to release a beta in 2 weeks.

 

Best regards,

 

Marco Manunta

 

So ~2 weeks for beta drivers.

 

Link to post
Share on other sites

Yes, Conte_Oliver, I did and it didn't change much in terms of SQ.

 

Abolit, did you tray what I wrote up about increase buffers?

G

2010 Mac Pro (westmere 6-core, 16G Ram)[br]M2Tech Vaughan DAC[br]McIntosh MA6600 integrated[br]B&W805S[br]Luxman P1_u[br]Sennheiser HD800[br]Silver Streak Interconnects

Link to post
Share on other sites
Got a reply from M2Tech yesterday:

Dear Huy,

 

thank you for your e-mail. We actually know about using Northstar and Chord drivers to use our products. The fact is that a company cannot suggest using other companies part or apps to run her own products. Anyway, our new driver is almost ready, we hope to release a beta in 2 weeks.

 

Best regards,

 

Marco Manunta

 

So ~2 weeks for beta drivers.

 

Good news! At least he did not forget his long overdue homework...

Link to post
Share on other sites
Read post #16 of this read for a little expectation management....

I know, I know... I just want to make everyone a bit positive, if not less negative. :P

 

In fact given this incident I am planning to replace my whole gear from HiFace + CA840C to simply an USB Class 2 Audio DAC like LHlabs Geek Pulse X.

Link to post
Share on other sites

Wonder if the new hiface driver will include a Direct Mode (bypassing Apple Core Audio)?

MacMini Quad i7/Audirvana Plus 3.5/DigiOne Signature Player/Schiit Yggdrasil GS/Aragon Palladium 1 amplifiers/Stacked Energy 22 speakers (Reference Connoisseur on bottom & Pro 22 on top) set tweeter to tweeter/Kimber Monocle XL speaker wires/stereo Mordaunt Short 309 subwoofers

Link to post
Share on other sites
Wonder if the new hiface driver will include a Direct Mode (bypassing Apple Core Audio)?

 

At this point not making the driver interger mode compatible will be the definitive flaw for M2tech.

Hackintosh I7 16GB Ram, Roon, HQPlayer, Drobo 8 TB NAS, Raspberry Pi 3 NAA, Gustard X20 ES 9018 Xmos, Audio GD C39 Preamp, The First ONE DIY Amp, Monitor Audio GS20 Speakers, Monitor Audio RSW12 Subwoofer, PI Audio MagikBuss filter.

Link to post
Share on other sites
Wonder if the new hiface driver will include a Direct Mode (bypassing Apple Core Audio)?

 

I've been in email contact with Marco Manunta and asked this specific question, and he responded not at first they just want to restore the original function.

 

At this point not making the driver interger mode compatible will be the definitive flaw for M2tech.

 

After receiving the initial reply that the driver would not be integer capable I too responded with essentially the same message, i.e. we've waited far too long for this driver for it not have additional capability.

 

Marco replied again that they plan too enhance the driver in time. I encourage everyone to contact Marco and tell him we want integer mode sooner rather than later.

 

For those that don't have Marco's email address: [email protected]

Mac Mini, Audirvana Plus, Metrum Hex NOS DAC w/Upgraded USB Module-2, UpTone Regen Amber, Pass Labs INT-30A Amplifier, B&W 802 Diamond Speakers, Shotgun Bi-wire Kimber 4TC Cables. Headphone setup: Burson Soloist Amp, Audeze LCD-3 Headphones.

Link to post
Share on other sites

 

I encourage everyone to contact Marco and tell him we want integer mode sooner rather than later.

 

For those that don't have Marco's email address: [email protected]

 

Be careful what you ask for, nothing slips a SW schedule faster than late feature requests on top of an already late release. My marketing buddies always want more when a schedule slips (because we have more time) but the reality is feature creep only causes additional delays.

2012 MBP (OSX 10.11 and Amarra Symphony w/IRC)-> Revelation Dual Conduit USB -> Berkeley Alpha USB -> Verastarr Silver Signature AES -> Devialet D250-> Siltech 550L -> KEF 104/2 (Steve Nugent Custom).

 

Power conditioning Audience Adept AR2p -> Verastarr Grand Illusion, Siltech Explorer 270p and Crystal Cable Standard Diamond

Analog: VPI Classic 3, Sumiko Pearwood Celebration ii, Siltech 770i RCA

Link to post
Share on other sites
Be careful what you ask for, nothing slips a SW schedule faster than late feature requests on top of an already late release. My marketing buddies always want more when a schedule slips (because we have more time) but the reality is feature creep only causes additional delays.

As a software lead I cannot agree more. Let them roll out a WORKING driver first.

Link to post
Share on other sites
As a software lead I cannot agree more. Let them roll out a WORKING driver first.

 

 

Normally I'd agree, but in this case I'm more concerned that once they get a basic driver out they'll simply move the Highface-1 and similarly derived OEM boards to legacy product status and not invest any additional time or money on further development.

 

So my vote is to still push for integer mode now because there's a good chance it's a now or NEVER situation.

Mac Mini, Audirvana Plus, Metrum Hex NOS DAC w/Upgraded USB Module-2, UpTone Regen Amber, Pass Labs INT-30A Amplifier, B&W 802 Diamond Speakers, Shotgun Bi-wire Kimber 4TC Cables. Headphone setup: Burson Soloist Amp, Audeze LCD-3 Headphones.

Link to post
Share on other sites
I've been in email contact with Marco Manunta and asked this specific question, and he responded not at first they just want to restore the original function.

 

images (1).jpeg

Hackintosh I7 16GB Ram, Roon, HQPlayer, Drobo 8 TB NAS, Raspberry Pi 3 NAA, Gustard X20 ES 9018 Xmos, Audio GD C39 Preamp, The First ONE DIY Amp, Monitor Audio GS20 Speakers, Monitor Audio RSW12 Subwoofer, PI Audio MagikBuss filter.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...