Jump to content
IGNORED

M2Tech HiFace Mavericks problem


Recommended Posts

Thank you slowmotion!

Do you happen to have the link to r5 driver? Thanks!

 

The choppy sound looks like having some thread priority issues which the audio streaming is blocked when the OS X loading is relatively high.

 

Did you try the r5 driver from North Star yet? The previous tutorial was using r4 driver which the newer r5 (dated 19-Dec-2013) contains some bug fixes.

 

I am listening with r5 driver right now and so far the sound is clean and not choppy anymore.

2010 Mac Pro (westmere 6-core, 16G Ram)[br]M2Tech Vaughan DAC[br]McIntosh MA6600 integrated[br]B&W805S[br]Luxman P1_u[br]Sennheiser HD800[br]Silver Streak Interconnects

Link to post
Share on other sites

I got it!

 

If somebody needs it here it is http://www.northstar.it/drivers/Mavericks_10.9/Northstar1055r5_192Khz.dmg

 

 

The choppy sound looks like having some thread priority issues which the audio streaming is blocked when the OS X loading is relatively high.

 

Did you try the r5 driver from North Star yet? The previous tutorial was using r4 driver which the newer r5 (dated 19-Dec-2013) contains some bug fixes.

 

I am listening with r5 driver right now and so far the sound is clean and not choppy anymore.

2010 Mac Pro (westmere 6-core, 16G Ram)[br]M2Tech Vaughan DAC[br]McIntosh MA6600 integrated[br]B&W805S[br]Luxman P1_u[br]Sennheiser HD800[br]Silver Streak Interconnects

Link to post
Share on other sites
Thank you slowmotion!

Do you happen to have the link to r5 driver? Thanks!

 

North Star Design - high end audio products

The upper left side on the web page, there is a Mavericks specific driver download link.

 

BTW I install the North Star driver in a slightly different way than Huy Hong mentioned:

 

# Download and install the Northstar DAC async driver via Maverick OSX

 

# Restart system, verify the Async 192 driver IS LOADED=YES thru Utilities/System Information/Software/Extensions/async192

sudo sed -i "" "s/900/37643/g" /System/Library/Extensions/async192.kext/Contents/Info.plist

sudo kextload -b 'com.async.driver.async192'

 

# Restart system

 

 

 

The trick is to let Mavericks to install the North Star driver first, then modify the USB ProductId and reload it again with HiFace 1 (or whatever M2Tech products) ProductId.

Link to post
Share on other sites

Thanks slowmotion!

 

North Star Design - high end audio products

The upper left side on the web page, there is a Mavericks specific driver download link.

 

BTW I install the North Star driver in a slightly different way than Huy Hong mentioned:

 

# Download and install the Northstar DAC async driver via Maverick OSX

 

# Restart system, verify the Async 192 driver IS LOADED=YES thru Utilities/System Information/Software/Extensions/async192

sudo sed -i "" "s/900/37643/g" /System/Library/Extensions/async192.kext/Contents/Info.plist

sudo kextload -b 'com.async.driver.async192'

 

# Restart system

 

 

 

The trick is to let Mavericks to install the North Star driver first, then modify the USB ProductId and reload it again with HiFace 1 (or whatever M2Tech products) ProductId.

2010 Mac Pro (westmere 6-core, 16G Ram)[br]M2Tech Vaughan DAC[br]McIntosh MA6600 integrated[br]B&W805S[br]Luxman P1_u[br]Sennheiser HD800[br]Silver Streak Interconnects

Link to post
Share on other sites
North Star Design - high end audio products

The upper left side on the web page, there is a Mavericks specific driver download link.

 

BTW I install the North Star driver in a slightly different way than Huy Hong mentioned:

 

# Download and install the Northstar DAC async driver via Maverick OSX

 

# Restart system, verify the Async 192 driver IS LOADED=YES thru Utilities/System Information/Software/Extensions/async192

sudo sed -i "" "s/900/37643/g" /System/Library/Extensions/async192.kext/Contents/Info.plist

sudo kextload -b 'com.async.driver.async192'

 

# Restart system

 

 

 

The trick is to let Mavericks to install the North Star driver first, then modify the USB ProductId and reload it again with HiFace 1 (or whatever M2Tech products) ProductId.

 

stupid question: how do I load the driver after restarting the system? it shows not loaded in system information. Thanks!

Link to post
Share on other sites
stupid question: how do I load the driver after restarting the system? it shows not loaded in system information. Thanks!

 

The trick is to clean up everything first - i.e. remove the old M2tech drivers first, then reboot.

 

After the Mac is clean without M2tech driver, you install the North Star driver, then reboot.

 

In my case the driver will be loaded but no audio device will be detected (since the ProductId is not the same as our device).

 

Then we trick the loaded driver by patching the Info.plist:

 

sudo sed -i "" "s/900/37643/g" /System/Library/Extensions/async192.kext/Contents/Info.plist

 

and then force the driver to be reloaded by

 

sudo kextload -b 'com.async.driver.async192'

 

then reboot and in my case the driver loaded with the correct ProductId and thus recognised the HiFace 1.

 

The above steps work on my 2012 MacBook Air. I have not tried it out on other Mac models though.

Link to post
Share on other sites

It's a good trick for hiface or other m2tech converters but this driver is not working properly with m2tech dacs. I installed the latest north star driver and still experiencing crackles and pops in playback mode. It's less noticeable in A+ than Jriver for mac.

2010 Mac Pro (westmere 6-core, 16G Ram)[br]M2Tech Vaughan DAC[br]McIntosh MA6600 integrated[br]B&W805S[br]Luxman P1_u[br]Sennheiser HD800[br]Silver Streak Interconnects

Link to post
Share on other sites
just checked on the M2Tech website and they removed the Mavericks "warning" on the Hiface driver page but it's still on the other download pages. Maybe they're about to release something??? Crossing fingers (but won't bet any money on this)

 

Alternatively it might also mean M2Tech gives up working on the driver and try to force us to upgrade to Hiface 2 instead... Let's hope it is not the case.

 

But then I don't give it a damn as long as the North Star driver works. ?

Link to post
Share on other sites

I just had another go at this and still can't get through the process. The kext isn't loading with an authentication error, here's the console log

 

14/01/2014 16:44:38.520 sudo[430]: nieldm : TTY=ttys000 ; PWD=/Users/nieldm ; USER=root ; COMMAND=/sbin/kextload -b com.async.driver.async192

14/01/2014 16:44:38.621 com.apple.kextd[12]: WARNING - Invalid signature -67030 0xFFFFFFFFFFFEFA2A for kext "/System/Library/Extensions/async192.kext"

14/01/2014 16:44:38.671 com.apple.kextd[12]: Invalid signature -67030 for kext <OSKext 0x7f9c1d932dc0 [0x7fff79469eb0]> { URL = "file:///System/Library/Extensions/async192.kext/", ID = "com.async.driver.async192" }

14/01/2014 16:44:38.688 com.apple.kextd[12]: Can't load /System/Library/Extensions/async192.kext - authentication problems.

 

Anyone have any idea what am I missing here?

"The greatest deception men suffer is from their own opinions"

Link to post
Share on other sites
Using Sudo is equivalent to Root. I am not sure if you can log into a Mac as root as a user...

 

Enabling root in Mavericks;

 

OS X Mavericks: Enable and disable the root user

 

Neil, not sure that you aren't in root already because doesn't the indentifier above 'USER=root' mean exactly that.. I've limited experience with this so only surmising..

 

You could also try getting info on the async192.kext file and then changing permissions for all the user groups to Read & Write..?

iMac i7 > Amarra Symphony | Audirvana+ > Intona Industrial > Singxer F-1 DDC > Eastern Electric Minimax DAC+ | iFi nano iDSD > Line Magnetic LM-518IA > ProAc Response 3 + REL R-528

Link to post
Share on other sites
I think, I'll have to contact Metrum Acoustics and ask if they have come up with a plan B

 

I did that very thing a little over a month ago, and at that time they had no plan. They felt M2Tech had no choice but resolve the issue as 15 companies other than M2Tech were also effected, i.e. too much at stake for M2Tech not to deliver.

 

I replied I had little confidence in M2Tech resolving this in a timely manner and that Metrum was risking their reputation by not taking action. I'd be curious if they've changed their position yet, please keep us posted.

Mac Mini, Audirvana Plus, Metrum Hex NOS DAC w/Upgraded USB Module-2, UpTone Regen Amber, Pass Labs INT-30A Amplifier, B&W 802 Diamond Speakers, Shotgun Bi-wire Kimber 4TC Cables. Headphone setup: Burson Soloist Amp, Audeze LCD-3 Headphones.

Link to post
Share on other sites
Enabling root in Mavericks;

 

You could also try getting info on the async192.kext file and then changing permissions for all the user groups to Read & Write..?

 

I am not sure OSX likes you setting the permissions to read/write on System extensions. I tried that and got a pile of errors at boot time and had to repair permissions.

 

Anyhow, we shouldn't be having to phart about like this.....

"The greatest deception men suffer is from their own opinions"

Link to post
Share on other sites

Following above sequence I obtained Young driver to appear on audio device...but I have to repeat the procedure every time. After i reboot driver doesn't show. No Integer Mode. Any idea?

Thanks

g

MacMini 2012 i5 2.3| 4GB |Crucial M4 64 Gb SSD |10.9.1| NorthStar Driver | Optimization Script |HiFace 1| JRiver 19 Mac | Buffalo II DAC | Mastersound 220| Rega Naos

Link to post
Share on other sites

If it's a permission issue with the kext file, you have to do the following:

 

sudo chmod -R 755 /System/Library/Extensions/async192.kext

sudo chown -R root:wheel /System/Library/Extensions/async192.kext

sudo touch /System/Library/Extensions

sudo kextload -b 'com.async.driver.async192'

 

You'll still see the "Invalid signature -67030 for kext" error in the Console log but the driver still loads

Link to post
Share on other sites
It's a good trick for hiface or other m2tech converters but this driver is not working properly with m2tech dacs. I installed the latest north star driver and still experiencing crackles and pops in playback mode. It's less noticeable in A+ than Jriver for mac.

 

I got similar cracking on higher quality rips (24/96) and was told that getting an AC-powered USB hub would negate the cracking/popping (something with usb power out of the motherboard being noisy). Did so and I still get a few seconds of minor cracking at the beginning of tracks, sound perfect afterwards.

 

This is on A+.

Link to post
Share on other sites

Dear Huy Hong, you really are a wizard with a Mac.

Many Thanks

Strangely Integer Mode in confirmed with BitPerfect, but JRiver no. Boh?

g

MacMini 2012 i5 2.3| 4GB |Crucial M4 64 Gb SSD |10.9.1| NorthStar Driver | Optimization Script |HiFace 1| JRiver 19 Mac | Buffalo II DAC | Mastersound 220| Rega Naos

Link to post
Share on other sites

The cracklings and popping are still there with a powered usb hub ( I tried Belkin 7 ports powered hub) or without being less or more noticeable (listening to my m2tech Vaughan dac). It's OK as a temporary solution for Audirvana Plus. Jriver mac does not seem to be handling north star driver very well.

 

I got similar cracking on higher quality rips (24/96) and was told that getting an AC-powered USB hub would negate the cracking/popping (something with usb power out of the motherboard being noisy). Did so and I still get a few seconds of minor cracking at the beginning of tracks, sound perfect afterwards.

 

This is on A+.

2010 Mac Pro (westmere 6-core, 16G Ram)[br]M2Tech Vaughan DAC[br]McIntosh MA6600 integrated[br]B&W805S[br]Luxman P1_u[br]Sennheiser HD800[br]Silver Streak Interconnects

Link to post
Share on other sites
If it's a permission issue with the kext file, you have to do the following:

 

sudo chmod -R 755 /System/Library/Extensions/async192.kext

sudo chown -R root:wheel /System/Library/Extensions/async192.kext

sudo touch /System/Library/Extensions

sudo kextload -b 'com.async.driver.async192'

 

You'll still see the "Invalid signature -67030 for kext" error in the Console log but the driver still loads

 

This does indeed work.

 

Huy Hong, thank you very much indeed.

 

Mr Manunta...on the off-chance you are actually following developments on this site, this DOES NOT constitute a fix, it is a workaround whilst we wait for you to extract the digit. What it DOES tell me is that you need to hire Huy Hong.

"The greatest deception men suffer is from their own opinions"

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...