Jump to content
IGNORED

HQPlayer's Network Audio Adapter


Recommended Posts

1 minute ago, The Computer Audiophile said:

AHHHHHHHH, ANEMAN, the bane of my existence! :~)

 

I have audio all solved for everything except HQPlayer OS (Jussi's special Ravenna version).

 

If I can't get it working I'll simply use Tidal, Spotify, Apple Music, Soundcloud, Qobuz, without HQPlayer.

 

But with my RME ADI-2 I can route ALL those through HQPlayer so that's the last thing I'm trying.

 

But yeh, I have a poster on my wall that I throw darts at each day, this:

 

ANEMAN_Wallpaper_1920x1200.thumb.jpg.01df583ac41d28ba7ac7c6af0d175a62.jpg

Link to post
Share on other sites
4 minutes ago, asdf1000 said:

 

I have audio all solved for everything except HQPlayer OS (Jussi's special Ravenna version).

 

If I can't get it working I'll simply use Tidal, Spotify, Apple Music, Soundcloud, Qobuz, without HQPlayer.

 

But with my RME ADI-2 I can route ALL those through HQPlayer so that's the last thing I'm trying.

 

But yeh, I have a poster on my wall that I throw darts at each day, this:

 

ANEMAN_Wallpaper_1920x1200.thumb.jpg.01df583ac41d28ba7ac7c6af0d175a62.jpg

I need to circle back with the Merging guys to ask them to work on a music mission. Enable Roon Ready and NAA within the Anubis. It's all possible. 

Founder of Audiophile Style

Announcing The Audiophile Style Podcast

Link to post
Share on other sites

Setting number of channels in HQP Config page to 8 helps a little. Even though I'm only using 2 channels headphone output. Still some pops with 48k but less.

 

Question @Miska, forget about DSD256 but with your Hapi, are you actually able to do 2 channels x PCM 192kHz , with Ravenna version of HQP OS?

 

Or you have issues too?

 

If you are having issues and it's just the Merging ALSA driver that sucks then I shouldn't really be wasting anymore time with this for now 

Link to post
Share on other sites
13 hours ago, The Computer Audiophile said:

I need to circle back with the Merging guys to ask them to work on a music mission. Enable Roon Ready and NAA within the Anubis. It's all possible. 

 

One problem is Merging seemed to have put fixing their ALSA driver behind other priorities like fixing their Win10 MAD driver (especially new WDM component) and getting official support for Big Sur on macOS... then a high priority will be to follow with Apple Silicon support next...  Kind makes sense to prioritise those things.

 

As well as Anubis firmware improvements so that they can finally release next Zman module based products...

 

Many of their Switzerland team have been in lockdown recently too. This must have a slow down effect on development.

 

For Roon Ready and NAA they need to get their ALSA support fixed...  A few have complained about bugs with it and Merging has been silent on it for almost a year.

 

Given all other priorities mentioned, I can't see Roon Ready or NAA happening in 2021 but man do I hope I'm wrong.

 

Do share what they reply with when you mention to them!

 

 

Link to post
Share on other sites
49 minutes ago, asdf1000 said:

For Roon Ready and NAA they need to get their ALSA support fixed...  A few have complained about bugs with it and Merging has been silent on it for almost a year.

Actually I'm wrong on this.

 

NADAC has been Roon Ready somehow for years so clearly someone at Merging knows how to make this work.

 

I haven't read reports of the kinds of issues I've been having (HQP OS Ravenna edition playing direct to Anubis via ALSA)

Link to post
Share on other sites
On 2/21/2021 at 6:17 AM, asdf1000 said:

Actually I'm wrong on this.

 

NADAC has been Roon Ready somehow for years so clearly someone at Merging knows how to make this work.

 

I haven't read reports of the kinds of issues I've been having (HQP OS Ravenna edition playing direct to Anubis via ALSA)

 

If NADAC is Roon Ready, it doesn't mean that it would have to be using RAVENNA at all... If NADAC would include NAA software module, then lot of things would be totally different too.

 

So it could be something different than the RAVENNA ALSA driver. You know, the input board that runs RAVENNA stack, needs to somehow interface to the actual DAC. So it could run something else in parallel to the RAVENNA stack in general.

 

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to post
Share on other sites
8 hours ago, Miska said:

 

If NADAC is Roon Ready, it doesn't mean that it would have to be using RAVENNA at all... If NADAC would include NAA software module, then lot of things would be totally different too.

 

So it could be something different than the RAVENNA ALSA driver. You know, the input board that runs RAVENNA stack, needs to somehow interface to the actual DAC. So it could run something else in parallel to the RAVENNA stack in general.

 

 

Yes all true, likely it's not using Ravenna ALSA driver.

 

Any thoughts on the "RTP packets" issue? Does that give any clues on what is going on?

 

And can you actually get this to work? HQP OS Ravenna version -> ALSA backend -> your Hapi  ?

 

WIth PCM192kHz? DSD256? Even just stereo?

 

If you can't get it to work with your Hapi without issues, then there's no point in me wasting more time on this.

 

Although I am hapi to re-try if something changes (ASLA driver improves, HQO OS improves or if you have another suggestion).

Link to post
Share on other sites
12 hours ago, asdf1000 said:

Any thoughts on the "RTP packets" issue? Does that give any clues on what is going on?

 

No idea... Did you try to create a unicast stream instead of default multicast one?

 

12 hours ago, asdf1000 said:

And can you actually get this to work? HQP OS Ravenna version -> ALSA backend -> your Hapi  ?

 

I got it working couple of times in the past, but not recently.

 

12 hours ago, asdf1000 said:

WIth PCM192kHz? DSD256? Even just stereo?

 

Stereo DSD256...

 

12 hours ago, asdf1000 said:

If you can't get it to work with your Hapi without issues, then there's no point in me wasting more time on this.

 

As I said before, if you don't get it working, just go with Windows or macOS based NAA...

 

12 hours ago, asdf1000 said:

Although I am hapi to re-try if something changes (ASLA driver improves, HQO OS improves or if you have another suggestion).

 

At the moment I'm waiting for Merging to update their ALSA driver.

 

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to post
Share on other sites
4 minutes ago, Miska said:

As I said before, if you don't get it working, just go with Windows or macOS based NAA...

 

macOS NAA doesn't work as mentioned before.

 

On HQP OS Config page (regular version not Ravenna version) I can see CoreAudio Ravenna driver and select it but when I hit apply , it won't stick on it. It just selects another Network Backend device. And works fine for other Core Audio devices but not Ravenna.

 

I tried on both Catalina and Big Sur (since Big Sur is technically not officially supported).

 

6 minutes ago, Miska said:

At the moment I'm waiting for Merging to update their ALSA driver.

 

I'll wait for this and revisit when HQP OS gets updated.

 

Until then, still sounds great without HQP of course.

 

Link to post
Share on other sites
32 minutes ago, asdf1000 said:

Could you test sometime in the near future, if you get a spare moment? 

 

I test it every now and then, but no success recently. I cannot do more than just wait for Merging to update the driver.

 

Windows and macOS (Catalina) have been working fine so far.

 

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to post
Share on other sites
11 minutes ago, Miska said:

Now there's a native build of networkaudiod for Apple's M1 too and updated build for Intel Macs as well.

 

 

Thanks will try this.

 

Good news is "plot" function is now working well on HQP OS, after I previously had issues.

 

And I also prefer the parametric EQ syntax in HQP OS now, compared with the Impulse responses I created (slightly lower CPU usage).

 

iir:type=peak;f=80;g=-2.3;q=1.4,iir:type=lshelf;f=105;g=5.5;s=0.71,iir:type=peak;f=165;g=2.0;q=1.4,iir:type=peak;f=1850;g=-4.7;q=1.6,iir:type=hshelf;f=2000;g=8.0;s=0.71,iir:type=peak;f=2120;g=3.0;q=3.0,iir:type=peak;f=2875;g=-2.3;q=3.5,iir:type=peak;f=5750;g=-6.5;q=4.0,iir:type=peak;f=7150;g=-1.7;q=6.0,iir:type=hshelf;f=13000;g=-8.0;s=0.71

 

If anyone is using Focal Elegia headphones 😄

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...