Jump to content
IGNORED

HQPlayer's Network Audio Adapter


Recommended Posts

13 minutes ago, hykhleif said:

greetings

 

I wonder if I can get some advice

 

I only listen to tidal now 

 

set up

 

chord mojo--- avid integra--- harbth 5shl plus 40th anniversary

 

Avid Integra amp it has no remote control

 

my dac for the time being is chord mojo and i have the chord poly, sometimes i use the poly but most of the time i use the mojo connected by usd to my computer

 

i like to be able to control the volume from my couch without always having to reach out to the amp, and maintain the sound quality.

 

i am now considering roon with hq player to a have good digital volume control, as using the digital volume control of tidal apps i feel the sound quality is not as great as using the volume control on my amp

 

would using hq player with roon be a good move to use them to control volume

 

The volume control in HQP is excellent in terms of maintaining SQ. I have been using it for several months now, using Roon on an iPad to adjust the HQP volume, works very well.

 

The one issue with software controlled volume is accidentally having the volume max’d out and damaging your equipment (speakers).

 

In the HQP settings, you can limit the max (and min) volume limits to help avoid accidents. If you decide to go this route, we can advise you on how to set the limits.

Eric


Ubuntu Studio Linux box (i7-9700, 8 cores, 16GB RAM, Intel X520-DA1 NIC, HQP Desktop) > fiber optic > MikroTik CRS305-1G-4S+ > fiber optic > fitlet2 (Linux Mint - HQP NAA) > T+A DAC8 DSD > Nord One UP NC500MB mono blocks > Klipsch La Scala — digital volume control with HQP via Roon client, DSP with HQP convolution engine, Intel NUC (Roon server)

Link to post
Share on other sites
9 hours ago, ericuco said:

 

The volume control in HQP is excellent in terms of maintaining SQ. I have been using it for several months now, using Roon on an iPad to adjust the HQP volume, works very well.

 

The one issue with software controlled volume is accidentally having the volume max’d out and damaging your equipment (speakers).

 

In the HQP settings, you can limit the max (and min) volume limits to help avoid accidents. If you decide to go this route, we can advise you on how to set the limits.

 can u advise on dialing in settings to do that, so i can compare the digital volume to analog volume in HQ player

Link to post
Share on other sites
6 hours ago, hykhleif said:

 can u advise on dialing in settings to do that, so i can compare the digital volume to analog volume in HQ player

 

First off have your amp(s) or preamp turned off so that your speakers cannot receive a signal. You can also just turn down the hardware volume control all the way to "off", usually full counter-clockwise. Depends on how confident you are that no sound is reaching your speakers.

 

Next, go the HQP Setting panel and set max volume to -25 and min volume to -60. Be sure to save the settings. These settings set the limits on the HQP volume control knob on the main HQP panel. At a max of -25, if something goes wrong and the volume gets turned all of the way, it will be loud but should not do any damage.

 

You should be able to adjust the HQP from within Roon. On my iPad the control is in the bottom right section of the Roon panel. If you can view the HQP volume control knob, you should see it respond to adjustments made in Roon. Assuming that is working, set the HQP volume to something like -50 which is really low.

 

Ok, time to start seeing where you are. If you had turned off your amp(s) or preamp, turn them on but make sure the hardware volume control is all the way "off" or at least a very low volume setting. Start playing music through Roon/HQP. You probably won't hear anything given the volume setting are down. Slowly start turning up the volume on the hardware control (preamp). With HQP volume set at -50, you should be able to turn the hardware control all the way up (full clockwise) and just be able to hear music.

 

In the end, you want to leave the hardware control set at full clockwise or no attenuation.

 

Assuming that you are able to set the hardware control to full clockwise, slowly start raising the HQP volume control to a comfortable listening position and see where the HQP volume is at, probably between -40 and -30.

 

In the end, you want to set the max HQP volume setting slightly greater than your normal listening level. On my system, the HQP volume is usually between -38 and -32 so I have the max set to -25.

 

Finally, I assumed you are using the Roon/HQP combo. If you are just using HQP, it is the same procedure just be careful working with the HQP volume control knob.

Eric


Ubuntu Studio Linux box (i7-9700, 8 cores, 16GB RAM, Intel X520-DA1 NIC, HQP Desktop) > fiber optic > MikroTik CRS305-1G-4S+ > fiber optic > fitlet2 (Linux Mint - HQP NAA) > T+A DAC8 DSD > Nord One UP NC500MB mono blocks > Klipsch La Scala — digital volume control with HQP via Roon client, DSP with HQP convolution engine, Intel NUC (Roon server)

Link to post
Share on other sites
7 hours ago, ericuco said:

 

First off have your amp(s) or preamp turned off so that your speakers cannot receive a signal. You can also just turn down the hardware volume control all the way to "off", usually full counter-clockwise. Depends on how confident you are that no sound is reaching your speakers.

 

Next, go the HQP Setting panel and set max volume to -25 and min volume to -60. Be sure to save the settings. These settings set the limits on the HQP volume control knob on the main HQP panel. At a max of -25, if something goes wrong and the volume gets turned all of the way, it will be loud but should not do any damage.

 

You should be able to adjust the HQP from within Roon. On my iPad the control is in the bottom right section of the Roon panel. If you can view the HQP volume control knob, you should see it respond to adjustments made in Roon. Assuming that is working, set the HQP volume to something like -50 which is really low.

 

Ok, time to start seeing where you are. If you had turned off your amp(s) or preamp, turn them on but make sure the hardware volume control is all the way "off" or at least a very low volume setting. Start playing music through Roon/HQP. You probably won't hear anything given the volume setting are down. Slowly start turning up the volume on the hardware control (preamp). With HQP volume set at -50, you should be able to turn the hardware control all the way up (full clockwise) and just be able to hear music.

 

In the end, you want to leave the hardware control set at full clockwise or no attenuation.

 

Assuming that you are able to set the hardware control to full clockwise, slowly start raising the HQP volume control to a comfortable listening position and see where the HQP volume is at, probably between -40 and -30.

 

In the end, you want to set the max HQP volume setting slightly greater than your normal listening level. On my system, the HQP volume is usually between -38 and -32 so I have the max set to -25.

 

Finally, I assumed you are using the Roon/HQP combo. If you are just using HQP, it is the same procedure just be careful working with the HQP volume control knob.

thanks so so so much for this detailed guide, totally appreciate it

 

so following this will in your opinion make only small difference in sound quality using the digital volume vs the actual amp volume

Link to post
Share on other sites
18 minutes ago, hykhleif said:

so following this will in your opinion make only small difference in sound quality using the digital volume vs the actual amp volume


I was able to remove a passive preamp device from my system by using digital volume control in which case I got slightly better SQ.
 

What effects on your system is something you will have to determine yourself. Might be better or might be worse.

 

Best of luck.

Eric


Ubuntu Studio Linux box (i7-9700, 8 cores, 16GB RAM, Intel X520-DA1 NIC, HQP Desktop) > fiber optic > MikroTik CRS305-1G-4S+ > fiber optic > fitlet2 (Linux Mint - HQP NAA) > T+A DAC8 DSD > Nord One UP NC500MB mono blocks > Klipsch La Scala — digital volume control with HQP via Roon client, DSP with HQP convolution engine, Intel NUC (Roon server)

Link to post
Share on other sites
10 hours ago, skipspence said:

Can I kindly ask to check or enable such a support for Solarflare SFN6122F. Can't check myself for it's not delivered yet.

 

It is not enabled at the moment. Linux kernel seems to include drivers for SFC6000 and SFC9000/SFC9100 series, I don't know if those are applicable for SFN6xxx.

 

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to post
Share on other sites
11 hours ago, Miska said:

 

It is not enabled at the moment. Linux kernel seems to include drivers for SFC6000 and SFC9000/SFC9100 series, I don't know if those are applicable for SFN6xxx.

 

The "sfc" stands for net driver for the Linux kernel provided by Solarflare. Assuming that SFC6000 is for SNF6xxx series NICs, they may be applicable, so they should be enabled in Linux kernel?

Link to post
Share on other sites
On 8/13/2020 at 12:32 PM, skipspence said:

The "sfc" stands for net driver for the Linux kernel provided by Solarflare. Assuming that SFC6000 is for SNF6xxx series NICs, they may be applicable, so they should be enabled in Linux kernel?

 

There are two separate drivers in Linux kernel for those two series, with driver description saying what I repeated above. So I'm not sure if the assumption is correct or not.

 

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to post
Share on other sites
2 hours ago, Miska said:

 

There are two separate drivers in Linux kernel for those two series, with driver description saying what I repeated above. So I'm not sure if the assumption is correct or not.

 

Well thanks, guess I'll wait 'till mine arrives here, then dare to second this my request, or would it to ask you to enable both be too much?😔

Link to post
Share on other sites
  • 3 weeks later...
On 8/11/2020 at 5:19 PM, skipspence said:

 

Can you please tell if HQPlayer OS working as NAA supports optical NICs like Solarflare?

Thanks

 

You can always use debian or ubuntu and install/enable the solarflare drivers yourself which is what I have done.

Custom room treatments for headphone users.

Link to post
Share on other sites
49 minutes ago, jabbr said:

 

You can always use debian or ubuntu and install/enable the solarflare drivers yourself which is what I have done.

 

Actually using daphile which is gentoo, working well with solarflare "out of the box", not tried hqplayer naa on debian or ubuntu yet...but thanks for suggest anyway.

Link to post
Share on other sites
On 9/3/2020 at 6:22 PM, skipspence said:

 

Actually using daphile which is gentoo, working well with solarflare "out of the box", not tried hqplayer naa on debian or ubuntu yet...but thanks for suggest anyway.

 

Sure! one would expect that if any part of linux causes a difference with NAA it would be the kernel e.g. low-latency or realtime kernel patches. These are generally distribution independent.

Custom room treatments for headphone users.

Link to post
Share on other sites
10 hours ago, jabbr said:

 

Sure! one would expect that if any part of linux causes a difference with NAA it would be the kernel e.g. low-latency or realtime kernel patches. These are generally distribution independent.

 

Willing to try debian since non of the latest hqp naa bootable images seem to support solarflare. Which distro do you mean would be enough only for naa usage? Live-SD/USB? Aiming for minimal installation, only naa>sfp. Also need advise to install/enable the drivers if any? Not very competent in linux though... Thanks in advance

Link to post
Share on other sites
4 hours ago, skipspence said:

 

Willing to try debian since non of the latest hqp naa bootable images seem to support solarflare. Which distro do you mean would be enough only for naa usage? Live-SD/USB? Aiming for minimal installation, only naa>sfp. Also need advise to install/enable the drivers if any? Not very competent in linux though... Thanks in advance

 

People seem to focus on the distros as if they have a sound. In reality there are several different kernels as well as kernels that are compiled with different options including drivers. When NAA is running, it interacts with the kernel to receive data from the network and write data to the audio device.

 

Ubuntu studio comes with the low-latency kernel which should be good for most audio applications but there are also a set of realtime patches for special applications. For your purpose ubuntu with low-latency kernel will be fine. If you have debian and want to try the realtime kernel its here: https://packages.debian.org/buster/linux-image-rt-amd64

 

@Miska also supports fedora (fc31,fc25) with NAA. I don't use fedora.

 

So if the images he supplies don't do what you need, you can install either ubuntu, debian and fedora, install the drivers you need, install the NAA package and voila -- it works.

 

My recommendation would be to install ubuntu with low-latency kernel and the buster NAA package -- note I run focal (20.04) and the buster NAA deb works just fine. I think its just a little bit easier than debian to use, but if you want debian go ahead and install it -- just install it.

Custom room treatments for headphone users.

Link to post
Share on other sites
6 hours ago, jabbr said:

My recommendation would be to install ubuntu with low-latency kernel and the buster NAA package -- note I run focal (20.04) and the buster NAA deb works just fine. I think its just a little bit easier than debian to use, but if you want debian go ahead and install it -- just install it.

 

I installed it all as per your recommendation - all works and plays nice! Thanks again!

Link to post
Share on other sites
6 minutes ago, jabbr said:

To set the record straight regarding NAA on Ubuntu 20.04 ... I used the buster deb not the bionic deb... @Miska since 20.04.1 is LTS, consider its own deb?

 

I'm still waiting for the new version to become available through do-release-upgrade on 18.04. At least last week it didn't work yet.

 

The Bionic deb should work on Focal too. Likely also Debian Buster one works too. networkaudiod has pretty simple dependencies.

 

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to post
Share on other sites
6 minutes ago, Miska said:

 

I'm still waiting for the new version to become available through do-release-upgrade on 18.04. At least last week it didn't work yet.

 

The Bionic deb should work on Focal too. Likely also Debian Buster one works too. networkaudiod has pretty simple dependencies.

 

 

Yeah its 20.04.1 now so I don't know what the deal is with that.

 

I don't know why bionic deb didn't work, might've been something weird with me. but buster works

Custom room treatments for headphone users.

Link to post
Share on other sites

I just grabbed an Intel NUC7CJYH w/ 8gb Ram & 120gb SSD off Fleabay today as an upgrade to my existing NAA x5-z8350 mini pc.

 

Since I currently boot a thumbdrive w/ HQPlayer NAA image naa-411-x64.7z, does it matter if I leave the SSD for Win10 Pro Qobuz streaming & home theater video streaming duties? (versus replacing SSD w/ SXDC card).  Or is the SSD electrical noise still an issue even if not being used while NAA thumb drive is operating?

Link to post
Share on other sites
17 hours ago, brother love said:

I just grabbed an Intel NUC7CJYH w/ 8gb Ram & 120gb SSD off Fleabay today as an upgrade to my existing NAA x5-z8350 mini pc.

 

Since I currently boot a thumbdrive w/ HQPlayer NAA image naa-411-x64.7z, does it matter if I leave the SSD for Win10 Pro Qobuz streaming & home theater video streaming duties? (versus replacing SSD w/ SXDC card).  Or is the SSD electrical noise still an issue even if not being used while NAA thumb drive is operating?

 

Yes, you can leave Windows untouched as it is and boot NAA from USB memory stick or from a microSD card.

 

I don't think the idling SSD makes much difference to noise of NUC's USB output. Or you could just leave the previous machine running NAA.

 

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...