Jump to content
4est

HQPlayer's Network Audio Adapter

Rate this topic

Recommended Posts

3 hours ago, bodiebill said:

Solved by copying qwave.dll to Windows\System32 and \Windows\SystemWOW64 folders.

 

That still doesn't make it work correctly.

 

Your system is missing QoS component, you can install and enable that properly too. On desktop Windows versions, it is installed and enabled by default. On server versions it seems like you need to explicitly install that OS component.

 

Share this post


Link to post
Share on other sites
On 2/7/2019 at 8:58 PM, Miska said:

 

I don't know, I have not seen such on my devices yet...

 

Something from the kernel, so probably something hardware related.

 

 

Thank's @Miska,
I'm in touch with @ALLOsupport and i will try to understand why "usb packets delay warnings" are shown only with NAA and at any rate. However no obvious SQ or functional consequences at the moment. 

Share this post


Link to post
Share on other sites
14 hours ago, Miska said:

 

That still doesn't make it work correctly.

 

Your system is missing QoS component, you can install and enable that properly too. On desktop Windows versions, it is installed and enabled by default. On server versions it seems like you need to explicitly install that OS component.

 

 

Ok, thanks. I was already able to play music with HQP+NAA but will try to also install the Quality of Service future in core mode.

Share this post


Link to post
Share on other sites
3 hours ago, bodiebill said:

Ok, thanks. I was already able to play music with HQP+NAA but will try to also install the Quality of Service future in core mode.

 

Note that it also needs to be enabled for the network interface to operate correctly! (on Win10 it is enabled by default)

 

network-qos.png.c90a869d5dc4c9983fff076e3084dfc8.png

Share this post


Link to post
Share on other sites
15 minutes ago, Miska said:

 

Note that it also needs to be enabled for the network interface to operate correctly! (on Win10 it is enabled by default)

 

network-qos.png.c90a869d5dc4c9983fff076e3084dfc8.png

Interesting...I need to check to see if QOS Packet Scheduler is enabled on my server and NAA.  I've never had issues before though so I wonder if its really necessary?  

Share this post


Link to post
Share on other sites
33 minutes ago, tboooe said:

Interesting...I need to check to see if QOS Packet Scheduler is enabled on my server and NAA.  I've never had issues before though so I wonder if its really necessary?  

 

It just improves reliability and consistency of the stream.

 

Share this post


Link to post
Share on other sites
26 minutes ago, bodiebill said:

to install Quality of Service in core mode, from command line start powershell and enter:

Install-WindowsFeature DiskIo-QoS

I am no expert but isnt that for storage QoS?  I think Miska was referring to network Qos?  If so, I think the command is:

Enable-NetAdapterQos.  @Miska????

Share this post


Link to post
Share on other sites
14 minutes ago, tboooe said:

I am no expert but isnt that for storage QoS?  I think Miska was referring to network Qos?  If so, I think the command is:

Enable-NetAdapterQos.  @Miska????

 

Yes, that sounds right...

 

I don't have any Windows Server versions, so I don't know about details. But this feature I'm talking about is about network QoS. When correct feature is installed, also qwave.dll should appear, it is the API talking to the QoS stack. Then it still needs to be also enabled for the network adapter.

 

Share this post


Link to post
Share on other sites
9 minutes ago, Miska said:

 

Yes, that sounds right...

 

I don't have any Windows Server versions, so I don't know about details. But this feature I'm talking about is about network QoS. When correct feature is installed, also qwave.dll should appear, it is the API talking to the QoS stack. Then it still needs to be also enabled for the network adapter.

 

So I think in Server enabling qwave feature also enables QoS packet scheduler.  I just checked my network adapter settings and the packet scheduler was enabled for all of my NICs even though I do not remember actually doing it myself.

 

Install-WindowsFeature -name qWave

Share this post


Link to post
Share on other sites
On 2/7/2019 at 8:58 PM, Miska said:

 

I don't know, I have not seen such on my devices yet...

 

Something from the kernel, so probably something hardware related.

 

 

Just FYI:

According to ALLO issue was mainly observed with AMANERO devices.
ALLO has quickly updated DietPi / Volumio USBridge USB driver: 

I''ve checked, playing from NAA during few hours: No more "delay ..." messages. 

We'll see if it's stable in the long run.

 

 

 

Share this post


Link to post
Share on other sites
27 minutes ago, tboooe said:

So I think in Server enabling qwave feature also enables QoS packet scheduler.  I just checked my network adapter settings and the packet scheduler was enabled for all of my NICs even though I do not remember actually doing it myself.

 

Install-WindowsFeature -name qWave

 

Thanks for correcting me. Indeed it seems that qWave enables QoS for AV streams:

Quality Windows Audio Video Experience (qWave) is a networking platform for audio video (AV) streaming applications on IP home networks. qWave enhances AV streaming performance and reliability by ensuring network quality-of-service (QoS) for AV applications.

Sounds like what Miska was pointing at?

Share this post


Link to post
Share on other sites
22 hours ago, tboooe said:

So I think in Server enabling qwave feature also enables QoS packet scheduler.  I just checked my network adapter settings and the packet scheduler was enabled for all of my NICs even though I do not remember actually doing it myself.

 

Install-WindowsFeature -name qWave

 

Sounds right. Good that you've found how to pull in that feature into Server! Lot of people have been asking about it, so this should be really helpful.

 

Share this post


Link to post
Share on other sites
21 hours ago, bodiebill said:

Thanks for correcting me. Indeed it seems that qWave enables QoS for AV streams:

Quality Windows Audio Video Experience (qWave) is a networking platform for audio video (AV) streaming applications on IP home networks. qWave enhances AV streaming performance and reliability by ensuring network quality-of-service (QoS) for AV applications.

Sounds like what Miska was pointing at?

 

Yes, that's it!

 

Share this post


Link to post
Share on other sites

After applying

Get-NetAdapterQos -Name "*" | Enable-NetAdapterQos

Install-WindowsFeature -name qWave

I still see "Network QoS functionality not available" in NAA. Any idea?

 

Share this post


Link to post
Share on other sites
16 hours ago, bodiebill said:

After applying

Get-NetAdapterQos -Name "*" | Enable-NetAdapterQos

Install-WindowsFeature -name qWave

I still see "Network QoS functionality not available" in NAA. Any idea?

 

IIRC, there's also a Windows service related to that, is it running? You are using networkaudiod version 3.5.6?

 

 

Share this post


Link to post
Share on other sites
19 hours ago, bodiebill said:

After applying

Get-NetAdapterQos -Name "*" | Enable-NetAdapterQos

Install-WindowsFeature -name qWave

I still see "Network QoS functionality not available" in NAA. Any idea?

 

When you type Get-NetAdapterBinding do you see QoS Packet Scheduler as one of the settings?

Share this post


Link to post
Share on other sites
5 hours ago, Miska said:

 

IIRC, there's also a Windows service related to that, is it running? You are using networkaudiod version 3.5.6?

 

 

I am using networkaudiod-356 but see no IIRC service.

Share this post


Link to post
Share on other sites
2 hours ago, tboooe said:

When you type Get-NetAdapterBinding do you see QoS Packet Scheduler as one of the settings?

 

Yes:

Ethernet           QoS Packet Scheduler            mspacer                  True

Share this post


Link to post
Share on other sites

Hi AudiophileStylers

 

Anyone else run into this issue with the new NAA Version 356 on Mac OS?

 

[/Users/networkaudiod-356/networkaudiod] (681): clSocket::SetOption(): setsockopt(): Can’t assign requested address

 

I can run NAA 354 with no issue?

 

Thanks!

 

 

Share this post


Link to post
Share on other sites
35 minutes ago, jrd1975 said:

[/Users/networkaudiod-356/networkaudiod] (681): clSocket::SetOption(): setsockopt(): Can’t assign requested address

 

Yes, I've seen the same with NAA 356 when I tried.

 

But then again I've never been able to get NAA to work on MacOS - although the same Mac and same chain can run Windows NAA fine (Windows running on the Mac via Boot Camp).

 

I'm going to be wiping my Mac soon as I prepare to finally update it to Mojave. Will re-test then.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×