Jump to content
ted_b

JRiver tips and techniques: user experiences repository

Rate this topic

Recommended Posts

I suppose I need to eat some crow now and apologize for my behavior earlier in this thread. It was unwarranted.

 

Ted_B, JRiver, and the forum as a whole. I apologize.

 

Stop. No need. JRiver is indeed a very powerful tool, and the learning curve can be steep, depending on how quickly one wants to replicate his/her views into the library. Although I'd like to redo my part one and two videos cuz I left a lot out (and therefore may do part three just for that) please view them at your leisure and maybe a light or two will come on. It is often one flip of a switch ()panel view to category, for example) that will make your display wayyyy more friendly (i.e cover art vs file listings, etc). And as I say on the videos, "undo" is your friend.

 

All this being said, my main reason for using JRIver is still its sonics (yes, I use a different engine with it in one setup, but listen to direct JRiver in two other setups, and find it to sound way more musical than anything else that has a GUI. Some terminal based stuff sounds as good, but gimme a break.). And a close number two reason is JRemote, the best ipad app there is.

Share this post


Link to post
Share on other sites

When did JRiver for Mac originally get released? However long ago that was and through the release of 19 I started and stopped and stuttered in my use of JRMC. For the longest time I simply didn't get it. But I kept reading things like this thread and trying again and going back to the more comfortable iTunes/Audivrana that I knew. Then a little light went on with JRiver and then another and another to the point for music playback I now use it 95% of the time. I still need to get more confident and knowledgeable with tagging and do my ripping with XLD but I can now see how powerful a tool this can be and with some more patience and learning I will achieve a level of familiarity that will make it old hat.

 

Come me to think of it that's how it went for me with iTunes, Pure

Music, MAX, XLD and Audivrana too.


"If you fly a flag of hate you are no kin to me"

Ry Cooder

Share this post


Link to post
Share on other sites
Stop. No need. JRiver is indeed a very powerful tool, and the learning curve can be steep, depending on how quickly one wants to replicate his/her views into the library. Although I'd like to redo my part one and two videos cuz I left a lot out (and therefore may do part three just for that) please view them at your leisure and maybe a light or two will come on. It is often one flip of a switch ()panel view to category, for example) that will make your display wayyyy more friendly (i.e cover art vs file listings, etc). And as I say on the videos, "undo" is your friend.

 

All this being said, my main reason for using JRIver is still its sonics (yes, I use a different engine with it in one setup, but listen to direct JRiver in two other setups, and find it to sound way more musical than anything else that has a GUI. Some terminal based stuff sounds as good, but gimme a break.). And a close number two reason is JRemote, the best ipad app there is.

 

When did JRiver for Mac originally get released? However long ago that was and through the release of 19 I started and stopped and stuttered in my use of JRMC. For the longest time I simply didn't get it. But I kept reading things like this thread and trying again and going back to the more comfortable iTunes/Audivrana that I knew. Then a little light went on with JRiver and then another and another to the point for music playback I now use it 95% of the time. I still need to get more confident and knowledgeable with tagging and do my ripping with XLD but I can now see how powerful a tool this can be and with some more patience and learning I will achieve a level of familiarity that will make it old hat.

 

Come me to think of it that's how it went for me with iTunes, Pure

Music, MAX, XLD and Audivrana too.

 

I still think I reacted badly and the apology was needed.

 

That said, I have been thinking about this and I think that the reason it worked when I redid the tags for We All Love Ella is obvious, they were all right, but I checked and there was another folder for that album too. I also think the reason Some Girls worked when I removed the other folder is that I had gone through the other folder, the one I knew about, and verified/fixed all the tags already, so when I got rid of the other one that had been created the problem was immediately fixed. So, long winded way of saying I think JRiver made those other folders somehow in the process of trying to fix the tags with JRiver, which I tried and failed at.

 

edit: I also think that for a piece of software as complex as JRiver Media Center there needs to be a real manual, not a sometimes poorly written wiki.


No electron left behind...

Share this post


Link to post
Share on other sites

Doc.. I'm with ya all the way.. JRiver is not necessarily intuitive so stick with it..

 

For example Ted or someone maybe you could help out here.. I for the life of me am struggling with simply playing files..!!! Yep. Just the simple play the file from the Audio list (in the standard view)! I'm daft I know: but why is it when I pull up the "Audio" tab options..say my list of Stereo DSD's that I formed using the great "How to do this instructions" earlier in the thread.. Why is it then I just can't get JRiver to simply play one of the albums in this list!!! hahahha…Is that too much to ask! LOL! If I double click on a track in the list, nothing happens.. If I right click on a track in the list, I get a myriad of play options.. Play (with Play Doctor), Play, Add to playing now, More Play Optioons etc etc.. but where is the "Just Play the darn album" option??? WTF!!!.. hahahahaha… and why is it, if I select just plain ol "play"…sure the first track starts playing.. but that's it!!! It just plays over and over the same track..instead of what it should do..that's play the first track of the album then go onto the next track down, then the next etc etc.. hahahaha this is just plain stupid.. And if you try to select the entire album in the heading above the track list (remember I'm in the standard view of "audio" here) nothing happens.. it's not selectable!! .. I gotta have some setting wrong here LOL!!

Edited by wappinghigh

New simplified setup: STEREO- Primary listening Area: Cullen Circuits Mod ZP90> Benchmark DAC1>RotelRKB250 Power amp>KEF Q Series. Secondary listening areas: 1/ QNAP 119P II(running MinimServer)>UPnP>Linn Majik DSI>Linn Majik 140's. 2/ (Source awaiting)>Invicta DAC>RotelRKB2100 Power amp>Rega's. Tertiary multiroom areas: Same QNAP>SMB>Sonos>Various. MULTICHANNEL- MacMini>A+(Standalone mode)>Exasound e28 >5.1 analog out>Yamaha Avantage Receiver>Pre-outs>Linn Chakra power amps>Linn Katan front and sides. Linn Trikan Centre. Velodyne SPL1000 Ultra

Share this post


Link to post
Share on other sites

Wap, see below. Options -> General -> Behavior sets up what double clicks do. And make sure repeat (upper right corner) is set to what you need.

 

JRiver play and repeat.jpg

Share this post


Link to post
Share on other sites

One of the things I have learned about jriver is that it will find all the duplicates in your library. I have deleted a lot of redundant folders which I found only by clicking on an album and seeing 2 or 3 versions of the same song.


Speakers: Vandersteen Model 7s, 4 M&K ST-150Ts, 1 VCC-5; Amplification: 2 Vandersteen M7-HPAs, CI Audio D200 MKII, Ayre V-6xe; Preamp: Doshi Audio Line Stage v3.0; Phono Pre: Doshi Audio Phono Pre; Analog: Wave Kinetics NVS with Durand Telos composite arm; SME 3012R arm, Clearaudio Goldfinger Statement v2; Reel to Reel:  Technics RS-1500; Doshi Tape Pre-Amp; Studer A810, Studer A812, Tascam BR-20; Multi-channel: Bryston SP-3; Digital: Custom PC (WS 2016/AO/HQPlayer/Roon)> Lampizator Big 7 DAC

Share this post


Link to post
Share on other sites

Ted_B,

 

Thank you for your detailed videos and the help you've given throughout this thread!

 

I have three questions:

 

1. Currently when JRiver plays a SACD ISO that contains SACD and FLAC files, the SACD version of a track will play, then the FLAC version of the same track will play next.

 

What is the best way to get the program to only play the SACD versions within my SACD ISO files?

 

2. I have my music files separated in folders named "DSD", "SACD ISOS", "24-bit", "Flac", "WAV", "JAZZ", "Classical", et al, with subfolders containing the artist and album names. I absolutely love navigating through my library via these folders, or "Folder View" as other programs call it. I know we can go into the "Files" sidebar view and maneuver to specific folders, but is there a way to get my specific folders to show on the "Audio" sidebar, along with "Albums", "Genre", "Artists", etc?

 

3. Do you prefer upsampling your DSD 64 or PSM music to DSD128?

 

Thanks in advance.

Share this post


Link to post
Share on other sites

I'm sure Ted can give you details but you can define view schemes and sub schemes for display of specific groups of files. To replicate the folders on disk you might try a rule such as Filename (path) contains x.

 

You could also create a view special rule to only show SACD in a scheme if a dup exists.

 

Ted_B,

 

Thank you for your detailed videos and the help you've given throughout this thread!

 

I have three questions:

 

1. Currently when JRiver plays a SACD ISO that contains SACD and FLAC files, the SACD version of a track will play, then the FLAC version of the same track will play next.

 

What is the best way to get the program to only play the SACD versions within my SACD ISO files?

 

2. I have my music files separated in folders named "DSD", "SACD ISOS", "24-bit", "Flac", "WAV", "JAZZ", "Classical", et al, with subfolders containing the artist and album names. I absolutely love navigating through my library via these folders, or "Folder View" as other programs call it. I know we can go into the "Files" sidebar view and maneuver to specific folders, but is there a way to get my specific folders to show on the "Audio" sidebar, along with "Albums", "Genre", "Artists", etc?

 

3. Do you prefer upsampling your DSD 64 or PSM music to DSD128?

 

Thanks in advance.


DIGITAL: Windows 7 x64 JRMC19 >Adnaco S3B fiber over USB (battery power)> Auralic Vega > Tortuga LDR custom LPSU > Zu Union Cubes + Deep Hemp Sub

 

ANALOG: PTP Audio Solid 9 > Audiomods Series V > Audio Technica Art-7 MC > Allnic H1201 > Tortuga LDR > Zu Union Cubes + Deep Hemp Sub

 

ACCESSORIES: PlatterSpeed, BlackCat cables, Antipodes Cables, Huffman Cables, Feickert Protracter, OMA Graphite mat, JRemote

Share this post


Link to post
Share on other sites

Dawgneck, thanks for the nice comments.

 

If you are getting FALC listings in your attempt to play an SACD ISO (file type SACD) then you simply have another album ripped into FLAC with the same name. ISO's contain DSD stereo and multichannel content (and often the redbook wav counterpart, but I don;t ever show the redbook layer when I show an ISO). But it certainly isn't FLAC.

 

If you want a folder view go to the main audio category on the left, right click and "add library view" then choose one of the defaults, the one called "disc location". You can customize it more later, but this will get you started.

 

I don't upsample currently.

Share this post


Link to post
Share on other sites

Thanks for your replies, Hifitubes and Ted_B.

 

I will give your tips a go later tonight.

 

Ted_B, you are correct, I mistakenly typed FLAC when I meant to type WAV. Is there a way to show/play the SACD files and ignore the WAV files?

 

Thanks!

Share this post


Link to post
Share on other sites

As per Matt (Ashland, JRiver CTO) they do nothing with the redbook part of an SACD. I think you are, again, seeing the redbook rip you did of the same title?

Share this post


Link to post
Share on other sites

Library Update

 

I am still noticing that it can take several jriver restarts for music that I have added to my library to show up. And, sometimes it shows up without the cover art.

 

I know that things are set up to update since the music eventually shows up, but I don't know why I have to restart for that to happen. And even then it may not immediately appear.


Speakers: Vandersteen Model 7s, 4 M&K ST-150Ts, 1 VCC-5; Amplification: 2 Vandersteen M7-HPAs, CI Audio D200 MKII, Ayre V-6xe; Preamp: Doshi Audio Line Stage v3.0; Phono Pre: Doshi Audio Phono Pre; Analog: Wave Kinetics NVS with Durand Telos composite arm; SME 3012R arm, Clearaudio Goldfinger Statement v2; Reel to Reel:  Technics RS-1500; Doshi Tape Pre-Amp; Studer A810, Studer A812, Tascam BR-20; Multi-channel: Bryston SP-3; Digital: Custom PC (WS 2016/AO/HQPlayer/Roon)> Lampizator Big 7 DAC

Share this post


Link to post
Share on other sites
Pasted below, but easier to search this page for "remove". Yes, it's possible. In this case, you would replace "filename" with "album". IIRC, the beauty of this is you could paste the correct expressions across infinite files, just as long is they all need the trim you set. It works very well.

 

Expression Language - JRiverWiki

 

 

Right(…): Retrieves a specified number of characters from the right of a string

Description right(string, quantity)

 

The Right() function retrieves the specified quantity of characters from the right of the string. If quantity is larger than the length of string, the original string is returned.

Examples right([filename], 3)

 

Returns the last three characters from the filename (typically this is the file's suffix).

hifitubes, could you give me an example? or maybe you, ted?

 

I have a whole bunch of albums with (16-48) next to the album title and I would like to remove that string on all the albums. what command should i use and where on the tag window should I put it.

 

much appreciated.

Share this post


Link to post
Share on other sites

Go to files view. Highlight all the albums with that suffix (or in search box in right upper corner , click on pulldown arrow, pick wizard, and do "album - ends with - (16-48)" ) and then when you have the list do a control-a (i.e highlight all) and open the tag window in the lower left corner. In the album field type (without the quotes)

"=removeright([album],7)"

which means remove the last seven characters from the album name. So "Abbey Road (16-48)" becomes "Abbey Road".

 

As always, undo is your friend.

Share this post


Link to post
Share on other sites
Go to files view. Highlight all the albums with that suffix (or in search box in right upper corner , click on pulldown arrow, pick wizard, and do "album - ends with - (16-48)" ) and then when you have the list do a control-a (i.e highlight all) and open the tag window in the lower left corner. In the album field type (without the quotes)

"=removeright([album],7)"

which means remove the last seven characters from the album name. So "Abbey Road (16-48)" becomes "Abbey Road".

 

As always, undo is your friend.

you are the man, mr. ted. can't thank you enough.

Share this post


Link to post
Share on other sites

Jremote question

 

Sometimes when I select an album the next screen shows cover art for each song but instead of showing the name of the song beneath it shows the bitrate. I seem to have the same configuration for 2 different views but they don't show the same information.

 

image.jpg

 

image.jpg


Speakers: Vandersteen Model 7s, 4 M&K ST-150Ts, 1 VCC-5; Amplification: 2 Vandersteen M7-HPAs, CI Audio D200 MKII, Ayre V-6xe; Preamp: Doshi Audio Line Stage v3.0; Phono Pre: Doshi Audio Phono Pre; Analog: Wave Kinetics NVS with Durand Telos composite arm; SME 3012R arm, Clearaudio Goldfinger Statement v2; Reel to Reel:  Technics RS-1500; Doshi Tape Pre-Amp; Studer A810, Studer A812, Tascam BR-20; Multi-channel: Bryston SP-3; Digital: Custom PC (WS 2016/AO/HQPlayer/Roon)> Lampizator Big 7 DAC

Share this post


Link to post
Share on other sites

David, two things:

1) you have the cover art grid view picked in the upper right corner of your Jremote, so it will show cover art for each song. I choose the first option, which shows cover art for the album at the top, then list tracks. The second option is list order, but cover art thumbnail for each, followed by track info in list order

2) your view is defined as album artist (auto), followed by album, followed by sample rate. Remove sample rate, and the tracks names will show. Track names show in the lowest child (meaning once you click on the sample rates (in the example above).

Share this post


Link to post
Share on other sites

Perfect. Thanks. I guess I put in sample rate during the initial setup.


Speakers: Vandersteen Model 7s, 4 M&K ST-150Ts, 1 VCC-5; Amplification: 2 Vandersteen M7-HPAs, CI Audio D200 MKII, Ayre V-6xe; Preamp: Doshi Audio Line Stage v3.0; Phono Pre: Doshi Audio Phono Pre; Analog: Wave Kinetics NVS with Durand Telos composite arm; SME 3012R arm, Clearaudio Goldfinger Statement v2; Reel to Reel:  Technics RS-1500; Doshi Tape Pre-Amp; Studer A810, Studer A812, Tascam BR-20; Multi-channel: Bryston SP-3; Digital: Custom PC (WS 2016/AO/HQPlayer/Roon)> Lampizator Big 7 DAC

Share this post


Link to post
Share on other sites

I have tried asking this question over on the JRiver forum but there was no response so I hope someone here might be able to point me in the right direction.

 

When I use Gizmo on a browser to select and play albums I find that many are not shown under the 'Artist' view but can be found under other views. It does not seem to matter what device I use (Android, WinXP or Win 7) they all have the same albums missing. They do display as expected on the server PC (Win2012) under JRiver 17.

 

Creating a new library does not help, the same items are missing. Could there be a different database serving Gizmo that needs to be fixed?

Share this post


Link to post
Share on other sites
I have tried asking this question over on the JRiver forum but there was no response so I hope someone here might be able to point me in the right direction.

 

When I use Gizmo on a browser to select and play albums I find that many are not shown under the 'Artist' view but can be found under other views. It does not seem to matter what device I use (Android, WinXP or Win 7) they all have the same albums missing. They do display as expected on the server PC (Win2012) under JRiver 17.

 

Creating a new library does not help, the same items are missing. Could there be a different database serving Gizmo that needs to be fixed?

 

MikeK,

Can you show us a screencap of the Gizmo view and then one of another view (which shows the album that is missing in Artist view)? Maybe it's missing some tags?

Share this post


Link to post
Share on other sites

GenreBeatles.jpg

B

This is one example using Gizmo on my WinXP PC. The first image shows the 'Artist' view for The Beatles and the second shows the 'Genre' view (HD for these because they were from the USB version). All these albums and all the rest are shown together under the JRiver 'Artist' view on the server PC.

 

If the issue was to do with tags then would that suggest Gizmo is doing someting different with them?

ArtistBeatles.jpg

Share this post


Link to post
Share on other sites

Well, I suspect Gizmo is only seeing "The Beatles" while the other one sees "Beatles, The"? Dunno. It's clear that the Genre view is missing the Anthologies, too. JRiver's own view is smart enough to ignore articles like "The" and "A" (if set correctly in JRiver; discussed on an earlier post in this thread).

Share this post


Link to post
Share on other sites

Thanks Ted, but I am still not sure how tagging could be the issue. It seems to be purely a client issue as all is OK on the server side.

 

Anyway, as it is not a known issue I will go back and check my tagging more thoroughly, maybe look for anomalies with 'Artist' and 'Album Artist'...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...